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i2 Analyst's Notebook user help
Welcome to the i2 Analyst's Notebook documentation, where you can find information about how to use
i2 Analyst's Notebook in your investigations.
Getting started
Analyst's Notebook data on page 2
To build up a full picture of an investigation, Analyst's Notebook can access data from a range of
sources. Within Analyst's Notebook, data is stored as entities, links, and properties.
Charts on page 13
Charts display the intelligence that relates to an investigation. You can create charts both manually and
automatically by using information from various sources. This information might be personal knowledge,
written reports, photographs, video clips, spreadsheets, email, word-processing files, and databases.
Working with i2 Analyze on page 62
If you are using Analyst's Notebook Premium, you can connect to i2 Analyze and, depending on your
deployment, access intelligence data from within your organization and from external sources.
Common tasks
Add information to a chart on page 30
To represent the information that you receive, you can add entities and links to your chart, then add
information to chart items. Items can store information in properties such as identity and date and time,
in attributes, and in cards.
Import data on page 34
Data in formats such as text files or spreadsheets can be directly imported into Analyst's Notebook
using import specifications. You can run imports using existing specifications or create your own
designs by using the step-by-step import wizard. Import designs give you control over how Notebook
converts data into entities and links that are placed on the chart surface for analysis.
Search for information on page 122
To find chart items that might be of interest to your investigation, you can search item properties for
specific information. Different search tools on the Analyze tab fulfill different needs.
Find networks on page 127
You can find the connections and intermediaries between items of interest, discover what is linked
to a specific entity, and find groups of interlinked entities. These networks might contain entities and
relationships that support the activity of items of interest.
Modify item appearance on page 217
After you add an item to the charting surface, you can modify its appearance from the default style that
is specified by the chart. You can emphasize items on the charting surface, and present only the most
crucial data on the charting surface.
Arrange items on page 221
You can automatically move chart items so that their presentation suits the data, and so that items are
uniformly positioned. You can improve the clarity of the chart, for example by shaping links so that they
do not obscure other chart items.
Present and publish charts on page 240
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To present the data on your chart effectively, you can build a sequence of chart items to step through,
and you can zoom into multiple areas of the chart. If you publish the chart, you can save the chart in a
format that is appropriate for the recipients, and you can print the chart.

Contacting i2 Support
i2 Support provides assistance with product defects, answers FAQs, and helps users to resolve
problems with the product.
After trying to find your answer or solution by using other self-help options such as technotes, you can
contact i2 Support. Before contacting i2 Support, your company or organization must have an active
software subscription and support contract, and you must be authorized to submit problems to i2.
To contact i2 Support about a problem:
1. Define the problem, gather background information, and determine the severity of the problem.
2. Gather diagnostic information.
3. Submit the problem at https://i2group.com/support.
If the problem that you submit is for a software defect or for missing or inaccurate documentation, i2
Support creates an issue report. The report describes the problem in detail. Whenever possible, i2
Support provides a workaround that you can implement until the issue is resolved and a fix is delivered.

Analyst's Notebook data
To build up a full picture of an investigation, Analyst's Notebook can access data from a range of
sources. Within Analyst's Notebook, data is stored as entities, links, and properties.
Analyst's Notebook entities represent real world objects such as bank accounts and telephones, or
events such as meetings or appointments. Links represent the relationships between entities, such as
associations between people, ownership of vehicles, transactions between bank accounts, or meetings
between people. In Analyst's Notebook, entities and links are known as items.
Properties are used to store information that is known about an item, such as whether a person has
a criminal record, or the date and time of a meeting. It is important to think about where to store each
piece of information. The choices that you make affect the type of analysis that you can do or how you
present the information. For example, you might choose to store information, such as the date of birth of
a person or model of a vehicle, as an attribute rather than in a card. You can then display that property
on the chart surface and use it in your analysis.
You can also add annotation to your chart in the form of a label or legend. Labels are used to add
annotation, such as adding a title for a presentation. They are not used for analysis. Legends provide a
key for the information on the chart surface.

Entities
Entities represent real-world objects such as a people, locations, and bank accounts, or they represent
events such as meetings.
Each entity has a representation to determine how it is displayed on the chart surface and a type to
categorize it. An entity contains properties, which store information about the object or event. For
example, a person might have a name, date of birth, and eye color and a meeting might have date,
time, and duration.
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Representation
You can choose how to display entities on your chart surface by using different entity representations,
for example icon, event frame, or theme line.
Table 1: Different entity representations.
Entity representations: different ways of displaying entities.
Representation

Description

Icon

An image or picture.

Theme line

A line that is used to represent a key element
of an investigation, such as a suspect, or bank
account. Theme lines are often used with event
frames to represent a sequence of events over
time.

Event frame

A representation of an occurrence that is used
to emphasize date and time information, such as
a meeting, or an appointment. Event frames are
often used with theme lines.

Circle

Typically used for textual intelligence on the chart
surface or to indicate an organization or a group
visually. A circle is sometimes used to enclose
other entities.

Box

Typically used to enclose other entities on a chart
to indicate an organization or group visually.

Text block

Any piece of information. Often used for textual
intelligence on the chart surface.

OLE object

An object that is created in another application
and incorporated into your chart, for example a
spreadsheet, word-processor document, video
clip, or graphic file.

Type
Each entity has a type to categorize it, for example Person, Bank Account, Meeting, or Vehicle. This
type categorization means that you can locate and analyze information more efficiently.
The template that is used to create the chart contains a set of entity types. If you need an alternative
entity type, you can create your own by customizing your chart. However, before you create a new entity
type, make sure that a suitable one does not exist. You can merge any new entity type that you create
back into the standard template.
Entity types have characteristics that define the type such as icon image and name.
Table 2: Analyst's Notebook entity type characteristics.
The different characteristics that each entity type defines.
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Characteristic

Description

Icon

The image that is used on the chart, when the
entity is represented as an icon, theme line, or
event frame. You can load custom icons into the
system for specialized entities.

Name

The name that is used to identify the entity type.

Line color

For representations that use a border, the color
of the line that is used for entities of this type.
You can also change the line color on a per entity
basis.

Shade color

The dominant color of the icon that is used for
entities of this type when represented as icons,
event frames, or theme lines. You can also
change the shade color on a per entity basis, for
example, to show if a particular car is red.

Semantic type

A category that defines the real-world meaning
of data, and therefore defines how applications
interpret that data. For example, Person is a
semantic type that might be assigned to entity
types such as Male, Offender, and Subscriber.
You can search for entities that are assigned a
Person semantic type. Using this search criteria,
Analyst's Notebook finds entities that have an
entity type of Male, Offender, Subscriber, and any
other types that have the semantic type Person
assigned. You can also change the semantic type
on a per entity basis.

User palettes

The palettes that contain the entity type.

Related tasks
Adding items on page 30
You can add entities and links to your chart. The items on your chart represent real world objects and
relationships.
Related reference
Item type definitions on page 23
Entity types and link types categorize the information on your chart and are part of a chart's properties.
If the existing item types are not suitable for your data, you can add or edit entity types and link types.

Links
A link represents a relationship between two entities, such as ownership of a vehicle by a person or a
transaction between two bank accounts. It is represented on the chart surface by a line between the two
entities.
Links might have an arrow for direction to indicate a flow of commodities or transaction, or they can be
without direction, representing some general association.
All links have the same representation of a line between the two related entities. The style of the line
can indicate confidence in the relationship. For example, a solid line might represent an established
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relationship such as the documented ownership of a vehicle. The template that is used to create the
chart contains a set of line strengths that associate a confidence level with a line style. For example, a
solid line to represent confirmed information, a dashed line to represent unconfirmed information, and a
dotted line to represent tentative information. You can also create your own by customizing the chart.
If there are several relationships or transactions between the same two entities, you can choose to
display them as one single link, a link for each direction, or as separate links. This link multiplicity setting
is part of a link's style.
A link contains properties, which store information about it. For example, a transaction might have an
amount and a date and time.
Type
Each link has a type to categorize it, such as Owner, Transaction, or Subscriber. This type
categorization means that you can locate and analyze information more efficiently. For example, if a
chart contains vehicles and their owners, you can use an owner link type. You can then search for the
owner of a vehicle by specifying an owner link type in Visual Search.
Note: If you are adding a link of a specific type to a data source, for example if you are using i2®
Analyst's Notebook Premium to add a link to an iBase database, there might be restrictions on the types
of entity that can be linked.
The template that is used to create the chart contains a set of link types. If you need an alternative
link type, you can create your own by customizing your chart. However, before you create a new link
type, make sure that a suitable one does not exist. You can choose to merge any new link type that you
create back into the standard template.
Link types have characteristics that define the type such as name and color.
Table 3: Analyst's Notebook link type characteristics.
The different characteristics that each link type defines.
Characteristic

Description

Name

The name that is used to identify the link type.

Color

The color of the line that is used to represent links
of this type. You can also change the color on a
per link basis.

Semantic type

A category that defines the real-world meaning
of data, and therefore defines how applications
interpret that data. For example, Organization
Link is a semantic type that might be assigned to
link types such as Employee or Director. When
you search for a link with an Organization Link
semantic type, Analyst's Notebook search the
types Employee, Director, and any other types
that have the semantic type Organization Link
assigned. You can also change the semantic type
on a per link basis.

User palettes

The palettes that contain the link type.
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Related tasks
Adding items on page 30
You can add entities and links to your chart. The items on your chart represent real world objects and
relationships.
Related reference
Item type definitions on page 23
Entity types and link types categorize the information on your chart and are part of a chart's properties.
If the existing item types are not suitable for your data, you can add or edit entity types and link types.

Properties
Entities and links contain properties, which are used to store information about that entity or link.
Selecting the correct type of property to store information is essential for both visualization and analysis.
Properties can describe the following characteristics of a chart item:
•

Information that is known about the chart item such as its label and description.

•

Provenance details, such as the source or reliability of the chart item or of an individual piece of
information.

•

Settings to do with how the chart item is displayed such as line strength, fill color, and other visible
elements.

Information about an item might come from multiple sources, such as databases, witness statements,
or external documents. This information can be stored in cards, attributes, or when it comes from a
connected data source, in data records.
Note: By default, only the item label is displayed on the chart surface. Apart from information that is
held on cards or data records, all other properties can be selected for display.

Identities
An identity uniquely identifies an item on a chart or provides a unique link back to entity or link
information in a data source.
Two types of identities apply in different situations:
•

An Analyst's Notebook identity uniquely identifies entities in the chart (entities only).

•

For items created from one or more connected data sources, database identities uniquely identify the
original source records (entities and links).

An entity can have an Analyst's Notebook identity, one or more database identities, or both.
Alternatively, an entity can have no identity.
Identities are used to match items when you add new items to the chart by copying and pasting,
importing, or adding them from a data source. If the item that is being added has an identity that
matches the identity of an item that is already on the chart, the items are merged. The item that you are
adding to the chart might have more than one identity, for example two database identities, so it might
match more than one item on the chart. You can decide what to do, based on information that Analyst's
Notebook provides.
Analyst's Notebook identity and label
Typically, an entity has a label and an identity. By default, the label is the same as the identity but can
be changed. The label is displayed on the chart and does not need to be unique, whereas an entity's
identity, if it has one, must be unique within a chart. Analyst's Notebook identities are case-sensitive.
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It is important to use an identity that uniquely identifies an item, such as a car's license plate, or a
person's name together with their date of birth. An entity's identity means that you can copy entities
back and forth between charts without unwanted duplication.
If you do not have enough information to uniquely identify an entity, you can leave its identity blank. For
example, you might receive several reports that each involve a John Smith but that include no further
identifying information. In this situation, you might add several entities to your chart that are labeled
John Smith and have a blank identity.
Links do not have Analyst's Notebook identities.
Note: Do not use hyphens in entity or link labels to separate numeric and text values, for example
Smith-100 or 100-SMITH. Analyst’s Notebook interprets the hyphen as a minus symbol if it is
adjacent to a numeric value. This results in a negative value for the analysis attribute label value. If this
is not the intended interpretation either use a tilde (~) or en dash (–) instead.
Database identity
Entities and links can have one or more database identities. The database identity uniquely identifies
the item in the data source. When you are connected to the data source, you can view the live database
information that is associated with the item.
If you chart an item from a connected data source, the Analyst's Notebook identity might be set to blank
because a database identity is assigned to the item. Whether the identity is set to blank depends on
how the connection to the data source is configured.
Related tasks
Setting the identity on page 32
An entity's identity uniquely identifies it on the chart, regardless of how it is displayed. Analyzing charts
is typically based on the identity of entities.
Displaying data records on page 99
Depending on the data source, data records are attached to items when you add data from a data
source. Data records contain data that is copied from the source record, so that you can view any
copied data that is not displayed on the charting surface.
Related reference
Label behavior on page 20
Behavior options determine how labels are handled when links are created or items are merged. Set the
behavior for your needs within your standard template.

Data records
When you chart information from a data source, Analyst's Notebook creates a reference back to the
information in the data source. It can also create a record that contains a copy of the item's data from
that data source.
The creation of a data record is controlled by the product that you are charting from. For example, if you
are charting from i2® iBase, this option is configured in the charting scheme.
The data record that is created forms part of the item. It contains the information that was in the data
source at the time that the item was created on the chart.
You cannot edit the content of a data record. If the original data source is updated after the data record
was created, the record is not updated to reflect those changes.
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If an item contains information from more than one connected data source, it has a data record for each
data source. For example, two data sources might contain different information about the same person.
When you view a data record, it indicates which data source the information is from.
An item that is charted from a data source has a database identity that links back into the data source.
When you are connected to the data source, you can view the data in the data source from within
Analyst's Notebook. Depending on the data source and the connection to it, in some cases you can also
edit the data to update the data source. When you edit the data source in this way, the item on the chart
is charted again and the data record in the chart is refreshed.

Style
To highlight key aspects of your investigation or key pieces of information on your chart, you can
configure the style or appearance of an item.
The style of an item controls how it is displayed on the chart surface. By modifying style properties, you
can:
•

Set the shade color of an entity. For example, you can set the color of a vehicle icon.

•

Set the line color of a link.

•

Display a picture in place of an icon. For example, you can display a photo of a person.

•

Add a frame around an entity to draw attention to it.

•

Choose which pieces of information are displayed on the chart surface. For example, you can
display item grades and source type information.

•

Indicate the confidence of an item's data by making the displayed line dashed or solid.

•

Set the properties of an item's font.

•

Select the link multiplicity of a connection between two entities. For example, you can emphasize
that there are several associations between two entities by showing the connection as multiple links
rather than a single link.

Display
What information you can choose to display for an entity and how you display it on the chart surface
depends on which representation you use.
Table 4: Available information for display on a chart surface
Display

Used by

Date & Time

All items

Description

All items

Grades

All items

Label

All items

Link Area

Diverting event frames

Picture

Icons, theme lines, and event frames

Frame

Icons and theme lines

Pin

All entities and any links that link 2 theme lines

Source Reference

All items
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Display

Used by

Source Type

All items

Type Icon

Event frames only. Always displayed for icons and
theme lines.

Type Name

Event frames only

Fonts
You can set the font type, size, style, color, and shading for a chart item. For event frames, text blocks
and text labels, you can also set the text alignment.
Changing the font of an item updates:
•

Label text

•

Description text

•

Grade and source information text

•

Date and time text

You cannot change the font of an individual word or phrase.
Note: A font change does not apply to attribute text. Attribute text properties are specified per attribute
class in the Edit Attribute Class page of the Chart Properties window.
Link multiplicity
When multiple links are present between two entities, link multiplicity determines how these links are
displayed. Link multiplicity can be:
•

Single: The connection between two entities is shown as a single link. This single link represents an
association between two entities, which might in reality, comprise many different instances of that
association.

•

Directed: The connection between two entities is represented by one link for each possible direction.
A directed connection has therefore a maximum of four links. Each of those links might represent
several instances of the association, all in that same direction such as several transactions from one
bank account to another.

•

Multiple: Each link between two entities is displayed individually.

Cards
You can add descriptive unstructured information to items by putting the information into cards and
add provenance information to them. Typically one card is used for each piece of supplementary
information. You can use information in cards during analysis, such as searching.
Card information cannot be displayed on the chart surface.
You can store the following information on a card:
•

A single line of text that summarizes the information.

•

The main information that you want to include about the entity or link.

•

Date and time, including a time zone. Use the date and time that the event or information in the card
occurred, the date and time that the information was obtained, or the date and time that you added it
to the chart item. Your organization might have guidelines for you to follow. You can choose to add a
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description of the date and time if the exact date or time is not known such as about 4 pm or around
lunchtime. Alternatively you can also use the description to indicate what is represented by the date
and time that you entered.
•

Provenance information such as the source, reliability of the source, reliability of the information, or
its privacy rating.

To make it easier to manage cards or assign provenance information, add one card per piece or
information or one card for each set of information from a specific source. The choice that you make
depends on, for example, whether you want to assign different grades to different pieces of information.

Provenance information
The ability to track information to the original source and to assess the reliability of the information or the
source is important in investigations.
Some examples of the types of information are listed:
•

The source and type of the information such as a witness statement that has a document reference
number. When you chart an item from a data source, it contains a database identity that links it back
to the original data source.

•

The reliability of the source that provided the information or the reliability of the information itself.
For example, you might request information from an agency that concerns the registered owner of a
vehicle. This information might be considered reliable whereas an overheard conversation that leads
you to believe that a relationship exists between two suspects might not be accurate.

•

The privacy rating or classification of the information, that is, who is allowed to know about the
information.

You can add provenance information to chart items and to individual pieces of information in cards. For
example, you might have several pieces of information about a specific person. You can add each piece
of information to a card and include provenance information on each card.
The chart template controls what rating scale is used. Many organizations adopt their own grading
system. You can customize the rating scales to meet your requirements.
Related tasks
Setting the description & grades on page 33
All chart items are given grading information. Grades on an item classify or provide an evaluation
of some quality of the information that is represented by that item. For example, if the information is
reliable, confidential or from a trustworthy source.

Attributes
You can store specific discrete pieces of information on chart items as attributes. Attributes are often
displayed as part of the item on a chart surface for presentation purposes and are also used in analysis,
such as filtering.
Analyst's Notebook has two types of attributes:
•

Attributes store information about an item such as a person's date of birth or the make of a particular
item. You can add attributes manually or you can import information into attributes from a file or a
data source.

•

Analysis attributes are automatically generated and store calculated information such as the day of
the week that an event occurred or whether an item has any cards.
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Attributes are useful during analysis. For example, you can filter on attributes to choose which items to
display on the chart surface. When you list the items on the chart, you can sort based on attributes.
Attributes that are imported or created manually
You can use attributes to show specific characteristics about items on your chart. Attributes are typically
displayed below a chart item as a symbol and value.
An attribute has three key components:
•

An attribute class: Defines the kind of information that is stored. Each attribute class has a name,
symbol, and a type that defines the kind of information that the attributes can contain.

•

An attribute value: The actual information.

•

A semantic type: Allows information to be classified to give a real-world meaning.

Attributes that are automatically calculated
Analysis attributes contain calculated, dynamic information that is taken from an item's context in the
chart. Analysis attributes provide useful statistical information about chart items, which might help your
analysis. For example, which entity has the most links, which item has the earliest date and time, or
which transactions occurred on a Friday. You cannot edit analysis attributes.
Analysis attributes cannot be displayed on the chart surface in the same way as other attributes but you
can choose to include them in Infotips.
Note: If the label values in your analysis attributes incorrectly display negative numeric values, replace
hyphens in item labels with either a tilde (~) or an en dash (–).
Related reference
Attribute definitions on page 24
Attribute classes categorize the information that is stored as attributes on chart items and are part of
a chart's properties. If the existing attribute classes are not suitable for your data, you can add or edit
attribute classes. Attribute entries are preset values for attributes of a specific attribute class. For values
that you reuse regularly, define attribute entries and add them to the appropriate palettes.

Semantic types
To benefit from the visualization and analysis capabilities of Analyst's Notebook, assign semantic types
to items or attributes to identify their meaning.
Analyst's Notebook recognizes the semantic types that are assigned to data, enhancing the amount of
analysis that is available. Item types that have a common semantic parent type are recognized as being
related and might be returned in search results.
i2 provides the i2 Semantic Type Library, which consists of a set of entity, link, and property semantic
types. These semantic types can be assigned to the entity types, link types, and property types. Some
of these semantic types are used specifically by Analyst's Notebook to match entities, for example a
national identifier for a person, or a license plate for a vehicle.
If you cannot locate a suitable semantic type, you can derive your own custom semantic type from the
appropriate generalized semantic type. A custom semantic type is treated as a specialization of its
recognized parent semantic type.
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How to chart data
The decisions that you make on how to model your data and where to store it in Analyst's Notebook
affect how you can present and analyze the information.
Entities or properties
When you put your data into Analyst's Notebook, it is important to decide when to create separate
entities and when to store information in a single entity. For example, you might have the following
information about a person:
•

Name

•

Date of birth

•

Nationality

•

Address

•

Bank account details

•

Name of the organization where they work

Name, date of birth, and nationality are characteristics of a specific person and can therefore be stored
as properties on an entity that represents a person.
An address is a separate real-world object. Several people might live at the same address. Add it to
the chart once as a separate entity and link each person who lives there to that address. This method
avoids including the same information several times on the chart and reduces the potential for entering
the same information inconsistently.
A bank account is also a separate real-world entity. By creating a separate bank account entity and
linking the person to it, you can then show transactions between specific bank accounts rather than
between the bank accounts' owners. This model leads to more effective analysis, particularly if the
person has more than one bank account.
The organization where the person works is again a separate real-world entity. You can enable
analysis of which people work at various organizations by creating links between the people and
the organizations where they work. However, for presentation purposes, sometimes it is sufficient to
represent an organization as a box that encloses the people who work at that organization.
Example charts
Several example charts are provided with Analyst's Notebook. They show examples of how you might
want to chart and store information. The charts are typically in C:\Users\<username>\Documents
\i2\i2 Analyst's Notebook 9\Example Charts. They include examples of:
•

Storing and charting financial data in different ways.

•

The use of types and styles to highlight differences in the data.

•

The use of different entity representations to present your information, such as event frames when
you want to display the date, time, and description of events.

•

Storing and charting geographical data.

•

Handling data that contains hyperlinks, pictures, and different language alphabets.

•

Combining different chart styles (association and timeline) in a single chart.

If you open these charts in Analyst's Notebook, they contain annotation that helps you to understand
more about storing and charting data.
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Charts
Charts display the intelligence that relates to an investigation. You can create charts both manually and
automatically by using information from various sources. This information might be personal knowledge,
written reports, photographs, video clips, spreadsheets, email, word-processing files, and databases.
Analyst's Notebook displays and analyzes this information in visual form. Charts can depict:
•

Associations between entities such as people, places, vehicles, and organizations

•

The flow of data such as telephone calls and financial transactions

•

How related events unfold over time

Creating a chart
A new Analyst's Notebook chart is based on a template. When you create a chart, you can choose
between the standard template and other templates.
A template provides entity types, link types, and attribute classes for you to use in your chart. A template
also contains preset values for chart settings such as background color, page setup, and default item
style.
The standard template contains a wide range of item types and attribute classes, and is suitable for
general use. When you start Analyst's Notebook, it automatically creates a blank chart that is based on
the standard template. To make the template more suitable for your needs, you can customize it.
Other templates can provide a smaller or more specialized set of item types and attribute classes that
are appropriate to a specific domain. To ensure that a specific logo or box of standard text is present on
charts, you can use a template that includes them as items on the charting surface.
•

To create a chart that is based on the standard template, click File > New > New Standard Chart.

•

To create a chart that is based on a different template:
a) Click File > New > New from Template.
The New From Template window opens.
b) In the Create a area, click Chart.
c) In the Based on area, select a template from the list. To use a template that is not in the list, click
Browse, locate then select the template, then click Open.
Note: To create a chart that contains no entity types, link types, or attribute classes, select
Empty Template from the list.
d) Click OK.
Analyst's Notebook creates a chart that is based on the chosen template.

Related reference
Viewing and maintaining chart summary properties on page 26
Summary and custom properties contain user-defined and automatically generated information about
the content and use of the chart. Some of these properties are used in the chart Cover Sheet, which can
be set to display on opening a chart.

Opening charts
Analyst's Notebook can open Analyst's Notebook charts (.anb), and Analyst's Notebook Exchange
charts (.anx).
To open a chart, use the following steps:
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1. Click File > Open.
2. In the Open window, navigate to the directory that contains the chart you want to open.
3. Double-click the chart that you want to open. You can select multiple files to open several charts at
the same time.
If a chart is closed abnormally, for example as a result of a power failure, Analyst's Notebook might
save recovery files. These charts are recovered next time that you start Analyst's Notebook.
Related concepts
Share details about charts on page 14
You can add information about a chart to its cover sheet. The cover sheet can help recipients of the
chart to understand the purpose of the chart and identify the author.

File types that can be opened in Analyst's Notebook
You can open charts and templates that are created with Analyst's Notebook. Charts that are created in
XML format can also be opened.
The different file types that can be opened in Analyst's Notebook are listed in the following table.
Table 5: File types that can be opened in Analyst's Notebook.
Extension

Description

.anb

A chart that is created in Analyst's Notebook.

.ant

A chart template that is created in Analyst's
Notebook.

.anx

A chart in XML format that can be opened in
Analyst's Notebook and i2® Chart Reader.

Copying charts
When you copy a chart, all of the chart items are copied along with the legend. You might want to create
a copy of a chart and then add more information to it.
To copy charts, complete the following steps:
1. Click anywhere on the background of the chart that you want to copy to clear any selected items.
2. Click the Home tab, and then in the Clipboard group, click Copy > Copy Chart.
3. Open a new blank chart. Right-click anywhere on the chart background and click Paste.
4. You can paste the chart into a different application as an OLE object.

Share details about charts
You can add information about a chart to its cover sheet. The cover sheet can help recipients of the
chart to understand the purpose of the chart and identify the author.
Viewing the contents of a chart or its file name is not always a reliable way of establishing the sensitivity
of a chart. Recipients of your chart might use the information on the cover sheet to assess whether they
are cleared to view the chart before they open it.
The cover sheet contains the following types of information:
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Summary property

Standard information about the chart. The cover
sheet contains the following summary properties,
which you can add information into:

Custom property

•

Title

•

Subject

•

Author

•

Keywords

•

Category

•

Comments

Information about the chart that is not included
in the summary properties. You can use custom
properties to store chart characteristics that are
specific to your organization.
Two custom properties are created automatically
when you create a chart from the Standard.ant
template. These custom properties are Case and
Classification. You can enter values for these
properties and add your own custom properties.

The headers and footers of your printed chart can contain information from the cover sheet. For
example, if your chart runs over a number of pages you might stamp each page with a security
classification, chart title, and publication status such as 'draft'.
Editable cover sheet
To prompt you to enter information, Analyst's Notebook can display the cover sheet in an editable state
when you save charts. You can choose whether the editable cover sheet is displayed only when you
first save a chart, or every time you save, or never. To choose an option, click File > Options, and then
on the Save page select the appropriate option in the Cover Sheet area.
To open the editable cover sheet of an open chart at any time, click File > Cover Sheet. You can
edit the same information on the Summary > Description and Origin pages of the Chart Properties
window.
Read-only cover sheet
You can choose to display a read-only cover sheet to recipients of the chart when they open it. To turn
on this feature, select the On Open check box on the editable cover sheet.
The read-only cover sheet is displayed before the chart loads. After the recipient reads the cover sheet
they can proceed to open the chart, or they can cancel the operation.
Related tasks
Opening charts on page 13
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Analyst's Notebook can open Analyst's Notebook charts (.anb), and Analyst's Notebook Exchange
charts (.anx).

Adding information to the cover sheet
You can add information to the cover sheet, and configure it to open when the chart is opened. You can
edit the cover sheet when you create or edit a chart.
To add information to the cover sheet of a chart:
1. Click File > Cover Sheet.
The Cover Sheet window opens.
2. Add information to the summary properties.
Tip: To help other users to find the chart, enter information that they might search for. For example,
you might enter the name of the investigation in the Subject property.
3. To create a custom property, click New in the Custom area.
4. To configure the cover sheet to open when the chart is opened, select the On Open check box.
5. Click OK.

Saving charts
Analyst's Notebook can save any open chart in Analyst's Notebook (.anb) format. The option to
include and customize a cover sheet is available when you save the chart. The cover sheet provides a
brief overview of the chart's contents and purpose. Properties of the cover sheet can be customized just
before the chart is saved.
It is good practice to save your chart with a meaningful file name when you first create a chart and add
something to it. You can then search for and view the charts that are related to an investigation.
To save a chart:
1. Click File > Save, or Save As.
2. If the Cover Sheet window is displayed, click OK on the Cover Sheet.
3. In the Save As window, navigate to the directory where you want to save the chart.
4. Type a file name in the File name box.
5. Click Save.
Note: If a chart with the same name exists in the specified location, the application asks whether to
overwrite the previous chart. If you click No, you must specify a new location or name for the saved
chart.
When you save a chart, it is validated for any significant compatibility issues with earlier versions. If the
application finds a problem, a relevant warning is displayed.

Saving a chart as a template
To reuse the chart settings in other charts, save the chart as a template. Saving charts as a template
can help save time and improve work efficiency if data used in multiple charts is similar and do not
require different chart specifications.
To save a chart as a template:
1. Click File > Save As.
The Cover Sheet might be shown.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 17

2. If the Cover Sheet is shown, click OK to save the Cover Sheet details, or click Cancel to close the
Cover Sheet.
The Save As window is shown.
3. Select the folder to save the template and type a file name in the File name box.
4. Select Analyst's Notebook Template (*ant) from the Save as type list.
5. Click OK.
All of entity types, link types, attribute classes, and any chart items on the chart are saved in the
template.

Chart and application settings
When you save a chart, either as a chart or as a template, many of the definitions, options, and settings
are also saved.
Saved with the chart
The following are all saved with the chart:
•

All the settings in the Chart Properties window:
•

Display settings: chart background color, grid size, theme line wiring options

•

Behavior options: label paste and merge rules, blank link labels

•

Definitions: entity types, link types, attribute classes, attribute entries and their semantic type
assignments, grading system, line strengths, and date and time formats

•

Time Bar display settings

•

All the default styles for each entity representation and for links

•

User palettes and their membership

•

The legend

•

Snapshots

•

Page setup settings

•

Whether entity types and attribute entries, or both are available in the palette bar

•

Display of the grid and page boundaries

Not saved with the chart (application settings)
The following settings are application settings. Application settings persist in Analyst's Notebook until
changed, regardless of which chart is opened.
•

All the settings in the analysis tools:
•

Visual Search criteria

•

List Items Options settings

•

Find Linked and Find Path Setup options

•

Find Text criteria

•

List Cards Options settings

•

Layout settings, unless saved by using the Save Layout Setup to Chart command.

•

Zoom settings (for example, the last zoom level). The initial view of a chart is always fits the chart in
the window.
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•

Insert from Palette pane and Add Links pane set up

•

Keyboard shortcuts

Managing user palettes
User palettes are used to group item types and attribute classes. You can modify existing user palettes
or add new ones to match the type of data you work with.
The default user palettes contain types and attributes that are commonly used in particular kinds of
investigation. For example, the finance palette contains all the relevant entity and link types that might
be used in a financial investigation. You can quickly choose the required type from the limited set in the
palette.
You can create a user palette and assign all the relevant entity and link types to this palette.
To manage user palettes:
1. Click File, point to Chart Properties, and then click User Palettes. The User Palettes window
opens. This window shows the name of the user palette, and whether it contains:
•

Entity types

•

Link types

•

Attribute classes

•

Attribute entries

2. Modify a user palette in one of the following ways:
Option

Description

New

Creates a user palette.

Duplicate

Creates a copy of the user palette that is
selected. A copy of this palette is created which
includes all assigned item types, attribute
classes, and attribute entries.

Rename

Rename a user palette. Double-click the name
of a user palette to rename it.

Delete

Deletes the user palette.
Note: When you delete a user palette, you
do not delete the entity types, link types, or
attributes that belong to that palette. A user
palette just displays a subset of the types and
attributes that the chart contains.

3. Click OK.

Modifying user palettes
User palettes contain item types, attribute classes, and attribute entries. You can change the contents
of a user palette. Modifying the contents and appearance of the user palette can help organize their
content to make finding item types and attributes easier to speed up chart creation.
To modify the content of an existing user palette:
1. Click File > Chart Properties.
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The Chart Properties window is shown.
2. Click Definitions and then select the page that you are interested in:
•

Entity types

•

Link types

•

Attribute classes

•

Attribute entries

3. Select the entity types, link types, attribute classes, or attribute entries that you want to add to or
remove from the user palette.
4. Click Properties and select the palettes to add the types and attribute entries.
5. Click OK.
The modified user palette is shown in the list of palettes in the Insert from Palette pane, and in the
User Palettes window.
Tip: To set up user palettes that you want to use in many different charts, save your chart as a
template.

Changing chart properties
Chart properties are a collection of settings and options that apply to a chart, such as the default date
and time for items. Chart properties also specify the item types and attribute classes that are available
for use in that chart.
Chart properties are saved along with your chart. These properties mean that when you distribute your
chart, the recipient sees the chart that you saved, in the same format. Similarly, when you open a chart
that you are sent, all the properties are as they were when the chart was saved.
You can set up templates to include chart properties that you use often. You can then create new charts
that are based on these templates.

Setting display options
Display options control the appearance of the chart surface. You can control the size of the grid,
background color, and link separation.
Setting the grid size
The grid size determines the spacing between grid points on the chart. You can specify the horizontal
and vertical distance between grid points on your chart separately.
Enter the required value in each box. The units that are used are determined by your Windows
environment.
You can enable snap to grid mode on this page.
Setting the link spacing value
The link spacing value determines the distance between multiple links on the same connection. This
value is used when you:
•

Add a link to a connection that already has a link. The new link is separated from existing links by
this distance.

•

Use the Compress Connection command. All links on the connection are rearranged so that they
are separated by this value.
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•

Import data with multiple links between entities into your chart.

Setting theme line wiring values
You can set the following values for theme line wiring:
Near

Sets the straight-line width of a theme line on
either side of an event frame, where the theme
line diverts through it.

Far

Sets the width of a diagonal segment of a theme
line.

Separation

Sets the vertical distance between theme lines as
they enter an event frame.

Height

Sets the distance between the top of the event
frame and the top theme line when it enters the
event frame.
Select the Use for Theme Line Icons check box
to position the theme line relative to the theme line
icon. The greater the value, the lower the theme
line is positioned.

Label behavior
Behavior options determine how labels are handled when links are created or items are merged. Set the
behavior for your needs within your standard template.
Specifying label merge and paste rules
Entities are merged when:
•

An entity is pasted into a chart that contains an entity with a matching identity

•

You use the Merge Entities command

Links are merged when:
•

You use the Merge Multiple Links command

•

Their connection style is changed, resulting in fewer links on the connection

•

You merge entities that are linked to the same entity. For example, if you merge two telephones that
are linked to the same person, the links are merged.

When two or more items are merged into a single item, you can specify what happens to the labels of
an item:
Merge

Labels are merged if the following conditions are
true:
•

One label is contained within the other, and

•

The matching text is a complete line of the
label

If both these conditions are not met, the labels are
appended (one is added to the end of the other).
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Append

One label is appended to the other. The label
of the item that is pasted, or the last item that is
selected is appended to the end of the original
label.

Discard

The label of the item that is pasted or the last
item that is selected is discarded. The label of the
original chart item is retained.

Summing numeric links
When the labels on your links are numeric or a number is contained within them, select Sum Numeric
Links to add the numbers together when links are merged.
Labels can have numbers that are embedded within them, that is, only part of the label is a number.
Analyst's Notebook can recognize that a label contains an embedded number.
To see the numeric value that Analyst's Notebook interprets from the link label, you can view the link's
Label Value analysis attribute. This attribute, contains the numeric value of the link, as extracted from
the label:
The rest of the label, that is to the left and right of the numerical part, is still merged.
Creating new links with a blank label
Select the Create Links with Blank Labels check box to create new links on your chart without a label.
Related concepts
Identities on page 6
An identity uniquely identifies an item on a chart or provides a unique link back to entity or link
information in a data source.

Setting icons options
The icon set that is used within the chart is configurable. You can use icons from the new icon set or
legacy icons.
You can open charts that contain icons from the new icon set in earlier versions of Analyst's Notebook.
However, these new icons cannot be displayed and are represented by the legacy icons.
Note: The new icons are not overwritten if you save the chart in versions later than Analyst's Notebook
6.

Identifying when events take place
The time bar is a visual aid to help you identify when events take place on your chart. It shows the
passage of time from left to right across your chart, and provides an overview of when events occur in
time in relation to each other.
The time bar comprises three main bands:
Band

Description

Interval

The interval band shows the intervals in which the
time bar is displayed. For example, hours, days, or
months.
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Band

Description

Tick

The tick band consists of major and minor ticks.
Major ticks represent, for example, days or hours,
and depend on the rate of time flow. Minor ticks
show times between major ticks. Minor ticks do
not have labels. When you move your mouse
pointer over a minor tick, hover help is displayed
that shows the date and time of the chart at that
position.

Marker

The marker band contains marker symbols that
indicate controlling items on the chart. Controlling
items are ordered and have both a date and time.

To edit the time bar:
1. Click File > Chart Properties > Options > Time Bar > Display.
2. Select the interval band:
a) Optional: Select Show in the Interval Band area, and select a color from the Line Color list.
b) Optional: Select Show in the Tick Band area, and select a color from the Line Color list.
c) Optional: Select Show in the Marker Band area, and select a color from the Line Color list.
3. Choose the interval label and tick label alignment.
4. In the General area, select the border and background color.
5. To change the style of the text in the time bar, modify the settings on the Interval Font page and the
Tick Font page.
6. Click OK to close the Chart Properties window.

Time zones
When you create a chart that contains events that take place in different time zones, you can specify in
which time zone each event took place.
Each item on your chart with a date and a time has a time zone. This time zone might or might not be
the same as the time zone of the chart.
Note: Date and time attributes do not have a time zone.
Chart time zone
The time zone of the chart is typically your local time, that is, the time where you are working. Analyst's
Notebook reads the time zone in the date and time properties of your computer and applies that time
zone to the chart. You can, if required, specify a different time zone for the chart.
The time zone of the chart is used:
•

In the time bar

•

As the default time zone when you create items with a date and time. The time zone of an item can
then be changed to any other time zone.

•

When you set up features such as visual search
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How do I find out which time zone the chart is in?
To view the time zone of the chart, follow one of these steps:
•

In the Chart Properties window, click Defaults > Date & Time. The Time Zone list displays the time
zone of the chart.

•

Point the mouse pointer at any tick in the time bar. The tooltip that is displayed contains the time
zone of the chart. To display the time bar on your chart, click the View tab, and then in the Show
group, select the Time Bar check box.

Item time zone
All chart items with both a date and a time have a time zone that is associated with them. When the date
and time are first set on a chart item, the time zone is the same as the time zone of the chart. The time
zone of the item can then be changed to any other time zone.
The date and time of an item is displayed on the chart in its own time zone, by using the specified date
& time format. The date & time format might or might not show the time zone name.
Related tasks
Setting the date & time on page 32
A chart item can have both a date and a time, or just a date or a time. It can also have a description of
approximately when it occurred, if the exact date and time is not known.

Item type definitions
Entity types and link types categorize the information on your chart and are part of a chart's properties.
If the existing item types are not suitable for your data, you can add or edit entity types and link types.
Entity type definitions
Entity types have characteristics that define the type, including icon, name, line and shade color,
and semantic type. When you are defining an entity type or editing an existing type, you can further
customize the following characteristics:
•

In addition to the icons available in Analyst's Notebook, you can load your own custom icons for
specialized entity types.

•

If there is no suitable semantic type in the type library, then to provide an accurate classification of
your data you can derive a custom semantic type from an existing semantic type.

You can also choose which user palettes contain the newly defined entity type.
Link type definitions
Link types have characteristics that define the type, including name, line color, and semantic type. As
part of a link type definition, if there is no suitable semantic type in the type library, then to provide an
accurate classification of your data you can derive a custom semantic type from an existing semantic
type.
You can also choose which user palettes contain the newly defined link type.
Related concepts
Entities on page 2
Entities represent real-world objects such as a people, locations, and bank accounts, or they represent
events such as meetings.
Links on page 4
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A link represents a relationship between two entities, such as ownership of a vehicle by a person or a
transaction between two bank accounts. It is represented on the chart surface by a line between the two
entities.
Custom semantic types on page 260
You can derive custom semantic types based on the ones in the i2 Semantic Type Library, then use
them in other charts and share them with colleagues. Deriving a custom semantic type is appropriate
when you need a more accurate classification of your data than the standard type library provides.

Attribute definitions
Attribute classes categorize the information that is stored as attributes on chart items and are part of
a chart's properties. If the existing attribute classes are not suitable for your data, you can add or edit
attribute classes. Attribute entries are preset values for attributes of a specific attribute class. For values
that you reuse regularly, define attribute entries and add them to the appropriate palettes.
Attribute class definitions
The standard template contains several attribute classes that you can use when you are creating a
chart, for example, Nationality or Date of Birth. However, if you are working with specialized data, you
can define your own attribute classes to categorize your data. You can then use these attribute classes
in your chart or to create your own template.
An attribute class has the following characteristics:
Table 6: Analyst's Notebook attribute class characteristics.
The different characteristics that each attribute class defines.
Characteristic

Description

Symbol

The symbol that can be displayed on the charting
surface when an attribute of this class is added
to a chart item, for example a red triangle. An
attribute class symbol does not have to be unique.
You can use your own custom symbols.

Name

The name that identifies the attribute class.

Type

The data type: Text, Flag, Number, Date & Time.

Semantic Type

A category that defines the real-world meaning
of data, and therefore defines how applications
interpret that data. For example, Crime Type is
a semantic type that might be assigned to the
attribute class Offense. You can select a semantic
type from the i2 semantic type library or you can
derive your own custom semantic type from a
semantic type that is stored in the library.

When you define an attribute class, you can configure its style and format and choose which user
palettes contain that attribute class. For example, you can choose to display a symbol, prefix or suffix on
the charting surface and set the font properties of an attribute class.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 25

Note: If you add a prefix or suffix, such as a dollar sign for a monetary value, Analyst's Notebook does
not leave a space between the value and the prefix or suffix. You must enter a space as part of the
prefix or suffix.
You can also choose whether to display the attribute value itself. For example, when you use a flag
attribute, displaying the attribute name alone might be sufficient. The display options vary depending on
the type of the attribute class.
Attribute entry definitions
The standard template contains several preset values for some attributes, such as Nationality, for
example Spanish, Dutch, and Italian. These preset values are known as attribute entries. You can
define your own attribute entries with values that you use regularly. You can then use these attribute
entries in your chart or to create your own template.
When you define an attribute entry, you must select the attribute class, then enter a value and select the
user palettes on which you want the attribute entry to appear.
Related concepts
Attributes on page 10
You can store specific discrete pieces of information on chart items as attributes. Attributes are often
displayed as part of the item on a chart surface for presentation purposes and are also used in analysis,
such as filtering.
Custom semantic types on page 260
You can derive custom semantic types based on the ones in the i2 Semantic Type Library, then use
them in other charts and share them with colleagues. Deriving a custom semantic type is appropriate
when you need a more accurate classification of your data than the standard type library provides.

Defining a grading system
Grades provide an indication of quality of the information that is represented within an item. For
example, if the information is accurate or reliable.
To allow the quality of information to be evaluated consistently, the same grading system should be
applied to charts of the same type. You can use the Grading System page to define the grades that are
used within your template.
To define the grading system:
1. Click File > Chart Properties > Definitions > Grading System.
The grading system is displayed.
2. Select the Grade list to which you want to add a grade, then click New below the list.
A new grade is created below the selected grade with the default name of "New Entry".
3. Select this grade and type the letter, number, or name that is required for this grade.
4. To move the grade up or down the list, click the new grade and drag it to its new position.

Adding a line strength
Line strengths are a useful way of indicating the general status or quality of information that is
represented by an item. The line strengths that you define depend on the convention that is adopted by
your organization.
Line strengths can be used to indicate the quality of information that is available for items on your chart.
By default, the following line strengths are available:
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Confirmed
Indicated as a solid line, this line strength is applied as a default to all created items. A line strength
is confirmed if the information is of a high quality.
Unconfirmed
Indicated as a dashed line. A line strength is unconfirmed if the information is not of a high quality.
Tentative
Indicated as a dotted line. A line strength is tentative if the information is hypothetical.
You can update these defaults and add more line strengths if required. Any changes that you make are
stored with the chart properties and available to others when you share the chart.
To modify the available line strengths:
1. Click File > Chart Properties > Definitions > Line Strengths.
2. Click one of the following options:
Option

Description

New

Create a line strength, when the default line
strengths are not suitable.

Duplicate

Duplicate a line strength. The selected line
strength is duplicated and a line strength is
created with the following properties:
•

A name of "Copy "n" of Line Strength", where
"n" is the lowest unused number.

•

The same strength as the selected line
strength

a) Type a name for the line strength.
For example, hypothesis.
b) Change the line style, by selecting a style from the Strength list.
Tip: You can delete line strengths that are no longer used. You cannot delete a line strength that is
in use on the chart.
3. Optional: To modify an existing line strength, click the down arrow in the Strength list and select the
line strength to use.
4. Click OK.

Viewing and maintaining chart summary properties
Summary and custom properties contain user-defined and automatically generated information about
the content and use of the chart. Some of these properties are used in the chart Cover Sheet, which can
be set to display on opening a chart.
Use the Description and Origin pages in the Summary folder of the Chart Properties window to:
•

View the chart summary and custom properties

•

Edit the chart summary properties

•

Create new chart custom properties

•

Edit an existing chart custom property
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•

Delete an existing chart custom property

Chart summary properties on the Description page
Use the Description page to view and edit file information about the chart file, such as its title and
subject. You can amend all the following fields.
Field

Description

Title

Enter a title for this chart. On saving your chart
for the first time, the Title is used as the standard
file name, however you can change the title as
required.

Subject

Enter the subject of the chart. You can use
the subject field to group similar types of chart
together, for example, all those charts that pertain
to a particular investigation.

Keywords

Use keywords to help readers identify the purpose
of your chart.

Category

A broad term, for example Surveillance, to allow
your chart to be grouped with other similar charts.

Comments

Use comments to record useful information about
the chart.

For every new chart that you create from the Standard template, two custom properties are displayed, to
which you can add or delete values.
Field

Description

Case

The name of the operation or case or criminal
investigation to which the chart relates.

Classification

The sensitivity level of the information that is
contained in the chart, for example, Restricted.

Chart summary properties on the Origin page
Use the Origin page to view the history details of the chart, such as when it was last saved or printed.
You can amend only the Author field; all other fields display read-only information.
Fields

Description

Author

The name of the person who created the chart.

Template

The template on which this chart was based.
You can select the full path of the template. Click
anywhere in the box and drag to the right to see
the full path.
You can then copy the path to the clipboard.
Note: The Template property is not available for
printing in the headers and footers of your chart.
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Fields

Description

Editing Time

The total amount of time this chart is open for
editing.

Created

The date and time that this chart was created.

Last Saved

The date and time that the chart was last saved.

Last Printed

The date and time that the chart was last printed.

Revision Number

The number of times the chart is modified and
saved.

Editing chart summary properties
You can change the summary properties on the Description page and the Author box on the Origin
page by selecting all of the text in the field, and typing over the selection with your new text entry.
After you make your changes on either the Description or Origin pages, click OK to close the Chart
Properties window.
Note: Changes to custom properties are not saved until you confirm your changes on the Chart
Properties window, and save your chart.
Creating and editing a chart custom property
Create a custom property if you want to add information to the Cover Sheet that is not covered by the
summary properties. To create a custom property:
1. Click New in the Custom area of the Description page. The New Custom Property window is
shown.
2. In the New Custom Property window, enter a name for the custom property in the Name box and
custom property information in the Value box.
Note: You must enter both a Name and Value to create a custom property. The new custom
property Name must be unique in the list. Values that are entered in the Value box are interpreted as
plain text.
3. Click OK to close the window.
To edit a custom property Name or Value, you can:
•

Select the custom property row in the list, click Edit, and change the Name, Value, or both, displayed
in the Edit Property window.

•

Double-click either the Name or Value cell of the custom property that you want to edit and enter
your new Name or Value, and either click away from the table or press the Enter key.

When you create new custom properties or edit existing custom properties, you can sort the properties
in alphabetical order by their name or value. To do this, click either the Name or Value column header.
Sorting is not case-sensitive and numbers come before letters.
Note: Changes to custom properties are not saved until you confirm your changes on the Chart
Properties window, and save your chart.
Deleting a chart custom property
To delete an existing custom property from the Cover Sheet:

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 29

1. In the Custom area of the Description page, select an existing custom property from the custom
properties list.
2. Click Delete or press the Delete key.
Note: Changes to custom properties are not saved until you confirm your changes on the Chart
Properties window, and save your chart.
Related tasks
Creating a chart on page 13
A new Analyst's Notebook chart is based on a template. When you create a chart, you can choose
between the standard template and other templates.

Creating a template
A template contains preconfigured chart properties, and lists of permitted entity types and link types.
When you base a chart on a template, the appearance and meaning of data in the chart are consistent
with other charts based on that template.
After making changes to the properties of a chart, or adding additional item types, a template can be
saved. Saving a chart as a template allows other charts to be produced that use these properties and
types
To create a template, use the following steps:
1. Update your chart properties.
2. Click File > Template > Create Template. The Create Template window opens.
3. In the Create Template window, select the Location to store the template:
Option

Description

Local template

Local templates are designed to be used to ensure consistency between the
charts that you create when working independently. Templates should be stored
locally when working on chart types that are not used by the rest of your team.

Workgroup
template

Workgroup templates are designed to be used by the wider team.

Standard

Sets this template as the default template to use for new charts.

Note: When there is no workgroup template path set, this option is not
available.

Note: The paths that are used to store templates are defined in File > Options > Templates.
4. Optional: To create a template which contains all of the chart items and the legend, select Include
Chart Items and Legend.
5. Click OK to create the template.

Applying a template to a chart
In normal operations, a template is selected when a chart is first created. You can however apply chart
properties as defined in a template at any point.
Use the Merge Template window to import chart properties and settings from a template into your chart.
This is a way of making certain features in your chart consistent with those defined in a template.
To add chart properties that are stored in a template to an existing chart:
1. Click File > Template > Merge Template.
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The Merge Template window appears.
2. Choose the template to apply.
3. Select the types of chart property to apply.
4. Use Replace Existing Features to overwrite existing properties.
5. Click OK to apply the chart properties.

Add information to a chart
To represent the information that you receive, you can add entities and links to your chart, then add
information to chart items. Items can store information in properties such as identity and date and time,
in attributes, and in cards.
For example, to represent a telephone call, you might perform the following actions:
•

Add two telephone entities to the chart

•

Add a link between the telephones to represent the call

•

Enter a telephone number into the identity property of each entity

•

Enter the call date and time into the date and time properties of the link, and add the call duration as
an attribute

To emphasize specific items that you add to the chart, you can modify item appearance. You might
identify which items are of interest directly from the information that you receive. Alternatively, you might
identify items of interest after you use Analyst's Notebook to analyze your data.
After you add information to a chart, you can use a label to annotate the chart, add a summary, or add a
title.

Adding items
You can add entities and links to your chart. The items on your chart represent real world objects and
relationships.
To add an item to the chart:
1. To display the Insert from Palette pane, click the Home tab, and then in the Palettes group, click
Insert from Palette.
2. To add an entity, select a representation at the top of the Entities section, select a palette from the
drop-down list, then drag an entity type onto the charting surface.
Tip: To add multiple entities of the same type, double-click the entity type, then click the charting
surface to add entities. To stop adding entities, press Esc. You can add multiple links in the same
way, in the Links section.
3. To add a link between two entities, select a palette from the drop-down list at the top of the Links
section, click a link type, then drag between the entities.
Related concepts
Entities on page 2
Entities represent real-world objects such as a people, locations, and bank accounts, or they represent
events such as meetings.
Links on page 4
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A link represents a relationship between two entities, such as ownership of a vehicle by a person or a
transaction between two bank accounts. It is represented on the chart surface by a line between the two
entities.

Searching item types
If you know the name of the item type that you are looking for, you can search the palettes for it.
Searching palettes can save time when compared to browsing.
To search for an entity type:
1. In the Insert from Palette pane, click the Search button at the top of the Entities section.
2. In the Search entity types box, type the first few characters of the entity type that you are looking
for. As you type, the list updates to display entity types that match the search text.
Note: You can search for link types in the same way in the Links section.

Adding information to items
You can add information that you have about a chart item into the properties of the item. You can use
analysis tools to gain insight from property values, and they can be displayed on the charting surface.
•

To edit the properties of an item, click the item on the charting surface, click the Home tab, and
then in the Edit Properties group click Data, Attributes, or Cards. In the Edit window, Analyst's
Notebook opens the corresponding folder of property pages.
Tip: To add the same information to several items at the same time, select them all, right-click on
one of the items, then click Combined Properties. For example, several telephones might have the
same area code. If some of the items already have a value for the property that you want to edit,
Analyst's Notebook displays blue hatching instead of a property value. You can collectively modify
date and time, description and grades, attributes, and style properties.

•

To add an attribute:
a) In the Edit window, click Item Properties > Attributes.
b) Click Add.
c) Select an attribute class from a palette, then enter information.
Alternatively, in the Attributes panel of the Insert from Palette pane, click an attribute class, enter
or select a value, then click OK.

•

To add a card:
a) In the Edit window, click Cards > Card List.
b) Click New.
c) Enter the information that you have.
You can include provenance information that is specific to the card, such as the source, reliability
of the source, reliability of the information, or its privacy rating.

•

The Edit window contains a Style folder. You can use the properties in that folder to add an image to
the item. You can also use the pages in that folder to modify aspects of item appearance.
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Setting the identity
An entity's identity uniquely identifies it on the chart, regardless of how it is displayed. Analyzing charts
is typically based on the identity of entities.
No entities can share an identity. If you enter a value that is already used by another entity, the text
changes to the error text color.
You must edit the entity identity so that it is unique before proceeding.
Note: Identities are case-sensitive. "Brian GREEN" and "Brian Green" are both allowed as different
identities on the same chart.
To set an identity:
1. Right-click an item, and select Edit Item Properties. The Edit window is shown.
2. Select Item Properties > Label & Identity.
3. Enter the identity of the chart item in the Identity box.
4. To set a label that is different from the identity, select Label is Different from Identity then enter a
label.
5. Optional: If an item has a database identity, it is shown in the Database Identities box.
6. Click OK.
Related concepts
Identities on page 6
An identity uniquely identifies an item on a chart or provides a unique link back to entity or link
information in a data source.

Setting the date & time
A chart item can have both a date and a time, or just a date or a time. It can also have a description of
approximately when it occurred, if the exact date and time is not known.
To set the date & time:
1. Right-click an item, and select Edit Item Properties.
The Edit window is shown.
2. Select Item Properties > Date & Time and complete the Date & Time page.
3. Select the Date and Time check boxes and enter the date or time.
4. If you do not know the date or time, enter a description about when the event occurred.
For example, "In the afternoon".
5. Set the time zone for the item.
6. Select how the item is ordered on the chart:
Option

Description

Free

An item is free when it is not ordered and can be
moved anywhere on the chart.

Ordered

An item is ordered when it cannot be moved to
the left and right of other ordered items.

Controlling (Ordered with Date & Time)

An item is controlling when it is ordered and has
both a date and time.
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7. Click OK.
Related concepts
Time zones on page 22
When you create a chart that contains events that take place in different time zones, you can specify in
which time zone each event took place.

Setting the description & grades
All chart items are given grading information. Grades on an item classify or provide an evaluation
of some quality of the information that is represented by that item. For example, if the information is
reliable, confidential or from a trustworthy source.
To set descriptions and grades:
1. Right-click an item, and select Edit Item Properties.
The Edit window is shown.
2. Select Item Properties > Description & Grades.
3. Enter the description.
4. Select the grades to add to an item from the lists in the Grades area. The following system is an
example of one such system, but this grading system might differ in your organization:
Option

Description

Grade 1

A to E and Ungraded
Used for the reliability of the source of the
information, where A signifies that there is no
doubt of the trustworthiness and competence of
the source. E signifies that there is considerable
doubt.

Grade 2

1 - 5 and Ungraded
Used for the confidence in this particular piece
of information that is provided by the source,
where one signifies that the information is known
to be true. Five signifies that the information is
suspected to be false or malicious.

Grade 3

1 - 5 and Ungraded
Used for the privacy rating of the information,
that is, its confidentiality status, where one
signifies that it can be freely disseminated to
other suitable agencies. Five signifies that it
must not be disseminated to anyone without
explicit permission.

5. Select the source type.
For example, a source type might be Informant, Witness, or Officer.
6. Select or enter a source reference.
7. Click OK.
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Related concepts
Provenance information on page 10
The ability to track information to the original source and to assess the reliability of the information or the
source is important in investigations.

Adding an image
You can replace the standard icons that Analyst's Notebook uses for icon, theme line, and event frame
representations with custom images. An image can help to provide extra information.
When you add an image to an entity, it is shown instead of the entity type icon. Images can be used
on the Representation Types: icons, theme lines, and event frames. For example, you can use
photographs to show people, or CCTV images to chart a sequence of events.
To add an image to your selection:
1. Right-click an item, and select Edit Item Properties. The Edit window is shown.
2. Select Style > Picture.
3. Locate the image that you want to add. If you know where the image is stored, you can browse to
this location. You can also paste an image from the clipboard.
Tip: The Picture Preview area of the Edit window shows how the picture appears.
4. Set the size of the image by selecting one of the following options:
Option

Description

Enlargement

Set the enlargement size of the picture.

Custom

Use the slider to change the size of the picture.

5. Click OK.

Adding a chart label
You can use labels to add annotations, chart summaries, or titles to an Analyst's Notebook chart.
To add a chart label:
1. Click the Home tab, and then in the Insert Entities group, click Label.
2. Move the pointer where you want the label to be positioned. When it is over the charting surface, the
pointer changes to show that you are adding a label to the chart.
Tip: To cancel Insert mode, press Esc.
3. Click to add the label.
4. To change the label text, click the label. Enter the text, then click anywhere else on the chart.
Tip: Press Ctrl+Enter to enter a new line of text.

Import data
Data in formats such as text files or spreadsheets can be directly imported into Analyst's Notebook
using import specifications. You can run imports using existing specifications or create your own
designs by using the step-by-step import wizard. Import designs give you control over how Notebook
converts data into entities and links that are placed on the chart surface for analysis.
Before you start importing data, it is important to understand the different paths that you can follow
to achieve a successful result. You can begin the import process with your source data or with an

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 35

import specification. It is also important to note that the appearance and behavior of the user interface
changes, depending on your application and server connections. If you are not connected to an i2
Analyze server, you are working unaligned to a schema and this is referred to as 'classic' mode. Data
that is imported in classic mode cannot be uploaded as a new record in the Information Store.
When you are connected to an i2 Analyze server, the user interface gains more options. The import
process is aligned to your server's schema and the properties and values available depend on the
schema the server is using. Schema aligned import data can be uploaded to the Information Store.
When you are creating or editing an import specification, you also have the option to create custom
item and property types. This is useful if the data that you want to import is not already represented
in your server's schema. Custom item and property types cannot be uploaded to the Information
Store, however they can be saved on the chart and in import specifications. When charts and import
specifications are shared, existing custom types can be selected and used by other analysts.

Import data formats
Analyst's Notebook can import data from spreadsheet files, XML files, and from any text file in which
each line describes a similar but discrete piece of information. For most formats, you create an import
specification to describe how the data is interpreted as entities and links on the chart surface. Some
formats are recognized by Analyst's Notebook and the data is imported without a specification.
Analyst's Notebook can import text and spreadsheet data in the following formats. To import data in any
of these formats, you need to use an import specification to define the entities that are represented by
the data and the links between those entities. An import specification might exist for the format you want
to import, or you can create a new specification to interpret your data. You should convert XML data in
to CSV or XLS format, or transform the data into ANX XML.
Format

Description

Text files (.txt, .csv, .tsv)

In text files that are suitable for import, the lines of
data have a consistent format. The data for one
item is never broken across lines. Data can be
separated by tabs or with a syntactical separator
such as a comma. Some text file formats are
predefined, for example a tab-separated value file
(.tsv) or a comma-separated value file (.csv).

Clipboard

Analyst's Notebook can import text data from
the Windows clipboard in any of the supported
formats.

Microsoft Excel spreadsheet file (.xls, .xlsx)

Analyst's Notebook interprets the rows and
columns of a spreadsheet in the same way that it
interprets the lines and separators of a text file.

If the data is in an XML file format that is recognized by Analyst's Notebook, such as an Exchange file,
an import specification is not necessary.
Note: Data imports from XML files cannot be used to create records in i2 Analyze.
Format

Description

Analyst's Notebook Exchange file (.anx)

Exchange files contain a standardized XML
representation of the data on an Analyst's
Notebook chart.
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Importing with a specification
An import specification defines how Analyst's Notebook interprets data imported from other file formats
and converts the data into entities and links for analysis on the chart surface.
An import specification controls how your data is imported and displayed. You can work with import
specifications in three distinct ways, depending on what is appropriate for your data. You can run your
import with an existing specification, edit an existing specification, or create a new specification.
When you choose your data source, which can be a text file, data on your clipboard, or a spreadsheet,
Analyst's Notebook inspects the data and lists any import specifications that are compatible. You do not
have to use a suggested specification and can create a new specification for any of these data sources.
Note: Depending on the application you use, and whether you are connected to an i2 Analyze server,
there are different types of import specifications. The 'classic' unaligned specifications that are used
in Analyst's Notebook have a file extension of .ximp. The import specifications in Analyst's Notebook
Premium, are aligned to a schema and have a file extension of .oimp. The schema controls what items
are available when you define your import, which is different from a standard template in Analyst's
Notebook. You cannot convert .ximp specifications into .oimp files or upload them to the Information
Store.

Starting from a data source
Analyst's Notebook supports data import from a number of sources. When you select the data
source for your import, Analyst's Notebook examines the data and searches for compatible import
specifications.
To locate files for import:
1. Click the Home tab, and then click Import. A list of options is displayed in a drop-down menu.
Option

Description

Import from File

Opens the Select Data File to Import window.

Import from Clipboard

Opens the Clipboard Preview window and
shows any text data on your clipboard.

Import from Excel Spreadsheet

Opens the Select Data File to Import window
and shows any spreadsheet files.

2. Select the option from the menu that describes the data you want to import.
a) If you select a text file format such as .txt, the Select How to Import the File pane opens.
b) If you select a spreadsheet file format such as .xls, the Select How to Import the File pane
opens with an extra option to select a worksheet. If your spreadsheet contains only a single
worksheet, that worksheet is selected automatically.
c) If you want to select data from your clipboard, you need to copy the data to the clipboard. The
Clipboard Preview window shows the contents of the clipboard. If the clipboard contains the
correct data, click Continue.
If Analyst's Notebook identifies any suitable specifications, they are listed in the Select How to
Import the File window. A flag next to each specification indicates the quality of the match:
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No flag

Column headers in the specification match
column headers in the data source you are
importing. You can use this specification to
import the data in the same way that you
imported previous data with this specification.
No column headers are defined in the
specification. The specification is a match for
the data, based on a comparison between
the format of the data in the first few rows of
the file and the format that is expected by the
specification.
You can use this specification as a template to
create a new specification. The new specification
might not require any changes or only minor
changes to be suitable for your data.
There are incompatibilities between the data
source and the specification. Successful import
is not possible.
Note: Specifications in this category are
not listed unless you clear the List only
specifications that match the import data
check box.

3. To use a specification that is listed to run the import, click Use existing specification, select the
specification, then click OK.
The application displays the Importing window to report on the progress of the import process. The
window contains the following information:
•

The duration of the import process

•

An indication of whether the process was successful

•

A count of how many entities and links were created

4. Optional: In the Importing window, click Save Report to save detailed information about the import
process as an HTML file.
Note: If you do not take this opportunity to save a report, you do not have a permanent record of the
import process.
If your data is not compatible with an existing specification, you can import your data with a new
specification or you can use an existing specification as a template.

Starting from an import specification
You can import data into Analyst's Notebook from a location that is defined by an import specification
rather than starting from the data source.
You can view existing specifications and decide on the importing tasks that are appropriate for the data
you want to import.
1. To use an existing specification to import data from the same location as the last time the import was
run:
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a) From the Home tab, click Import > Saved Specifications. The Import Specifications window is
displayed.
b) Select a specification from the list in the Import Specifications window.
c) In the Importing Tasks pane, select Import with selected specification & last file.
2. To use an existing specification to import data in the same format at the last time the import was run:
a) From the Home tab, click Import > Saved Specifications. The Import Specifications window is
displayed.
b) Select a specification from the list in the Import Specifications window.
c) In the Importing Tasks pane, select Import with selected specification. The Select Data File
to Import window is displayed.
d) Find the file that contains the data that you want to import, and then click Select.
After either of the first two steps, the application displays the Importing window to report on the
progress of the import process.
3. Optional: In the Importing window, click Save Report to save detailed information about the import
process as an HTML file.
Note: If you do not take this opportunity to save a report, you do not have a permanent record of the
import process.
If you want to import data that requires you to create or edit an import specification, you can start from
the Importing Tasks pane. Follow the procedure for creating or editing an import specification.

Creating or editing an import specification
An import specification defines how Analyst's Notebook converts data into entities and links that it
can analyze. When you import data from spreadsheet or text files, you must either create an import
specification, or amend an existing specification to suit your needs.
Importing data into Analyst's Notebook involves choosing a source file and then finding a compatible
specification, or choosing a specification and applying it to one or more source files. If you need to
create or amend an import specification, both paths lead to a step-by-step wizard that allows you to see
how your specification processes the data in a particular source file.
As part of creating or editing an import specification, you provide the wizard with information about the
structure of the data in the source file. The wizard then gives you a fine level of control over how the
data in the file turns into entities and links on a chart. In particular, the wizard allows you to:
•

Specify the format, the separators, and the meaning of white space in the data to be imported

•

Include or exclude rows in the incoming data, individually or through rules

•

Combine values in the data to be imported, or make bulk adjustments to them

•

Specify the types of the entities and links to generate from each row of data

•

Define mappings from the incoming data to the properties of entities and links

•

Choose how Analyst's Notebook determines whether two incoming entities or links are the same

Depending on whether Analyst's Notebook is connected to an i2 Analyze server, the specifications that
you create are different, and those differences are reflected in the steps of the wizard. The sequence
and the purpose of the wizard, however, do not change.
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Setting the import data structure
When you specify a source file (or the clipboard) to the import wizard, it analyzes the contents and tries
to deduce its structure. If the table that the wizard displays is not a good representation of your data (for
example, if the columns do not contain discrete values), you can adjust the settings manually.
To define the structure of the incoming data:
1. On the Define Columns page of the import wizard, set how your data is structured.
Option

Description

Delimited

Within each row, fields in the data are separated
by particular characters called delimiters.
Select any combination of the Comma,
Semicolon, Tab, or Space check boxes.
Optionally, select Other and enter your own
character.

Fixed Width

Within each row, every field has the same width
as the equivalent field in the other rows. Each
field within a row might have a different width,
but the width of a specific field is consistent
throughout every row of the data.
Click the displayed data, and specify where each
field begins:
•

To insert a column break, click in the ruler
area at the position where you want a break.

•

To move a column break, drag its vertical line
to a new position.

•

To delete a column break, double-click it.

By default, the wizard assumes that the incoming data uses the same text encoding as your operating
system. If the table contains characters that you do not recognize, you can tell the wizard to try a
different one.
2. Click Encoding. In the Encoding area, select an encoding option.
Option

Description

Plain Text

The incoming data contains only ASCII text,
which includes only punctuation marks,
uppercase and lowercase Latin alphabetic
characters, and digits 0 - 9.

Regional Settings Default

The incoming data uses the encoding that
the operating system specifies as the system
default.

Other Encoding

The incoming data uses the encoding that you
select from a list.
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The result of using the selected encoding for the incoming data is displayed in the Preview box. If
characters are not correctly displayed, select a different encoding. Otherwise, click OK.
3. When the table in the import wizard displays correctly formatted tabular data, click Next.

Selecting rows for import
If a row in the incoming data is not intended for import, you can configure the import wizard to exclude
it. For example, a row in the data might contain column headers rather than values, or a particular row
might be invalid.
If a row in the incoming data contains column headers instead of values to be imported:
•

Select Extract column headers from row and enter the row number in the adjacent field.
The column headers above the table in the wizard change to display the names from the data.
If some rows in the incoming data are prefixed with a particular character to indicate that they do not
contain values:
•

Select Ignore rows starting with and enter the character in the adjacent field.
Every row that begins with that character is excluded from the import.
After the rules do their work, you can exclude or reinstate individual rows:
•

To exclude specific rows from the import, select the rows in the table and click Exclude Selected
Rows.

•

To reinstate excluded rows, select the rows in the table and click Include Selected Rows.

Rows that are excluded from the import are struck through in the table. The application does not import
excluded rows when you reach the end of the wizard.

Transforming incoming data
It is unlikely that all the incoming data is in the right format to be imported straight away. You might need
to join values in the source together so that they align with properties in the schema. You might need to
format particular values in a certain way. Or, you might need to tell Notebook what to do when it detects
a missing value. For these and similar reasons, you can specify actions that transform the incoming
data.

Combining columns
You can create new values in the incoming data by combining values from the existing columns. For
example, you might combine an "Area Code" column and "Local Number" column to create a "Full
Telephone Number" column.
You combine columns by adding a new column, choosing which existing columns to combine, and
specifying how to combine them. User-defined data columns are identified in the data preview table with
a highlight color.
To merge columns:
1. On the Column Actions page, click New.
The New Column window is displayed.
2. Enter a name in the Enter the name of the new column field.
For example, you might enter "Full Telephone Number".
3. From the Source Columns list, double-click a column or a separator to add it to the Joined
Columns list.
The Joined Columns list specifies the columns and separators that are used in the new column,
and the order that they are used in.
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For example, you might combine an "Area Code" column and a "Local Number" column and
separate them with a space:
a) Double-click "Area Code" in the Source Columns list.
b) Double-click (space).
c) Double-click "Local Number".
4. To change the position of a column or separator in the new column, select the column or separator in
the Joined Columns list and click Up or Down.
5. Click OK.
The new column is created.

Modifying values
You can use column actions to modify incoming data values. For example, you can remove specific
characters, or change the capitalization of text. You can also configure a column action to modify data
only when specific conditions are met.
Through column actions, you can change the text in a column to uppercase, prefix it, or replace it with
a value from a substitution file. Equally, you might decide to remove ordinal suffixes such as st, nd,
rd, and th from (English-language) dates. These transformations are actions, and you can apply any
number of them to individual data columns. The wizard indicates modifications in the data preview table
with a graphic symbol.
The wizard applies actions sequentially, in the order that they are displayed in the Actions Applied list.
If the Stop processing subsequent actions when conditions are met checkbox is selected, a
column action is applied to any value in the column that meets the conditions, but no further actions are
applied to those values.
To create a column action and apply it to a column:
1. Select the column that you want to modify.
2. From the Available Actions list, select a column action and then use the arrow buttons to move it to
the Actions Applied list.
The wizard displays an icon in the header of the selected column to indicate that a column action is
set.
3. Configure the settings for the column action.
The configuration for each action is different.
For example, if you select the Add Prefix action, you must enter the prefix that you want to add.
4. Optional: Configure the column action to modify values only when specific conditions are met.
You can create more than one condition.
a) In the Condition list of the Apply only when the following conditions are met box, select a
condition.
b) Enter an appropriate value into the Value field.
c) Optional: To stop processing subsequent actions when the conditions are met, select the Stop
processing subsequent actions when conditions are met checkbox.
The table at the top of the page reflects the effect of your new column action on the incoming data.
Column actions
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The Analyst's Notebook import wizard provides column actions that can modify incoming data in several
different ways. The following table contains a complete list of the available actions.
Action Name

Description

Add Prefix

Adds characters immediately before the existing value. For example, if
you know that all the telephone numbers in the data have the same area
code, but that code isn't in the data, you can add it.

Add Suffix

Adds characters immediately after the existing value.

Change Capitalization

Changes the case of text. You can change case to lowercase or
uppercase, capitalize initial letters, or reverse the current capitalization.

Compress Repeated
Characters

Replaces a repeated character with a single instance of that character.
For example, automatically generated data might contain extra space
characters that you can use this column action to remove.

Copy Value from Previous
Row

Replaces the value in a column with the value from the same column in
the row above it.

Extract Text using Fixed
Widths

Extracts a range of text from the value in a column by specifying the fixed
positions of its first and last characters within the value. For example,
you might use this action to extract only the hours and minutes from time
values that contain seconds in the incoming data.

Extract Part using
Separators

Splits column values into parts that are separated by a particular
character. You can extract one or a range of parts from the value by
specifying their position within it. For example, using space as the
separator character, the value Andrew Peter Smith is made up of
three parts. To extract the middle name from the value, you type 2 in the
Extract part number box. To extract multiple parts, you can use the Up
to and including part option. Decide which direction you want the count
to begin from and click the corresponding button.

Find and Replace Text

•

From the beginning of the column, you can only include part numbers
that are greater than your first part. For example if your first part is 3,
you cannot include parts 1 and 2.

•

From the end of the column, you can only include part numbers that
are less than your first part. For example, if your first part is 4, you can
include parts 1, 2 and 3.

Replaces a sequence of characters with another sequence of characters.
For example, to remove English ordinal suffixes, you can replace st, nd,
rd, and th with a sequence of zero characters.
Note: This column action can cause unintended changes. For example,
if you replace the st date ordinal suffix with zero characters, words such
as August might be modified too.

Prefix with Another Column Adds the value from another column to the beginning of the value in
the selected column. For example, you can prefix time values with date
values to create a combined date and time column. You can also specify
a separator character to use between the values.
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Action Name

Description

Remove Characters

Removes all occurrences of the specified characters from each value.
You can configure the column action to remove spaces or tabs, and
enter custom characters to remove. For example, to remove ) and ( from
telephone numbers like (863) 555 0140, enter () in the Remove
other characters field.

Remove Prefix

Removes characters only when they appear at the beginning of values.
For example, you might remove "MR " from names like MR SMITH.

Remove Suffix

Removes characters only when they appear at the end of data. For
example, you might remove " Esq" from Andrew SMITH Esq.

Replace from Substitution
File

Replaces specific sequences of characters with other sequences of
characters. For example, if your data contains marital status codes, you
can replace them with words: S=Single, M=Married, D=Divorced.

Replace Value

•

The substitution file can have the extension .csv, .tsv, or .txt.
The file contains pairs of character sequences on each line.

•

Each pair consists of a sequence of characters to find in values,
a separator, and a sequence of characters to replace the found
characters with. The separator can be a tab, a comma (,), an equals
sign (=), or a colon (:).

•

To use a separator character as part of a character sequence,
enclose it in double quotation marks (") or precede it with a backslash
(\). To make the Analyst's Notebook disregard text in the file (to
include a comment, for example), precede it with a semicolon (;).

Replaces a whole value with another value.

Suffix with Another Column Adds the value from another column to the end of the value in the
selected column. For example, you can suffix date values with time
values to create a combined date and time column. You can also specify
a separator character to use between the values.
Trim Characters

Trims unwanted characters such as spaces, tabs, or others from the
beginnings and ends of values. For example, to trim { and } from {Jelicos
Restaurant}, click Trim other characters and enter {}.

Column action conditions
In the Analyst's Notebook import wizard, you can configure column actions so that they run only when
specific conditions are met. The following table contains a complete list of the available conditions.
Condition

Description

Contains

Where the field contains the exact portion of text, which can be at the
start, middle or end of the field.

Does not contain

Where the field does not contain the specified sequence of characters.

Does not end with

When the field does not end with the specified sequence of characters.

Does not start with

When the field does not start with the specified sequence of characters.

Ends with

Where the field ends with the specified sequence of characters.
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Condition

Description

Is blank

Where the field is blank.

Is not blank

Where the field is not blank.

Length equal to

Where the field length (in characters) is equal to the specified number.

Length greater than

Where the field length (in characters) is greater than the specified
number.

Length less than

When the field length (in characters) is less than the specified number.

Regular expression

When the data meets a general pattern set by the specified expression.
For example, the expression [0-9] will match on 1, 2, 3, 4 up to 9.

Starts with

When the data starts with the specified sequence of characters.

Regular expressions in import action conditions
You can use regular expression parameters to define matching patterns that will be used to apply
actions. A regular expression is written as a sequence of characters. The syntax combines text with
special characters to define the pattern.
Table 7: Supported regular expression characters
Character

Description

.

Matches a single character. For example, ABC
123. matches ABC 1234 and ABC 1235.
Note: This character is equivalent to the '?'
character when you are searching for files by
name in Windows Explorer.

^

Matches the start of a line. For example, ^ABC
matches ABC 1234 and ABC 2345 but not 1234
ABC.

$

Matches the end of a line. For example, 1234$
matches ABC 1234 and CBA 1234 but not 1234
ABC.

*

Matches zero, one or more repeats of the
previous character. For example xx* matches xx,
xxxxxxx

[]

Matches any character inside the brackets. You
can specify a range of characters, for example
[0-9], [a-z].

[^]

Matches any characters except the characters
in the list. For example: [^ABC] matches any
character other than "A", "B", or "C".

|

Matches either the expression before the bar OR
the expression after the bar. For example 1234$|
1235$ matches any license plates that end in
1234 or 1235.
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Character

Description

\

Ignores the special meaning of the next character.
For example, abc$|def$|\|$matches any text
that ends in abc, def or |.

Analyst's Notebook does not support extended regular expression combinations (), \(\), \>, \<, \{,
\}, and \digit.

Exporting transformed data
When your import specification includes column actions that transform incoming data, you might need to
track the differences between the data in its source and the data you imported. The import wizard allows
you to export the modified data to a text file before you import it.
You can export the data that was modified by column actions to a comma-separated value file or a tabdelimited text file.
To export your data:
1. In the Column Actions page, click Export.
The Save Data As window is shown.
2. In the Save Data As window, select the folder to save the exported data in.
3. In the File name field, enter a file name for the exported data.
4. From the Save as type list, select the type of file *.txt or *.csv.
5. Click Save.
A file that contains the exported data is created with the specified file name in the selected folder.

Import designs
When you create an import specification, part of the process is to specify an import design. The import
design defines the structure and types of the entities and links that the import wizard creates from each
row in your data.
Creating an import design has up to three stages:
1. If you are working with a classic specification, you can use the Select Design page of the wizard
to select a representation of the relationships between the items you are importing. Otherwise, the
wizard moves straight to the Assign Columns page.
2. The import design appears on the Assign Columns page as a small entity and link chart. You can
edit the small chart to select which types of entity and link are created in the chart when you import
your data.
3. The Assign Columns page is also where you provide the instructions that govern how values in the
incoming data become the property values of entities and links. The Property and Value table, next
to the import design chart, is key to building and creating records.
Note: For a schema-aligned specification, the available entities, links, and properties depend on the
i2 Analyze schema on the server that you connected to most recently. You can add custom item and
property types to model data that is not supported in your current schema.
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Adding entities and links to the import design
The entities and links that you add to the import design in an import specification should accurately
represent the real world data in the import file. A good design results in the creation of appropriate
entities and links in the chart.
The default import design on the Assign Columns page contains two entities that are connected by a
link. You can add entities and links to this basic design to reflect each row of data you want to import
and represent on your chart.
For example, an import file might contain telephone call data that also includes the names of telephone
owners. To represent calls in that situation, you might set the type of each entity in the default design
to Telephone (or Communications Device, or similar), and set the type of the link to Telephone Call (or
Communication). To represent the owners, you might go on to add two Person entities to the design,
and Owner links between each Person and Telephone.
1. To add an entity, click Add New Entity above the import design. Within the import design, the
mouse pointer becomes an empty circle; click the left mouse button to add an entity.
2. To add a link, click Add New Link above the import design. Within the import design, drag a link
between two entities.

Setting entity or link types in the import design
Every entity and every link in an import design must have a type. The default import design contains two
entities and a link as examples to help you set types that reflect your incoming data. To use an import
design, you must set the type for each entity and link it contains.
The entity or link types that you can set depends on the import specification. For a classic specification,
they match the types in the Analyst's Notebook template and you cannot add custom types. For a
specification that is aligned with an i2 Analyze schema, they match the entity and link types in that
schema, unless you set custom types for your import.
•

To set a type for either a classic or an i2 Analyze aligned specification:
a) In the import design, click an entity or a link.
b) In the table next to the import design, select a type from the Type list.
In the aligned case, any types that are invalid because of link end constraints have a red cross
next to them.
When you select a type, the import design displays the entity or link type name. If you selected
an entity type, the entity type icon is displayed in the import design. Link types are numbered
according to how many links you are including in the import design. You cannot change the
summarization of links set by the current schema from the Assign Columns window, however
you can run the import and use Link summarization on the records bar. For more information,
see Link summarization.

Once you have set types for your incoming data, you can configure property values for the entities and
links. If you are working with an i2 Analyze aligned specification, you can also create new custom types
and properties to work with data not supported in your schema. For more information, see Creating
custom entity or link types, and Setting custom properties.
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Creating custom entity and link types
When you are using i2 Analyst's Notebook Premium aligned with an i2 Analyze schema, you can create
your own custom entity and links types.
Usually the chart items you create as part of the import process, are governed by your charting scheme.
Sometimes the values of the incoming data that you want to import might not have a type defined
in your schema. For example, you want to import data about dog thefts that includes "dog owners",
"breeders", and a "purchased from" link, however you cannot find suitable types to use from your
existing schema. You can create new custom types so that your import design closely represents your
data. You can also use custom types that you, or other analysts, have created and saved in charts and
import specifications.
•

To create a new custom entity type:
a) In the import design, click an entity or Add New Entity.
b) In the table next to the import design, highlight the Type row and click the drop-down arrow.
Select New Custom Type from the list.
The New Custom Type dialog box opens.
c) Type a name for your new custom entity type in the Name field.
Name is not the label displayed on the chart, it is the identifier for the new custom entity type.
d) Click Select in the Icon box. From the Choose Icon box, select a suitable icon for your custom
type. You can add your own custom icons to the folder. For more information, see Custom icons.
If you do not select an icon, your custom type has the default icon shown.
e) Click OK.
You cannot edit the name or icon of a custom type once you click OK. If you want to change the
name or icon, you need to delete the custom type on the chart and create another. Alternatively,
you could use Duplication as an easy way to create new types, and carry over custom properties
you have already created.

•

To create a new custom link type:
a) In the import design, click a link or Add New Link.
b) In the table next to the import design, highlight the Type row and click the drop-down arrow.
Select New Custom Type from the list.
The New Custom Type dialog box opens.
c) Type a name for your new custom link type in the Name field.
Name is not the label displayed on the chart, it is the identifier for the new custom link type.
d) Select the default summarization for your custom link from the options Single, Directed or
Multiple.
If you select link summarization of Single or Directed, the link label is the number of records of the
type that the link contains. This is shown as <record count> in the import design. If you create
custom properties on the link type and choose to include the properties in the label, the label is
visible in the record inspector after you run the import.

Your custom entity and link types are available to use in your import and can be saved as part of the
import specification.
Note: Records of custom types cannot be uploaded to the Information Store or used as seeds for
External Searches in i2 Connect.
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Duplicating custom entity and link types
When you are using i2 Analyst's Notebook Premium aligned with an i2 Analyze schema, you can
duplicate custom entity and link types.
You might want to create new custom entities and links that share a number of properties with types you
have already created. The custom type duplication feature means you can use existing custom types to
create new types, as part of the import process. For example, you create a custom type of "Sports Utility
Vehicle" and add properties for "Make", "Model", "Color", "Engine Size", "License Plate", and "Chassis
Number". You want to import data for a custom type of "Truck" that includes the same properties as
those you selected for your "Sports Utility Vehicle", and you might want to add more that are specific
to trucks. Duplication is a useful way to save the time and effort of creating similar types from scratch.
You can also duplicate custom types that you, or other analysts, have created and saved in import
specifications. System types, that is the entities and links defined in your schema, cannot be duplicated.
Note: Records of custom types cannot be uploaded to the Information Store or used as seeds for
External Searches in i2 Connect.
•

To duplicate a custom entity type:
a) In the import design, click Add New Entity.
b) In the table next to the import design, highlight the Type row and click the drop-down arrow.
Select the custom type that you want to duplicate from the list.
The new entity name and icon become the same as the type you chose, and the custom
properties are displayed.
c) With the new entity selected, highlight the Type row and click the drop-down arrow. Click
Duplicate Type.
The Duplicate Entity Type dialog box opens and the Name field is blank.
d) Type a name for your custom type in the Name field. You cannot use the name of an existing
type. From the Choose Icon box, select a suitable icon for your custom type. You do not have to
choose a different icon, however you will not be able to change the icon once you click OK. You
can add your own custom icons to the folder. For more information, see Custom icons.
e) Add more custom properties if required.
f) Click OK.

•

To duplicate a custom link type:
a) In the import design, click a link or Add New Link.
b) In the table next to the import design, highlight the Type row and click the drop-down arrow.
Select the custom type that you want to duplicate from the list.
The new link name becomes the same as the type you chose, and the custom properties are
displayed.
c) With the new link selected, highlight the Type row and click the drop-down arrow. Click Duplicate
Type.
The Duplicate Link Type dialog box opens and the Name field is blank.
d) Type a name for your new custom link type in the Name field. You cannot use the name of an
existing type.
e) Select the default summarization for your custom link from the options Single, Directed or
Multiple.
If you select link summarization of Single, the link label is the number of link records of the same
type, and is displayed as <record count> in the import design. If you create custom properties
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on the link type and choose to include the properties in the label, the label is visible in the record
inspector after you run the import.
f) Add more custom properties if required.

Using existing custom entity and link types
You can use custom types that have been saved in other import specifications.
You are investigating organised dogfighting for example, and want to create a new import specification.
Some of the data in the import is not represented in your schema, however you recently created some
custom entity and link types for a dog theft case that might be useful in your current specification. You
can search through saved specifications and select from any of the custom types they contain. You can
choose to use existing custom types as they are, or as the basis for new types. This can save you the
time and effort of creating new types and properties, where existing types already contain the same or
similar properties.
Note: Records of custom types cannot be uploaded to the Information Store or used as seeds for
External Searches in i2 Connect.
1. In the import design, click Add New Entity, or Add New Link.
2. In the table next to the import design, highlight the Type row and click the drop-down arrow. Click
Existing Custom Type.
A window opens showing any saved specifications that contain custom types, and details about them
such as author and date of last modification.
3. Click a specification to see the custom types and properties that are present in that specification.
You can resize the columns if required.
4. Click to highlight the name of the custom type you want to use.
5. Click OK.
The custom type and its properties appear on the import design.

Setting custom properties
You can set custom properties for both the entity and link types supported in an i2 Analyze schema, and
for custom types created by you and other analysts.
Usually the chart items you create as part of the import process, are governed by your charting scheme.
Sometimes the values of the incoming data that you want to import might not have a property setting
defined in your schema. For example, you want to import data about dog thefts that includes "types of
dog" and "microchip identity numbers", however you cannot find suitable properties to represent this
data. You can create new custom properties so that each of these columns can be assigned in the
import process. It is important to understand how to build and create records outside of the charting
scheme. Entity chart items use the icon of the entity type you choose in the design, and the label is the
record label of the lead record. The link summarization setting for link chart items decides the label,
which is either the record label or record count. For both custom entity and link types, no attributes are
created or chart item properties mapped to. You must also specify logical types to tell the import wizard
what sort of data it is processing. These are usually determined by the logical types in your schema,
however you need to specify a logical type for a new custom property at the time that you create one.
1. In the import design, click an entity or a link.
The record or item properties are displayed in a table next to the import design. If you are working
with a new custom type, only the type is displayed because other values have not yet been specified.
2. Click New Custom Property.
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3. Type a name for your new property, and click the check box if you want to include the property name
in the item's label.
You cannot create a new property with a name that you have already used in this import
specification, even if you choose a different logical type.
4. Select a logical type and variant. The default is a single-line text string.
In all instances, other than single-line text, the logical type is displayed in brackets next to the
property. For example Microchip number *(Integer).
5. Click OK.
The property is created with a * next to the name, to indicate it is a custom property. The value
remains (not set) until incoming data is assigned.
6. Repeat the process until you have created the required properties for the item. You can delete
custom properties, toggle the label inclusion option and move properties up and down in the list,
using the buttons beneath the list.
Once you have created the properties you need to model the incoming data, you can assign columns
to the relevant values in the import wizard. You can return to the Assign Columns page to add or delete
custom properties at any time before running the import.
Note: Custom properties on i2 Analyze schema types cannot be uploaded to the Information Store or
used when present on seeds for External Searches in i2 Connect.
Logical types and variants
When you set custom properties in i2 Analyst's Notebook Premium, you need to define logical types and
variants to determine the type of data stored in the property.
Usually logical types are defined by your schema, however you override the schema settings when you
set custom properties in the import wizard. It is important to select the correct logical type for the data
that you would like to store, and the type of analysis that is needed.
These are the logical types you can specify and when you might use them:
Logical type

Variant

Description

Text

Single-line string

Use this option for properties
such as names or categories.
The default length for single-line
strings is 250 characters.

Multiple-line string

Use for descriptive sections of
text, up to 32,700 characters.

Integer

Use Integer for counting
numbers. Integers are whole
numbers and values can be
positive or negative.

Double

Use Double for measurements
other than financial values.

Decimal

Use Decimal for financial values.

Date & Time

Use for values that occur at a
specific instant. The timezone
can be selected on the Date &
Time Format page.

Number

Date & Time
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Logical type

Boolean

Variant

Description

Date

Use for properties where the
value is the entire day.

Time

Use for time only values that
don't apply to a specific date.

Boolean

Use for properties whose values
are either "Yes", "No", or "No
value".

Assigning incoming data to entity and link properties
After you create an import design, you can configure how the property values of imported entities and
links are set from the incoming data.
You can use values from incoming data as the property values of the entities and links that Analyst's
Notebook creates during the import process. For example, you might set the Call Duration property of a
Telephone Call link from a value in the Duration column of an import file.
Note: The details of assigning data are different, depending on whether you are working with a
schema-aligned or a classic import specification:
•

In a classic specification, you can assign values to the properties of Analyst's Notebook items, and to
cards and attributes on those items.

•

In a schema-aligned specification, you can assign values to the properties of i2 Analyze records.

In some cases, you can assign values from more than one column of import data to a property. For
example, a Full Name property might consist of data from a Given Name column and a Surname
column.
To configure how a property value is set from incoming data:
1. In the import design, click an entity or a link.
The record or item properties are displayed to the right of the import design.
2. Drag a column from the preview table at the top of the wizard to a cell in the Value column of the
property list.
The column name is displayed in the property table within square brackets. For example,
[Duration].
3. To assign more than one column to a property value, hold the Shift key and drag a second column
to the cell in the Value column of the property table. The second column is also assigned to the
property value, and is separated from the first column by a space.
For example, [First Name] [Surname].
Note: You can use this technique to assign multiple columns to single-line text, multiple-line text, or
'suggested from' properties (lists that you can type other values into). To achieve the same effect for
other properties, use column actions to create columns that contain multiple values before you reach
this point.
4. If you are working with a classic specification, then you must assign a column to the "Identity"
property of an entity that uniquely identifies it on the chart.
Depending on the data, you might use the number of a telephone, or the license place of a vehicle,
for example.
5. Choose what action to take when the import wizard encounters a blank value in a column.
a) Select the property name, and then click the browse button that appears next to the value.
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b) In the window that opens, choose whether to replace a blank value with a fixed value.
c) If you are working with a classic specification, and the blank value is for the identity of an entity,
choose one of the following options:
•

Do not create the entity

•

Create the entity with a blank identity

•

Create the entity and set its identity to, then enter a value.

Setting the direction of links
By setting the direction of the links that you import, you can show the flow of money in a financial
transaction, for example, or the instigator of a telephone call. You can give every link the same direction,
or you can set the link direction from values in the incoming data.
To set the direction of an imported link:
1. Select a link in the import design.
The property table is displayed to the right of the import design and contains the Direction
property.
2. In the property table, browse in the Direction row.
The Edit window opens.
3. To assign the same direction to each link that is imported as a result of the design, select Direction
from... and then choose a direction from the list.
4. To assign direction from values in the incoming data:
a) Click Single column, and select the column that contains the data that determines link direction.
b) In each Value field, enter the value that indicates that the link direction is set as illustrated. The
Value field is case-sensitive.
c) In the Any other value list, select a direction to assign any link that is not assigned a direction as
a result of the previous step.
d) Click OK.

Setting the strength of links
If you are working with a classic import specification that is not aligned to an i2 Analyze schema, you
can set the strength of imported links. You can give each link the same strength, or you can set link
strength from values in the incoming data.
Setting the strength of the links that you import can provide a visual representation of your confidence
in the data. For example, if you set the link strength to Tentative, the links display as dotted lines
instead of solid ones.
To set link strength:
1. Select a link in the import design.
The property table is displayed to the right of the import design and contains the Strength property.
Unless previously modified, the property has a default value of Confirmed.
2. In the property table, select the Strength row, and then click the browse button that appears.
The Edit window opens.
3. To assign the same strength to each link that is imported as a result of the design, click Strength
and select a link strength from the list.
4. To assign strengths from values in the incoming data:
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a) Click Single column, and select the column that contains the data that determines link strength.
b) Optional: Select the Replace blank value with check box, and select a strength to assign when
no values are present in the data.
c) Click OK.

Setting grades for imported items
If you are working with a classic import specification that is not aligned to an i2 Analyze schema, you
can set the grades of imported items. Grades typically indicate source quality and information quality;
each chart has its own grading scheme.
To set a grade:
1. Select an item in the import design.
The property table is displayed to the right of the import design and contains the Grade properties.
Unless previously modified, each grade has a default value of (lowest).
2. In the property table, select each grade row in turn, and click the browse button that appears.
The Edit window opens.
3. To assign the lowest grade to every imported item, select Lowest grade.
4. To assign the same grade to every imported item, select Grade and then choose a grade from the
list.
5. To assign a grade from values in the incoming data:
a) Select Single column, and select the column that contains the data that determines the grade.
b) Optional: Select the Replace blank values with check box, and select the grade to assign any
item that does not receive a grade as a result of the previous step.
c) Click OK.

Setting date and time formats
Often, the data that you import into Analyst's Notebook contains date and time information. In general,
this information can come in a range of different formats. If your data contains dates and times, your
import specification must tell the application how to interpret them.
You must specify how the values in each date, time, or date & time column that you assigned on
the Assign Columns page are formatted. To provide location context for date & time values, you
must select a time zone. If you do not specify the correct format, the application might import the data
incorrectly or fail to import the data at all.
As soon as you assign an incoming column to a date, time, or date & time property in the design, the
import wizard gains a Date & Time Format page. To set a date and time format:
1. Click a column in the table at the top of the page.
If the values in the column do not match the selected format, a yellow triangle is displayed in the
column header. A yellow triangle is also displayed next to any values for which the format is invalid.
2. Select a predefined date and time format, or enter a custom format:
a) To use a predefined date and time format, click a format in the list.
Each row contains an example of the format in use, and a description. If the format is not valid for
the data in the column, a warning is displayed in the table.
Note: A valid date format might not be the correct date format. For example, 10 December 2013
can be expressed as 10/12/2013 or 12/10/2013. If your import data expresses 10 December 2013
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as 10/12/2013 within a column, the mm/dd/yyyy date format is valid for that column, but is not
correct.
If you think you have the correct format but the yellow triangle still appears, check the values
in your date and time columns for extra characters such as spaces. You can remove unwanted
characters by using Trim Characters on the Column Actions page.
b) To use a custom format, enter a date and time format in the Custom format field.
An example date and time value with that format is displayed in the adjacent field. If the format is
not valid for the data in the column, a warning is displayed in the table.
Tip: If an existing format is similar to the one you want to set, click a format in the list of
predefined formats and modify it.
3. Change the time zone of the source data, unless you want your import to default to the same time
zone as the chart.
If you are working with Analyst's Notebook Premium, and have set new Date and time only custom
properties, you can select time zones on the Date & Time Format page. You can have a number of
columns that contain date and time properties, therefore you can set different time zones for each if
required.
Note: Although Analyst's Notebook allows you to set the time zone for custom properties that are
date only or time only, when you run your import these properties default to the same time zone as
the chart.
4. If you set custom types with date and time, or date, or time properties in your import design, you can
enable copying to timeline charts on the Date & Time Format page. This function is available for
custom types only. The charting scheme sets the item date and time for you when you use types
specified in your i2 Analyze aligned schema.
Date and time properties in the import design can now receive values from the incoming data correctly.

Matching records using system rules
When you are creating or editing an import specification that is aligned with an i2 Analyze schema, you
can tell the import wizard to use system match rules to identify duplicate system records on your chart,
and in the Information Store.
When you use system rules to identify and resolve duplicate information, you limit the unnecessary
creation of new records. For example, your incoming data might contain details about a person that
match with a record in the Information Store. If that record was ingested from an external source, it
is regarded as system governed. Analyst's Notebook selects the system record for that person entity
rather than creating a new record. If your data matches with a record that is uploaded by another
analyst, that record is used instead of creating a duplicate. Missing values in analyst governed records
can be enriched by a range of incoming data, whereas system governed records gain security and
source reference updates. The system rules are defined by your system administrator. For link
matching, the rules are set to exact matches on link direction, and match with the same pair of end
records.
1. Click the check box to select System Matching.
The wizard compares the property values that you assigned in Assign Columns to the system rules.
If the system rules require further assignments, a flag appears next to System Matching.
2. Hover your mouse pointer over the flag to see a detailed message about your import.
You can proceed with your import without assigning the required property values, although revisiting
your import design at this stage can improve the quality of your record matching. For example, in
your import design you might have assigned a property value of Last Name to a Person entity. If you
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have a system rule that looks for a match on Last Name, this identifies matches in your import data
and in the match locations you select. However, if the system rule specifies Last Name and Passport
Number, the wizard tells you which value is not assigned. You can return to Assign Columns and
add more property values to satisfy the requirements of the system rules before you run the import.
3. Click the check boxes to select the locations to include in record matching. The import process uses
the system rules to identify matches in the incoming data, with Information Store records, and on
your target chart.
When you run the import, a progress window is displayed. If matches are found, the import is paused.
Another window is displayed that shows you the number of matches between the imported data and
records from the locations you selected. This information is to help you understand what is happening
to your records during the import process and what other actions you might take. For example, if your
import data matches with records in the Information Store, you might want to use the Get Matches
function to identify them.
Click Continue to proceed with the import. When the import completes, a message is displayed to show
timing details and the numbers of records that were created or replaced. Alternatively, you can click
Cancel to end the import and return to the chart.

Matching records locally
When you are creating or editing an import specification that is aligned with an i2 Analyze schema, you
can tell the import wizard to use local matching to identify duplicate records in your incoming data, and
with records on your chart.
Local matching is useful for identifying multiple records in the incoming data and on the chart. For
example, a file that contains telephone call data is likely to refer to the same telephone more than
once. In that case, you probably want the chart to contain a single telephone entity with links to other
telephones, rather than lots of separate one-to-one relationships. Analyst's Notebook also tells you
if information in your data import already exists on your target chart. If you do not need to search for
duplicates in the Information Store, local matching gives you more control over the properties you are
most interested in, as you define the matches during the import process. Also custom types cannot
be matched with records in the Information Store. If system matching is unchecked on the Record
Matching page, you can use local matching for system and custom types. Alternatively, you can check
system matching to run at the same time as local matching. System types are matched against the
rules defined by your system administator, while custom type matching is defined by you. Note that for
custom types to match, they must have the same name and identifier.
1. Examine the Imported types box, which contains a list of the entities and links in your import design.
The list includes both system and custom types. If you click the check box for system matching, any
system types that are used in system matching rules are removed from the list.
2. Select the type that you want to work with.
The available options are different, depending on whether you choose an entity type or a link type.
For entity types, you specify which property values must match in order for two incoming entities to
be considered as duplicates. When the values of all the selected properties match, only one of the
entities is imported. If a selected property has no value (but all of the other values match), you can
decide whether to treat it as a duplicate.
For link types, you have the additional option never to consider two links as duplicates, regardless
of any property values. Furthermore, the list of properties implicitly includes the direction of a link.
When two links have different directions, they are never treated as duplicates.
3. Decide which property values determine what constitutes a match in your data.
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For example, it might be reasonable in some cases to match Person entities according to the
combination of their given names and surnames. For data from a different source, you might use a
passport number or social security number instead.
4. Click the check boxes in the Identity column to specify the properties to use for matching.
Imported types without any selected properties have a yellow triangle next to their name. If
properties are selected, the triangle changes to the icon for that type. This is the case for both
system and custom types.
5. To prevent the import of less complete records, click the check box for Do not import a new record
if any of the selected properties have blank values. This means that if any of the properties
you select for matching have blank values, the import wizard ignores those records. This option is
unchecked by default.
When you run the import, a progress window is displayed. If matches are found with records on the
chart, the import is paused. Another window is displayed that shows you the number of matches
between your imported data and charted records. This information is to help you understand what is
happening to your records during the import process. Duplicate records in the incoming data are not
imported, if you chose to match on a specific property. For example, if your data contains 1000 records
for the same main telephone number and you chose to match 'Main number', only 1 record for that
telephone number is placed on the chart. If your incoming records contain more properties than the
matched record on the chart, that record is enriched so the data is not lost.
Click Continue to proceed with the import. When the import completes, a message is displayed to
show timing details and the numbers of records that were created or replaced. The Analyst's Notebook
records bar gives more information about the types of records now on your chart. Alternatively, you can
click Cancel to end the import and return to the chart.

Complete import details
On the Import Details page of the import wizard, you can specify summary information about the import
specification so that you can review it quickly in future. It also gives you the ability to provide some
global settings for the import process.
On the Import Details page, you can:
•

Add summary details for the specification, such as subject, author, or category information.

•

Include custom details, such as codes or classifications that are specific to your organization or
investigation.

•

Determine whether entities and links are imported to the current chart or a new chart.

•

Set whether new chart items are also selected, and whether the selection should add or replace an
existing one.

•

Choose a layout to apply to the new chart items.

•

Place minimum and maximum limits on the number of links between any two entities.

•

Enable a "verbose" mode that performs and reports on the import process row-by-row.

•

Remove blank entity records and blank link records.

•

For a specification that is aligned with an i2 Analyze schema:
•

you can specify the security setting that all imported records receive.

•

you can add source references to records as they are imported to the chart and choose to be
prompted to update the values each time you run the import specification.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 57

These features are either not mandatory or they have default settings. If the other pages of the wizard
are complete, you can import data with your specification.

Setting the occurrences of imported links
Depending on the nature of the incoming data, you might not want to create connections between
entities when the number of links falls outside a defined range. You can also decide not to import
entities that are connected to only one other entity.
1. On the Import Details page, select Link occurrences removed to open the Link Occurrence
Options window.
2. Select a check box and enter values in the corresponding boxes, as follows:
Option

Description

Remove links with occurrences below

Connections are not created (and their links are
not imported) when they would contain fewer
than the specified number of links. The value
must be greater than or equal to one.

Remove links with occurrences above

Connections are not created (and their links are
not imported) when they would contain more
than the specified number of links. The value
must be greater than or equal to zero.

Remove single connections

Entities are not imported when they have only
one link within the incoming data. Both the entity
and the link are discarded.

Important: Use the Link Occurrence Options with caution. In removing entities and links during
the import process, you might discard information that is crucial to the analysis.
3. Click OK.
Your changes are confirmed on the Import Details page. You can change this option before you run
the import.

Removing blank records
Sometimes the data you want to import is incomplete, resulting in the creation of records that contain no
properties. On the Import Details page, you can choose whether or not to remove blank entity and link
records.
Your incoming data might not have values for some of the assigned properties in your import
specification. To prevent the unnecessary creation of these chart items, the default setting for new
import specifications is to remove blank entity records. You can set the options in your import details
to also remove blank link records. You can also decide to only remove blank link records, or you can
deselect both options.
1. On the Import Details page, look at the blank records options in the central column.
The check box next to Remove blank entity records is already selected. The option to Remove
blank link records is not selected.
2. Set the options to suit the requirements for your import specification, or leave them unchanged to
remove only blank entity records.
3. When the Import Details page is complete, click Import to run the import specification.
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Applying a layout to an import specification
On the Import Details page of the import wizard, you can apply automatic layouts to the chart that
receives any new items. Layouts are applied in the sequence in which they are displayed in the list, with
the layout at the top of the list applied first.
The layout properties in the Select Layouts window are similar to the properties that are displayed
if you click the Arrange tab, click Layout Setup, and then select a layout from the list. However, any
changes that you make in the Select Layouts window are saved only in your import specification. The
layouts that you can select for your import are guided by the type of chart you generate.
To set the layout of the chart that contains new items:
1. On the Import Details page, click Change in Layout imported items using.
2. Double-click a layout in the Available Layouts list. The layout is added to the Layouts Applied List.
3. Set the properties for the selected layout. The available properties vary from layout to layout.
4. Optional: Select the Layout imported items only checkbox to apply the layout only to the new
items, rather than the whole chart.
5. Click OK to return to the Import Details page.

Setting the security of imported records
An import specification that is aligned with an i2 Analyze schema must include the security dimension
values that records receive as they are created. Initially, the values in the specification match the
defaults in your user settings, but you can change this behavior on the Import Details page.
For a schema-aligned import specification, the Import Details page includes a list of all the dimensions
in the security schema of the i2 Analyze deployment.
The procedure for providing default values is different for single-value and multi-value dimensions:
1. In the Security for imported records section of the Import Details page, choose the security
dimension for which you want to change the default value.
2. For a multi-value dimension, click the button to display the edit window, select all the dimension
values to use, and then click OK.
3. For a single-value dimension, use the drop-down list to select a default security value.

Saving an import specification
Analyst's Notebook supports saving import specifications during and after the creating and editing
processes. You can use a saved specification to import an updated version of the same data, or to
import new data that has a familiar format.
To save a new import specification, or to save changes to an existing specification:
•

On any page of the Edit Import Specification window, click Save.

If you are creating an import specification, the application prompts for a name.
To create an import specification from one that is already open for editing:
•

On any page of the Edit Import Specification window, click the arrow next to Save, and then click
Save As.
The application prompts for a name for the new specification, and then opens the duplicate for
editing.
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Managing import specifications
Analyst's Notebook supports a range of facilities for managing and organizing the import specifications
that you and others in your team create. As well as using the standard functions for renaming and
duplicating specifications, you can configure local and shared storage locations.
The tools for managing import specifications fall into two categories. You can change the behavior of the
application for all specifications, or you can operate on particular specifications.
Analyst's Notebook supports storing import specifications in two locations that it calls "local" and
"workgroup". When you save a specification, you can choose which location it is stored in. You can use
configuration settings to change the target of both locations.
•

Change the physical folders that the application uses as the "local" and "workgroup" folders:
a) In Analyst's Notebook, click the Home tab, and then click Import > Saved Specifications.
The Import Specifications window is displayed.
b) In the Other Tasks pane, select Change Local Folder or Change Workgroup Folder.
The Browse For Folder window is displayed, with any current setting selected.
c) Select or create a target folder, and then click OK.

Note: The intention is for the "workgroup" location to be a shared folder, but the application does
not enforce that guideline.
Analyst's Notebook displays import specifications from the "local" and "workgroup" locations in a single
list. The list of operations that you can perform then changes according to which (and how many)
specifications you select.
•

Perform file system operations on one or more import specifications:
a) In Analyst's Notebook, click the Home tab, and then click Import > Saved Specifications.
The Import Specifications window is displayed.
b) Select one or more import specifications.
c) In the Specification Tasks pane, select one of the commands:
Option

Description

Edit

Open the import specification for editing.

Rename

Edit the name of the import specification that
you (and potentially other users) see in the
Saved Specifications window.

Duplicate

Create a duplicate of the import specification.
The new specification has the same name as
the original, with the prefix "Copy of ".

Copy to Workgroup Folder

If the import specification is in the "local"
location, copy it to the "workgroup" location.

Show data file in Explorer

Open Windows Explorer at the location
of the data file that is stored in the import
specification.

Show specification in Explorer

Open Windows Explorer at the location of the
import specification.

Delete

Delete the import specification.
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By default, the Import Specifications window displays specifications that are relevant to your context.
In Analyst's Notebook, you see classic specifications. In Analyst's Notebook Premium with Opal
services, you see schema-aligned specifications. However, you can also work with classic specifications
in Analyst's Notebook Premium:
•

In the Options pane of the Import Specifications window, select Show classic specifications.
Any classic specifications in the "local" or "workgroup" locations are added to the list.

Automating file imports
If you have files in the same format that you regularly import, you can automate the process with a
command prompt utility. The import process can create items in a new or an existing chart.
Series Import is a command prompt utility that opens Analyst's Notebook if it is not already open. It then
automatically runs a named import specification to load data into the chart.
This utility allows multiple import specifications to be run without manual user intervention. A batch file
(.bat) can call the Series Import utility as many times as you need.
Note: To use Series Import with schema-aligned import specifications, you must include the file
extension .oimp when you create a batch file. For example, SeriesImport -b filename.oimp c.
1. Create import specifications by using the standard import wizard.
2. Create a batch file that references your import specifications.
3. From a command prompt, run the batch file.

Example single file import
You can automatically run a single import specification against its associated data source. This example
creates a chart and adds the example data to it.
SeriesImport -b Example 1 Specification -c

Running this command results in the following actions:
•

A new chart is created from the Standard template and given a default name, for example Chart1.

•

The Example 1 Specification import specification is run, importing the data file Example 1.txt (set
in the import specification).

Example batch import
Using a batch file, you can run a series of imports that add data into multiple charts.
SeriesImport
SeriesImport
SeriesImport
SeriesImport

-b
-b
-b
-b

Example
Example
Example
Example

1
1
3
4

Specification
Specification -i Example 2.txt -c
Specification -p Military.ant -c
Specification -p Standard.ant -f

Running these batch files results in the following actions:
1. The Example 1 Specification import specification is run, importing the data file specified within
the specification. If a chart is already open, the data is imported into the existing chart.
2. The Example 1 Specification import specification is run, importing the data file
Example.2.txt. The data is imported into a new chart.
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3. The Example 3 Specification import specification is run, importing the data file specified within
the specification. The data is imported into a new chart that is created from the Military template.
4. In the same chart, the Example 4 Specification import specification is run, importing the data
file specified within the specification. The Standard template is merged with the original Military
template.

Importing data in XML format
Analyst's Notebook can import data that is stored in XML files if the files are converted to another format
or you provide a style sheet that transforms the data to a compatible format.
You could convert XML files to CSV or XLS format and build a specification to import your data.
Alternatively, you can transform XML data into Analyst's Notebook Exchange files with an XLST style
sheet. XML data that is converted into ANX XML structure can be imported into Analyst's Notebook
without an import specification.
•

To import XML data in Analyst's Notebook Exchange, you specify the location of the source file and
some processing instructions.
a) Click the Home tab, and then click Import > Import from Analyst's Notebook Exchange File.
Note: Despite its name, this command supports importing data in any XML format, not only
Analyst's Notebook Exchange files.
b) In the Select Data File to Import window, locate the file that contains your data, and then click
Open.
c) In the Import XML window, configure the behavior of the XML import wizard:
Apply Style Sheet

If you are not importing an Analyst's Notebook
Exchange (.anx) file, select this option and
specify an XSLT style sheet. The style sheet
must transform the XML so that it validates
against the Analyst's Notebook schema.

Create New Chart

Select this option to import the data into a new
chart instead of the current chart.

Layout Imported Items

Select this option to apply a peacock layout to
the imported data. Any items that are already
on the chart are not affected.

Enable Enhanced Validation Rules

Select this option to perform more careful
validation before the data is imported.

d) Click OK to import the data from the XML file that you selected.
When the import process finishes, the application displays a message that indicates the success or
failure of the process. If the import fails, the message includes the location of a log file.
Note: Data imports from XML files cannot be used to create records in i2 Analyze.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 62

Working with i2 Analyze
If you are using Analyst's Notebook Premium, you can connect to i2 Analyze and, depending on your
deployment, access intelligence data from within your organization and from external sources.
An installation of i2 Analyze can contain an Information Store, that is a structured store for intelligence
data, a framework for connecting to and retrieving intelligence data from external sources, and a
searchable store for Analyst's Notebook charts that analysts can use for storing, and for sharing work
with their peers.

Create i2 Analyze chart items
You can create chart items that contain i2 Analyze records. These records can contain information that
you receive from other sources, or information that you assert based on your analysis.
When you first create a chart item that contains an i2 Analyze record, the record only exists in the chart
item on your chart. When you are ready to share this information, you can upload the record into the
Information Store.
You can create duplicates of a chart item that contains an i2 Analyze record, to use as the basis for a
similar record. Duplicate records gain a new record identifier but retain all properties, source identifiers,
source references, notes and security classification. It is useful to use duplicate records if you want to
create a series of similar records on the chart, for example you are charting a number of vehicles of the
same make.
Analyst's Notebook Premium includes a record bar beneath the ribbon to provide information about the
numbers and types of records on your chart, and their state. You can use the record bar to select the
records that you want to work with quickly.
All records
Entity records

Entity records for the most recent i2 Analyze
server

Link records

Link records for the most recent i2 Analyze
server

Analyst governed records

Records for the most recent i2 Analyze
server that were created by analysts

System governed records

Records that were preloaded into the most
recent Information Store

Chart only

Records for the most recent i2 Analyze
server that are not in its Information Store

Information Store

Records that are in the most recent
Information Store

Not uploaded

Records that are aligned with, but not in, the
most recent Information Store

Edited; can be uploaded

Records that have been edited and can be
uploaded to the most recent Information
Store

New or edited
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Edited; upload is blocked

Records that have been edited but are
blocked from upload by changes in the most
recent Information Store

Unaligned

Records for the most recent i2 Analyze
server that are not aligned with its
Information Store

Changes available; no chart
edits

Records with changes in the most recent
Information Store but no edits on the chart

Changes available; edited on
chart

Records with changes in the most recent
Information Store and edits on the chart

Orphaned

Records that are no longer available from the
most recent Information Store

Changed in store

Creating i2 Analyze entities
i2 Analyze entities store their important information in records. To create entities that contain records,
drag your selection from the Information Store palette and enter property values in the Record
Inspector.
In a chart, the first time that you connect to the Information Store, a new palette is created that contains
all of the types in your Information Store.
When you create an i2 Analyze entity, that item contains an i2 Analyze record. You can enter values for
some or all of the record properties, and you must enter values for mandatory properties. You can
1. Ensure that the Information Store palette is displayed. This palette contains the entity types that
correspond to the types in your Information Store.
If the Insert from Palette pane is not visible, click the Home tab, and then click Insert from Palette.
If there is more than one palette, you can select the Information Store palette from the palettes list at
the top of the entity section of the pane.
2. Optional: To create an entity that has a representation other than icon, select the representation at
the top of the Insert from Palette pane.
Note: You cannot create an i2 Analyze entity with the OLE Object entity representation.
3. Drag the entity type that you want to create from the palette onto the chart.
The Record Inspector displays the record that you created. The property types that are initially
displayed correspond to the following property types from the Information Store:
•

Properties whose values are used in the record label

•

Mandatory properties

4. Enter values on the Properties page of the Record Inspector.
You can enter values for properties that are not listed by using the plus button on the Properties
page. As you create further entities, the Record Inspector remembers which properties you typically
use.
5. Optional: To create a duplicate entity, select the target entity on the chart. On the Ribbon menu,
click Copy > Duplicate, from the Home tab or right-click on the selected entity and choose
Duplicate from the screen menu.
When you save your chart, the i2 Analyze entity that you created is saved.
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When you are ready to share information, you can upload the records that you create to the Information
Store.

Creating i2 Analyze links
i2 Analyze links store their important information in records. To create links that contain records, drag
your selection from the Information Store palette and enter property values in the Record Inspector.
In a chart, the first time that you connect to the Information Store, a new palette is created that contains
all of the types in your Information Store.
When you create a link that has one of these types, an i2 Analyze record is created in the item. You
can enter values for some or all of the record properties, and you must enter values for mandatory
properties.
To create an i2 Analyze link, the entities that you connect must contain i2 Analyze records, and the link
type that you use must be permitted between the two entities according to the rules of the Information
Store. For example, it might be permitted to connect two people by an association link but not by an
owner link.
When a chart item contains multiple i2 Analyze records, such as when two i2 Analyze entities are
merged, one of the records is assigned to be the lead record. When you create an i2 Analyze link that is
connected to an i2 Analyze entity, the link record is connected to the entity's lead record.
1. Ensure that the Information Store palette is displayed. This palette contains the link types that
correspond to the types in your Information Store.
If the Insert from Palette pane is not visible, click the Home tab, and then click Insert from Palette.
If there is more than one palette, you can select the Information Store palette from the palettes list at
the top of the link section of the pane.
2. If either of the entities that you want to connect contains multiple i2 Analyze records, ensure that
the appropriate record is assigned as the lead record in each entity before you create your link. To
assign a new lead record:
a) Double-click the entity to display its records in the Record Inspector.
b) Select the record to assign as the lead record in the list view.
c) Click More actions

(
> Set as lead .
The lead record is changed. As a result, the label and the icon on the chart might also change.
3. In the palette, click the link type that you want to create, then drag between the two entities that you
want to link.
Note: If you try to create a link that is not valid between the two entities, you are prompted with a list
of valid link types to select from.
The Record Inspector displays the record that you created. The properties that are initially displayed
correspond to the following property types from the Information Store:
•

Properties whose values are used in the record label

•

Mandatory properties

•

Link direction
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4. Enter values on the Properties page of the Record Inspector.
You can enter values for properties that are not listed by using the plus button on the Properties
page. As you create further links, the Record Inspector remembers which properties you typically
use.
5. Optional: To create a duplicate link, select the target link on the chart. On the Ribbon menu, click
Copy > Duplicate, from the Home tab or right-click on the selected entity and choose Duplicate
from the screen menu.
When you save your chart, the i2 Analyze link that you created is saved.
When you are ready to share information, you can upload the records that you create to the Information
Store.
Related concepts
Multiple records in one chart item on page 70
Chart items in Analyst's Notebook Premium can contain multiple i2 Analyze records. If you merge two
entities that contain records, the result is a single entity that contains two records. If there are several
link records that connect the same two entities on the chart, you can choose to represent them as a
single link item.

Chart Store
The i2 Analyze Chart Store provides server-based, secure storage for the charts that you create. You
can share charts from the Chart Store with your colleagues, or take advantage of the organizing and
indexing features that make charts easier to find.
Analyst's Notebook Premium has features that help you to interact and work with charts in ways
that enable you and your team to gain insights and collaborate on investigations. Everyone with
authorization can quickly access the latest intelligence and add to the data, ensuring that the most up to
date information is available to all team members.
Discovering charts
How you search for charts in the Chart Store depends on the deployment of i2 Analyze that you
connect to:
•

If your i2 Analyze server includes the Chart Store and the Information Store, you can use Quick
Search to find charts by specifying terms that they might contain. The returned results include
records and charts that match the search terms. You can then refine your search or use filtering
to focus on finding charts.
Other search tools in Analyst's Notebook Premium do not support the discovery of charts.

•

If your i2 Analyze server includes the Chart Store but not the Information Store, use the Shared
Charts button on the Home tab to search for charts.

Opening charts
Analyst's Notebook Premium provides two ways to open charts from the Chart Store:
•

You can open charts from the returned results window. When you select Open, you are
presented with the Save As window. You must save a local version of the chart, and then the
chart will open.

•

The File menu maintains a list of the most recently saved charts. If you previously uploaded a
chart to the store and it appears in the list, you can open it from the File menu. If changes have
been made to the chart by another user, you are notified to get the latest version.
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Sharing charts
You can share charts by uploading them to the Chart Store. By doing so, you benefit from access
to all the information that accompanies the chart in the store, such as notes, source references, and
version history.
To upload or update the current chart in the Chart Store, click Upload Chart on the Publish tab. If
the chart has not been uploaded before, Analyst's Notebook Premium displays the Chart Inspector,
where you can provide a name and other information for the uploaded chart.
If the Chart Inspector is already open, you can click Upload to achieve the same result.
Note: If you have a large number of charts to share, and you have permission to do so, you can
use the Upload from Folder feature to upload charts to the Chart Store in bulk.
The status of the current chart is displayed in a number of places to help you, including in the
application header. You can click Check for Updates on the Publish tab to ensure that you are
working with the latest version.
If another user causes a chart to change in the Chart Store while you edit a local version, you
cannot upload your changes until you accept the update from the store. A good strategy for working
with the Chart Store is to save the local version regularly, and to upload a new version of the chart
when your edits become significant.
Note: You can continue to share .anb files with colleagues, but if the charts you share have also
been uploaded to the Chart Store, those files can quickly diverge from the versions in the store.
Reconciling the differences between such charts can be a time-consuming process.
Chart identifiers
All charts created since the introduction of the Chart Store receive a unique identifier that does not
change when you save or upload them. This identifier powers the Chart Store's versioning feature
and helps to prevent duplicate charts from being uploaded.
However, if you want to use an existing chart as the basis for new, distinct work, then you need to
create a duplicate file with a new identifier. To do so, use Save As Copy from the Save As menu.
You can then upload the new chart to the Chart Store independently from the original.
Chart Inspector
The Chart Inspector is available from the Publish tab. Chart Inspector provides everything you need to
view and edit information about your chart. You can use the Chart Inspector to add properties, notes,
security settings, and source references to your charts; to check for updates; to upload a new version;
or to delete it from the store.
Security
You can assign security settings to charts in the Chart Store in the same way as for records in the
Information Store. However, security conflicts can occur if the chart has different settings from the
records it contains. For example, a chart with unclassified settings might contain controlled records.
When you upload a chart that exhibits a security conflict, Analyst's Notebook Premium provides the
option of proceeding with the upload by clicking Upload anyway. Alternatively, you can abandon
the upload by clicking anywhere else on the screen and returning to the chart.
Version history
The version history of the current chart is available from the Publish tab and from inside the Chart
Inspector. The most recently uploaded version is listed at the top, and you can click Get latest to
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open it if you don't already have that version. You can also select an earlier version of a chart from
the list and click Make latest to work with it as the latest version.
If you do reinstate an earlier version of the chart, it moves to the top of the list and all the previous
versions are retained in the version history.
You can delete specific, previous versions of the chart from the list, but not the latest version. If you
want to use a previous version as the basis for new work, use the Open as copy option from the
Version History window. (The Save As Copy command from the Save As menu works in exactly
the same way.)
Deleting charts
When you delete a chart through the Chart Inspector, you remove all versions of the chart from the
Chart Store. If other users have downloaded the chart, their copies become orphaned, as do any
files that you have saved locally. To delete specific versions of the chart, use the version history
instead.

Uploading charts in bulk
If you have a large number of charts to upload to the Chart Store for the first time, you can use Upload
from Folder from the Publish tab. The operation can be resource-intensive, and so it is prudent to use it
in line with the recommendations here.
In order to upload charts in bulk, you must be granted permission to do so. If you do not see the Upload
from Folder button but think that you should, contact your system administrator.
When Analyst's Notebook uploads charts, it indexes their contents and generates images of them. The
more charts there are, and the larger they are, the more significant the amount of processing becomes.
Charts that contain images are especially demanding.
If you have a large number (hundreds or thousands) of charts to upload, and especially if some of those
charts have the characteristics above, i2 recommends uploading in batches rather than all at once.
1. In the ribbon, on the Publish tab, click Upload from Folder.
Analyst's Notebook displays the Upload Charts from Folder dialog.
2. Specify the path to a folder that contains the charts you want to upload to the Chart Store.
From this dialog you can click the checkboxes to Include subfolders in your upload, and Add
Chart Store identifiers to chart files. When you add identifiers, Analyst's Notebook maintains
relationships between the charts on disk and the charts in the store. These relationships drive the
version control mechanism, for example.
3. Click Edit to provide common information for the uploaded charts, such as notes, security settings,
and property values.
4. Click Upload to start the upload process.
Analyst's Notebook displays a dialog that reports progress and provides the option to view a more
detailed log file.
All the charts from your selected folders and subfolders are uploaded to the Chart Store. In the root
folder of the upload, the BulkUploadSummary.log file lists the actions, status and record identifier
for each uploaded chart. The BulkUploadSummary.log file indicates both successful uploads and
errors if any uploads failed. Each folder that contains at least one uploaded chart gains a file named
BulkChartUpload.dat. Analyst's Notebook uses the BulkChartUpload.dat files to ignore charts
that have been successfully uploaded, should you want to run bulk upload from these folders again.
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Palettes in i2 Analyze
You can create records using entities and links from a choice of user palettes, depending on your type
of deployment.
Your i2 Analyze deployment might have access to data in the Information Store, external data through
the i2 Connect gateway, or both. When you connect to the Information Store, you have a default user
palette that contains the entity types and link types defined by your schema.
If the Insert from Palette pane is not visible, click the Home tab, and then click Insert from Palette.
The Information Store palette is at the top of the palettes list in the entity section of the pane.
As well as the Information Store, you might have one or more connections to external data sources
whose record types are not mapped to your Information Store schema. In the Insert from Palette pane,
there is a palette for the Information Store and each of your unaligned connectors. When you create
entities and links from these palettes, they are categorized as "Unaligned" in the record bar and cannot
be uploaded.
You might be using a number of different aligned and unaligned connectors at the same time. In the
Insert from Palette pane there is a palette for Information Store, an External palette for the gateway,
and a palette for each connector. All aligned records can be uploaded, while unaligned records cannot.
If you are using the i2 Connect gateway only, you can see the External palette for the gateway in the
palettes list. You can create new entities and links using the External palette but you cannot upload any
records or the chart. You can save a local copy of your chart.
You can upload and share charts that contain unaligned records, however the records remain
unaligned.

Working with an Information Store
Before you can search for, create, update, or delete the records in an Information Store, you must
connect to and log in to it through Analyst's Notebook Premium.
1. If you do not already know them, find out the address (URL) of the Information Store and your login
details (user name and password) from your system administrator.
2. Click Change Connection Details

in the upper-right corner of the application window.
3. Enter the URL of the Information Store and click Connect.
4. If you are prompted, enter your user name and password and click Log in.
Note: When you are logged in, if you don't do anything, then after a short time you might be
automatically logged out.

Key concepts
When you connect to an Information Store from Analyst's Notebook Premium, you can access the data
that is contained in the Information Store, and share your own records.
The data in an Information Store is contained in entity records and link records. You can search for
records uploaded by other analysts to use in your investigations. You can copy data from the store
to visualize into new charts, and you can enrich existing charts with new intelligence. When you use
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Analyst's Notebook Premium to create records, you can upload them to the Information Store to share
with other people who have the required level of access.
Depending on your deployment, you might have access to connectors that enable you to search for
and retrieve data from external data sources. You can work with records from external sources, even
if the connector or gateway schemas are not aligned with your Information Store schema. Charts that
contain both aligned and unaligned records can be saved locally, or uploaded to the Chart Store for
other analysts to work on. You cannot upload unaligned records to the Information Store. Analyst's
Notebook Premium tells you if a record is unaligned in both the record bar beneath the ribbon menu and
the Record Inspector.
Note: Your organization controls your access to the Information Store and you might not have
permission to work with restricted data.

Items and records
When Analyst's Notebook Premium is connected to an Information Store, the items that you add to a
chart can contain i2 Analyze records. From the application's point of view, each record holds of a set of
information about the item that contains it. The appearance of the item depends on the information in
the records that it contains.
An i2 Analyze record can contain properties with values; details about its history and settings; and notes
that you or other contributors have added to provide extra information.
Properties
Properties are the primary mechanism for storing information in a record. Each property contains a
piece of data about an entity or link record of a particular type. For example, a 'Person' entity record
might have property types such as 'Given Name', 'Date of Birth', and 'Passport Number'. Adding
information to property values allows that information to be categorized and analyzed in different
ways. Some property values affect the appearance of the item that contains them, such as when
they are used as the label.
Notes
Notes allow you to add information to a record that is not dependent on its type. You can add a note
to a record to provide information that is not included in any of the properties. Furthermore, you
can add notes to records that were loaded into the Information Store from external sources without
affecting the original information.
Details
In addition to the property values, records contain information about who has permission to view
them, who created or modified them in the past, and where they came from. These details might
enable you to talk to the person who created a record, or to determine who else has access to it.
Note: Your organization controls your access to records in the Information Store. Based on your
access level, you might not be able to access restricted records, or perform specific tasks such as
uploading records, deleting records, and accessing notes.
Records in chart items
The chart always has all the data for all the records in all the items that it contains. You can work with
the records on the chart even when you are not connected to the Information Store:
•

When you search for and retrieve information from the Information Store to Analyst's Notebook
Premium, the application creates chart items that contain copies of the Information Store records.

•

If you create an item that contains an i2 Analyze record (through the Information Store palette), the
application stores the new record in the chart until you can upload it to the store.
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Analyst's Notebook treats items that contain i2 Analyze records differently from standard Analyst's
Notebook items. For example, item properties such as the label are derived from property values in the
record, and so some of the Analyst's Notebook options for editing these items are disabled.
Even when you are connected to an Information Store, charts can also contain items that do not use
the Information Store schema. When you create these items, the properties that they contain are based
on types that are defined in an Analyst's Notebook chart template. You cannot upload records to the
Information Store from items that do not contain i2 Analyze records.
Note: Other chart items might originate from another data source such as iBase and contain data
records.

Multiple records in one chart item
Chart items in Analyst's Notebook Premium can contain multiple i2 Analyze records. If you merge two
entities that contain records, the result is a single entity that contains two records. If there are several
link records that connect the same two entities on the chart, you can choose to represent them as a
single link item.
Merged entities and existing links
When you merge two i2 Analyze entities, the resulting entity contains the records from both entities:

Any links that were connected to the original entities are retained on the merged entity:
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Each link is connected to the record in the entity to which it was originally connected.
In the Information Store, link records connect two entity records. Therefore, when you create an i2
Analyze link between two i2 Analyze entities on your chart, the link connects to a particular record in
each entity.
Lead records
When a chart item contains multiple i2 Analyze records, one of the records must be assigned as the
lead record. The lead record is used in the following ways:
•

Analyst's Notebook Premium bases the label that is displayed on the chart surface for an item on
information in the lead record.

•

When you create an i2 Analyze link, the link is connected to the lead record in each of its ends.
When you upload the link to the Information Store, the link connects those records.

In entities that contain multiple records, the lead record is shown in the Record Inspector with a blue
diamond

.
If you need to, you can change the lead record assignment before you create a link. Changing the lead
record can also cause the label and the icon on the chart to change.

Sharing information
When you work with the Information Store, you can share information and assertions with other analysts
and discover whether other analysts have findings that are of interest to you. You can collaborate with
other analysts by uploading new or edited records, and notes to the Information Store.
There are many reasons to share your information. For example:
•

To share records that you have created

•

To update shared information with new intelligence
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•

To add notes to new or existing records that provide more insight about an item, or provide
operational information

•

To benefit from the intelligence shared by other analysts

However, there are also times when you might not want to share or update information. For example,
in evidential situations, you might not be allowed (or it might be inadvisable) to share your proposals for
further investigation before they are confirmed.
The security settings and processes in your organization might constrain which records you can and
cannot share.

Searching the Information Store
You can find records of interest in the Information Store by searching for terms that they might contain,
or by using a structured search to look for data in specific properties. You can also use a structured
search to discover relationships.
Different search tools in the Search Information Store group on the Home tab of the ribbon fulfill
different needs:
Quick Search
Search for text that appears in the records stored in your Information Store. You can filter the results
of a Quick Search after the search completes to help you to find the information you need.
Visual Query
Create searches that allow you to find specific structures in the data. You can draw the structure
that you are looking for and use conditions to constrain the search.
Expand
When chart entities contain copies of records from the Information Store, you can expand to find
connected records, and add items that contain copies of those records to the chart.
Expand with Conditions
Instead of copying all the connected records to your chart, you can add conditions to the expand
function so that you copy records only of particular types.
Get Paths
You can select two entities on your chart and find the paths that connect them.
Get Matches
You can find out whether selected records on your chart match with records in the Information
Store.

Using Quick Search
You can use Quick Search to find records and charts of interest in the Information Store by specifying
terms that they might contain. After you receive the first set of results, you can refine them to find the
information that you are most interested in.
You can use Analyst's Notebook Premium to find records and charts in the Information Store that match
search terms that you enter. By default, the application finds records and charts that closely or exactly
match all the terms that you enter. You can use operators and rules to change the default behavior.
Note: Other search tools do not support the discovery of charts. Use Quick Search to search for charts
in the Information Store.
Matching behavior
By adding special characters to your search term, you can control the level of specificity:
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" "

To search for an exact word or phrase, enclose
it in double quotation marks. For example,
"John Doe" matches the phrase John Doe but
not the word John.

" "~integer

To search for terms that are within a specified
distance from each other, enclose two or more
terms in double quotation marks followed by
tilde (~) and an integer value. The integer
specifies the distance limit, where the distance
is the number of words that can be between
each pair of terms. For example, "John
Doe"~1 matches John James Doe but not John
James Simon Doe.
To match terms in a different order, changing
the order of the terms counts as a distance of 2
towards the total distance value. For example,
"Doe John"~1 does not match John James
Doe, but "Doe John"~3 does.
To return a match, each word in the search term
must be within the specified distance of any
adjacent words in the search term.

?

Matches a single unknown character. For
example, J?n matches Jan and Jon but not
Jean.

*

Matches zero or more unknown characters. For
example, J*n matches Jn, Jan, Jon, and Jean.

Logical operators
By default, when you search for multiple words, the results must match all the words that you
enter. For example, John Doe (no double quotation marks) searches for items that contain words
like John and words like Doe. You can change the search behavior and build more complicated
searches by using the following logical operators:
AND

Searches for records that contain all words or
phrases. For example, Offense AND "John
Doe" searches for records that contain words
like Offense and also contain the exact phrase
John Doe.

OR

Searches for records that contain at least one
word or phrase. For example, Offense OR
"John Doe" searches for records that contain
words like Offense, or the exact phrase John
Doe, or both.
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Searches for records that do not contain the
word or phrase. For example, Offense NOT
"John Doe" searches for records that contain
words like Offense but do not contain the exact
phrase John Doe.

NOT

Search scope
You can use the Advanced

option to specify where term matches are found.
1. On the Home tab of the ribbon, in the Search Information Store group, click Quick Search.
The Information Store Quick Search window opens.
2. Type the terms that you want to search for, and press Enter.
When you type the search terms, Analyst's Notebook Premium explains how it interprets the search
expression. For example, it shows the locations of implicit AND operators, and inserts parentheses
to make operator precedence explicit.
When you press Enter, Analyst's Notebook Premium searches the Information Store, and displays
the records and charts found, if any.
3. After you receive results, you can refine the search terms or use filtering to reduce the result set. To
filter results based on record types, property values, or metadata, select a type and then choose one
or more properties or metadata categories to filter by.
For example, a search for the word Ford might display results for people and cars. Select the
Person type to display results for people, and then select properties that are related to the person's
name to filter out everything except people whose name contains a word like Ford.
Each filter is displayed at the top of the window.
Note: To remove a filter, delete it by clicking the cross next to the filter.
When the search results are displayed, you can copy one or more of the records that they represent to
your chart or you can open a chart that has been saved in the store.

Structured searching
You can use Visual Query to search for records in the Information Store based on the values of specific
properties and on their relationships to other records. The records that you find depend on the structure
of the queries that you create.
Two steps are involved in building a Visual Query:
•

Define the structure of the query to indicate the types and relationships of the records that you are
interested in.

•

Add conditions to the items in the structure to define some of the values in the records that you want
to find.
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Visual Query structure
Any query structure that you build defines the types of records that you are searching for and the
relationships between them.
The query structure constrains the search by type and by relationship. It can consist of:
•

A single query entity
For example, a query structure that contains only a Person can find people in the Information Store
regardless of any relationships they might have.

•

An entity-link-entity query combination
For example, a query structure that contains a Person, a Vehicle, and an Owner link between them
can find people who own vehicles.

•

A more complex network of query items
For example, a query structure that contains a Person that is linked to a Vehicle with an Owner link,
and linked to an Account with an Account Holder link. This query can find people who own vehicles
and are account holders.

When you define a query structure, you can:
•

Specify link direction on any of the links in the structure. For example, you might want to search for
transaction links from an Account that has a specific account number to any other account.

•

Indicate that multiple records of a type must be present to meet the query criteria by adding a count
condition on an item in the query structure. For example, you might want to search for accounts that
are involved in transactions to at least two accounts that meet certain criteria. You can specify the
count condition using the operator Greater than or equal to with a value of 2, when you add query
conditions.

•

Where your query entity has links to two or more other entities, you can specify which relationship
the count condition applies to in your query structure.

Note: You cannot specify a count condition on more than one query item.

Defining the structure of a Visual Query
The first step of a Visual Query is to define the structure by adding query items.
1. On the Home tab of the ribbon, in the Search Information Store group, click Visual Query.
The Information Store Visual Query window opens. If you have used the Visual Query feature
before, there might be a list of saved queries in the window.
2. Open a saved query, or click New query to create one.
Analyst's Notebook opens a new tab in the Information Store Visual Query window.
For a new query, the Edit query structure window opens immediately.
For a saved query, you can click the Edit structure button

.
3. In the Edit query structure window, add the query entities that represent the structure that you want
to find. To add a query entity, drag an entity type from the query palette to the query surface.
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When you place or select a query entity on the query surface, the details about that entity are
displayed. Query items must have unique labels. You can overtype the default label should you want
to change it.
4. Link the query entities in the structure with the query links that you want to find. To create a link,
select the two query entities that you want to link.
If there are no suitable link types available between the selected entities, you see the No valid
link types message.
5. From the Multiple query items window, select a link type.
When you select a link type, the options that you can apply to the link are displayed. Like entities,
links must have unique labels, however you can overtype the default label should you want to
change it.
6. Optional: To prevent the results from being returned, deselect the Include in results box. For
example, from your query structure of a Person, a Vehicle and an Owner link, you might want to see
the owners but not the vehicle details. You should leave Include in results selected for the Person
query entity. When you turn off the option for the Vehicle query entity, the link is automatically turned
off too, and an icon is displayed next to all the query items that are not included.
Be aware that a link record can only be returned if both end records are present. When you choose
to exclude entities, you also exclude their associated links.
7. Optional: To add a direction to a query link, choose an option from the Direction list.
8. Optional: To indicate that the structure must contain multiple records for a query item, set a count
on the query item. For example, using your query structure of a Person, a Vehicle and an owner
link, you might want to find people who own a set number of cars. Select the Vehicle query entity
in the query structure, then click the Count condition button. Click OK and in the count condition
structure, select Equal to. Type the number of vehicles the count should be equal to.
You can set a count on only one item in the query structure. If you set a count on a second item, the
first one is removed.
9. Optional: If you have enabled Count condition and you have an entity linked to two or more other
entities, you can select a relationship to apply the count condition to. By default, all entities are
selected. Click the check box to deselect an entity. You cannot deselect all the entities in the list.
10.Click OK.
After you click OK, you can edit the query structure at any time by clicking the Edit structure button

.
After you define the query structure, add conditions to the items in the structure, and then run the query.
Related concepts
Visual Query conditions on page 77
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You can constrain a search according to the properties and metadata of records in the Information
Store by adding conditions to the Visual Query. You can add conditions to any of the items in a query
structure.

Visual Query conditions
You can constrain a search according to the properties and metadata of records in the Information
Store by adding conditions to the Visual Query. You can add conditions to any of the items in a query
structure.
A query condition is made up of a property or metadata type, an operator, and one or more values. The
number of values depends on the operator that you choose.
By adding query conditions, you can look for records with specific values or ranges of values in their
properties and you can use metadata such as record identifiers, or date of upload. You can narrow the
focus of the search by gradually adding more conditions, increasing the complexity of the query. For
example:
•

If your query structure consists of a single Person type, you can narrow the focus to search for all
people with the given name John and family name Doe.

•

By adding query conditions to more than one query item, you can find people called John Doe who
own a car with a license plate that starts ABC.

•

By adding a count to a query structure, then entering a value of 2 for the count as part of the
conditions, you can find people who own at least two cars.

•

By adding a condition to return records with notes that contain a particular string, you can identify
more records that might be relevant to your analysis.

•

By specifying characteristics that are described by a link between two accounts, you can identify
accounts that are involved in high value transactions, such as links that represent transactions of
value greater than $75000.

When you add conditions to a query, the first step is to select the query item, then the property or
metadata type within that query item for which you want to add conditions. After you select the type,
several operators are available to use. For example, 'Between', 'Is exactly', 'Is not,' 'Matches wildcard
pattern'. The 'Between' operator is inclusive (it includes the values that you enter). Not all operators are
available for all types, for example you can only select 'Is exactly' or 'Is not' for record identifiers.
When you add conditions to property and metadata types, there are several things to consider:
•

Aspects of date and time types

•

Use of wildcards

•

Multiple values in a single condition

•

Whether all conditions have to be met (AND), or just one of the conditions must be met (OR), or a
combination of both

Date and time types
For types that store date, time, or date and time values, you can create conditions such as 'Date of
Birth equal to 15 Mar 1966' or 'Date first uploaded later than 01 Jan 2018'. However, you can also add
conditions that use aspects of such values, which allow you to search for transactions that were made
on any Monday, or dates of birth that are 1 Jan in any year.
When you create a date and time condition, you must choose an aspect to use. For example, Date of
Birth might appear in the Add Condition window several times with different aspects: Date of Birth »
Date, Date of Birth » Day of Week, Date of Birth » Month.
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If you specify a time as part of a condition, you can choose how to deal with time zones. The choice that
you make affects the search that takes place. When you select a time zone, all times are converted to
that zone for comparison, so a time of 1pm GMT matches 8am EST. If you decide to ignore time zones,
times are compared literally, so that a time of 1pm GMT matches 1pm EST, as well as 1pm in any other
time zone.
Wildcards
If the value is a string, the 'Matches wildcard pattern' operator is available. The following wildcards are
supported:
?

Matches a single unknown character. For
example, J?n matches Jan and Jon but not Jean.

*

Matches zero or more unknown characters. For
example, J*n matches Jn, Jan, Jon, and Jean.

Multiple values
By default, each line in the value of a condition is treated as a single value, including any spaces and
wildcards. If the value is a string and you select 'Is exactly' or 'Is not' as the operator, you can enter
several values. You can include more than one value by entering each value on a separate line. If a text
file contains the values that you want to use, you can import values from the file. Any file that you use
must have the file type .txt and must contain row-separated values.
Combining conditions
After you create one condition, you can add another that uses the same type, or create another on a
different type or a different query item.
If you specify conditions on different items in a query structure, the conditions on the different items
must all be met (AND). For example, if the structure of your query contains a Person entity that is linked
to a Vehicle entity, you might specify the following conditions:
•

On the Person entity, Family Name is exactly Young.

•

On the Vehicle entity, License Plate contains 123.

The query results contain people with the family name Young who are linked to a vehicle, which
contains 123 in the license plate.
Typically, when you add conditions on different types of the same query item, all of the conditions must
be met (AND). However, it can depend on the type.
If you add more than one condition on a single type, how the conditions are combined depends on the
type, the operators that you choose, and the order in which you add the conditions. After you add a
condition, the query indicates how the conditions will be combined (AND or OR).
If you specify multiple values for a single condition, at least one of the values must be met (OR).

Adding conditions to a Visual Query
After you define the structure of a Visual Query, you can add query conditions to the items in the query
structure to look for records with specific values in their properties and metadata.
This example describes the conditions that you might specify for the following query.
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Imagine that you want to search for people who are called John Doe, own a car, and hold at least two
accounts. The car is blue and the license plate starts with ABC. To achieve this query, the structure
must take the form of a Person that is connected to a Vehicle with an Owner link. The Person must also
be connected to an Account with an Account Holder link. The Account must be given a count condition.
You must then set the following query conditions:
•

•

•

On the Person query entity:
•

Given Name is exactly John.

•

Family Name is exactly Doe.

On the Vehicle query entity:
•

Color is exactly Blue.

•

License Plate starts with ABC.

On the Account query entity, the count condition must have the value greater than or equal to 2.

1. The Query conditions pane of a new or open query in the Information Store Visual
Query window contains a list of all the items in the query structure. Click the plus icon

next to the item that you want to add the condition to.
The Add or remove conditions window opens. Property types are listed first, followed by metadata
types.
2. Select the property or metadata type, or date and time aspect for which you want to add conditions
and click OK.
3. For each property or metadata type, select the operator and enter or select the value. For some
types and operators, you can enter multiple values. To enter multiple values:
a) Click the Edit value list button

next to the value.
b) Enter each value on a separate line.
c) Optional: If you have a text file that contains the values that you want to add, you can import it.
Click Import text file and browse to the file. Any file that you import must have the file type .txt
and must contain row separated values.
Note: Value fields in a condition have a maximum number of characters. If you try to import a file
that contains too many characters, no text is inserted.
Note: Searches are not case-sensitive.
4. To add a second or subsequent condition with the same type, click the Actions button

next to the type, then click Add Another.
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5. Repeat steps 1 - 4 for the other entities and links in the query structure for which you want to add
conditions.
6. After you add the conditions, click Run.
Analyst's Notebook Premium searches the Information Store, and displays the results.
7. After you receive results, you can refine the search terms or use filtering to reduce the result set. To
filter results, select a value (or a value range) for a particular property or metadata category.
For example, a search for people with the first name John who are linked to an address might
display many results for the Person type. You might then select a property value range to filter out all
results except people whose date of birth falls in the range 1959 - 1964.
Each filter is displayed at the top of the window.
Note: To remove a filter, delete it by clicking the cross next to the filter.
8. Include context automatically includes the associated links when you copy entity records from the
results set to the chart. For example, if your results include people and the cars that they own, when
you copy a Person record to the chart, their Vehicle records and link records are also displayed.
Click the Include context button to deselect the option.
You can use the include context option with records returned in the results set. If you specify in your
query structure that you do not want linked vehicles returned in the results, you cannot use include
context to retrieve them.
When the search results are displayed, you can copy one or more of the records that they represent to
your chart.
Related concepts
Visual Query structure on page 75
Any query structure that you build defines the types of records that you are searching for and the
relationships between them.

Saving a Visual Query
You can save a Visual Query so that you can run it on multiple occasions without repeatedly specifying
the same search structure and conditions. You can also arrange for a saved Visual Query to run
automatically and alert you when its results change from one run to the next.
When you are creating or editing a Visual Query in Analyst's Notebook, you can save it with a name
and a description that help you to find and run it again. The Information Store Visual Query window
contains a list of all the available queries, and provides features for managing them.
When you enable alerts for a saved Visual Query, i2 Analyze monitors the query results to detect
changes in the Information Store. If the query finds more records than it did when you activated the
setting, or some records no longer match the query, Analyst's Notebook displays an alert. To view alerts
and the records that caused them, click the View alerts button in the Analyst's Notebook title bar.
To save a new query, or to save an open query with a new name:
•

On the same page as the Query structure pane, click Save as.
The Query details window appears.

•

Enter a name and a description for the new Visual Query.

•

If you want this query to generate alerts, select the check box.
You can change your decision later through the Alerts setting on the Saved queries tab.

• Click Save.
To save changes to a query that you opened from the list:
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•

On the same page as the Query structure pane, click Save.
Analyst's Notebook updates the saved Visual Query.

Any Visual Query that you save is added or updated in the Saved queries list, and becomes available
for you to use whenever you log in to the connected i2 Analyze server. If you also enabled alerts, and
data that matches the query changes, then alerts appear in the Alerts list.

Adding geographic locations to a Visual Query
When records contain geospatial properties, you can define a Visual Query that locates records based
on a search area in i2 Maps.
When you use i2 Maps as your map provider in Analyst's Notebook, you can define a search area by
drawing a rectangle or polygon on your base map. You can also define a specific area, district, or region
by using GeoJSON data from other applications.
For example, you might want to search for, and chart, people with connections to a particular location.
You can create a Visual Query with a geospatial condition as part of your query structure. When you run
the query, Analyst's Notebook finds the entity records that are linked to that area.
To get started, define the structure of your Visual Query in the usual way. You can add geospatial
conditions for entities that have a property type of Geographic Location.
•

To create a search area using Maps:
a) In the Query conditions pane of your Visual Query, click the plus icon

next to the entity you want to add the condition to.
The Add or remove condition window opens.
b) Select a Geographic Location property and click OK.
c) To edit the geospatial area, click the

icon.
The Edit search area window opens and displays the Map view. You can zoom in and out, and
pan to different parts of the map.
d) Optional: Click Options to see the base maps and overlay elements that are configured for your
deployment.
e) To draw a shape on the map, click either the polygon icon or the rectangle icon.
Polygon

Click to insert the first point, then click to add
more points. Click on the first point again or the
Finish option to complete the polygon.

Rectangle

Drag over the area and release the mouse
button to complete the rectangle.

f) Use the Edit shapes or Delete shapes options to make changes if required.
Note: When you draw a shape on the map, Analyst's Notebook calculates the GeoJSON
coordinates and the feature collection object in the GeoJSON window.
g) Click OK when you have finished drawing and editing your search area.
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The Edit search area window closes and a thumbnail graphic is displayed next to the entity.
h) Optional: Click the Actions icon

to add or remove geographic locations.
•

To create a search area using GeoJSON data:
a) To edit the geospatial area, click the

icon
and click on GeoJSON to change the search area from Map.
b) Paste or enter a GeoJSON feature collection object into the text area.
c) Click on Map to view your GeoJSON data on the map or OK to return to Query conditions.
A thumbnail graphic of the map view with an outline of your GeoJSON area is displayed next to
the entity.
d) Optional: Click the Actions icon

to add or remove geographic locations.
e) After you add the conditions, save your query or click Run.

Expanding entities
When chart entities contain copies of records from the Information Store, you can expand to find related
records, and add items that contain copies of those records to the chart.
Three stages are involved in expanding entities that contain copies of records from the Information
Store:
1. Examine the records that the selected chart items contain.
2. Find records in the Information Store that are directly connected to them.
3. Add chart items that contain copies of the directly connected records.
Rather than simply adding all the related information to your chart, you can also expand with conditions,
allowing you to decide on the types of records to add. For more information, see Expand with conditions
on page 83.
Any selected chart items that do not contain records are ignored in expand operations.
If an expand operation finds a record that was already copied to the chart, the application tests whether
the record in the Information Store was updated since the copy was made. If a new version is available,
the record in the chart item is marked to indicate that changes are available. You can choose to get
these changes.
Note: If a record was deleted from the Information Store since the copy was made, the copy is not
deleted from the chart. Instead, the record is marked as orphaned, and its relationship to the Information
Store is broken.
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•

To expand all selected entities that contain records:
a) On the chart, select the entities that you want to expand.
b) Click the Home tab of the ribbon, and then in the Search Information Store group, click
Expand.
Links and connected entities are added to the chart.

You can now use the Analyst's Notebook tools to analyze the items that contain the copied records.

Expand with conditions
Rather than using expand to add all the available, related information to your chart, you can choose
instead to expand with conditions. When you do so, you can select which types of records to copy to the
chart.
In an expand with conditions operation, you can choose to filter by entity types, link types, or both. For
example, if you select a Person entity on your chart, you might choose only to expand to records that
have the Vehicle entity type. Alternatively, an Owner link type might be used to connect vehicles with
people, and also accounts with people. But it might also be possible to connect accounts and people
through an Access To link type. By filtering on entity and link type, you can choose only to expand to
accounts that are owned by people.
Note: For information on how to expand without using conditions, see Expanding entities on page
82.
To expand with conditions:
1. On the chart, select the entities that you want to expand.
2. Click the Home tab of the ribbon, and then in the Search Information Store group, click Expand
with Conditions.
The Information Store Expand with Conditions window opens.
3. To choose the type of filtering to apply, click Expand by type

in the window header and select entity type, link type, or both.
A list of record types that are connected to the selected entities is displayed. If a large amount of
connected records are found, you are asked whether you want to Display the list.
4. Select the record types and click Copy to Chart.
Note: To expand by a single type, you can hover over the type and click Copy to Chart.
A summary of records that were copied (or marked to show that changes are available) is displayed
in the Expand with Conditions window. The relevant links and entities are added to the chart.
These entities and links are selected, together with any relevant existing entities and links on the
chart. You can click a row in the summary to change the selection. For example, to select only the
originally selected entities, click the Seeds row in the summary.
5. To close the Expand with Conditions window, you can do one of the following:
•

Click Finish. The Expand with Conditions window is reset for next time that you expand.

•

Click the Expand with Conditions ribbon button. Next time that you expand, the window opens
on the last page that you used.

To continue expanding, select entities from the summary and click Expand Again.
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Get paths
You can discover if two entities on your chart are connected by finding the paths between them.
The Get Paths function in Analyst's Notebook finds connections in the Information Store between the
lead records in two selected chart items.
1. On the chart, select the two entities that you want to find a path for.
2. Click the Home tab of the ribbon, and then in the Search Information Store group, click Get Paths.
3. From the drop-down list, select the shortest path or paths with a maximum length up to 8 steps.
Paths that meet your criteria are displayed on the chart.
Note: You might see a message that the Information Store contains no paths that meet your criteria.
This does not mean that no paths exist and you should try different maximum lengths to rule out
connections. Be aware if paths exist that are greater than a maximum of 8, the Information Store
returns no paths.

Get matches
You can use the Get Matches function in Analyst's Notebook to compare the records on your chart with
records in the Information Store.
You might have records on your chart that match with records in the Information Store. It might be
useful to know more about real world objects and relationships that are known to the system, even if
you do not want to unite or merge the chart records at this stage of your analysis. Get Matches is a form
of system matching that compares the records on your chart with the Information Store and identifies
possible matches. If matching records are identified, you can either unite the entity records, or merge
the link records on your chart.
Note: Link records can match only when their end records are contained by the same pair of entities.
•

To find records that match with the Information Store:
a) On the chart, select the chart items that you want to check for matches.
b) Click the Home tab of the ribbon, and then in the Search Information Store group, click Get
Matches.
The Matching Records Found dialog displays the number of matches found for system
governed and analyst governed records. You can see if they are entity records or link records,
and the resulting action if you decide to proceed with getting the matches. You also see a warning
message if the server exceeds the limit of the number of records that can be returned per seed.
You could use Find Matching Records to reduce the number of records per seed before running
Get Matches.
c) Click Continue to unite the matched entity records on the chart, or click Cancel to return to the
chart. If you decide not to proceed with getting matched records, the chart records with matches
are not updated but are selected. Matching link records from the Information Store are copied
to the chart. You can use Find Matching Records to examine these matches, and merge them if
required.
Note: It is possible for links between entity records to be lost, for example if an Information Store
record matched with two linked chart records. Although this situation is unlikely, you can use Find
Matching Records to resolve potential duplication before running Get Matches.
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Adding chart items
After any operation that finds records in the Information Store - Quick Search, Visual Query, or Expand
with Conditions - you can create chart items that contain copies of those records. You can then use
these items as the starting point for more searches of the Information Store.
Before you can use Analyst's Notebook tools to analyze search results, you must copy the records that
they represent to a chart. Each chart item that you create in this way contains a copy of the record from
the Information Store that provides a snapshot of the information at the time of charting. If the data in
the Information Store is updated after you copy a record and you want that chart to reflect that change,
you must use the Get Changes feature to update the records on the chart.

Copying records to a chart
When the results of an Information Store Quick Search or Visual Query are displayed, you can choose
to create chart items that contain copies of the records. To add information to a chart, you must select
records from the search results and choose the chart that you want to target.
1. If the search results contain many records, you can filter the results by clicking one or more listed
properties or types.
2. In the Information Store Quick Search window or the Information Store Visual Query window,
select the check boxes next to the records that you want to chart. To select them all, select the check
box at the top of the list.
3. Click Copy to Chart.
The Copy to chart pane opens. A list of open charts is displayed with the current chart selected.
4. Click the chart in which to create items with copies of the selected records.
If you click New Chart or select a chart that does not have a charting scheme, you must select the
charting scheme that you want to use when the items are added to the chart. If you require changes
to a charting scheme or want a new charting scheme, contact your administrator.
5. To close the Information Store window, you can do one of the following:
•

Click Finish. The Information Store window is reset. Next time that you search the Information
Store, you must start from a blank search or query.

•

Click the relevant ribbon button (Quick Search or Visual Query). Next time that you start a
search or query, the window opens containing the criteria from the last time.

To proceed with further search operations, click Search Again.

Charting schemes
Charting schemes define what items that contain i2 Analyze records look like when they appear on your
chart. A charting scheme maps the properties of records to properties on the chart item.
For example, a Date of Birth property might be mapped to a chart item, or Given Name and Surname
properties might be mapped to a chart item label.
Specifying which attribute classes and labels to populate from different properties defines how those
properties are displayed on the chart item. In addition, by using connection multiplicity, you can display
multiple links between two entities as a single link, but still retain the information from the individual
records in the chart item.
You can change the charting scheme that is associated with a chart at any time.
Note: If you change the charting scheme, or link summarization settings when there are more than
2000 records on the chart, the undo stack is cleared and the charting scheme change is not recorded.
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The undo limit is set to 2000 records to save on memory consumption. You can reselect the original
charting scheme, or revert any changes made to link summarization should you need to.

Changing the displayed information
The information from records that is displayed on a chart item is controlled by the charting scheme.
When you are working with items that contain i2 Analyze records, you can control the appearance of the
items by changing the charting scheme.
As part of the deployment of i2 Analyze, charting schemes are created that determine how the
information stored in i2 Analyze records relate to item properties and attributes on the chart. Depending
on the charting schemes that have been included, you can select different ways to display the
information in your chart. You might want to change the display in the following situations:
•

The chart is intended for multiple audiences who require different amounts of detail to be displayed.

•

Charted items might need to show each link separately, or all links between two entities as one link,
depending on the type of analysis you want to do. For example, if you change the chart from an
association chart to a timeline chart, you might want to choose a different connection style.

In the bar below the ribbon, select the required charting scheme from the Charting scheme list.
Note: If the type of display that you require is not available in the list, you can request changes to a
charting scheme, or new charting schemes, by contacting your administrator.

Link summarization
You can override the charting scheme and control how your link records are summarized into links for
display on the chart.
Usually the charting scheme you are using defines what items that contain i2 Analyze records look
like on the chart, including how link records are displayed. You can view your current charting scheme
or choose from available charting schemes on the records bar, below the ribbon menu. If there are
multiple links between the same two entities on the chart, you can override the charting scheme setting
and choose how to display those links. This is useful because you have greater control over the look
of your chart and how it relates to the type of analysis you want to do. You might want to examine
the relationships between entities in detail by including multiple links. Alternatively, you might want
to combine links with the same direction, or you might choose to use single links to represent all
connections of the same type, to improve the readability of your chart. You can also change the link
summarization option setting for custom link types.
•

To change link summarization for the current charting scheme and custom link types:
a) With your chart open, click the Link Summarization button in the records bar.
The Link Summarization Settings window opens. Any link types from your schema and custom
link types that are present on the current chart are listed, along with link summarization options.
b) Click a link type from the list in the side panel. Custom link types have a unique identifier
displayed in brackets alongside the name.
The Link Summarization Settings window displays information that is relevant to the selected
link, for example the link type's current setting and the implications of choosing a different setting.
c) The current setting is selected by default, whether it is taken from the schema or from when the
custom link was created. If you want to change the default setting, click the button next to your
preferred setting. You can choose from Single, Directed or Multiple.
The Single option combines all links records between the same two entities into a single link, with
a label of the record count. The Directed option combines all links records in the same direction
between the same two entities, with a label of the record count. The Multiple option charts
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each link between the same two entities separately, labeled with the record's label. If you have
many links, the Multiple option can make your chart difficult to read. When you override a link
summarization setting, the link gains a blue glyph to indicate the change. The link summarization
button is highlighted in orange.
d) If you do not want to make changes to the link summarization settings, click Cancel, or click OK
to confirm your changes.

Editing records in i2 Analyze chart items
You can view and edit records in a chart item in the Record Inspector. Depending on the type of
record, and your access permissions, you can upload your changes to the Information Store. You can
view, edit, and create records even if you are not connected to the Information Store, but you must be
connected to search the Information Store or upload any data.
You can edit the i2 Analyze records that you create before and after you upload them to the Information
Store. For some other records, especially if they were loaded into the Information Store from an external
system, you can edit notes but not property values. Other records still are read-only, and you cannot
edit them at all.
After you make edits, you can upload them to the Information Store only if there have been no changes
to the corresponding record in the store since you last uploaded or got changes. If changes are
available, you must get those changes before you can upload any edits of your own.
When you view the records in a chart item that contains multiple records, or you select multiple items,
the Record Inspector indicates how many records there are in your selection. You can page through
each record to view and edit its properties or add notes. You can also view a list of the records that are
contained in the selected items. Display the list or page view by clicking List or Page.
1. Click the chart item for which you want to view or edit i2 Analyze records.
If the Record Inspector is not already open, double-click the chart item to open it. The records that
the item contains are displayed.
2. If the item contains multiple records, one of the records is assigned as the lead record. To assign a
different lead record:
a) Select the record to assign as the lead record in the list view.
b) Click the More actions button

,
then click Set as lead.
3. Select the relevant record in the list view, then click the Page button. There are now several ways
that you can edit a record. For example:
•

Edit its property values.

•

Add notes to a record or edit existing notes.

•

View or edit details about a record. For example, set its security information.

You can choose to enter values for properties that are not listed by using the plus button

on the Properties page to change which properties are listed. If you remove a property from the
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property list, any value that is contained in the property is deleted from the record. If you upload your
edits to the Information Store, deleted values are also deleted in the Information Store.
Note: You cannot remove mandatory properties or any property that makes up the label.

Working with notes in a record
Notes provide a way to add free-form operational data to i2 Analyze records in the Information Store. If
you have access to the feature, then you can view the notes on any i2 Analyze record. If you have write
access to a record, then you can add to, edit, and delete the notes that it contains.
Your organization controls access to notes based on the user groups that you belong to. If you need to
use notes but you do not see the Notes tab in the Record Inspector, contact your system administrator.
Analyst's Notebook treats notes like the other properties of i2 Analyze records. If you update a record
in a chart item with changes from the Information Store, any new notes from the store are added to the
record. If you delete a note and upload the record, the note is deleted from the record in the Information
Store.
In the Record Inspector, notes are sorted by when they were first uploaded, with the most recent note at
the top of the list.
To add or edit a note:
1. Ensure that the record that you want to edit is displayed in the page view of the Record Inspector.
2. Click the Notes tab.
3. If the record has no notes, you can create one by typing into the empty field.
4. If the record already has notes, you can click New to add a note, or click an existing note to edit it.
The note is added to (or updated in) the record in the chart item, along with information about who
added or edited the note, and when it was added or edited.
5. To delete a note, select Actions

(
next to the note, and then click Delete.
When you complete your edits, upload the affected records to the Information Store. For more
information about uploading records, see Uploading records to the Information Store on page 91.

Editing record security
When you create a record, default security settings are automatically assigned so that you can upload
that record to the Information Store. If you can edit the properties of a record, you can also edit the
security dimension values that are assigned to it.
The following information about a record is available on the Details tab of the Record Inspector:
Activity
Details about the history of the record, such as who first uploaded the item and when. This
information is provided so that you can track any changes that occur.
Security
The security dimension values that apply to the record. The values that are specified in the Security
section affect who has access to the record when it is uploaded to the Information Store. The
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default values that are assigned when you first create a record are controlled by your system
administrator.
To edit the security settings of an i2 Analyze record, follow these steps:
1. Ensure that the record that you want to edit is displayed in the page view of the Record Inspector.
2. Click the Details tab to display details about the record.
In the Security section, you can see the current security dimension values for the record. If you can
edit these values, Edit buttons and drop-down lists are visible.
3. Select the security dimension that contains the values that you want to edit.
4. Select the dimension values to apply to the record.
When you complete your edits, upload the affected records to the Information Store. For more
information about uploading records, see Uploading records to the Information Store on page 91.

Keeping records up to date
You must upload the records that you add to your chart to the Information Store before other people can
access the information that they contain. When you are working with records that have been uploaded,
you can check for changes and update the records in your chart with the latest information.
The following flowchart shows the possible states of records that have been added to your chart:

Where:
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Not uploaded
The record has been added to the current chart, but it has not been uploaded to the Information
Store. Any edits that you make to the record are also local to the chart.
Uploaded
The record has been uploaded to the Information Store, but it has not been edited in the chart or the
Information Store since that upload (or since it was copied to the current chart).
Edited
The record has been uploaded to the Information Store, and it has been edited in the chart since
that upload (or since it was copied to the current chart). You can upload the record again to apply
the edits to the record in the Information Store.
Changes available
The record has been uploaded to the Information Store, and it has changed in the Information Store
since that upload (or since it was copied to the current chart). You can get the changes from the
Information Store to update the copy of the record in the chart.
Changes available - Upload blocked
The record has been uploaded to the Information Store, and it has been edited in the chart and
changed in the Information Store since that upload (or since it was copied to the current chart).
Upload is blocked until you get the changes from the Information Store and reapply the edits.
Orphaned
The record has been uploaded to the Information Store, but it has been deleted from the Information
Store since that upload (or since it was copied to the current chart). The record in the chart no
longer has a counterpart in the Information Store.

Getting changes to records
To keep the chart copies of your records up to date, you can use the Get Changes function. You can
get changes from the Information Store to individual records, to records in all the currently selected
items, and to records brought together using the unite function. You cannot get changes to unaligned
records.
When records are changed by other analysts and uploaded to the Information Store, your chart items
might contain records that have been updated since you copied them to the chart. Using Get Changes
ensures you are working with the latest version of a record. If a record on your chart is deleted from
Information Store, your copy does not receive further updates. If your deployment contains both an
Information Store and i2 Connect, you might be working with records on the chart that are not aligned
to the Information Store schema. Unaligned records cannot be uploaded to the Information Store, and
therefore are not updated when you use Get Changes.
1. Select the chart items whose records you want to update.
2. On the Home tab of the ribbon, in the Share Records group, click Get Changes.
The Get Changes window opens with a summary of the records that contain updated versions in the
Information Store.
Important: If you edited any of the records that have changes in the Information Store, the window
provides the opportunity to copy information from those records to the clipboard. When you accept
the changes, your edits are overwritten and you must reapply them afterward.
3. To accept the changes, click Get Changes.
If you copied any of your edits to the clipboard, you can retrieve that information to make your changes
again to the updated records in your chart.
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Uploading records to the Information Store
If you have access to the feature, you can upload new or edited records to the Information Store. You
can upload individual records, all the records in the currently selected items, or records brought together
by the unite function.
Your organization controls your ability to upload records based on the user groups that you belong to. If
you need to upload records but you are unable to do so, contact your system administrator.
Uploading new or edited records to the Information Store is subject to some rules:
•

For records that have read-only properties in the Information Store, you can edit the copies on your
chart, but you cannot upload them. You might be able to upload changes to notes and details of
some read-only records.

•

For all other records in the Information Store, you can upload new records or edits to records. If you
have access to them, you can also delete notes.

•

If there are changes to the record in the Information Store, you cannot upload your edits; the upload
is blocked. Records must be up to date with the latest changes from the Information Store before you
can upload them.

•

If you have selected united records on your chart, they are uploaded to the Information Store as
separate records.

•

If your deployment contains both an Information Store and the i2 Connect gateway, you might
be working with some records that are not aligned to the Information Store schema. The Record
Inspector displays the "Unaligned" badge beneath the record label, while unaligned records are
counted in the record bar beneath the ribbon menu. In the Upload Records window, you are told if
there are records it is not possible to upload.

1. Select the chart items whose records you want to upload.
2. On the Home tab of the ribbon, in the Share Records group, click Upload Records.
The Upload Records window opens with details of how many records will be uploaded, any records
that cannot be uploaded, and reasons why.
3. To upload the records that can be uploaded, click Upload.
If a record could not be uploaded, it might be because there are changes to the record in the Information
Store. When you close the Upload Records window, the records are marked Upload blocked in the
Record Inspector. You can use Get Changes in the Share Records group to get the changes to these
records from the Information Store, then you can upload your edits.

Working with source references
Source references provide you with information about the origins of i2 Analyze records and connections
to the sources of relevant data that is held in other locations.
Source references capture and preserve connections to data that persist throughout the lifecycle of the
record. This is useful because you can easily locate information that is associated with the record. For
example, you might want to know more about the spreadsheet from which the record was imported,
or the witness statements connected with your investigation. You can view, create, modify, and delete
source references on analyst governed i2 Analyze records. These are records created by Analysts in
the Record Inspector or through an ad hoc import. When you upload records to the Information Store,
other users with access can view or amend the source references. If source references are added to
records when data is ingested into the Information Store, they are system governed. These records are
displayed as read-only and you cannot edit them.
To work with the source references of an i2 Analyze record:
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1. Select the record and double-click to open the Record Inspector.
2. Click the Details tab to display details about the record.
3. In the Source references section, you can see any current
source references. You can edit a source reference if the Actions

button
is available. You can also add a new source reference by clicking Add

and completing the form.
a) Complete all mandatory fields. Fields that are not mandatory are displayed only if a value is
entered.
b) To edit a source reference, click Actions

and click Edit.
c) To delete a source reference, click

Actions
and click Delete.
d) To add a link to an image, paste the URL in the Image URL field.
A thumbnail of the image is included in the source reference. You can click the thumbnail to open
the image URL.
Upload the record to the Information Store.
Note: When you merge records or unite match sets, Notebook maintains source references by creating
them on incoming records.

Deleting records from the Information Store
If you can access the functionality, and you have write access to the records in question, then you can
delete i2 Analyze records from the Information Store through Analyst's Notebook. Record deletion is
permanent, and it can have a broad impact that you must consider carefully before proceeding.
Your organization controls your ability to delete records from the Information Store based on the user
groups that you belong to. If you need to delete records but you are unable to do so, contact your
system administrator.
Sometimes, you might need to delete a record that you or a colleague has uploaded to the Information
Store. For example, an investigation might have come to an end, or you might simply have made a
mistake. If you have copies of the records that you want to delete on your chart, and provided that you
have permission to do so, you can delete them from the Information Store.
Warning: Deleting records from the Information Store cannot be undone, and it has potential
consequences for more records than you can see. All link records must have an entity at each
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end, so if you delete an entity record, you also delete all the links that are connected to that
entity. This deletion takes place regardless of whether the affected links are on the current chart,
or their security settings. Deleting a single, highly connected entity record might therefore affect
many link records.
The first part of the process involves choosing the records that you want to delete, and deciding how
you want to delete them.
1. On the current Analyst's Notebook chart, select the items that contain copies of the records that you
want to delete from the Information Store.
Analyst's Notebook populates the Record Inspector with information about all the records in the
selected items.
2. On the Home tab of the ribbon, in the Share Records group, click Get Changes.
The records in the chart must reflect the latest versions of the records that you want to delete.
3. If you want to delete records one at a time, select the Page view in the Record Inspector and find
the first record to delete. If you want to delete all the selected records, select the List view.
4. In the Record Inspector, open the More actions menu and select Delete from Information Store
(or Delete all from Information Store).
The Delete Records from Information Store window opens.
The window contains a summary of the records that you selected and whether you can delete them.
Common reasons why you might not be able to delete records from the Information Store include:
New records
These records have never been uploaded to the Information Store, so it is not possible to delete
them.
Blocked records
The records in the chart do not reflect changes that have taken place in the Information Store.
Controlled records
The records in the Information Store are controlled by a process such as synchronization with an
external source, and are therefore not yours to delete.
Unaligned records
If your deployment contains both an Information Store and i2 Connect, you might be working with
some records that are not aligned to the Information Store schema. As unaligned records cannot be
uploaded to the Information Store, it is not possible to delete them.
5. If you can delete any of the records that you selected, click Delete permanently to delete them from
the Information Store, or Cancel to close the window.
6. If none of the records that you selected can be deleted, close the Delete Records from Information
Store window.
When you close the Delete Records from Information Store window, Analyst's Notebook Premium
updates the state of any of the selected records that remain on the chart. For example, records that
were blocked from deletion are marked as having Changes available.
If you clicked Delete permanently, then the affected records are deleted from both the Information
Store and the chart. If a deleted record was the only one in a chart item, then the item is also deleted
from the chart. If you deleted an entity record, then all its connected link records are also deleted from
the chart and the Information Store.
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External searches
Some i2 Analyze servers allow you to access information from external data sources, as well as or
instead of the Information Store. The available data sources depend on how your system administrator
configured the server for your organization.
You can use the External Searches feature in Analyst's Notebook Premium to search external data
sources for information. Your system administrator can configure queries to accept parameters that help
to fine-tune your searching. Queries can also allow you to select items on the chart and use them as
seeds in more complex search operations.
For example, when the i2 Analyze server provides access to external data sources and the Information
Store, you can upload the results of external searches to the Information Store as new records. You
can use records from external sources to complement the analysis that you perform with any other
i2 Analyze records. You cannot create your own queries for external data sources, only your system
administrator can do that.

Searching external sources
Your system administrator can enable you to search multiple external data sources for information that
is relevant to your investigation, in various different ways. Analyst's Notebook Premium presents all of
the available queries in the External Searches window.
In general, you can categorize queries for external data sources according to two criteria: Whether you
can (or must) provide parameters, and whether you can (or must) specify seeds.
•

When a query supports parameters, you can customize the query before you run it, with the aim of
seeing more targeted results. For example, a query that searches for people might be configured so
that you can specify ranges of birth dates. A query for cars might allow you to enter a partial license
plate.

•

When a query supports seeds, it changes its behavior when (or does not work until) you select
items that are already on the chart. A query might use information from selected items for several
purposes:
•

Some queries search for information in external sources that is related to information that is on
the chart. For example, they might try to find bank accounts that are known to be operated by a
selected person.

•

Some queries use the information from a selected item as a starting point. For example, they
might search for telephone calls that happened at around the same time as a selected call.

In Analyst's Notebook Premium, the External Searches window contains everything that you need in
order to understand, configure, and run the queries that search external data sources.
1. On the Home tab of the ribbon, click External Searches.
The External Searches window opens, and the queries that your system administrator defined
are listed on the Queries page. The list of available queries is displayed in up to three sections:
Available with the current chart selection, Available with or without a chart selection, and
Not available with the current chart selection. Sections are not displayed if there are no queries
available.
2. Optional: Use the Filter these queries field to enter text that filters the list of queries by name.
3. Click a query to select it and display more information about it.
The pane on the right of the Queries page lists the actions that you can perform with the selected
query. The same pane also describes what types of information the query can return, indicates
whether the query supports or requires seeds, and might include a longer explanation of its behavior.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 95

4. Unless the query requires seeds that you have not selected, you can click Open.
What happens next depends on whether the query supports parameters:
•

If the query does not support parameters, it runs immediately and you see a new page that
contains search results from the external data source.

•

If the query does support parameters, you see a new page where you can enter values for those
parameters before you run the search.

Note: Queries that have no mandatory parameters have an extra action: Copy to chart. This action
copies any search results straight to the chart without first showing them in a list.
After the query runs, the External Searches window gains a Results view that contains the search
results. From here, you can select results and copy them to the chart surface, or you can refine your
search by filtering the results.

Running a parameterized query
Opening a query that supports parameters from the External Searches window in Analyst's Notebook
is different from opening one that does not. Parameterized queries prompt you to enter search condition
values before you run them, with the aim of producing more targeted results.
1. Follow the general procedure for searching external sources as far as Step 4: Open the External
Searches window, select a query, and click Open.
When a parameterized query opens, the External Searches window gains a new tab that contains a
Conditions view.
The Conditions view can be different for every query. Its appearance depends on how your system
administrator configured it. The main area of the view contains fields where you provide the condition
values that customize the query when it runs.
2. Enter a value for every mandatory field, and as many of the other fields as you need.
Mandatory fields are initially colored red, and change color to indicate that your entry meets the rules
for the value. If your entry is not valid, a message beneath the field advises you what change you
need to make.
3. Click Run to start the query.
After the query runs, the tab in the External Searches window that has the Conditions view gains a
Results view that contains the search results. From here, you can select results and copy them to the
chart surface, or you can refine your search by filtering the results.
You can also switch between the Results view and the Conditions view by using the directional arrows
on the information bar. In this way, you can rerun the query with modified parameters without returning
to the Queries list.

Running a seeded query
To run a query that supports seeds against an external data source, you must first understand the
kinds of seeds that it requires, and select some on an Analyst's Notebook chart. When you satisfy the
requirements, the query becomes available for use.
When a system administrator configures a seeded query on an external data source, they can place
restrictions on the types, number, and origin of the seeds that they require. Before you can open a
seeded query, you must select chart items that contain records that obey its restrictions, as indicated in
the Queries tab of the External Queries window.
1. Follow the general procedure for searching external sources as far as Step 3: Open the External
Searches window and select a query.
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When a query supports or requires seeds, the pane on the right of the Queries page describes what
you must select:
Seed type constraints
The types of seeds that the query uses, and the number of each type.
Seed count limits
Lower and upper boundaries (if any) on the total number of seeds.
Seed data sources
The data sources from which seeds must originate.
If one of these headings is not in the list, then the selected query has no requirements of that kind.
2. Select chart items that meet the requirements of the seeded query.
3. Select the query and then click Open or Copy to chart, depending on whether the seeded query
also supports or requires parameters.
After this point, the seeded query behaves just like any other query against an external data source.
You can specify parameters or browse search results, and then add results to the chart or filter them
further.

Matching records on the chart
When you copy a record from an external data source that matches with a record on your chart,
Analyst's Notebook updates the chart record with incoming data instead of creating a duplicate record.
This is a useful way to improve the quality of your data, as you can enrich your records with information
from other sources and manage unnecessary duplication.
When you run a search query against an external data source, some of the returned records might
match with the records on your chart. Record matching updates the data in both analyst and system
governed records. Analyst governed records are those created and uploaded by Analysts, whereas
system governed records are ingested into the Information Store automatically and are read-only.
Record matching does not change record properties, it changes property values. For example, you
create a person record for Sam Steele on your chart. You add property values for his age and hair
color, which is brown. You then run an external search query that finds a match with a record for Sam
Steele. The incoming record has no property value entered for age and hair color is black. Analyst's
Notebook updates your chart record with all the data from the incoming record, including changing hair
color to black. Existing values on your chart record are maintained when the incoming record has blank
properties. Updates for analyst governed records can include security settings, source references, and
source identifiers. Record matching can update source references and source identifiers for system
governed records, but does not change the security settings.
Note: Blank property values are not reported as matches.
1. On the Home tab of the ribbon, click External Searches and run your search query.
2. Select the records you want to copy to the chart.
The Copying records to charts message is displayed. If matches are found, the Matches Found
Dialog is displayed.
3. The number of system governed and analyst governed records with matches are reported in the
Matches Found Dialog. You can choose to cancel the operation or continue.
If you choose to copy the matched records found in your external search, your chart records are
updated with data from the matching external records.
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Add data from data sources
You can add data to your chart from data sources such as databases. If you have access to several
data sources, you can collate the data that each source provides about an item of interest.
After you connect Analyst's Notebook to data sources, you can search for more information about items
of interest. For example, you might find further details about people of interest, such as their aliases,
and the links that form the networks that they are part of. Then, you can add the data to your chart.
Some data sources support data entry from within Analyst's Notebook. You can simultaneously
add data to the data source and chart. For example, after you chart existing data source items that
correspond to people of interest, you might add items from newly received intelligence, such as a
witness report.

Connecting to a data source
To use a data source, Analyst's Notebook must connect to it. When a data source is connected, you can
access its data and use the features that the data source provides.
If the Connect menu that is in the Data Sources group of the Home tab is disabled, or does not contain
commands for the data source that you want to connect to, you need to take more action. For example,
to connect to iBase databases, you must install the iBase user application on your workstation, even if
the database is stored elsewhere.
Analyst's Notebook connects automatically to some data sources.
1. Click the Home tab, and then in the Data Sources group, click Connect.
Analyst's Notebook displays commands that connect Analyst's Notebook to data sources.
2. To connect to a data source, choose an appropriate command from the list, then if prompted enter
further information such as a user name and password.
Analyst's Notebook connects to the data source. Commands that are provided by the data source are
added to the Connected Sources and Item Actions menus.
If the Data Sources pane is displayed, and the data source provides access to its features through the
pane, the source is selected at the top of the pane. Features that the source provides are displayed in
the lower part of the pane.

Finding data in a data source
You can search a data source for information about an item that is of interest to you. For example, you
might search on the name of a person of interest, then after you identify them in the data source, you
might search further to identify their associates.
The features that are provided differ by data source. To discover all the features that a data source
provides, you must connect Analyst's Notebook to the data source, then look in the appropriate areas of
Analyst's Notebook.
•

To use features that are not item-specific, such as a search feature, click the Home tab, and then in
the Data Sources group, click Connected Sources.

•

To use features that are item-specific, such as a feature that adds items that are related to an
existing chart item, select a chart item that originates from a connected data source, then follow
these steps:
•

Click the Home tab, and then in the Data Sources group, click Item Actions.
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•
•

Right-click the selected chart item, then click the name of the data source in the menu that is
displayed.

Some sources provide access to their features through the Data Sources pane. To access these
features, click the Home tab, and then in the Data Sources group, click Connect > Data Sources
Pane. Select the data source from the list at the top of the pane. After Analyst's Notebook connects
to the data source, the features that the source provides are displayed in the pane.

Add chart items from a data source
After you find information of interest in a data source, you can add corresponding items to your chart.
The new information extends the intelligence that the chart contains, and you can use the analysis
capabilities of Analyst's Notebook on the information.
Some data sources provide the facility to configure the appearance of data source items when they are
charted.
If the item from the data source has the same database identity as an item that is already present on the
charting surface, then a duplicate item is not added. Depending on the data source, Analyst's Notebook
adds properties to the chart item, and updates the data that is stored in other properties. Some data
sources provide the facility to select which chart item properties Analyst's Notebook copies data to.
Tip: If an entity originates from a data source and is represented by a picture from the data source such
as a photograph, you can use a different image. For example, you might have an alternative photograph
stored on your workstation. You must change the entity to an icon, and then select a picture. To change
the representation, click the entity, click the Style tab, then click Change Representation. To select a
picture, click Set Picture in the Entity Style group.

Changes to chart properties when data source items are charted
Charting items from a data source might change the properties of your chart. For example, Analyst's
Notebook might automatically add new entity types and attribute classes to the chart.
When you chart an item from a data source, Analyst's Notebook checks whether the item's entity type or
link type, and the attribute classes of the item, exist in the chart. These checks are on the item type or
attribute class name. If they do not exist, Analyst's Notebook adds them to the chart.
If the chart already contains an item type or attribute class that has the same name, then they determine
the appearance of the data source item. For example, the item type in the chart specifies the icon that
represents the item, and the existing attribute class might specify a prefix.
Some data sources provide the facility to choose which item types and attribute classes are used when
you chart items from the data source.

Data source items that match chart items
If your chart already contains the data source item that you are charting, Analyst's Notebook can update
the existing chart item. If your chart contains items that originate from other sources and represent the
same real world object or relationship as the item that you are charting, you can merge the items to
consolidate the multi-source data.
When a chart contains items from different data sources, your analysis might uncover potential duplicate
data. For example, the top two people in a list of social network analysis results might originate from
different data sources and have different names, but match on other key characteristics. To merge the
entities, select them on the charting surface, click the Analyze tab, then click Merge and Combine >
Merge Entities. You can also use the Find Matching Entities feature to detect duplicate entities.
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Displaying data records
Depending on the data source, data records are attached to items when you add data from a data
source. Data records contain data that is copied from the source record, so that you can view any
copied data that is not displayed on the charting surface.
You can view the data records that are attached to a chart item that has one or more database
identities. A database identity uniquely identifies a source record in the originating data source.
To show the Data Records pages for an item:
1. Right-click the item on the chart and click Edit Item Properties.
2. Choose a database instance folder, and then click a data record in it.
Note: Data records are displayed only when one item is selected on the chart.
Analyst's Notebook displays the data in the data record. Data records are intentionally read-only.
A data source might provide the facility to view the current data about the item, in the data source. You
can see changes that were made in the data source since the item was charted.
Related concepts
Identities on page 6
An identity uniquely identifies an item on a chart or provides a unique link back to entity or link
information in a data source.

Selecting items that originate from a data source
After you connect to data sources and chart items from them, the Data Sources pane displays the
number of chart items that originate from each source. After you select a source, Analyst's Notebook
can select all the items that originate from that source.
1. At the top of the Data Sources pane, identify the row that corresponds to the data source whose
items you want to select.
Note: Only the sources that provide access to their features through the Data Sources pane are
listed.
2. Click the Select chart items button in that row.
All chart items that originate from that data source are selected on the chart surface. You might
choose to analyze the items collectively, for example you might add them all to the Activity View.

Identifying the data sources that an item originates from
You can identify the data sources that an item on the charting surface originates from. After you connect
to those data sources, you can use their features to gain more insight into the items of interest.
1. Right-click an item on the charting surface, and then select Edit Item Properties.
The Edit window opens.
2. Click Item Properties > Label & Identity.
The Database Identities list displays the name of the data sources that the item originates from, and
the database keys that identify the source records.
Choose a data source and connect Analyst's Notebook to it, then use the features that the connected
source provides for working with its data. For example, you might add the network that the selected item
is part of to the chart.
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Detect and resolve duplicate data
To ensure that the quality of your analysis is not compromised by duplicate data, you can search for
entities on the charting surface that might represent the same real world object. Analyst's Notebook
provides a number of tools to help detect and resolve any duplication without the loss of critical data.
When you attempt to paste or import items into a chart or when you chart items from a data source,
Analyst's Notebook automatically compares the identity of items already on the chart with the incoming
items. If a match is found, the item is not copied to the chart. An item's label is not necessarily the same
as identity, for example you can copy any number of Person entities with the same name to a chart. It is
the database identity that is used to automatically detect duplicate data.
Multiple records with different identities often exist for the same entities, and they might contain different
details that collectively give a broader view of an entity. The records might also be incomplete, contain
errors, or alternative spellings. The difference in identity means that the duplication is not automatically
detected, however you can conduct your own analysis to detect and resolve matching items without
compromising your investigation.

Resolve duplicate data that you identify
During your analysis, you might identify that some of the data you are working with represents the
same information and you need to decide how to resolve the duplication. For example, you find that two
entities are aliases for the same person and you do not want them both to appear on your chart.
Merging is one way to resolve duplication that is not automatically dealt with. To help you, Analyst's
Notebook provides tools that manually merge entities, multiple links, and combine attribute classes.
These tools are located in Merge and Combine on the Analyze tab.

Merge chart items
You can manually merge items with different identities on your chart. You can merge entities, merge
links in the same connection, and merge entities and their links that are connected to a common entity.
Merging entities
It is useful to merge entities when you identify two or more entities on your chart that represent the
same real-world object. For example, you might incorporate data into your chart from a source that uses
different naming conventions or you might discover that several people on your chart are the same
person with different aliases. You can find the Merge and Combine tools on the Analyze tab of the
Notebook Ribbon. Select the entities you want to merge and use the Merge Entities option. Use Undo
to reverse the merge action.
Merging links
It is useful to merge links when you have several links between two entities that represent a number
of events and you want to represent them as a single link. For example, you might want to represent
several transactions from one bank account to another as a single link that indicates the total amount
that is transferred. Select the links you want to merge and use Merge Multiple Links from the Merge
and Combine tools on the Analyze tab.
The following actions might result in the automatic merging of links between entities:
•

When you change the multiplicity of a connection, resulting in fewer links in the connection.
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When you change the multiplicity of a connection from a Multiple connection to a Directed or Single
connection or from a Directed connection to a Single connection, links might merge. Which links
are merged depends on their arrowheads. For example, changing from a Multiple to a Directed
connection merges links with arrows in the same direction.
•

When two or more entities that are linked to a common entity are merged.
When two or more entities are merged that have a link to the same entity, those links are combined
into one connection. The resulting multiplicity is the highest order of all the merged connections. A
Multiple connection takes precedence over a Directed or Single connection. A Directed connection
takes precedence over a Single connection. For example, if the existing connection is Multiple, links
are always added to the connection.
Any corners on a connection that is being merged are retained and corners on the other connections
are discarded.

•

When a link is imported or pasted into a chart, where the entities at each end of the link already
exist.
The highest multiplicity of the connections between the entities determines whether the pasted
or imported link is merged or added. For example, if the multiplicity of the existing connection on
the chart or the multiplicity of the connection for the link that is being pasted or imported is set to
Multiple, the link is always added.

When entities with links between them are merged, the links are deleted:
•

Any attributes on a link that is deleted are moved to the resulting merged entity.

•

If a link contains information such as date and time or description, a card which contains this
information is added the resulting merged entity.

•

Any link style information, such as link color, direction, strength, and width is lost.

Selecting which is the resulting item
When you merge chart items, the order that you select the items to be merged is important. Analyst's
Notebook merges the second and further selected items into the first item that is selected.
Note: When you merge a selection of items from List Items, the order of selection in List Items is
preserved in the chart. Therefore, the correct behavior is used when the entities are merged.

Combine attribute classes
You can combine one attribute class and its values with another attribute class, and optionally delete the
source attribute class.
Examples of when you might want to combine attribute classes:
•

You might incorporate data into your chart from different sources that use different attribute classes
to represent the same information.

•

You might want to make the values of an analysis attribute visible on the chart. You can make these
values visible by combining the analysis attribute into an attribute class, which can be displayed.

To combine attributes, you must specify the source attribute class and the target attribute class:
•

The source attribute class (Paste Values of Attribute) is the attribute class whose instances you
want to convert. You can specify that this attribute class is deleted after the attribute classes are
combined.
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•

The target attribute class (Onto Values of Attribute) is the attribute class to which you want instances
to be converted. The target attribute class does not need to be in use on your chart. It is typically the
same type as the source attribute class, for example Text or Flag, but rules also exist for combining
attributes of different types.

Any source attributes on the chart are converted to the target attribute. If a chart item already has an
attribute of the target attribute class, then the value is pasted according to the On Paste behavior that is
defined for the target attribute class.
Rules for combining attributes of different types
Typically, you combine attributes of the same type, for example, two Text attributes or two Number
attributes. In this case, the values are pasted from the source attribute to the target attribute.
The following rules apply when you are combining attributes of different types.
Source

Target

Rules

Text

Number

Only possible when the source
value can be interpreted as a
number, that is, when the text
contains numbers. For example,
the value Text 3 becomes 3.
Otherwise, it is not combined.

Text

Flag

When the source value begins
with Y, y, T, t, or 1, then the
target value is set to YES.
Otherwise, the target value is set
to NO.

Text

Date & Time

Only possible when the source
value is a valid date and time.
Otherwise, it is not combined.

Number

Text

Number is pasted as text.

Flag

Text

Pasted as YES or NO.

Date & Time

Text

Pasted as the date and time,
formatted as it is displayed on
the chart.

Merged data
When data is merged as a result of a paste or import, or after you use one of the merge and combine
tools, as much information as possible is retained.
The merged chart items retain the following information:
•

Location on the chart.

•

Chart item type, for example entity type Subscriber.

•

Date, time, and ordered or controlling state.

•

Semantic type assignment.
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•

Existing cards. The merged chart item also inherits any cards on the chart items that are merged into
it.

•

Data records

The resulting labels depend on the label merge and paste rules settings that you select on the Options
> Behavior page of the Chart Properties window. For example, if the label of one vehicle entity is
ABC123 and the label of the other vehicle entity is Blue articulated truck, you can choose to
append the labels, which results in ABC123 Blue articulated truck. For links, if Sum Numeric
Links is selected, the resulting label is the total value of the merged link labels.
When merged items contain information that would otherwise be lost, a card that contains this
information is added to the resulting item. Examples of information of this type are date and time,
description, grades, source type, and source reference. A card is only created when a merged item
contains information that is different from the item into which it is merged. When you are merging
several items, a card is created for each item that contains different information.
If entities that are being merged both contain instances of the same attribute class, the attribute values
are merged according to the rules that are specified in the attribute class definition.
When merged items contains data records, the data records are maintained separately in the merged
item. Each data record is identified by its unique database key.
Resulting links also retain the position, strength, type, and width of the first selected link and incorporate
the direction of the links that are merged into it.
Resulting entities inherit all links from the merged entities.

Finding and resolving matching entities
You can resolve the potential matches by inspecting the results and deciding what action to take. When
you add data to a chart, it is important to try to ensure that multiple items do not represent the same
real-world object, event, or relationship.
Use the Find Matching Entities feature to compare chart items, identify any entities that might represent
the same real-world object, and resolve the potential matches. In addition to matching based on
entity labels, you can also look for potential matching entities based on their semantic types, and the
meaningful content. When you identify potential matches, you might want to select the matched entities
for closer inspection, link the entities for inspection later, or merge the entities.
The following examples demonstrate some types of duplicate data that the Find Matching Entities
feature might reveal and describe how you might choose to resolve it:
•

Several entities that have similar labels, such as "Sam STEELE", "SAMSTEELE", and "SAM steele"
might exist on your chart. If you have further evidence to support the supposition that these entities
all represent the same person, you can merge the entities. All of the information in the entities'
properties and all the links to these entities are then stored in a single entity.

•

When you add information to a chart from different sources, data that is potentially the same might
be formatted differently. For example, the entities 01234 56789 and 0123456789 might represent the
same telephone number or bank account.

•

Many Address entities might have the same post code but have slightly different addresses. More
investigation is required to determine whether they are duplicate locations. You can add Match links
between the entities to record possible duplication and investigate further.

•

Two Person entities on your chart might have different labels, but the same date of birth and national
identifier. This information might indicate that the two names are aliases for the same person. You
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might choose to link them and investigate further or, if you already have information that indicates
that are they same person, you can merge the entities.
1. Click the Analyze tab, and click Find Matching Entities on the ribbon menu.
The Find Matching Entities pane opens.
2. Select the type of matching you want from the list.
Option

Description

Label Matching

A specialized form of entity matching that
compares entity identities and labels. No two
entities can have the same identity but identities
can differ by letter case or by their digits only.
For example, you can search for identities that
have matching letters, excluding letter case and
digits.

Smart Matching

The semantic type that is assigned to the entity
is used as the basis for the match. For example,
the entity types Doctor, Male, and Anonymous
might all be assigned the Person semantic type.
Common properties of people such as national
identifier and date of birth are then examined
to find potential matches. Smart matching
considers a broad range of criteria, including
attribute instances and database properties that
are assigned the same semantic types. You
can specify a threshold to indicate how strong
the match must be and you can choose which
entities to include in the search.

Smart Matching Against Selection

Similar to Smart Matching, however chart items
are matched only against the current selection
on the chart surface. For example, if the entity
Danny KENT is the only entity that is selected on
the chart, matches are made only against Danny
KENT.

Previously Linked Matches

Search your chart to find matches that you
previously found and preserved on the chart
by adding a Match link between them. You can
find matching entities, ignoring any previously
linked entities, as many times as you like. When
everything of interest is linked, use Previously
Linked Matches to retrieve all the resulting links
from your previous searches.

3. To set up the search criteria for the type of entity matching that you select, click Setup.
4. Click Find.
Any matches are displayed in a tree view in the Matched Sets area of the Find Matching Entities
pane.
5. Use the tools in the Matched Sets area to resolve the matches.
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Note: You can run Find Matching Entities as many times as you like with different options and
different setups.

Label matching
Search for entities that might represent the same real-world object based on their identities and labels
and on specified criteria. For example, you can compare letters only, digits only, or choose to ignore
characters such as spaces or tabs.
Label matching is specialized form of entity matching that does not consider criteria such as attribute
instances and database properties.
If the entity has an identity, it is used when searching for a match. If the entity does not have an identity,
for example if the entity is charted from a data source, the label is used. To override this behavior, select
the Use All Identifiers check box in the Match Entities area of the Setup Label Matching window. All
identities and labels are compared.
To prevent matches based on identity and label alone, you can match only entities of the same type or
of the same type and with a specific semantic type assigned. For example, matching "Sam STEELE
(Male)" with "Sam STEELE (Female)" based only upon their identity and label would not be a good
match.
Entity Matching works by comparing a set of characters between one entity and another. You can
choose to include only letters, only digits, ignore certain characters, and ignore case. For example,
one data source might represent telephone numbers as three groups of digits that are separated by
a hyphen (123-456-789). Another data source might represent telephone numbers without separation
but with an extension number (123456 ext 789). The digits are the same in both cases. You can use
label matching to compare digits only, ignoring the hyphens to match the entities and merge them into a
single entity on your chart.
Label matching reports the search results as sets of potential matches, which are known as matched
sets.

Smart matching
Search for entities on the charting surface that might represent the same real-world object based on
their entity types and criteria such as attribute instances and database property values.
Smart matching uses a set of predefined rules for deciding whether two entities might represent the
same real-world object. It examines entities and their associated links, and compares their property
values to produce an overall score. A score of one indicates a weak match. A score of nine indicates a
strong match. Smart matching reports the search results as sets of potential matches, which are known
as matched sets.
You can choose the strength of match that you want smart matching to report by selecting a threshold.
Depending on the threshold that you choose, you might get fewer but stronger matches, or more but
weaker matches. Typically you start to search your chart with a threshold of 9 to find the strongest
matches, and then repeat each search with lower and lower thresholds.
By changing the threshold, you can split sets of matched entities into more accurate matched sets. For
example, you might have five entities on your chart, two assigned with a Gender attribute set to Male
and three assigned with a Gender attribute set to Female. All entities have the same label but in slightly
different letter case. Selecting a threshold of 1 and 6 in different searches matches the same entities in
both searches but produces different matched sets, as shown in the table.
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Note: The entity type is used for matching but it never implies any property values. In this example,
the Male and Female entities types are treated as Person entities. For smart matching to compare on
gender, gender property values must be assigned to the entities, such as a gender attribute.
Entities in chart

Threshold

Matched sets

Sam Steele (with Gender attribute: Male)

1

Sam Steele (5 Entities)

SAM STEELE (with Gender attribute: Female)

•

Sam Steele

sam steele (with Gender attribute: Female)

•

SAM STEELE

Sam STEELE (with Gender attribute: Male)

•

sam steele

•

Sam STEELE

•

Sam steele

Sam steele (with Gender attribute: Female)
Sam Steele (with Gender attribute: Male)

6

SAM STEELE (3 Entities)

SAM STEELE (with Gender attribute: Female)

•

SAM STEELE

sam steele (with Gender attribute: Female)

•

sam steele

Sam STEELE (with Gender attribute: Male)

•

Sam steele

Sam steele (with Gender attribute: Female)

Sam Steele (2 Entities)
•

Sam Steele

•

Sam STEELE

Rules for smart matching
Smart matching first determines whether entities are eligible to be matched by checking they meet the
following criteria:
•

Comparisons are made between entities that share semantic type behavior. For example, a
comparison can be made between the Organization and Law Enforcement Agency semantic
types because Law Enforcement Agency is a specialization of the Organization semantic type. A
comparison cannot be made between Organization and Person semantic types.

•

Comparisons are made between entities if they have some attributes that have the same property
semantic type, or data record properties that have the same property semantic type.

Where eligible pairs of entities are identified, their properties values are compared and scored according
to how closely they match. The scoring takes account of:
•

Typographical errors; for example, Michael and Micheal.

•

Common synonyms; for example, Richard and Dick.

•

Phonetics; for example, Michael and Mikel.

•

Titles; for example, Mr, Mrs, and Dr.

•

Suffixes; for example, OBE and Phd.

•

Numeric properties; for example, phone numbers match from the right to account for area codes that
might be formatted differently.

Some entity types and property types have semantic behavior. For these types, higher scores are
given for identifying property values such as a car license plate. Less significant facts such as car
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color contribute less strongly. Lower scores are also given where one piece of information contradicts
another, for example Mr D KENT contradicts Mrs D KENT.
Note: Not all property values have semantic behavior. If they do not have semantic behavior, their
values are ignored in semantic matching. For example, the Person properties that have matching
behavior are Title, First Name, Middle Names, Last Name, Full Name, Name Suffix, Gender, Date of
Birth, Job Title, and Email Address. The other properties are ignored.
Matches with database clashes
When you are using Analyst's Notebook with another database application such as iBase or i2® iBridge,
entities that are extracted from the database have an associated database identity.
Matches involving database clashes can occur when two matching entities originate from a single
database that does not support multiple database keys. These entities are included in a matched
set and the set name is appended with the word Clash; for example, <set name>: Clash (4
entities). These clashing entities can be merged, however, vital information might be lost. The
information that is retained after clashing entities are merged depends on whether the entities have
unique database keys and whether the database supports multiple database keys.

Entity and property semantic types recognized by smart matching
Some entity and property semantic types are recognized and used by smart matching.
Each property plays a role in assessing the likelihood that two entities represent the same real-world
object. Some properties identify the entity, such as a national identifier for a person or a license plate
number for a vehicle. Other properties contribute additional information. At least one identifying property
must be assigned to an entity for a match to occur.
This table lists the entity semantic types that are recognized by smart matching and the related property
semantic types that are also considered.
Note: All of the recognized property semantic types can contribute to a match for a pair of entities
but they contribute less than the property types associated with the entity type. For example, a phone
number identifies a phone but it can also contribute to a person match.
The \ symbol in the table indicates a child semantic type.
Property semantic types in bold indicate identifying types or components of identifying types. For
matching to take place, at least one identifying type must be assigned to an entity. For example,
to match entities that are assigned the Car entity semantic type, the entities must have a Vehichle
Identification Number (VIN) or a Vehicle License Plate Number or both. They might also have other
information such as make and model of the vehicle.
The Culture column contains the following entries:
Neutral
The matching behavior of these entity types is culturally independent. For example, Bank Card,
Phone and Web Site entity types match regardless of the language and region of the data.
Partial
The matching behavior of these entity types has some US/UK specific behavior, but matching these
types is still effective in all languages and regions. For example, Motor Vehicle, Organization and
Event.
US/UK
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The matching behavior of these entity types depends on the US/UK English culture. For example,
Person and Location entity types assume US/UK English culture for names and addresses. You can
match these entity types outside of the US/UK English language and region, however, the results
might not be as expected.
Culture

Entity types

Property semantic types

Neutral

Bank Card

Card Number

\Credit Card

Card Type

\Debit Card
Neutral

Bank Account

Account Number
Account Routing Number (US)
Bank Sort Code (UK)

Partial

Motor Vehicle

VIN

\Bus

Vehicle License Plate Number

\Car

Vehicle Model

\Police Car

Vehicle Color

\Motorcycle

Vehicle Make

\Truck

Vehicle Body Style
Vehicle Year

Neutral

Event

Event Date Time

\Meeting

Event Date or Event Start Date

\Crime

Event Time or Event Start
Time
Event Title
Event End Date
Event End Time

US/UK

Person

National Identifier

\Law Enforcement Officer

Person Full Name

\Offender

Person First Name

\Person Alias

Person Middle Names
Person Last Name
Email Address
Date Of Birth
Person Title
Person Suffix
Gender
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Culture

Entity types

Property semantic types

Partial

Organization

Organization Name

\Company
\Bank
\Court
\Criminal Organization
\Government Agency
\Law Enforcement Agency
\Organization Name Alias
Neutral

US/UK

Phone

Phone Number

\Cell Phone

Local Number

\Fax Machine

Area Code

\Pager

International Code

Location

ZIP Code

\ATM

Full Address

\Mailing Address

Address Line 1
Address Line 2
Address Line 3
Address Line 4
Address Line 5
Apartment Number
Building Number/Name
Street Name
City Name
State Name
Post Office Box
Country Name
Country Code

Neutral

Website

Web Address

\Web Page

Link semantic types recognized by smart matching
Some link semantic types are recognized and used by smart matching.
The following table lists link semantic types for which there is smart matching behavior.
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Link types

Description

Is Equivalent To (and any type that is derived from When it is assigned to a link between two entities
this link semantic type)
being compared by smart matching, this link
semantic type is recognized by smart matching,
and contributes positively to the overall score for
the match.
Does Not Match

This link semantic type is assigned to a link when
you use the Exclude feature of Find Matching
Entities.
Link types that are assigned the Does Not
Match semantic type are recognized by smart
matching and prevent the entities at each
end from matching. The link semantic type is
used to indicate that the two entities are not
representations of the same real-world object,
even though there are similarities between the two
entities.

Possible Match Between

This link semantic type is assigned to a link when
you click the Link button in this window. It means
that the links are not then found again when
Ignore Previously Linked is selected.
Links of this semantic type are found by the
Previously Linked Matches option.

Ignored by Matching

You can assign this link semantic type to any of
the links on a chart to exclude them from Find
Matching Entities. It does not prevent two items
from matching but the link is ignored as a reason
for matching. Links might otherwise be taken into
account.

Assumed semantic types for labels
There are some entity types for which the label text is used for matching in addition to the property
values. Semantic types are assumed for the label.
The table indicates how the entity labels are treated during matching.
Entity semantic type

Assumed property semantic type

Person

Person Details *

Organization

Organization Name

Phone

Phone Number

Motor Vehicle

Motor Vehicle Details *

Location

Location Name

Event

Event Title

Bank Account

Bank Account Details *
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Entity semantic type

Assumed property semantic type

Bank Card

Bank Card Details *

Web Site

Web Address

Mailing Address

Full Address

Bank

Bank Name

* When one of these property types is assumed for a property value, smart matching analyzes the
textual content to identify different details. For example, the Bank Account Details property value is
analyzed to try to identify an account number and a bank name.

Previously linked matches
You can build up your analysis by linking potential matches that you find. You can then retrieve all of
your previous results when you are ready to further resolve those potential matches.
Typically you might choose to run Find Matching Entities with the Smart Matching options, setting
different thresholds and the Label Matching option to find potential matches. As a result of these
searches, you might be unsure whether the matches are real matches and you might want to do further
analysis before you decide whether to merge the entities. You can choose to link the potential matches
with links of type Possible Match Between and later use the Previously Linked Matches option to
retrieve all the matches that you previously found and linked.
You can choose to retrieve previously linked matches for only entities of the same type or of the same
type and with a specific semantic type assigned. You can also choose whether to include hidden
entities.
Note: You cannot search background items. If required, use the Send to Background > Foreground
All on the Arrange tab to bring all chart items to the foreground.

Resolve matched entities
When you find matching entities, you can merge them or exclude the matches from further searches. If
further investigation is needed, you can copy the Match links from the Find Matching Entities pane to
the chart to record the potential duplication.
The results of a Find Matching Entities search are displayed as a list of matched sets in the Find
Matching Entities window. When you select a set in the Matched Sets area, the entities that are
contained in the set appear as a chart fragment in the Members of Selected Set area. Links between
the entities represent the matches. You can view the properties of a matched entity or link between the
entities by double-clicking it in the chart fragment.
For smart matching, each link also indicates the score that is given to the match between the two
entities at each end of the link. Each link contains a card that describes the reason for the resulting
score. To view this information, double-click the link and open the Cards page. The card description
shows which properties were examined and what contribution they made to the match score.
In the Description area, several symbols are used to indicate what contribution the properties made to
the score:
+

The property made a positive contribution.

-

The property made a negative contribution.
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~

The property does not reinforce nor weaken the
match.

!

The value for the property was contradictory, for
example Mr Alison SMITH.

You can use the number score and the card description to help you decide whether to merge individual
matches that are found. When you merge the matching entities, the details of the source entity are
retained in the merged entity for future reference.
Merging matched entities
To merge some or all of the entities in a matched set:
1. In the Find Matching Entities pane, select the matched set in the Matched sets area.
2. In the Members of Selected Set area, select the entity to merge into to make it the target entity. The
target entity appears enlarged in the chart fragment.
3. Add all of the entities that you want to merge into the target entity to the selection by holding down
the Ctrl key as you select them in turn.
4. Click Merge. The selected entities are merged in the chart fragment and on the chart surface. The
target entity in your chart contains a card for each merged entity, which contains a description of
the merge. The resulting label depends on the label merge and paste rules that are specified in the
Behavior page of the Chart Properties window.
Linking matched entities on the charting surface
To copy one or more Match links in a matched set to the chart:
1. Select the Match links in the chart fragment.
2. Click Link. The selected Match links are copied to the chart.
The link style is distinct from the other link styles that are used in Analyst's Notebook. It has a label of
Match (for Label Matching) or a label of Match (Strength: N) (for Smart Matching where N is the match
score). The link contains a card, which has a description for the match.
Note: A link is not copied to your chart if the entities are already connected with a link of type Match. It
does not matter if the reason for the match in subsequent searches is different.
Excluding matches
Excluding matches is useful to record that two or more entities are not duplicates, and prevents those
matches from occurring in future Find Matching Entities searches. When you exclude selected Match
links, the label on the link changes to Does Not Match.
1. Select the links on the chart fragment that you want to exclude from further Find Matching Entities
searches.
2. Click Exclude. The Match label on each selected link in the chart fragment changes to Does Not
Match. These links are then also copied to the charting surface.
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Copy and paste
When you copy and paste records between charts, Analyst's Notebook Premium identifies and resolves
matches between the records copied from the source chart and the records already present in the target
chart.
For incoming records, that is the records copied from the source chart, Analyst's Notebook Premium
performs a series of checks to establish if matches exist among the records present in the target chart.
When matches are found, Analyst's Notebook Premium determines the best way to combine or unite the
source and target records. This is a useful way of limiting duplication that can affect the quality of your
analysis and clutter your charts. To deselect default matching on copy and paste, refer to Combining
records on paste on page 265.
Matching in copy and paste is based on three criteria, tested in this order:
•

Record identifiers

•

Source identifiers, provided by External Searches

•

System matching rules configured by your system administrator.

If a source record and target record match according to a criteria, they are combined and not examined
further.
For pairs of records that did not match on their record identifiers, the result on the target chart depends
on whether either record has previously been uploaded to the Information Store. For example, if the
source record has previously been uploaded to the Information Store, it is given priority over a target
record that has not. If neither record has been uploaded, the source record is again given priority.
Source record

Target record

Record Identifier

Not uploaded

Not uploaded

The record identifier of the
source record is kept and the
records are combined.

Uploaded

Not uploaded

The record identifier of the
source record is kept and the
records are combined.

Not Uploaded

Uploaded

The record identifier of the target
record is kept and the records
are combined.

Uploaded

Uploaded

The records are united behind a
lead record.

Sometimes multiple records are found that all match each other. Analyst's Notebook Premium
determines the best source and target records based on:
•

System governed records are preferred over Analyst governed records

•

The number of properties with values for system rule criteria

•

The number of properties with values

•

The record that was created first according to the time stamp.

When two records are brought together to form one record, their properties, notes, source references,
and source identifiers are combined and any duplicate values are discarded. The security settings used
belong to the record identifier that was kept. When records are united, one is assigned as the lead
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record, which is displayed on the chart. Each record grouped behind the lead record retains its own
properties and values.
When you paste your copied records onto the chart, a status message tells you if matches are found
and what action occurred, for example the number of pasted records that were combined with matching
records. If some or all of your pasted records have multiple matches, the status message tells you that
can resolve the matches by using Find Matching Records.

Find matching records
Sometimes your charts can contain multiple records that represent the same real-world objects and
relationships. The Find Matching Records feature in Analyst's Notebook helps you to identify potential
matches and reduce the number of matching records. This means you can keep key information
together, uncover new connections and minimize duplication on your chart.
When multiple records exist for the same item, they are not necessarily populated with exactly the same
information but do have some values in common. The likelihood of finding multiple records increases
when you use data from a number of different sources, such as the Information Store and i2 Connect,
and records that you create on the chart. For example, when you search sources for "Samuel Steele",
you might find that records exist for "Sam Steele", "Sammy Steele", "S Steele", or other variations. You
might have created your own records for "Samuel Steel" that include information that has not already
been uploaded. It is possible that some or all of these records represent the same person and contain
varying amounts of key information, source references, and notes. The match rules provided, along with
the rules that you create, give you a fine level of control in searching out potential matches.
i2 Analyze records contain source identifiers that are used to identify the unique record in the source
system that generated them. Although these source identifiers are not visible to analysts, Find Matching
Records is able to match the source identifiers on records of the same type. Source identifiers can
produce reliable matches because they are not subject to the possible inconsistencies present when
property values are entered. For example, you might have two or more records for the same Person
entity that are not discovered as a match, because the names are spelled differently. The rule provided
for source identifiers can find these records, even when the property rules did not produce a match.
When relationships between entities are represented by multiple link records, your chart can become
cluttered and difficult to read. For example, you might find matching links between Person entities and
the property they have access to such as vehicles, addresses, or devices. You could improve the look of
your chart by merging duplicate link records, as long as they link the same end record.
The presentation of the records in match sets allows you to easily compare the values that they have in
common and examine any anomalies. You can then unite matching Information Store records behind a
chosen target record on the chart, merge the information from chart records into a single target record,
or resolve a combination of chart and Information Store records by both uniting and merging. For
matching link records, the choice of which records to merge gives you the ability to control the links that
you want to see on the chart, and those that you do not.

Creating rules for matching entity records
When you create rules for matching i2 Analyze records, you decide what information Analyst's Notebook
uses to identify matches in the records on your chart.
Depending on how your system administrator has configured Analyst's Notebook, you might have a
number of rules that are available as defaults. You can activate or deactivate these rules but you cannot
amend them. You can also choose to create and edit your own rules. Match rules consist of:
•

A name and description.
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•

An entity type, for example a Person.

•

The property or properties to use in setting conditions, such as Last Name.

•

An operator that sets the kind of comparison for the match, such as Exact match.

•

Refinements to ignore particular characters and white space, if required.

•

The minimum conditions that must be met to report a match.

For example, in your data the combination of Passport Number and Date of Birth, or Last Name might
provide strong evidence of a Person match. You can create a rule that tells Analyst's Notebook to
identify the records on the chart with the same values for these properties. The example match rule
would be:
•

Entity type = Person

•

Match all:

•

•

Property type = Passport Number

•

Operator = Exact match

Match any:
•

Property type = Last Name

•

Operator = Exact match

•

Property type = Date of Birth

•

Operator = Exact match

Note: Analyst's Notebook maintains a separate set of match rules for each server. The rules that you
create remain in the Rules Overview window until you delete them, or connect to a different server.
1. Click the Analyze tab, and then in the Match group, click Find Matching Records.
The Find Matching Records window opens.
2. Click the Rules button, next to the Find Matches button.
The Rules Overview window opens.
3. Click the New rule button.
All the entity types from your current schema are listed.
4. Choose an option from the list, for example, Person.
The New person rule window opens.
5. Enter a name for your match rule in the Name field. You cannot create a rule without a name.
6. Optional: Enter a description of your match rule in the 'Description' field.
7. In the next column, if you want to create conditions that records
must meet in order to match, click the Add a condition button

.
The Add conditions window opens.
8. Select a property type such as First Name and choose an operator for the condition. The default
operator is Exact match. Click the drop-down menu arrow to select other options.
Operator

Description

Exact match

The search identifies property values in the
records that are exact matches. For example, if
your condition is set to the 'Last Name' property,
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Operator

Description
your match sets only contain records whose last
names match exactly.

Match first characters

The condition is met when the opening
characters of the property values match each
other. For example, enter the number '3' to
match with the first three characters.

Match last characters

The condition is met when the closing characters
of the property values match each other. For
example, enter the number '5' to match with the
last five characters.

Equal to

The condition is met when the property value
matches the value that was specified.

Note: You can choose the operator for property values that contain text. Some properties such as
age, height, date of birth, and weight are set to Exact match and cannot be changed.
9. Click the Refine condition button

next to the arrow to make further refinements to the conditions.
Your system administrator might have selected some default options for value
handling, such as when to ignore white space. You can change the default selection
to suit your own rules. A dot icon appears next to the Refine condition button

to indicate when these refinements are modified.
10.In the last column, you can apply a number of conditions of which at least one must be met. You
specify these conditions and refinements in the same way as you did for the previous column.
11.Click OK.
Your rule appears in the list on the Rules Overview window along with a summary of your chosen
conditions.
You might want to create more rules before looking for matches. The Duplicate option in the Rules
Overview window is useful for creating rules to edit, rather than starting from the beginning. When you
are ready to begin matching, activate the rules that you want to search with, click OK, proceed to the
Find Matching Records window and click Find matches.

Resolving matched entity records
You can merge and unite matching entity records on the chart. This means that disparate information
that is stored across multiple sources is brought together. Critical data remains easily accessible,
helping you to uncover paths in the data and improve chart readability.
When you activate and run match rules for entity records, Analyst's Notebook returns the results
in the Entities tab of the Find Matching Records window. The property values of the records in
each unresolved match set are displayed in a table, with matches and clashes indicated by different
icons. You can ascertain whether the records represent the same real world object or relationship by
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comparing the values that match, and those that do not. For example, if the Passport number in four out
of five of the records is a match, the anomaly might be that the number is missing from the fifth record,
it has been input incorrectly, or the record belongs to a different person. Further investigation of the
common property values can help you validate whether some or all of the records in the set are the
same person. You can then decide how to combine the information and make it easier to manage.
The icons that are used in the Find Matching Records window, and their meanings are:
Indicates that this property was specified in the
conditions of the match rules used in this search.

Indicates that this value is unique in the match set.
When there is no equivalent value in any other
record in the match set, this might be a reason not
to merge or unite this record.
Indicates that this value appears more than
once in the match set. The color and hatching
direction have no significance other than to denote
more matches, commonly when comparing large
numbers of records.
Merging records is particularly useful if you are working on a chart with records from the Information
Store and records that have never been uploaded. The target record in a merge keeps its record
identifier, version and security level. The properties, notes and source references of the other records
being merged are copied to the target record and any duplicates are discarded. The links from
the selected records are merged with the target record. You should be aware that if your selected
records have different security levels, you might be merging data from records with a higher security
classification than that of the target record. You can also use the Merge Records function in the Match
group on the Analyze tab to merge selected records quickly. Use Undo to reverse the merge action. It
is not possible to merge Information Store records with each other. The only option available is to unite
these records.
Uniting records is used when you are working with Information Store records, or when you want to
maintain all of the information on the records without any merging taking place. The records are brought
together into a single chart item and the record selected as the target becomes the lead record. When
you upload united records, all the records are kept separately in the Information Store and there is no
indication in the store that the unite occurred. You can upload a chart that contains united records to
the Chart Store and they continue to appear as united on the chart surface when you or another analyst
opens the chart. You cannot unite entity records of different schema item types, for example you cannot
unite Person records with Vehicle records.
If a match set contains both Information Store records and records that only exist on your chart (and
the option to merge where possible is on), you are presented with the Resolve command. This function
resolves matches by merging any records that can be merged and uniting the remaining records. When
you resolve a match set, it is good practice to select an Information Store record as your target to
preserve the network associated with that record. If links are transferred to a target record that is not
from the store, the network can become more fragmented when you upload records. You cannot upload
changes to the properties of system governed records, however you can add notes and details. The
Upload Records window provides information of changes that you have made to read-only records.
Note: If you make changes to records on the chart or delete records after finding matches, you might
need to run Find Matching Records again. Analyst's Notebook detects the changes and displays a
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message on the Find Matching Records window. The Label row updates to show the stale or deleted
records. These records cannot be selected or chosen as target records.
•

To merge and unite entity records:
a) Click an unresolved match set from the list in the Find Matching Records window.
The records in the set display in a table and the corresponding items are also selected on the
chart.
b) Choose the records you want to include in the Select row.
c) Click the button in the Target row, under the record to use as the target.
d) Click Options.
The Configure merge and unite window opens.
e) Click either Merge where possible, otherwise Unite or Always Unite matching records. You
can also choose to create a note of any clashing property values under the merge action.
If you click Merge where possible, otherwise Unite, records that are not in the Information
Store are merged. An Information Store record can only be included in the merge is when it is
selected as the target record. If you click Always Unite matching records, the selected records
move into the same item as the target record. When you select the chart item, you can view the
records it contains in the Record Inspector or if you hover over the selected chart item, you can
view the records in the Data Record area of the Infotip.
f) Depending on the match sets you select, you can choose to complete the merge or unite step in
one action. The Merge records in sets and Unite records in sets functions perform in the same
way as Merge records and Unite records. For example, you have four unresolved match sets
that you have made changes to. The button updates to say 'Unite records in 4 sets'. This option
saves you the time of uniting the match sets individually but it does not unite one match set with
another.

•

To resolve entity records:
a) Click an unresolved match set from the list in the Find Matching Records window.
If your match set contains some records that can merged and others that can only be united, and
you chose to Merge where possible, otherwise Unite, records and chart records, the option to
Resolve the records in that match set is active.
b) Click the radio button in the Target row to select the target record.
The Action column updates to show if the other records in the set will be merged or united.
c) Click Resolve records.

If you chose to merge records, the properties, notes, source references, and source identifiers from
the records in your selection are copied over, unless they already exist on the target record. Duplicate
records are removed from the chart. If the merge results in the target record containing more notes
or source references than the set limit, Analyst's Notebook displays a message. If you are concerned
about losing data, you should undo this action and curate the records you want to merge before
repeating Merge Records. Additionally, you could contact your system administrator and have the
count limits increased for notes and source references.
Records you choose to unite are brought together behind the target record, however all records retain
their information and can be individually viewed in the Record Inspector.
The option to resolve records results in a combination of values being copied onto the target record,
while Information Store records are united.
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Creating rules for matching link records
When you create rules for matching i2 Analyze link records, you decide what information Analyst's
Notebook uses to identify matches between the same end records on your chart.
Depending on how your system administrator has configured Analyst's Notebook, you might have a
number of link matching rules that are available as defaults. You can activate or deactivate these rules
but you cannot amend them. You can also choose to create and edit your own rules based on the link
conditions in your schema. Link match rules consist of:
•

A name and description.

•

A link type, Communication for example.

•

The property or properties to use in setting conditions, such as the duration of the communication.

•

The link direction that can either be matched exactly or ignored.

•

An operator that sets the kind of comparison for the match, such as Exact match.

•

Refinements to ignore particular characters and white space, if required.

•

The minimum conditions that must be met to report a match.

For example, your chart contains a large number of links relating to communication between devices.
You could improve the look and readability of your chart if you could identify and merge the matching
links. You can create a rule that tells Analyst's Notebook to identify the link records on the chart with the
same values for these properties. The example match rule would be:
•

Link type = Communication

•

Link direction = ignore

•

Match all:
•

Property type = Communication Type

•

Operator = Exact match

•

Property type = Communication Start Date and Time

•

Operator = Exact match

Note: Analyst's Notebook maintains a separate set of match rules for each server. The rules that you
create remain in the Rules Overview window until you delete them, or connect to a different server.
1. Click the Analyze tab, and then in the Match group, click Find Matching Records.
The Find Matching Records window opens.
2. Click the Links button.
3. Click the Rules button, next to the Find Matches button.
The Rules Overview window opens.
4. Click the New rule button.
All the link types from your current schema are listed.
5. Choose an option from the list, for example, Communication.
The New Communication rule window opens.
6. Enter a name for your match rule in the Name field. You cannot create a rule without a name.
7. Optional: Enter a description of your match rule in the 'Description' field.
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8. In the next column, if you want to create conditions that records
must meet in order to match, click the Add a condition button

.
The Add conditions window opens.
9. Select a property type such as Communication Type and choose an operator for the condition. The
default operator is Exact match. Click the drop-down menu arrow to select other options.
Operator

Description

Exact match

The search identifies property values in the link
records that are exact matches.

Match first characters

The condition is met when the opening
characters of the property values match each
other. For example, enter the number '3' to
match with the first three characters.

Match last characters

The condition is met when the closing characters
of the property values match each other. For
example, enter the number '5' to match with the
last five characters.

Equal to

The condition is met when the property value
matches the value that was specified.

Note: The default condition for Link direction is Exact match. To ignore link direction, click the
drop-down menu arrow and select Ignore.
10.Click the Refine condition button

next to the arrow to make further refinements to the conditions.
Your system administrator might have selected some default options for value
handling, such as when to ignore white space. You can change the default selection
to suit your own rules. A dot icon appears next to the Refine condition button

to indicate when these refinements are modified.
11.In the last column, you can apply a number of conditions of which at least one must be met. You
specify these conditions and refinements in the same way as you did for the previous column.
12.Click OK.
Your rule appears in the list on the Rules Overview window along with a summary of your chosen
conditions.
Note: Link records that do not connect the same ends are never a match for each other.
You might want to create more rules before looking for matches. The Duplicate option in the Rules
Overview window is useful for creating rules to edit, rather than starting from the beginning. When you

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 121

are ready to begin matching, activate the rules that you want to search with, click OK, proceed to the
Find Matching Records window and click Find matches.

Merging matched link records
You can merge matching link records on the chart. This means that duplicate information is removed,
preserving the data you need and improving chart readability.
When you activate and run match rules for link records, Analyst's Notebook returns the results in
the Links tab of the Find Matching Records window. The property values of the records in each
unresolved match set are displayed in a table, with matches and clashes indicated by different icons.
Link match sets are listed using the linked end records as identifiers, for example associate links
between Ben Steele and John Smith use both names in the match set list. Links are matched only
between the same pair of ends.
Entities might have multiple matching links representing calls, relationships and other connections, that
you can analyze in the Find Matching Records window. You can decide to keep the links that you
need to see, and merge others to reduce duplication and improve the look of your chart. You cannot
unite any link records.
Note: If you make changes to records on the chart or delete records after finding matches, you might
need to run Find Matching Records again. Analyst’s Notebook detects the changes and displays a
message on the Find Matching Records window. The Label row updates to show the stale or deleted
records. These records cannot be selected or chosen as target records.
•

To merge link records:
a) Click an unresolved match set from the list in the Find Matching Records window.
The records in the match set display in a table and the corresponding items are also selected on
the chart.
b) Click the radio button in the Target row to select the link record you want to keep.
c) Click

Merge records to bring the link records together.
When links are merged, source references and new notes (notes that have not previously been
uploaded), are copied into the target record up to a limit. Analyst's Notebook displays a message
telling you when this number has been reached and that some merged records might not
contain all their notes and source references. If you are concerned about losing data, you should
undo this action and curate the records you want to merge before repeating Merge Records.
Additionally, you could contact your system administrator and have the count limits increased for
notes and source references.
Link records are merged on the chart surface, and the target record keeps both its record identifier and
security level. If the target record has blank properties, it is enriched with data from the most recently
uploaded merged record. All unique source references, source ids and new notes are copied to the
target record, up to the server count limit. Although the link records are no longer visible on the chart,
they are not deleted from the Information Store. You can also use the Merge Records function in the
Match group on the Analyze tab, to easily bring link records together.
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Analytical chart layouts
Chart layouts can reveal groups and patterns in chart data. On association charts, you can identify
highly connected entities and groups of entities that are interlinked. On timeline charts, you can identify
groups of events that occurred close together in time.
Identify highly connected entities
The Peacock layout and Compact Peacock layout group an entity's connections around it on the chart.
Highly connected entities form visible areas of activity on the chart. The areas of activity that are formed
by the Compact Peacock layout are closer together, which can result in a smaller chart.
Identify groups of entities that are interlinked
The Grouped and Circular layouts can identify groups of entities that are interlinked on an association
chart. The Grouped layout visibly distinguishes several groups within a single network, whereas the
Circular layout arranges all members of a network in a circle. Both layouts can identify discrete networks
in chart data.
The Peacock and Compact Peacock layouts identify highly connected entities, which might be
connected to each other. For example, these entities might be the ringleaders of a gang. When the
areas of activity that are formed by the Peacock layout and Compact Peacock layout are separated on
the charting surface, the interlinking of the ringleaders is visible.
Identify events that occurred close together in time
The Grouped by Time layout identifies bursts of activity on a timeline chart. If the time interval between
two events is below a specified threshold, the events are separated by a small gap of a specified size.
A large gap separates each group of events. You can set the threshold value, the size of the small gap,
and the size of the large gap.

Search for information
To find chart items that might be of interest to your investigation, you can search item properties for
specific information. Different search tools on the Analyze tab fulfill different needs.
Search across all chart items and their data
Use the Search pane to search for text, numbers, or dates in any property of any item on the chart. This
feature is useful when you are not sure which property contains the information.
A text property match within the chart can be partial, and the search is not case-sensitive. The search
does not match synonyms or misspellings. For example, 'Rob' matches 'ROBERT', but not 'Bob'. To
provide matches for numeric data where values are rounded, or when the data has greater precision
than the search value, a match can be fuzzy. For example, 32.5 matches 32 and 33, and 32 matches
32, 32.1, and 32.9.
Results are displayed in a table and ranked by how well they match the search terms.
Search for text
Use Find Text to search across multiple properties that store textual information. You can limit the
search scope to the selected items, and limit the scope to only entities or only links.
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You can limit which properties are searched, so that Analyst's Notebook looks for the search text only in
relevant parts of the item. For example, it would not be useful to search the Source Reference property
for a vehicle license plate number.
A match within the chart can be partial. The search is not case-sensitive, unless you use wildcards
or a regular expression to search for a text pattern. For example, you can use wildcards or a regular
expression to search for a vehicle on a partial recollection of the license plate, such as the first and last
character.
Structured search
Use Visual Search to create a structured search, which searches for data in specific properties of chart
items. You can specify multiple search criteria. For example, you can specify that you are looking for
an entity that is assigned the Person semantic type, contains 'Tom Smith' in its label, and has 14 June
1982 for its 'Date of Birth' attribute value.
You can also specify characteristics that are described by a linked entity. For example, to find a Tom
Smith who lives at 12 Main Street, you can specify that Tom Smith must be linked to a Location entity
that has '12 Main Street' for its 'Address 1' attribute value.
You can search for relationships in your data. For example, to identify the accounts that are involved
in high value transactions, you can search for links that represent transactions of value greater than
$75000. If a matching relationship is found, you can choose to select any part of the relationship such
as the link, or a combination such as both entities and the link.

Searching for text
One of the simplest kinds of analysis in Analyst's Notebook is to search for specific words or phrases
in item information. For example, you can find all the chart items that contain a specific street name or
telephone number.
To search for text in chart items, you specify the text to search for, how and where to search for it, and
what to do with the items that contain it:
1. Click the Analyze tab, and then in the Find group, click Find Text.
Tip: Alternatively you can use the keyboard shortcut: Press Ctrl+F.
2. Type the text to search for in the Find box.
Note: Searching is not case-sensitive. A search for "smith" finds "SMITH", "Smith" and "smith".
You can then select any of the following options:
Option

Description

Complex Searching

Define a search by using wildcards or a regular
expression.

Find Items Not Matching

Searches for items that do not contain the text in
the Find box.

Search Cards

Enables card properties for searching in the
Coverage list.
Note: By default this option is selected.

Note: If you choose not to select any of these options, the same properties that are searched by the
Search pane are enabled in the Coverage list.
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3. Select the item properties that you want to search in the Coverage list.
4. In the Search Area section:
a) Select whether to search for text on both entities and links, entities only, or links only
b) To include hidden chart items in the search, select the Reveal Hidden check box.
c) To apply the search only to the chart items currently selected, select the Selection Only check
box. This option is only available when items are selected on the chart.
5. In the Action area, specify the action that you want to use on the items found:
Option

Description

Edit First

Opens the Item Properties window for the first
matching item at the page that contains the
search term. The text is highlighted. Press F3
to find any further matches within this item and
then move to the next item.

Select First

Selects the first item that is found that contains
the search term. Press F3 to find the next
matching item.

Select All

Provides a count of the number of matches.
Selects all matching items, and clears any
currently selected items that do not match the
search result.
Note: Background items that contain the search
term are included in the count, but cannot be
selected on the chart surface.

Add to Selection

Provides a count of the number of matches.
Adds any matching items to the current
selection. Only available when items are
selected on the chart.
Note: Background items that contain the search
term are included in the count, but cannot be
selected on the chart surface.

Remove from Selection

Provides a count of the number of matches.
Removes any matching items from the current
selection. Only available when items are
selected on the chart.

6. Check Select Sibling Links.
This option selects all the links between two entities when one link matches.
Note: This option applies when you are using Select First, Select All, or Add to Selection as an
action.
7. Click OK to run the search.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 125

Regular expressions
Regular expressions provide a way to search for a general pattern of text rather than a specific piece
of text. For example, you can use a regular expression to search for license plates that are based on a
partial sighting.
A regular expression is written as a sequence of characters. The syntax combines the text for which you
are searching with special characters to define the pattern.
Note: Unlike a simple search, a regular expression search is case-sensitive.
Table 8: Supported regular expression characters
Character

Description

.

Matches a single character. For example, ABC
123. matches ABC 1234 and ABC 1235.
Note: This character is equivalent to the '?'
character when you are searching for files by
name in Windows Explorer.

^

Matches the start of a line. For example, ^ABC
matches ABC 1234 and ABC 2345 but not 1234
ABC.

$

Matches the end of a line. For example, 1234$
matches ABC 1234 and CBA 1234 but not 1234
ABC.

*

Matches zero, one or more repeats of the
previous character. For example xx* matches xx,
xxxxxxx

[]

Matches any character inside the brackets. You
can specify a range of characters, for example
[0-9], [a-z].

[^]

Matches any characters except the characters
in the list. For example: [^ABC] matches any
character other than "A", "B", or "C".

|

Matches either the expression before the bar OR
the expression after the bar. For example 1234$|
1235$ matches any license plates that end in
1234 or 1235.

\

Ignores the special meaning of the next character.
For example, abc$|def$|\|$matches any text
that ends in abc, def or |.

Analyst's Notebook does not support extended regular expression combinations (), \(\), \>, \<, \{,
\}, and \digit.
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Wildcard characters
Wildcard characters provide a way to make your search for text more general by standing in for
unknown characters. Wildcard characters can match any character.
Table 9: Supported wildcard characters
Character

Description

?

Matches any single character. For example, Mari?
n finds Marian, Marion, Marianne and Mariano, but
does not find Mariee, or Maria.

*

Matches zero or more characters. For example,
Ca* Finds Carmen JONES, and Caitlin FISK, but
does not find CA 5680

Note: Unlike a simple search, a wildcard search is case-sensitive.

Structured search
You can create a structured search, which searches for data in specific properties of chart items. You
can find entities or discover relationships.
To describe the items that you are looking for, you create a search structure. The structure can consist
of one entity type, or two entity types and a link type between them. For each part of the structure, you
can specify that a chart item must be of a particular item type or semantic type to satisfy the query.
Then, you can then use search conditions to add item characteristics to the query.
The characteristics of an entity can be described by its own properties and the properties of its linked
items. For example, to find a Tom Smith who lives at 12 Main Street, you can use a linked entities
structure. You can specify that one entity of a linked pair of chart items must have a semantic type of
Person and a label that contains "Tom Smith". Then, you can specify that the other entity must have an
entity type of House and have '12 Main Street' for its 'Address 1' attribute value.
You can use a structured search to find relationships. For example, to identify the accounts that are
involved in high value transactions, you can search for links that represent transactions of value greater
than $75000.
Tip: To search for items that are indirectly linked through intermediate items, use Find Linked Items or
Find Path.
To create a structured search:
1. Click the Analyze tab, and then in the Find Items group, click Visual Search.
2. Select the type of search:
Option

Description

Single Entity

Searches for data in entities only.

Linked Entities

Searches for data in entities and links.

3. To select the item types or semantic types to search for, click each part of the search structure then
select an entry from the Type list.
You can choose from the following options:
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•

To search for chart items that have any item type, select (any).

•

To search for items that have an item type from a specific palette, select (is member of) and then
select a palette from the Palette list.

•

To search for items that have a specific semantic type, select (semantic types), select a type
of match from the list, then click Browse to select a semantic type. The Semantic Types list
contains semantic types that are used on the chart.

•

To search for items that have a specific item type, select the item type from the Type list. The list
contains item types that are used on the chart.

4. Optional: For each part of the structure, you can specify a search condition in each of the Identity/
Label, Date & Time, and Attribute Class areas. To satisfy the query, an item must satisfy all the
conditions.
5. To specify a link direction in a search for linked entities, click the link in the structure, then select a
direction from the Direction list.
6. Optional: If items are selected on the charting surface, to restrict the search scope to all selected
items or all unselected items select the appropriate option from the Search Items list.
7. To choose what Analyst's Notebook does with the items that form the search results, select an option
from the Matched Items list. If items are selected on the charting surface, you can add the search
results to the selection, or clear the selection of items in the search results. In any scenario, you can
replace the selection with the search results.
Tip: If your search is for linked entities, you can select whether the Matched Items action applies to
all search results, or only the items that match specific parts of the structure. Select the appropriate
check boxes in the Apply To area. For example, if you are searching for people who own vehicles,
you can choose to select only the people in the search results.
8. To include hidden chart items in the search and reveal them as part of the operation, select Reveal
Hidden.
9. Click OK.
Analyst's Notebook runs the search.

Find networks
You can find the connections and intermediaries between items of interest, discover what is linked
to a specific entity, and find groups of interlinked entities. These networks might contain entities and
relationships that support the activity of items of interest.
Find a network that connects specific chart items
The network that connects items of interest can identify important intermediary entities. The links
between intermediaries, and between intermediaries and the entities of interest, might represent crucial
interactions.
Use Find Path to find a network that connects two chart items, directly or indirectly. If your chart items
contain date and time information you can search for a path that contains sequential events. For
example, to follow the indirect communication of information between two people.
Use Find Connecting Network to find a network that connects several entities, directly or indirectly. To
omit entities that are not of interest to your investigation, or to test hypotheses, you can exclude specific
types of entity and link, and specific entities, from the search.
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Find the items that are linked to a specific entity
The entities that are directly connected to an entity of interest might be significant. For example, they
might be accomplices. Indirectly connected entities and the wider network might contain items that
form the other end of significant chains of activity. For example, the destination account for a chain of
transactions used to launder funds.
Use Find Linked to find the network of the selected entities. You can use a search depth of 1 to identify
the directly connected entities. You can use a higher search depth to identify the wider network. Also,
you can follow connections based on criteria other than path length, such as sequence. For example, if
your chart items contain date and time information, you can identify sequences of events by specifying
that event date and time must advance as the network expands.
Use the Linked Entities pane to explore the selected entity's network. You can view a list of the entities
that the selected entity is directly connected to, then choose the most significant of them and see what
that entity is linked to. The Onward Entities column in the pane can help you to identify highly connected
entities.
Find groups of interlinked entities
A group of entities that interact with each other might be significant. For example, gang ringleaders
might communicate with each other to coordinate activity.
Use Find Clusters to find groups of interlinked entities. Each group is a local center of activity and
consists of entities that have more connections to each other than to entities outside the group.
Use the K-Core measure in the Social Network Analysis feature to find groups. A k-core is a group of
entities that are each connected to at least k other entities in the group. So, the two-core group consists
of entities that are linked to at least two other entities in that group. As k increases, the groups become
smaller and more tightly interlinked. The highest core group might identify individual groups of tightly
interlinked entities.
Use the Grouped layout to visibly distinguish groups of interlinked entities. The Peacock layout and
Compact Peacock layout form visible areas of activity around highly connected entities. When these
areas of activity are separated on the charting surface, the direct and indirect connections between
highly connected entities are visible.
All the described features are on the Analyze tab, except for the layouts, which are on the Arrange tab.

Find a connecting network
To discover whether several entities of interest are connected by a network, you can specify them as
required entities in your search, then Analyst's Notebook can search for a network that connects them
all, directly or indirectly. If a network is found, it might help you to identify important intermediaries.
Optionally, you can exclude specific types of entity and link, and specific entities, from the search.
For example, you might search for a network that joins several bank accounts that are involved in fraud.
The result might identify an intermediate account that distributes money to those accounts and possibly
plays a central role in the fraudulent activity. If you determine that the activity of that intermediate
account is legitimate, you can exclude it from the search, then search again.
If no single network joins all the entities, then the result can consist of the following elements:
•

One or more networks that include some of the required entities.

•

Single required entities that are not associated with any other required entity.
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These results might identify possible gaps in intelligence. Or, you can refute the suggestion that a
known network joins all the entities.

Exclusions
You can exclude specific types of entity and link, and specific entities, from a search for a connecting
network. Use exclusions to configure or refine the search, and to test hypotheses.
To configure or refine the search, you might add exclusions in the following scenarios:
•

A chart might contain telephone call and associate links between people. To discover whether a
network of communication joins several people, you can exclude the Associate link type. You can
exclude an item type at any time.

•

You can exclude specific people that you know are not involved in an incident that you are
investigating.

•

You might know that several people are employed by the same company. To avoid this known
association and search for an alternative network that connects the people, you can exclude the
company.

You can test hypotheses such as whether freezing a specific bank account prevents the movement
of funds between several other accounts of interest. After Analyst's Notebook identifies a connecting
network, you can exclude intermediate entities that you suspect might play a central role, and then
search again. The next search indicates whether an alternative network can join the entities of interest.
You can exclude a specific entity only after Analyst's Notebook identifies it as an intermediate entity in a
connecting network.
Related tasks
Configuring and running a search on page 129
To configure a search for a connecting network, add required entities and set up item type exclusions if
required. The search results indicate whether a connecting network exists.
Refining the search on page 131
After Analyst's Notebook generates results of a search for a connecting network, you can exclude item
types and specific entities from the next search. You can exclude items in the current result that are not
relevant to your investigation.

Configuring and running a search
To configure a search for a connecting network, add required entities and set up item type exclusions if
required. The search results indicate whether a connecting network exists.
1. Click the Analyze tab, and then in the Find Networks group, click Find Connecting Network.
The Find Connecting Network pane opens.
2. To add entities to the search, select the entities on the charting surface. Then, in the Find
Connecting Network pane, click Add Selected Entities.
3. To exclude item types from the search:
a) In the Exclusions area, click Change.
The Change Exclusions window opens.
b) Select the entity types and link types to exclude, and then click OK.
The Exclusions area summarizes the exclusions.
4. Click Find Network.
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The Network entities list displays the required and intermediate entities that form the search result. The
intermediate entities are displayed in bold.
If the result consists of a single network that connects all the required entities, it is selected on the
charting surface and Analyst's Notebook fits it to the window.
If the result consists of smaller networks and unconnected entities, then the Network entities list
separates each of these elements with a horizontal line. Every network and unconnected entity in the
result is selected on the charting surface and Analyst's Notebook fits the result to the window.
To fit a specific network to the window, click a member of that network in the Network entities list.
Tip: A network might be obscured if the chart contains a lot of data, or the entities in the network are far
apart on the chart surface. To make the network clearer, select the network, copy it to a new chart, then
apply a suitable layout.
Related concepts
Exclusions on page 129
You can exclude specific types of entity and link, and specific entities, from a search for a connecting
network. Use exclusions to configure or refine the search, and to test hypotheses.

Search process
To find a connecting network, Analyst's Notebook combines the shortest paths between pairs of
required entities until a connecting network is produced.
Process
When you search for a connecting network, Analyst's Notebook finds the shortest paths between
pairs of required entities. Then, Analyst's Notebook gives each path a value. Direct links between
required entities have maximum value. The value of an indirect path is determined by the following
characteristics:
•

The number of its intermediate entities that are shared with other shortest paths.

•

The number of other shortest paths that pass through those shared intermediate entities.

To construct the connecting network, the highest value paths are added to the result. If the result
contains all required entities, the process ends. Otherwise, the next highest value paths are added until
a network that joins all the required entities is produced.
This process ensures that the resulting network contains intermediate entities that are on the greatest
number of shortest paths between required entities, which helps you to identify important intermediaries
in the network. Where several shortest paths exist between a pair of required entities, this process also
ensures that the path with the most highly connected intermediate entities is added to the network.
Example
The following diagram depicts a connecting network on a chart surface. Required entities are colored
red. Intermediate entities, and links in the connecting network, are colored blue. All other items are not
part of the connecting network.
The chart contains two shortest paths between entity 1 and entity 3. The path in the connecting network
contains an intermediate entity that is shared with the path between entity 2 and entity 3.
Entity 3 and entity 4 are joined by their direct link.
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Refining the search
After Analyst's Notebook generates results of a search for a connecting network, you can exclude item
types and specific entities from the next search. You can exclude items in the current result that are not
relevant to your investigation.
1. In the Exclusions area, click Change.
The Change Exclusions window opens.
2. To exclude item types, select the entity types and link types to exclude.
3. To exclude specific entities, select entities in the Specific entities list.
The list contains intermediate entities in the current search result and entities that are already
excluded from the search.
4. Click OK.
The Exclusions area summarizes the exclusions.
5. Click Find Network.
New search results are generated.
Related concepts
Exclusions on page 129
You can exclude specific types of entity and link, and specific entities, from a search for a connecting
network. Use exclusions to configure or refine the search, and to test hypotheses.

Formatting search results
To emphasize the results of a search for a connecting network, you can format the items within a found
network. The emphasis can make the outcome of your analysis clearer for recipients of the chart.
The entity formatting options apply only to entities represented by icons or theme lines.
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Formatting search results modifies the existing format of chart items. If your chart already contains
meaningful formatting, consider making a copy of the chart.
If you format a network, then modify and rerun the search, Analyst's Notebook restores the original
format of the network so that out-of-date results are not emphasized.
Tip: If you want a network to remain formatted after you rerun the search, you must manually format
it. For example, you might want to visually contrast a connecting network with an alternative network
that you found by excluding intermediate entities then running the search again. To manually format a
network, click a member of the network in the Network entities list, then on the charting surface rightclick a member of the network and click Combined Properties. In the Edit Chart Items window, you
can collectively format the network items.
1. In the Network entities list, click a member of the network that you want to format.
2. To format with the current settings, in the Find Connecting Network pane, click Format Network.
3. To configure formatting settings then format the network:
a) In the Find Connecting Network pane, click Options. The Formatting Options window opens.
b) Modify the settings.
c) To apply the settings to the network, click Format Network.
d) Click OK. The settings are saved and the Formatting Options window closes.
Tip: If the search result consists of smaller networks and unconnected entities, you can apply
different formatting to each of these elements. Click another element in the Network entities list,
then click Options to modify formatting options and format the element.
The network is formatted.
To later restore the network to its original formatting, in the Find Connecting Network pane, click a
member of the network, and then click Undo Formatting.

Searching for paths between two items
You can find out whether two items on your chart are connected, however indirectly, by searching for a
path between them. You can set criteria for which items are allowed on the path.
A path is a specific route between two items on a chart and it includes both entities and links. Most
commonly, a path is between two entities, but it can be between two links or an entity and a link. To find
a path, you must select exactly two items on a chart. The order in which you select the items defines the
direction in which Analyst's Notebook searches for the path. This order can be significant if you choose
to follow link directions for example, or look for events that happened in chronological order.
By default, Analyst's Notebook finds the path between two items that has the fewest number of links.
When two shortest paths are found, they are both selected. You can specify that the path found must
also take account of:
•

Link direction

•

Entities or links with attribute values that match a condition that you specify

•

Time flow (either forward or backward in time)

•

The time gap between successive items on the path

1. Select an origin item first, and then select a destination item on the chart.
2. Click the Analyze tab, and then in the Find Networks group, click Find Path.
The Find Path window opens.
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3. Click the General tab of the Find Path window and specify the general criteria for finding a path
between the two selected items.
4. Optional: To specify date and time criteria when you search for a path:
a) Click the Date and Time tab of the Find Path window.
b) Select the Follow Date and Time check box and specify the required criteria.
5. Click OK to search for a path between the two selected items.
Note: The OK button is displayed only when exactly two items are selected on the chart. If less than
or more than two items are selected, the Find Path Setup window displays a Close button instead.
To search for a path, click Close to save the settings, select two items, and follow the preceding
steps to find paths between the items.

General Find Path criteria
You can choose whether to take account of link direction and specify the items to include when
Analyst's Notebook searches for a path. When a path is found, you can choose what action to take.
Considering link direction
You can choose to consider link direction when Analyst's Notebook searches for paths by selecting Use
Link Directions and selecting one of the following options.
Option

Description

With Arrows

Links are only traveled in the direction of their
arrows.

Against Arrows

Links are only traveled against the direction of
their arrows.

Nondirectional links and bidirectional links are always considered as part of the path, regardless of
whether Use Link Directions is selected.
Restricting which items are included in the paths
You can restrict the search so that it looks for paths that contain only entities and links with an attribute
whose value matches a specified condition. Select the attributes from the Include Entities with
Attribute and Include Links with Attribute lists and configure the conditions by using the controls that
appear. To include entities or links with an attribute of any value, select the Is Present condition. To
include entities or links that don't have the selected attribute, select the Is Absent condition.
If (any) is selected, attributes are ignored when Analyst's Notebook searches for a path.
You can choose whether to include hidden items when Analyst's Notebook searches for a path. To
include hidden items, select the Reveal Hidden check box. All hidden items on the chart are revealed
when a path is found.
Note: If the Reveal Hidden status in the main application is set to Reveal Fully or Reveal in Gray, this
check box is selected by default.
Resulting actions
You can choose the actions that Analyst's Notebook takes when it finds a path:
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Action

Description

Select Entities

Selects all the entities on the path.

Select Links

Selects all the links on the path.

Hide Others

Hides all chart items that are not on the path.
This option is disabled when Reveal Hidden is
selected.
Tip: To show all the hidden items, click the View
tab, and then in the Show and Hide Items group,
click Show All.

Add Depth Attribute

Adds an attribute to each of the chart items on the
path, indicating how many entities removed they
are from the origin entity. The origin entity has a
depth attribute value of zero.
You can select an existing Number attribute to
use, or specify a new one. Only Number attributes
that are defined in your chart are available in the
list. If you enter a new attribute, it is created as a
Number attribute.
If you add a depth attribute to all items on the
path, you can remove that attribute from any chart
items that are not on the path by selecting the
Remove Attribute from Others check box.

Date and time Find Path criteria
You can set the rules for finding a path between two items based on the relative dates and times of
chart items along the path.
Searching forward or backward in time
You can search for a path along which the date and time of each successive item must be later
(forward) or earlier (backward) in time than the previous item.
Limiting the path to a specified period
You can limit a path to a fixed time period. Items with dates and times outside this period are not
considered as part of a path.
When you select the Earliest Date and Time check box, the specified date and time defaults to the
date and time of the origin item, if one is selected and it has a date and time. If no items are selected on
the chart or the selected origin item does not have a date and time, it defaults to the earliest date and
time of all items on the chart.
When you select the Latest Date and Time check box, the specified date and time defaults to the date
and time of the destination item, if one is selected and it has a date and time. If no items are selected
on the chart or the selected destination item does not have a date and time, it defaults to the latest date
and time of all items on the chart.
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Selecting the type of path to find
You can choose whether Analyst's Notebook searches for the path with the fewest number of steps or
the path, which arrives at the destination item at the earliest date and time. If more than one path meets
the specified criteria, then all such paths are shown.
Setting date and time options
When Analyst's Notebook searches for a path, you can specify whether the date and time is considered
on entities, links, or both.
An item does not need a date or time to be considered in relation to the times of other items on the path.
If an item has only a date, it is still included in the path if its date does not contradict the specified flow of
time. For example, the date must be the same as or after the date of the previous item on the path when
the time flow is forwards.
You can specify the behavior for items without a date.
Option

Description

Stop

Stops the search along this path and the item is
not included in the result.
This option might be useful for charts that contain
telephone call data or financial transactions, when
all links are expected to have both a date and a
time.

Continue

Includes the item in the path.
This option might be useful when you want the
path to continue through theme lines, which do not
have a date.

Continue if Ordered

If the item is Ordered and is in the correct position
relative to the previous item on the path, it is
included in the path. Otherwise, the search is
stopped along this path.

Specifying each item on a path is within a certain time of the previous item
You can restrict the path to contain only successive items that have a date and time within a time gap
that you specify. For example, you can specify that every link on a path must take place within an hour
of the previous link. This option can apply to just links, just entities, or both entities and links, depending
on the options selected in the Date and Time area.

Listing linked entities
The Linked Entities pane lists the entities that are linked to the selected entity. To help you identify
potentially significant entities, you can sort the list on different properties.
1. Select an entity on the charting surface.
2. Click the Analyze tab, and then in the List group, click Linked Entities Pane.
The Linked Entities pane opens and lists the entities that are linked to the selected entity.
3. To choose from the full list of properties that the list can be sorted on, click Sort then select a
property from the list.
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Property

Description

Entity

The label of the entity. The list is sorted in
ascending alphanumeric order. If an entity has
no label, its identity is used.

Link

The label of the link that connects the selected
entity and the linked entity. The list is sorted in
ascending alphanumeric order. If the connection
consists of several links, then the number of
links is displayed, for example (2 links).

Onward Entities

The number of other entities that the linked entity
is connected to. The list is sorted in descending
numerical order.

Angle

The positional angle of linked entities in relation
to the selected entity. Entities that are positioned
directly above the selected entity, at zero
degrees, are listed first, and degree position
increases down the list so that entities are listed
in clockwise order.

Position

The list is sorted so that panning between
entities is minimized. You can walk through
the items, clicking them to view their position in
the chart. The entities at the top of the list are
typically the entities nearest the selected entity.

Following a path of linked entities
To explore the selected entity's network, you can choose an entity in the Linked Entities pane and see
what it is linked to.
To list all of the onward entities for a linked entity:
1. In the list, identify an entity of interest, then click it. Analyst's Notebook pans the chart to center the
entity in the window.
Tip: Entities that are connected to many other entities might be significant. The Onward Entities
column helps you to identify these entities. To summarize the immediate network of a linked entity,
hover over its label in the list. If the entity has 12 or fewer onward entities, a tooltip lists their labels. If
the entity has more than 12 onward entities, a tooltip displays the label of the first 10 onward entities,
and the number of other onward entities. If an entity has no label, its identity is used.
2. To see what the entity is linked to, in the list, click the List Linked Entities button beside the entity
label.
The content of the list is replaced.
3. To list the linked entities for your previous selection, click List Linked Entities again. The icon and
identity of the previous selection is displayed again at the top of the Linked Entities pane.
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Finding items linked to a selection
You can extend the current selection of items on a chart to include entities that are linked to the
selection, directly or indirectly, and, optionally, the links between them. You can set rules about which
items are selected.
Options are available on the Select tab of the Analyst's Notebook ribbon, in the Extend Selection
group. Use these options to extend your selection in a number of ways. Alternatively, you can use the
Find Linked Items feature to further extend your selection.
Before you find linked items, you must select one or more items on the chart as a starting point for the
search. Typically, you select one or more entities as the starting point. However, you can select links.
When you select a link, Analyst's Notebook automatically selects the entity at one or both ends of the
selected link, depending on other settings (for example, link directions). It then searches for linked
items.
You can specify that the linked items found must take account of:
•

Search depth

•

Link direction

•

Entities or links, with attribute values that match a condition that you specify

•

Time flow (either forward or backward in time)

•

The time gap between successive items on the path

1. Select one or more items on the chart.
2. Click the Analyze tab, and then in the Find Networks group, click Find Linked Items > Find
Linked Items.
The Find Items Linked to Selection window opens.
Note: To use the current settings, select one or more items and click Find Linked Items > Find
Linked Items with Current Setup.
3. Click the General tab of the Find Items Linked to Selection window and specify the general criteria
for finding items that are linked to the selection.
4. Optional: To specify date and time criteria when you search for items that are linked to the selection:
a) Click the Date and Time tab of the Find Items Linked to Selection window.
b) Select the Follow Date and Time check box and specify the required criteria.
5. Click OK to find items that are linked to the selection.
Note: The OK button is displayed only when one or more items are selected on the chart. If no
items are selected, the Find Linked Setup window displays a Close button instead. To find linked
items, click Close to save the settings, select one or more chart items, and follow the preceding
steps.

General Find Linked criteria
You can choose how far removed from the original selection to search, whether to take account of link
direction, and specify the items to include when Analyst's Notebook searches for linked items. When
Analyst's Notebook finds linked items, you can choose what action to take.
Setting search depth
You can choose how far removed from the original selection to search by setting a search depth. For
example, by using a search depth of one Analyst's Notebook looks for only those entities that are linked
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directly to the original selection. By using a search depth of three, Analyst's Notebook looks for items
that can be indirectly linked three levels away from the original selection.
Clear the Search Depth check box to search all entities that are linked to the original selection,
regardless of how many levels of links there are between them.
Considering link direction
You can choose to consider link direction when Analyst's Notebook searches linked items by selecting
Use Link Directions and selecting one of the following options.
Format

Description

With Arrows

Only links that have an arrow pointing away from
the original selection are searched.

Against Arrows

Only links that have an arrow pointing towards the
original selection are searched.

Nondirectional links and bidirectional links are always considered when searching for linked items,
regardless of whether Use Link Directions is selected.
Restricting which items are included when searching for linked items
You can restrict the items that are included to only those entities and links with an attribute whose
value matches a specified condition. Select the attributes from the Include Entities with Attribute and
Include Links with Attribute lists and configure the conditions by using the controls that appear. To
include entities or links with an attribute of any value, select the Is Present condition. To include entities
or links that do not have the selected attribute, select the Is Absent condition.
If (any) is selected, attributes are ignored when Analyst's Notebook searches for linked items.
You can choose whether to include hidden items when Analyst's Notebook searches for linked items. To
include hidden items, select the Reveal Hidden check box. All hidden items on the chart are revealed
when linked items are found.
Note: If the Reveal Hidden status in the main application is set to Reveal Fully or Reveal in Gray, this
check box is selected by default.
Resulting actions
You can choose the actions that Analyst's Notebook takes when it finds linked items:
Action

Description

Select Entities

Selects all of the entities that are found by the
Find Linked operation.

Select Links

Selects all of the links that are found by the Find
Linked operation.
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Action

Description

Hide Others

Hides all chart items that are not linked to the
original selection.
This option is disabled when Reveal Hidden is
selected.
Tip: To show all of the hidden items, click the
View tab, and then in the Show and Hide Items
group, click Show All.

Add Depth Atttribute

Adds an attribute to each of the linked items,
showing how many entities removed they are from
the nearest item in the original selection. Items in
the original selection have a depth attribute value
of zero.
You can select an existing Number attribute to
use, or specify a new one. Only Number attributes
that are defined in your chart are available in the
list. If you enter a new attribute, it is created as a
Number attribute.
If you add a depth attribute to all items that are
linked to the selection, you can remove that
attribute from any chart items that are not found
by Find Linked by selecting the Remove Attribute
from Others check box.

Date and time Find Linked criteria
You can set the rules for finding items that are linked to the original selection based on the relative dates
and times of chart items that are linked to the selection.
Searching forward or backward in time
You can search for items that are linked to the original selection along which the date and time of each
successive item must be later (forward) or earlier (backward) in time than the previous item.
Limiting the search to a specified period
You can limit the items that are found to a fixed time period. Items with dates and times outside this
period are not selected.
When you select the Earliest Date and Time check box, the specified time defaults to the earliest date
and time on the chart.
When you select the Latest Date and Time check box, the specified time defaults to the latest date and
time on the chart.
Setting date and time options
When you find linked items, you can specify whether the date and time is considered on entities, links,
or both.
An item does not need a date or time to be considered in relation to the times of other items.
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If an item has just a date, it is included in the selection, if the date does not contradict the specified flow
of time. For example, the date must be the same as or after the date of the previous selected item when
the time flow is forwards.
You can specify the behavior for items without a date.
Option

Description

Stop

Does not find the item. No further items that are
linked to this item are considered, but items up to
the item without a date are found.
This option might be useful for charts that contain
telephone call data or financial transactions, when
all links are expected to have both a date and a
time.

Continue

Finds the item and continues to look for further
linked items, according to the Search Depth
setting.
This option might be useful when you want to
continue through theme lines that do not have a
date.

Continue if Ordered

If the item is Ordered and is in the correct position,
it is included. Otherwise, no further linked items
are searched.

Specifying each item on a path is within a certain time of the previous item
You can restrict the linked items to contain only successive items that have a date and time within a
time gap that you specify. For example, you can specify that every link on a path must take place within
an hour of the previous link. This option can apply to just links, just entities, or both entities and links,
depending on the options selected in the Date and Time area.

Searching for clusters of entities
A cluster is a group of entities that have more connections to each other than to entities outside the
group. Finding clusters is useful in charts that contain high volumes of data with many interlinked
entities to find potential groupings such as key players in a criminal investigation.
As part of the search process, Analyst's Notebook measures how interconnected each group of entities
is. This measure of interconnectivity is known as the binding strength.
The method that Analyst's Notebook uses to calculate binding strength is based on link connectivity. In
its simplest form, this method considers the binding strength of a group of entities to be the number of
links that must be deleted to split the group into two distinct chart fragments. For example, the binding
strength of the chart in the following diagram is 1. To split it into two, you need to delete only the single
link between Entity C and Entity E.
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Splitting the chart identifies two chart fragments. To identify clusters Analyst's Notebook continues
to split the groups of entities, until it can no longer divide the chart any further. It assigns the highest
binding strength that it can to each item during the process. Any connected group of entities that has
a binding strength greater than its immediate neighbors is considered to be a cluster. In this chart,
Analyst's Notebook finds two clusters, one with a binding strength of three (entities A, B, C, and D) and
the other with a binding strength of four (entities E, F, G, H, and I). You can filter clusters by specifying
a binding strength threshold. Any cluster with a binding strength below the threshold is not reported. In
the example, if the binding strength threshold is set to three, both clusters are reported. If the threshold
is raised to four, Analyst's Notebook reports only the cluster with a binding strength of four.
Every group of connected entities has a binding strength; the higher the binding strength, the more
interconnected the entities. Link connectivity clusters cannot overlap, so entities cannot belong to more
than one cluster.
To search for clusters of entities:
1. Click the Analyze tab.
2. Optional: To modify or review the search criteria, in the Find Networks group, click Find Clusters >
Find Clusters Setup. The Setup Clusters window opens.
a) Enter a binding strength threshold.
The binding strength threshold determines the minimum binding strength a group of entities must
have before Analyst's Notebook considers it to be a cluster.
b) When you enter a binding strength threshold, you can choose how Analyst's Notebook
determines the binding strength when there are multiple links between entities or values on the
links. This setting is known as the link weight.
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Link Weight Setting

Description

Connections Only

Treats each connection as a single link
regardless of how many links there are
between two entities. This setting is the most
common option.

Connection Links

Counts all links between entities. For example,
by using the Connection Links setting, this
group of entities has a binding strength of six
because six links must be deleted to split the
chart in two.

Link Attribute

Adds the values of a specified Number
attribute on each link in a connection. Select
the attribute in the Link Weight Attribute list.

Connection Sum Links

Calculates the total value of all the numeric
parts of the link labels between two entities.

c) In the Cluster Members area, specify how Analyst's Notebook handles any clusters that it finds.
Setting

Description

Select Cluster Members

Selects entities and the links between them
that are found in a cluster. The selection of all
other chart items is cleared.

Hide Others

Hides all entities and links that do not belong to
a cluster.
Note: If Reveal Hidden mode is selected when
you search for clusters, then the hidden items
remain visible.
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Setting

Description

Cluster Attribute

Assigns an attribute to every cluster member.
You can select an existing Text attribute from
the list or enter a new attribute name. Analyst's
Notebook creates a new Text attribute with this
name. Analyst's Notebook assigns attribute
values to the cluster members:
•

C1 for members of the cluster that has the
highest binding strength.

•

C2 for the cluster that has the next highest
binding strength, and so on.

If two clusters have the same binding strength,
the cluster with the most entities takes priority
when the cluster attribute is assigned.
Binding Strength Attribute

Assigns an attribute to every chart item to
indicate the binding strength that it would be
assigned if it was part of a cluster. You can
select an existing Number attribute from the
list or enter a new attribute name. Analyst's
Notebook creates a new Number attribute with
this name.

3. To search for clusters, in the Find Networks group, click Find Clusters > Link Connectivity
Clusters.
To emphasize any clusters that are found, you can change the color or line width of the links in each
cluster. To format the links in a cluster, select all the links in the cluster, right-click on one of the links,
then click Combined Properties. In the Edit Chart Items window, you can collectively format the links.

Extending clusters
Analyst's Notebook can extend selections to include entities that are connected to a cluster but that are
not bound tightly enough to form part of the cluster itself.
If you add a binding strength attribute when you find clusters, you can then extend the cluster selection
to include any neighboring entities that have a lower binding strength. For example, the chart in the
following diagram has a central cluster with a binding strength of three. As part of your analysis, you
might decide to select any linked entities that have a binding strength of two and then analyze the final
selection further.
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To extend the clusters selection to include more entities and links:
1. With the clusters selected, in the Find Networks group, click Find Linked Items.
2. From the Include Entities with Attribute list, select the binding strength attribute that you assigned
when you searched for clusters, select a condition, and then enter any values.
For example, in the chart that is shown, a single cluster is found, which has a binding strength of
three. You might want to select entities that are linked to it that have a binding strength of two by
links that have a binding strength of two. Select the condition equal to and enter a binding strength
value of 2, then repeat the step for the Include Links with Attribute list.
3. Click OK.
In the example chart, two entities and two links are added to the selection.

Map chart items
To help analyze items with location-based information, chart items can be visualized on map surfaces.
Mapping chart items can be used when investigating events that occur in a particular location or sets of
locations.

Map chart items in i2 Maps
You can create chart items that contain location data, and visualize them on map surfaces using i2
Maps.
When your i2 Analyze records contain data in geospatial properties, their geographic coordinates and
map locations are displayed in the Properties tab of the Record Inspector.
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You can add coordinates for entities that have the Geographic Location property configured in your
schema. For example, location specific entities such as addresses support the inclusion of geospatial
information. By default the coordinate system used is WGS84, where the first value is North (latitude)
and the second is East (longitude). If you have coordinate values from a different system, such as
Easting and Northing, you might be able to convert them to WGS84 datum when you create your new
record.
To work with i2 Maps, go to the Analyze tab of the ribbon and click Map Provider in the Gain Insight
group. Select i2 Maps from the Map Provider list, then click Maps. The i2 Maps window opens and
Analyst's Notebook displays the base map configured by your system administrator. Click Options to
see the base maps and overlays that are available in your deployment.
It is useful to add a number of different addresses to the map to understand more about their locations
in relation to each other, or to events that occurred nearby. The default option for automatically adding
records in i2 Maps is set to 'on'. This means that if records have coordinate values entered in the
Geographic Location properties field, those records are added to the map even when the map view is
not displayed. You can click the Add records automatically button to toggle the setting to either 'on' or
'off'.
Existing data is not affected by toggling the automatic setting. For example if you add geospatial data to
the chart while the function is 'off', the new data is not added to the map when you later toggle it to 'on'.
Similarly, data that you add to the map when the function is 'on' is not removed if you toggle the setting
to 'off'.
i2 Maps must be your active map provider in order for Analyst's Notebook to automatically add records
to the map. If you are working in i2 Maps, with Add records automatically enabled and you switch
map provider, new markers are not added. For example, you switch map provider and copy new
i2 Analyze records that contain geospatial data to the chart. The records are not added to the map
because i2 Maps is no longer active. This is also the result if you add geospatial properties to i2 Analyze
records that are already on the chart, after switching to an alternative map provider.
You can also add entities to the map from the chart surface. If a record has coordinate values entered in
the Record Inspector, a small version of the map is displayed with a location marker. To manually add to
the map, right-click the chart entity and select Add to map from the menu.
Marker clusters help you manage multiple markers by grouping them together, making the map
easier to read. The option to use marker clusters in i2 Maps works in a similar way to adding records
automatically, in that the default setting is 'on'. Click the Use marker clusters button to toggle the
setting to either 'on' or 'off'.
Note: The Add records automatically and Use marker clusters settings are individual to each chart.
When either of these settings is turned off, it remains set to off until reactivated, even after you save and
reopen the chart. If you have multiple charts open, other charts are not affected.

Map chart items in i2 Esri
To analyze Analyst's Notebook chart items that contain location data, you can visualize them on map
surfaces in the i2 Esri Maps window.
You can connect to Esri ArcGIS Online and select any publicly available map in the Basemap Gallery.
Alternatively, you might configure Analyst's Notebook to connect to your own internal Esri Portal for
ArcGIS.
Chart items that contain location information in the form of coordinates can be displayed on the map.
For example, you might decide to map chart items if you are investigating information about events that
occurred in a particular location or set of locations.
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Access the i2 Esri Maps feature from the Analyze tab of the ribbon in the Gain Insight group. Select i2
Esri Maps from the Map Provider list, then click Maps. The i2 Esri Maps window opens and Analyst's
Notebook automatically displays the map.
Note: You must have an internet connection to connect to Esri ArcGIS Online and access the publicly
available maps.

Selecting maps
The maps available for selection depend on various security settings. The available maps are located in
the Basemap Gallery.
When you open the i2 Esri Maps window for the first time, a default map is displayed. The other maps
that are available to you are shown in a gallery at the edge of the window. If the map that you require is
not visible in the gallery, you might need to log in to your ArcGIS portal instance.
When you select a map, it is associated with the chart. When you save your chart, if one or more chart
items have been sent to the map, the association is saved with the chart. The extents and zoom level of
the map are also saved.
If you create a new chart or open an existing chart, Analyst's Notebook displays the last open map
unless another map is already associated with the chart that you are opening.
To display a map and associate it with the current chart:
1. Click any map in the gallery to select it. If the gallery is not shown, click Map Gallery to make the
maps available for selection. To close the gallery, click Map Gallery again. Alternatively, double-click
a map to select it and close the map selection at the same time.
2. Optional: If the required map is not visible in the gallery, you might need to log in to your ArcGIS
portal instance. In the i2 Esri Maps window, click Log In and enter your user name and password. If
you do not know your user name or password, see your system administrator.
After you log in, more maps might become available for you to select.
3. If the map that you selected contains layers that are stored on a secure server, you might need
to provide further credentials. If a Windows Security window opens, enter your credentials for the
location where the map is stored. If you do not know this information, see your system administrator.

Location information
For an entity to be mapped successfully in the i2 Esri Maps window, it must contain location information
in the form of coordinates.
You can enter or store coordinates on entities in one or more of the following places:
•

Labels

•

Descriptions

•

Cards

•

Attributes with specific semantic type assignments

•

Data records

An entity can contain several coordinates that are stored in different places. After mapping, if the
coordinates are different, then the entity is displayed on the map in each location.
Coordinates in text
You can enter coordinates in labels, descriptions, or cards as part of their summary or description.
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Coordinates that are stored in text require an identifying prefix (LOC/) and suffix (//). For example,
LOC/28°16'45.55"N 81°33'59.44"W//.
Coordinates in attributes
You can enter coordinates in a single attribute, or you can split them into their constituent parts and
enter them as a combination of attribute values. The prefix and suffix are unnecessary when you use
attributes. For example, 28°16'45.55"N and 81°33'59.44"W.
Coordinates or the constituent parts of a location are detected in attributes that have the following
semantic type assignments:
•

Altitude

•

BNG

•

Datum Code

•

Decimal Degree

•

DMS

•

Easting

•

Hemisphere

•

Latitude

•

Longitude

•

MGRS

•

Northing

•

UPS

•

UTM

•

UTM Zone

Coordinates in data records
You can map items from data sources (for example, iBase), if the data records contain coordinates.
Coordinates are detected in data records that use the prefix and suffix LOC/ and //. The appropriate
semantic types must be assigned to the data record properties that make up the location.

Ellipse data
Ellipses or circles can be used to display the area around a set point on your map. If you would like to
store ellipse or point radius data for an item, you must define the area to be displayed as a JSON string.
The area that you would like to display is defined by using JSON properties:
JSON Property

Definition

centre

The geographic location of the center of the
ellipse, expressed in a supported coordinate
format.
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JSON Property

Definition

axisUnits

The units to use for the axis definitions. The
supported units are:
•

kilometer/km

•

meter/m

•

centimeter/cm

•

millimeter/mm

•

statute mile/mile/mi

•

Nautical Mile/mi[naut]/NM

•

yard/yd

•

foot/ft

•

inch/in

semiAxis1

This property defines the length of the major semiaxis of the ellipse, that is the longest distance from
the center point to the edge (in the units that are
specified in axisUnits).

semiAxis2

The length of the minor semi-axis of the ellipse,
that is the shortest distance from the center point
to the edge (in the units that are specified in
axisUnits).
Note: If a minor semi-axis is not defined, a circle
is drawn.

rotation

The angle from the X axis (horizontal) to the major
semi-axis in a counterclockwise direction.

rotationUnits

The unit type you want to use for rotation, for
example radians or decimal degrees.

fill

The transparency and color values to apply to the
ellipse. Fill uses ARGB values between 0 and 255
to fill the ellipse. There are default values, which
are stored in the settings.xml file. If you do not
specify values, and the default is not changed, the
fill is:

<Alpha>100</Alpha>
<Red>127</Red>
<Green>127</Green>
<Blue>127</Blue>
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JSON Property

Definition

maxPoints

The maximum number of points used to draw
the perimeter of the ellipse. There is a default
value, which is stored in the settings.xml file. If
you do not specify a value, and the default is not
changed, the maximum number of points is set to
100.

maxSegLength

The maximum length expressed in the specified
axisUnits between two points around the
perimeter. There is a default value, which is
stored in the settings.xml file. If you do not specify
a value, and the default is not changed, the
maximum segment length is set to 10.

For example:
{
"Ellipses": [
{
"centre": "0, 52",
"semiAxis1": 60,
"semiAxis2": 40,
"rotation": 1.5,
"axisUnits": "mile",
"rotationUnits": "rad",
"fill": {
"a": 255,
"r": 255,
"g": 255,
"b": 255
},
"maxPoints": 1000,
"maxSegLength": 8
}]
}

The minimum that is required to define a circle is:

{
"Ellipses": [
{
"centre": "0, 52",
"semiAxis1": 40
}]
}
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The minimum that is required to define an ellipse is:

{
"Ellipses": [
{
"centre": "0, 52",
"semiAxis1": 60,
"semiAxis2": 40,
}]
}

This definition is a JSON array that can contain the details for one or more ellipses. The definition must
be stored either in an attribute that has the semantic type set to Abstract Text > Geographic Area >
Geographic Ellipse, or you can enter ellipse information in labels, descriptions, or cards as part of their
summary or description.
Coordinates that are stored in text require an identifying prefix (ELL/) and suffix (//). For example,
ELL/ { "Ellipses": [ { "centre": "0, 52", "semiAxis1": 60, "semiAxis2":
40, }] }//.

Sending chart items to the i2 Esri Maps window
Items with location information in the form of coordinates can be sent to the i2 Esri Maps window.
When an entity contains coordinates, it is placed at that location on the map. If an entity contains
multiple sets of coordinates, the entity is displayed on the map at each different location. If an entity
does not contain coordinates, you can drag it to the map. The coordinates of the location where it is
dropped are assigned to newly created Latitude and Longitude attribute instances.
1. Select the entities that you want to send to the map.
2. Click the Analyze tab on the ribbon.
3. In the Gain Insight group, check that i2 Esri Maps is selected from the Map Provider list, then click
Maps.
The i2 Esri Maps window opens.
4. Ensure that the correct map is open or select the required map.
5. Add entities to the map in one of the following ways:
•

In the i2 Esri Maps window, click Add Selected Entities. The selected entities that contain
coordinates are added to the map. Entities that do not contain coordinates are not added and a
message is displayed in the status bar of the i2 Esri Maps window.

•

Right-click one of the selected entities on the chart and select Add to Map. The selected entities
that contain coordinates are added to the map. Entities that do not contain coordinates are not
added and a message is displayed in the status bar of the i2 Esri Maps window.

•

Drag multiple selected entities onto the map. Entities that contain coordinates are added to the
map at their coordinate locations. Entities that do not contain coordinates are not added and a
message is displayed in the status bar of the i2 Esri Maps window.

•

Drag a single entity on to the map. If it has coordinates, it is added to the map at that location. If
it does not contain coordinates, the coordinates of the location where the entity is dropped are
assigned to newly created Latitude and Longitude attribute instances.

The map pans to show the selected entities on the map.
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If a problem occurs when you send entities to the map, a warning message is displayed at the bottom of
the map. You can try the following resolutions:
•

Look at the location information for an entity and check that it is in the correct format. Right-click the
entity on the chart, and from the menu, select Edit Item Properties.

•

The coordinates on a chart item might be outside the maximum valid extents of the current map. If
you change to a map that has appropriate maximum valid extents, the chart items are displayed.

Working in the i2 Esri Maps window
Navigate the map window, find or remove mapped items, and copy the map view as a picture.
Navigating the i2 Esri Maps window
To zoom in, double-click the map. To zoom out, press Ctrl and double-click. If your mouse has a wheel,
rotate the wheel forward and back to zoom in and out.
To pan to different parts of the map, drag the map to a different position or use the arrow keys.
Mapped items
When a map contains large numbers of mapped entities, it can be hard to see how those entities
correlate with the entities on your chart. To find an entity on the map, select it on the chart. The map
pans to the corresponding entity on the map and selects it. If you select an entity on the map, the chart
pans to the corresponding entity on the chart and selects it.
To remove entities from a map, select them, then press Delete. Alternatively, right-click one of the
selected items and select Remove Selected or Remove Unselected. The items are removed from the
map but they are not deleted from the chart. You can also remove all entities from the map by clicking
Remove All at the top of the i2 Esri Maps window. Deleting an item on the chart also removes it from
the map.
When you edit the display properties of an entity by editing its chart item properties, the display is
updated on the corresponding entity on the map.
Copy the map as a picture
You can put a copy of the current map into another document as a picture. For example, if you are
writing a report in Microsoft Word, you can include a picture of the map. To copy a picture of the
current map to the clipboard, at the top of the i2 Esri Maps window click Copy as Picture. The current
extent of the map and any entities on the map are copied to the clipboard for you to paste into another
document.

Drawing shapes on a map
It is sometimes useful to highlight certain areas on a map by drawing shapes.
A number of shapes are available for you to draw, for example point marker, polygon, or arrow.
Note: Shapes are not geodesic, that is, they do not follow the contours of the map. They are flat
drawings.
1. In the i2 Esri Maps window, right-click on the map and click Draw or click the drawing tool.
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2. Click the shape that you require.
3. To draw the shape, do one of the following:
Option

Description

Triangle, Arrow, Rectangle, Circle, Ellipse

Drag an area and release the mouse button to
complete the shape.

Line, Polygon

Click to insert the first point, then click to add
extra points. Double-click to complete the line or
area.

Freehand Line, Freehand Polygon

Drag a line or an area and release the mouse
button to finish.

Point

Click the required position.

4. Optional: To delete a shape, select it and press Delete.
Note: You can close the drawing pane at any time by clicking the drawing tool.

Opening a bar chart that shows distance from a selected entity
When a single entity is selected on the map, you can open a bar chart and see the distribution of
other entities on your chart. Compare how far they are from the selected entity, based on their location
information.
It can be useful to see how close other chart items are to a specified mapped entity and how the other
chart items are distributed in relation to it. For example, if you know the location of a stolen car, you can
look at other crimes that happened at a range of distances from this location. You can then add some
or all of these entities to the map. If you then open a histogram that indicates the dates and times of
those crimes, you can use filters to discover other crimes in nearby areas that occurred in a similar time
period.
When you open a bar chart that shows the entity distribution, you can choose the number of steps
(rows) for the bar chart and the distance range to use for each step.
You can open more than one bar chart to show a range of distances from different entities.
1. Select a single entity on the map, then click Distance Bar Chart.
The Bar Charts page of the Bar Charts and Histograms pane opens with a new bar chart. The bar
chart shows a range of distances away from the selected entity and how many entities are located
within each range.
Note: At any time, you can select the central entity that was
used for the bar chart by clicking the select central item button

next to the Steps list.
2. Optional: To change the number of rows, select the required number of steps from the Steps list at
the top of the bar chart.
Note: By default, empty rows are not shown. To show empty rows, go to the Options page of the
Bar Charts and Histograms pane and select the Include Empty Rows check box.
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3. Optional: To change the distance range for each step, select the required value from the list of
distances next to the Steps list.
The bar chart shows how many entities are located in each distance range from the original entity. Any
items that are located outside the furthest range are not counted.
Select a row of the bar chart to focus on entities that are in a specified distance range and filter out the
other entities. The entities in the selected row are selected on the map and on the chart.

i2 Esri configuration
When you work with i2 Esri as your mapping implementation, there are some configuration options that
you might need to modify.

Configuring an Esri Portal for ArcGIS
By default, i2 Esri is configured to connect to Esri ArcGIS Online. You can configure the connection to
point to your own Esri Portal for ArcGIS.
To connect to your own Esri Portal for ArcGIS, you must edit the portal.config file. This file is
located in the following folder:
%AppData%\Local\i2\i2 Analyst's Notebook 9\ESRI Portal
The Microsoft constant special item ID list (CSIDL) is used to represent the standard folder. The actual
location might vary between different versions of Microsoft Windows.
The configuration file contains the following information:
<Portal>
<Uri>http://www.arcgis.com/sharing/rest</Uri>
<ItemId>c0a0cb9dbefb452b89f38ce4a9477834</ItemId>
</Portal>

Where:
Is the URI of the Esri Portal for ArcGIS that you
want to connect to.

Uri

Note: This URI should be in the following format
http://<host name>/sharing/rest
ItemID (optional)

Is the ID of the map that you want to connect to by
default in your Esri Portal for ArcGIS.

1. Locate the portal.config file and open it in your preferred editor.
2. Replace the URI with the URI of your Esri Portal for ArcGIS.
3. You can specify a map to open by default or use the first available map on your Esri Portal for
ArcGIS:
•

To specify a default map, replace the ItemID with the ID of the required map.
To obtain the ID of a map, go to the portal home page and click the map to open it. The ID is the
number at the end of the address. For example, the map http://www.arcgis.com/home/
webmap/viewer.html?webmap=c0a0cb9dbefb452b89f38ce4a9477834 has an ID of
c0a0cb9dbefb452b89f38ce4a9477834.
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•

To use the first available map, delete the following line:

<ItemId>c0a0cb9dbefb452b89f38ce4a9477834</ItemId>

4. Save the file.
You are now configured to connect to your own Esri Portal for ArcGIS. You must restart Analyst's
Notebook for the change to take effect.
To return to the default settings after you edit the configuration file, delete the portal.config file.
If the configuration file or the folder that contains it is deleted, a new configuration file is automatically
created that contains the default settings.

Setting up i2 Esri to use JSON definitions
If you plan on using ellipses to represent an area around a particular point, you can use a JSON
definition. These definitions can use a set of default values for settings that are not location specific, the
default values are stored separately.
Before you can start to work with the JSON definitions that describe geographic ellipses, you need to
identify the attributes that are going to be used to store that information. In addition, you can modify the
default ellipse behavior using the values stored in settings.xml:
<Settings>
<GeographicPolygons>
<GeodesicEllipses>
<MaximumPoints>10</MaximumPoints>
<MaximumSegmentLength>100</MaximumSegmentLength>
<RotateClockwise>false</RotateClockwise>
<MeasureRotationFromYAxis>false</MeasureRotationFromYAxis>
</GeodesicEllipses>
<DefaultFill>
<Alpha>100</Alpha>
<Red>127</Red>
<Green>127</Green>
<Blue>127</Blue>
</DefaultFill>
</GeographicPolygons>
</Settings>

•

To set up an attribute class that supports the ellipse data:
a) Open a chart.
b) Select File > Chart Properties.
c) Select Definitions > Attribute Classes.
d) Choose a Palette to add the new attribute class to, and click New > Text.
e) Enter a Name, and ensure that the Semantic Type is set to Abstract Text > Geographic Area >
Geographic Ellipse.
f) Select the Display options.
Note: JSON definitions can take up a large amount of space if they are displayed using Show
On Chart.
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g) Choose the User Palettes that should include the class, and the Behavior to use when items
containing the attribute are pasted or merged .
h) Click OK.
When your attribute class is saved, you can create or modify a chart template to include it.
•

To modify the default values for ellipse definitions:
a) Locate the settings.xml file, which is installed in C:\ProgramData\i2\i2 Esri Maps\
and open it in your preferred editor.
b) Change the provided defaults to your preferred values:
Setting

Description

MaximumPoints

The maximum number of points used to draw
the perimeter of the ellipse. If you do not
specify a value, the maximum number of points
is set to 100.

MaximumSegmentLength

The maximum length between two points
around the perimeter. If you do not specify a
value, the maximum segment length is set to
10.

RotateClockwise

Determines whether the provided ellipse
rotation value is applied in a clockwise
direction (true), or a counterclockwise direction
(false). If you do not specify a value, the rotate
direction is set to be counterclockwise.

MeasureRotationFromYAxis

Determines whether the provided ellipse
rotation value is applied from the y-axis (true),
or the x-axis (false). If you do not specify a
value, the rotate direction is set to be applied to
the x-axis.

Alpha

Sets the transparency level for the ellipse. This
is a value in the range 0 - 255. If you do not
specify a value, the alpha value is set to 100.

Red

Sets the red level for the ellipse. This is a value
in the range 0 - 255. If you do not specify a
value, the red value is set to 127.

Green

Sets the green level for the ellipse. This is a
value in the range 0 - 255. If you do not specify
a value, the green value is set to 127.

Blue

Sets the blue level for the ellipse. This is a
value in the range 0 - 255. If you do not specify
a value, the blue value is set to 127.

c) Ensure that the file with your changes is saved to C:\ProgramData\i2\i2 Esri Maps\.
You now have an attribute class that can be used to store the JSON definitions. Ellipse data can now
be imported, and will be displayed when entities that contain that data are added to a map. If you are
working as a part of a larger group you can consider:
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•

Storing templates that contain the attribute class in a network location, and set up as the default
when new charts are created.

•

Distributing the settings file to other machines.

Map chart items in Google Earth
You can map entities and links in Google Earth where they are displayed with their Analyst's Notebook
icons, labels, and link colors. Descriptions that contain coordinates, and card summaries from cards that
contain coordinates, are also displayed in Google Earth.
Google Earth adds the entities as temporary places, which are grouped under the chart name. You can
save these temporary places for reuse later by adding them to the My Places folder in Google Earth.
Google Earth mapping has its own Google Earth pane that reports on the items sent to the map
surface and provides options for changing the way that mapping works.

Google Earth settings
Analyst's Notebook configuration options determine where addresses and coordinates are detected
when entities are sent to a mapping surface.
Analyst's Notebook can be configured to restrict which entity properties it looks in for location
information. Restricting the properties helps to improve mapping performance and can also ensure
that specific data is used as the source of mapping information. For example, you might choose that
Analyst's Notebook looks only for location information in labels and attributes because it is the standard
place for your organization to store this type of information.
For successful mapping, entities must contain either coordinates or addresses.
Note: Coordinates or addresses are not required for links because their position is determined by the
entities at each link end. Links are always plotted as a single line.
The following entity properties can be specified as holding location information:
•

Labels

•

Descriptions

•

Card summaries

•

Card descriptions

•

Attributes

•

Data records

Specify the properties to search in the Chart Items panel of the Options page in the Map Chart Items
pane.
Coordinates
Coordinates can be entered as text (identified by a prefix and suffix) or as attribute values. For
example, you might enter the coordinates in the description and the datum as an attribute value. If
you do not want to use the standard LOC/ prefix and // suffix for text coordinates, you can change
the values. On the Chart Items panel of the Options page, click Specify Details under the Labels,
Descriptions and Cards check box.
When you enter multiple coordinates for the same entity, consider how the chart item is displayed
on the map. Each mapped chart item is displayed with the same label appended with a number, and
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has the same description. This description might be confusing where a chart item has coordinates in
the label, description, and card summary.
Addresses
Address information that can be converted by Analyst's Notebook into coordinate values can be
added to a mapping surface.
Two ways of identifying addresses are available:
•

By using a prefix of ADDR/ and a suffix of //
For example, ADDR/ My street, My city, My postal code//
If you do not want to use the standard ADDR/ prefix and // suffix, you can change the values.
On the Chart Items panel of the Options page, click Specify Details under the Labels,
Descriptions and Cards check box.

•

By deriving it from the label, description, and card properties as a whole.

Note: If an address is converted into a coordinate, then the item is focused when you map it. A
message is displayed if the address is not able to be converted.
Where an entity has multiple coordinates or addresses, at more than one location, then the entity is
displayed at each of those locations on the map surface.

How sending coordinates to Google Earth works
When you send chart items to Google Earth, Analyst's Notebook starts Google Earth. Google Earth
zooms to the mapped items, which are shown as placemarks. Google Earth also lists the chart and the
mapped items in the Temporary Places folder in the Places panel.
Relevant chart item properties are used as placemark properties:
•

The entity or link label becomes the name of the placemark.

•

The Analyst's Notebook icon is used as the placemark icon.

•

Your coordinates are displayed as longitude and latitude values.

•

The description is displayed as the placemark description.

•

For entities, the card summary is displayed if the card contains coordinates. For links, card
summaries and descriptions are never displayed.

Analyst's Notebook saves placemark information in a temporary file, and it is this file that is sent to
Google Earth. When you close Google Earth, all Analyst's Notebook placemarks are lost unless you
move them to the Google Earth My Places folder, for example by saving.
Note: When you send further items to Google Earth from the same chart, you are prompted to reload
the temporary file. Click Yes to continue or No to cancel. Alternatively, you can choose to disable this
prompt in Google Earth.
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Sharing mapping data with other users
You can export the mapping data from an Analyst's Notebook chart to a file that you can give to other
users. Exporting the mapping data in this way, enables the exported item to display the entity icons and
links in Google Earth or in any other mapping application that supports KMZ or KML files.

Sending chart items to Google Earth
Items with coordinates and addresses can be sent to Google Earth.
Any entity that you want to send to Google Earth must have an address, or coordinates. Links do not
require coordinates because they are drawn according to the coordinates entered for their link ends.
If just one of the link ends has multiple coordinates, then a link is drawn to each of those locations in
Google Earth.
1. Select the chart items that you want to send.
2. Click the Analyze tab on the ribbon.
3. If more than one map provider is available, in the Gain Insight group select Google Earth from the
Map Provider list.
If Google Earth is the only map provider, in the Gain Insight group, click Maps.
The Google Earth pane opens.
4. In the Map Chart Items pane, click the Sent Items tab.
5. Click Send Chart Item.

When coordinates cannot be found
When you send chart items to Google Earth, you might see the message: No coordinates found
on the Map Chart Items page.
To work out what is wrong, you can try:
•

For a single entity, right-click the selected entity, and from the menu, select Edit Item Properties.
Browse the pages to find out where the coordinates are entered.

•

For multiple entities, right-click the selected entities, and from the menu, select Combined
Properties. This enables you to determine whether there are coordinates that are set, for example,
as attributes.
Note: If the coordinates are correct, and are entered as attributes, check how the attributes are set
in the Specify Attribute Details window.

Finding a mapped chart item
When large amounts of data are placed on a mapping surface, it can be hard to correlate charted items
with their representations on a chart surface. Items that are listed as sent to the chart surface can be
used to control the focus of the mapping application.
To find a mapped item:
1. Select a chart item on the charting surface or on the Sent Items page of the Google Earth pane.
2. Click Find Selected Item in Google Earth.
This command causes Google Earth to center and zoom to that location.
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Showing and hiding chart items based on date and time
When you send chart items to Google Earth that have a date, time, or both, all items are initially mapped
and a time slider is displayed.
The time span is from the earliest date/time of the mapped items to the latest date/time.
To select a period to view, move the time slider and Google Earth shows and hides the appropriate
place marks.
Note: Date and time properties are used as start time, there is no end time so as you advance the time
slider, the collection of entities and links increase until they are all visible.

Setting up mapping options
The options that you select in the Options page are unique to each chart and are saved with it.

Sending more items or replacing items on the map
You can send chart items that have addresses or coordinates to a map. If you change item properties,
the item is replaced on the map.
On the Options page of the Map Chart Items pane, do one of the following steps:
•

Select Adds to the Map to add the selected chart items to the map.

•

Select Replaces Items on the Map to remove existing chart items from the map and replace them
with new items.

Sending items immediately to a map
You can immediately send selected chart items to a map.
Select the Selecting Items Sends them Immediately check box to instantly map the currently selected
chart items whenever the selection is changed by using, for example:
•

Select all

•

Select sets

•

Visual Search

•

List Items, bounding box selections

Note: If an item on the chart is updated, it is automatically updated on the map.

Sending links and inverting link colors
You can prevent links from being displayed and invert link colors on items on the map.
Do one of of the following steps:
•

Clear the Send Links check box to prevent the display of links in Google Earth even if selected on
the chart. When the check box is selected, links are displayed on the map when selected in Analyst's
Notebook and sent to Google Earth.

•

Select the Invert Link Colors check box to improve the clarity of the Google Earth map when the
links are drawn in a color that does not display well on the map.
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Mapping theme lines (virtual paths)
You can map theme lines, such as people or vehicles, that have links to chart items with dates and
times. The items must have coordinates and not addresses.
In Google Earth:
•

If the entity represented as the theme line has no coordinates, then, all the other mapped entities are
displayed with the theme line icon. If the theme line entity has coordinates, then all the other mapped
entities display with their own icon.

•

Each link between the theme line and an entity is displayed as a single wide line provided the entity
has a date and time.

•

The label of the theme line is merged with the label of the entity that it is linked to.

•

In the sidebar, each link is listed separately as a Virtual Path Link, which is appended with a number.

1. In the Map Chart Items pane, click the Options tab.
2. To map theme lines in this way, select the Show Virtual Paths check box.

Specifying how coordinates are used
You can specify how coordinates are used in the Label, Description, and Cards window.
To specify how coordinates are used.
1. Show the Label, Descriptions, and Card Details window by selecting one of the check boxes in the
Chart Items panel of the Options page.
2. Use the following check boxes to specify where Analyst's Notebook looks for coordinates:
Option

Description

Labels, Descriptions, and Cards

Coordinates are entered in the labels of entities,
entity descriptions, and on cards (and you want
to use these coordinates when mapping).

Attributes

Coordinates entered in attributes.

Data Records

Coordinates entered in data records.

3. Coordinates entered as text in labels, descriptions or on cards must be identified by enclosing them
in a prefix and suffix. If required, you can change these identifiers. The change applies to your
charts. However, existing prefixes and suffixes on charts are not updated.
Note: The prefix and suffix are not case-sensitive.

Specifying how addresses are used
You can specify how addresses are used in the Label, Description, and Cards window.
To specify where Analyst's Notebook looks for addresses:
•

Select or clear the Labels, Descriptions, Card Summaries, and Card Descriptions check boxes.

There are three types of address:
•

Text that is enclosed in an ADDR/ prefix and // suffix is always an address

•

Any text in the item properties is potentially an address

•

The label of any chart item assigned the Mailing Address semantic type is always an address
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Note: If required, you can change the address prefix and suffix. The prefix and suffix are not casesensitive.

Supported coordinate formats
Coordinates are entered in the appropriate format for the coordinate system that is used by your
organization. When sent to Google Earth, these coordinates are converted into the corresponding
WGS84 latitude and longitude values.
You can enter coordinates for the following coordinate systems by using Analyst's Notebook:
Coordinate system

Format Description

Example

British National Grid (BNG)

Grid reference (a two letter
code), easting value (a three
number code), northing value (a
three number code).

NZ346134 Or with a datum code
prefix: OGB-7*NZ346134

British National Grid (Decimal)

You can enter a pair of values
up to six digits long. The values
in the pair must have the same
number of digits. You can also
enter the grid letters.

500100 123099 Or, with a datum
code prefix: OGB-A*500100
123099

Decimal Degrees (DD)

Degrees north, degrees east.

13.34 90.76 Or, with a datum
code prefix: WGE * 13.34 90.76

Degrees Minutes Seconds
(DMS)

DMS North, DMS East.

35:54:15 14:31:8

You can enter degrees, minutes, 35° 54'15" 14° 31'8"
and seconds in any of these
formats:
•

35:54:15 14:31:8

•

35/54/15 14/31/8

•

35°54'15", 14°31'8"

•

52°14'36.61”, 0°42'57.09”//

•

WGE * 12°34'56" 98°76'54"

Note: Do not leave spaces after
the characters used for degrees,
minutes, and seconds. Do not
use 'd' for degrees or 'm' for
minutes. For the minute and
second symbols, use the plain
quotation mark character (' or ")
and the closing quotation mark
character (' or ”).
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Coordinate system

Format Description

Example

Military Grid Reference System
(MGRS)

Grid zone UTM zone Easting
Northing

4QFJ12345678 Or, with
the datum code prefix:
WGE*4QFJ12345678

Note: Eastings and northings
can be up to five digits long. You
can also enter the grid and UTM
zones.
Universal Polar Stereographic
(UPS)

Hemisphere Easting Northing

N 2500000 1850000

For example:
•

N 2500000 1850000

•

N 2500000E 1850000N

•

N 2500000 mE 1850000 mN

The northern hemisphere is
assumed if no hemisphere is
specified. For example, these
two coordinates give locations in
different hemispheres:

Universal Transverse Mercator
(UTM)

•

2001125.58678e
1666857.45654668n

•

S 2001125.58678e
1666857.45654668n

Zone number Hemisphere
Easting Northing

11U 465586 3973426

Note: There must be a space
after the hemisphere.

Indicating directions for coordinates
Unless you specify otherwise, the first value is North (latitude) and the second is East (longitude). The
first meter value is the easting and the second meter value is the northing.
Indicating directions for latitudes and longitudes
To specify a different direction or to indicate that the values are reversed, use the following (these
values are not case-sensitive):
•

N, North, or Y

•

S, South or - (minus)

•

E, East, or X

•

W, West or - (minus)

These examples are for the same location:
35:54:15 14:31:8
35:54:15N, 14:31:8E
North 35:54:15, east 14:31:8
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y35:54:15 x14:31:8
Indicating directions for eastings and northings
To specify a different direction or to indicate that the values are reversed, use the following (these
values are not case-sensitive):
•

N, North, or Y

•

S or South

•

E, East, or X

•

W or West

Separating pairs of values
You can use these characters or separate pairs of values:
•

Space

•

Comma followed by a space.

For example:
•

34.138 118.354

•

34.138, 118.354

Note: If the thousand separator in your Windows regional settings is not a comma, then, you can
also separate value pairs with just a comma.

Work with a datum
By default, Analyst's Notebook uses the WGS84 datum. However, depending on the coordinate system,
it might use a more suitable alternative, such as OGB-7, in the case of British National Grid coordinates.
WGS84, is the only worldwide reference system currently in place, and it is the most common datum
in place today. When the WGS84 datum is not applicable, you must specify the datum as part of the
entered coordinates. To use an alternative datum, you can enter coordinates with an explicit datum
code prefix. Coordinates cannot be accurate unless you also supply the reference geodetic system that
was used to calculate them.
For example, for Degrees Minutes Seconds, you can enter coordinates with or without the datum code
prefix:
WGE * 12°34'56" 98°76'54"
35°54'15", 14°31'8" (the WGS84 datum is assumed)
Alternatively, you can create an attribute class to hold a different datum code prefix.

Distributing mapping data
You can export the mapping data from an Analyst's Notebook chart to a file that you can give to other
users. Exporting the mapping data in this way, enables the exported item to display the entity icons and
links in Google Earth or in any other mapping application that supports KMZ or KML files.
Other mapping applications might include:
•

Google Maps

•

Microsoft Virtual Earth

•

ArcGIS Explorer
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Analyst's Notebook can export data as a KMZ (Keyhole Markup Zip) file. This file contains:
•

Mapping data that is converted to Keyhole Markup Language (KML), and saved in a file with a .kml
extension

•

Converted Analyst's Notebook icons

It can also export mapping data as a KML file, in which case the icons are not exported.
Successful interpretation of the mapping data in applications other than Google Earth depends on
whether the application supports the KMZ or KML file formats.

List the contents of your chart
Listing items, cards, and data records allows the information they contain to be sorted, filtered, and
copied to spreadsheets or other external documents. This allows you to analyze data that is not
necessarily visible on chart surface.
To open a list view, click the Analyze tab, and then in the List group select one of the following options:
Option

Description

List Items

A summary of all the items on the current chart
separated into lists of entities and links. For more
information, see Listing all the contents of your
chart on page 164.

List Most Connected

Open the List Most Connected pane to list the
entities with links on the current chart. For more
information, see Listing the most connected items
on page 165.

List Cards

A summary of all the cards that items on the
current chart contain.

List Data Records

A summary of all the records that items on the
current chart contain.

Linked Entities Pane

A summary of all the entities that are linked to
selected entities.

Listing all the contents of your chart
In order to view and sort all the data that has been entered into chart items, you can list the items to
display them in a separate dialog. Viewing the details in this manner allows you to see information that
may not be present on the chart surface.
1. To open the List Items windows, click the Analyze tab, and then in the List group select List Items.
2. To work with these results you can:
Option

Description

Options

Set options that relate to the items in your list,
and to the formatting of text when copied to the
clipboard.
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Option

Description

Sort

Specify the ordering of items based on specified
columns.

Filter

Reduce the list of items to those that you have
selected.

Reveal

Remove any filtering you have set.

Copy

Copy the information for selected items to the
clipboard.

Delete

Remove items from the list view.

Listing the most connected items
Highly connected items are often significant in analysis. You can list the entities and the links between
them based on the number of links present, then change the format of selected items to highlight them
on the chart.
You can choose to list highly connected items according to several different criteria. For example, you
can select links of a particular type, or concentrate on links in a particular direction.
After you list the entities that might be significant, you can change the format of these entities and
relevant links on the chart to highlight them. For example, if you list entities based on total inbound links,
when you click Highlight Top 10, the entity and its inbound links are formatted.
1. To list the connections on your chart. click the Analyze tab, and then in the List group select List
Most Connected.
2. In the Counts pane, select the connection type you are interested in from the Connected by list.
If you would like to list all the types of links, you can select Links of type: Any. To display only the
links that contain records, select Records of type: Any.
3. Select the option to use to list items:
Option

Description

Most links

Lists entities based on the number of links.

Most linked records

Lists the entities based on the number of
connections that contain records.

Most connected entities

Lists entities based on the number of entities to
which they are connected.

Most inbound

Lists entities based on the number of links
that are directed towards the entity, excluding
bidirectional links.

Most inbound records

Lists entities based on the number of link
records that are directed towards the entity,
excluding bidirectional links.

Most outbound

Lists entities based on the number of links that
are directed away from the entity, excluding
bidirectional links.
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Option

Description

Most outbound records

Lists entities based on the number of records
that are directed away from the entity, excluding
bidirectional links.

Connections with the most links

Lists entity-link-entity combinations based on the
number of links in the connection.

Connections with the most records

Lists entity-link-entity combinations based on the
number of records in the connection.

4. Optional: You can use the Restrict options to the reduce the list to items that you have selected on
the chart surface:
•

Restrict Results to Selected Entities - Only show entities that are also selected on the chart.

•

Count Only the Selected Links - Only count links that are also selected on the chart.

Tip: Analyst's Notebook shows active restrictions above the list of entities.
5. Optional: As you add items to the chart, you can use the Update option to refresh your list.
6. Optional: You can use the Copy options to export the contents of the list most connected window to
the clipboard in different formats.

Refining the list of connected items
In addition to filtering the most connected items based on link type, you can also use numerical values
that are stored in either the link label, or a record's properties. You can filter based on the value of
numerical properties of links, for example, to evaluate combined links that indicate multiple calls
between to phones, or links containing information about financial transactions.
When Analyst's Notebook calculates numerical link label values, the first numerical element of a link
label is used. For example, the following link labels all have a numerical value of seven:
•

7

•

Calls: 7

•

7 transfers

•

7 and 8

Negative values are considered in the calculation. For example, the link label -7 has a numerical value
of minus seven. So a negative value counts as seven links in the reverse direction of the link.
1. To list the connections on your chart. click the Analyze tab, and then in the List group select List
Most Connected.
2. In the Values pane, select the connection type that you are interested in from the Connected by list.
If you would like to list links of all types, you can select Links of type: Any.
3. Select the Value to use to refine your list.
4. Select the option that is used to list items:
Option

Description

Total inbound

Lists entities based on the total value of the
numerical link labels of the connected links that
are directed toward the entity.
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Option

Description
Numerical values on bidirectional links are not
included in the count.

Total outbound

Lists entities based on the total value of the
numerical link labels of the connected links that
are directed away from the entity.
Numerical values on bidirectional links are not
included in the count.

Net inbound

Lists entities based on the net inbound value of
the numerical link labels of the connected links.
The resulting value is the total of the numerical
link label values for the inbound links minus the
values for the outbound links.
For example, if an Account entity has two
Transaction links, one paying in 600 from
Account1 and one paying out 400 to Account2,
the net inbound value is 200.

Net outbound

Lists entities based on the net outbound value of
the numerical link labels of the connected links.
The resulting value is the total of the numerical
link label values for the outbound links minus the
values for the inbound links.
For example, an Account entity might have
three Transaction links, one paying in 600 from
Account1 and two paying out a total of 1000,
500 to Account2 and 500 to Account3. The net
outbound value is 400.

Total value of links

Lists the total of the numerical link label values
for all links, including links with no directions and
bidirectional links.
For example, if an Account entity has two
Transaction links, one paying in 600 from
Account1 and one paying out 200 to Account 2,
the total value is 800.

Totals with low net change

Lists the total of the numerical link label values
for all links, where the net change is lower than a
specified limit.
For example, if an Account entity has two
Transaction links, one paying in 800 from
Account1 and one paying out 800 to Account 2,
the net change is 0, but total value is 1600. You
can use this option to highlight accounts where
large amounts of money are passing through
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Option

Description
without remaining in the account, which might be
an indication of money laundering.

Connection totals

Lists entity-link-entity combinations based on the
total of the numerical link label values for all links
in a connection, including links with no directions
and bidirectional links.
For example, Account1 and Account2 might
have two Transaction links between them, one
paying 400 from Account1 to Account2 and the
other paying 600 from Account2 to Account1.
The connection total is 1000.

Connection net totals

Lists entity-link-entity combinations based on the
net total of the numerical link label values for all
inbound and outbound links.
For example, Account1 and Account2 might
have two Transaction links between them, one
paying 400 from Account1 to Account2 and the
other paying 600 from Account2 to Account1.
The connection net total is 200.
Numerical values on bidirectional links are not
included in the count.

5. Optional: You can use the Restrict options to reduce the list to items that you have selected on the
chart surface:
•

Restrict Results to Selected Entities - Only show entities that are also selected on the chart.

•

Count Only the Selected Links - Only count links that are also selected on the chart.

Tip: Analyst's Notebook shows active restrictions above the list of entities.

Highlighting connections on your chart
When you have a list of connected items in the List Most Connected Pane, you can use that list to
navigate these items on your chart surface, and highlight information.
Ensure that you have the List Most Connected pane open, and that you have some results to view.
For more information, see List the contents of your chart on page 164.
When you display items in the List Most Connected pane, each row contains the following information:
•

Highlighting status - The color that is being used to highlight the connections on the chart surface.

•

Icon - The icon that is being used to identify the entity.

•

Label - The label text.

•

Count - The number of links or link records of the selected type in the view.

•

Distribution - How the count of the selected link or record type is reflected in the overall link count for
the entity.
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1. To locate items on the chart, you can select items in the list. To select items in the list and on the
chart surface:
•

Label - Selects the entity.

•

Count or Distribution - Selects the links that are included in the current count (for record counts,
this action selects links that contain those records).

•

Both - Selects both the entity and links.

Tip: You can select multiple items by holding either Shift or Ctrl while making your selection.
2. To highlight items of interest, click the highlighting status indicator found to the left of the item's icon.
Tip: You can use the Highlight Top 10 option to highlight the top ten connections in the list.
3. Optional: To change the color scheme that is used to highlight items, select Highlight Colors .
You can choose between 4 standard color schemes that allow you to specify up to 10 highlight
colors. You can also edit these color schemes to match your color scheme. When you highlight more
than 10 items, the color scheme entries are repeated.
4. Optional: To further accentuate links that have been highlighted, you can use the Set Line Width to
increase the line width of highlighted links.
5. Optional: To remove all highlighting, select Undo Highlighting.

Listing linked entities
The Linked Entities pane lists the entities that are linked to the selected entity. To help you identify
potentially significant entities, you can sort the list on different properties.
1. Select an entity on the charting surface.
2. Click the Analyze tab, and then in the List group, click Linked Entities Pane.
The Linked Entities pane opens and lists the entities that are linked to the selected entity.
3. To choose from the full list of properties that the list can be sorted on, click Sort then select a
property from the list.
Property

Description

Entity

The label of the entity. The list is sorted in
ascending alphanumeric order. If an entity has
no label, its identity is used.

Link

The label of the link that connects the selected
entity and the linked entity. The list is sorted in
ascending alphanumeric order. If the connection
consists of several links, then the number of
links is displayed, for example (2 links).

Onward Entities

The number of other entities that the linked entity
is connected to. The list is sorted in descending
numerical order.

Angle

The positional angle of linked entities in relation
to the selected entity. Entities that are positioned
directly above the selected entity, at zero
degrees, are listed first, and degree position
increases down the list so that entities are listed
in clockwise order.
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Property

Description

Position

The list is sorted so that panning between
entities is minimized. You can walk through
the items, clicking them to view their position in
the chart. The entities at the top of the list are
typically the entities nearest the selected entity.

Following a path of linked entities
To explore the selected entity's network, you can choose an entity in the Linked Entities pane and see
what it is linked to.
To list all of the onward entities for a linked entity:
1. In the list, identify an entity of interest, then click it. Analyst's Notebook pans the chart to center the
entity in the window.
Tip: Entities that are connected to many other entities might be significant. The Onward Entities
column helps you to identify these entities. To summarize the immediate network of a linked entity,
hover over its label in the list. If the entity has 12 or fewer onward entities, a tooltip lists their labels. If
the entity has more than 12 onward entities, a tooltip displays the label of the first 10 onward entities,
and the number of other onward entities. If an entity has no label, its identity is used.
2. To see what the entity is linked to, in the list, click the List Linked Entities button beside the entity
label.
The content of the list is replaced.
3. To list the linked entities for your previous selection, click List Linked Entities again. The icon and
identity of the previous selection is displayed again at the top of the Linked Entities pane.

Copying list information
You can copy any information from a list to the clipboard. For example, you can copy a list of items and
paste it into a spreadsheet.
You can copy information from a list as tab-delimited text and paste it into any application that supports
text. In addition, you can copy a list of most connected items as a picture, text, rich text, or HTML and
paste it into an appropriate application.
•

To copy information in a table as text:
a) Select the entries in the table that you want to copy. To select multiple entries, use the Ctrl or
Shift keys.
b) Click Copy.
c) Open the application into which you want to paste the information, and press Ctrl + V.

•

To copy a list of most connected items:
a) In the List Most Connected window, select an option from the Copy list.
The displayed list of items is copied to the clipboard.
b) Open the application into which you want to paste the information, and press Ctrl + V.
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Statistical views of chart data
You can view data distribution and select and filter your data based on categories and ranges of data.
Viewing distribution and filtering helps you to identify, for example, peak activity in your chart.
You can view the distribution of your data in different ways:
Bar charts

Useful for viewing the distribution of data across
different categories. For example, in a chart that
contains transaction data, you might want to look
at the distribution of data across different account
types.

Histograms

Useful for viewing ranges of data. For example,
in a chart that contains transaction data, you
might choose to look at the distribution of the data
according to values of the transactions within
specific ranges.

Heat matrices

Useful for comparing data distributions across two
dimensions. For example, in a chart that contains
transaction data, you might want to look at how
many transactions fall into each combination of
the hour of the day and the day of the week.

The categories or ranges that you focus on can apply to the ends (or entities), links, or both. For
example, on a chart that contains bank accounts of different types with transactions between them,
available bar charts might include:
•

Ends - Account Type

•

Links - Transaction date and time

•

Both - Label text

You can then apply filters to focus on one or more categories or ranges of your data to gain a better
understanding of specific parts of your data.

Showing data distribution as bar charts and histograms
Using bar charts and histograms to look at the distribution of data in your chart and drill down into the
contents to concentrate on information that is of interest.
To open a bar chart or histogram:
1. Click the Analyze tab, and then in the Gain Insight group, click Bar Charts and Histograms.
The Bar Charts and Histograms pane opens.
2. Click the New tab.
Analyst's Notebook inspects the content of your chart and lists a useful set of bar charts and
histograms that apply to your data. Any entry that would produce a bar chart or histogram with just
one category or an even spread with just one entry in each category is not displayed in the list.
Each list entry includes up to three components.
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Component

Description

Label

A description of the bar chart or histogram. For
example:
•

Link Type - lists the available types of link on
your chart.

•

Label Value - lists the values of chart item
labels.

Count Summary

A count of the total number of items on the
current chart that match the criteria. This count is
split into ends (or entities) and links.

(as histogram)

Any list entry with this component can be
opened as a histogram or a bar chart.

Note: To list all possible bar charts and histograms, select the Show All check box.
3. Enter the name of a property or attribute in the Search properties field.
The list updates as you type to show the available bar charts and histograms that match your search
text.
4. Click the label to open a bar chart or if (as Histogram) is appended to the label, you can click (as
Histogram) to open a histogram.
You can open as many bar charts and histograms as you want. To open a bar chart but remain on
the New page of the Bar Charts and Histograms pane, for example to add further bar charts or
histograms, right-click an entry and select Add Bar Chart.
Note: If a bar chart is open for the histogram that you select, you cannot open it as a histogram
without first closing the bar chart. In the same way, you cannot open a bar chart without first closing
a corresponding histogram. Analyst's Notebook prompts you to change it from one to the other.
Each bar chart that you open appears on the Bar Charts page of the Bar Charts and Histograms
pane. By default, if the value for a row in a bar chart is zero, the row is not displayed. To display rows
that have a zero value, on the Options page of the Bar Charts and Histograms pane, select the
Include Empty Rows check box under Bar Chart Rows.
Any histograms that you open appear in a separate Histograms window.
You can now focus on specific chart items or apply filters to investigate your data further. You can also
look at combinations of properties by viewing heat matrices for the histograms that are open.

View data on a heat matrix
Heat matrices visualize the relationship between the properties of chart items in a grid that shows the
number of occurrences of different combinations of values.
Individual values in the heat matrix are represented by colors from a predefined range of colors. For
example, the lowest value is displayed in the lightest color, through to the highest value, which is
displayed in the darkest color.
Heat matrices can be used to quickly gain insight into your data, and identify areas for further analysis,
such as peak periods when events occur. They are displayed below the histogram in the Histogram
window.
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Note: Show and hide heat matrices by clicking Heat Matrix at the top of the Histogram window. If no
heat matrix is selected, when you click this option, a list of available heat matrices is displayed so that
you can select one.

Displaying a heat matrix
Heat matrices can help identify areas for further analysis, such as peak periods of activity. You can
change the time scale to help identify any patterns or trends. You can see how events occur, for
example, over days or months.
1. On the New page of the Bar Charts and Histograms pane, click the words (as Histogram) to open
a histogram.
2. From the Heat Matrix list, at the top of the Histogram window, select a heat matrix to display.
For example, the Date & Time:Day of Week heat matrix shows the number of occurrences of an
event on days of the week.
3. Optional: Select a scale from the Scale list at the top of the Histogram window.
Note: The Scale list is available only when results contain date and time information without a
predefined scale.
4. Optional: Select whether to use the chart time zone or the time zones on each chart item from the
Timezones list at the top of the Histogram window.
Note: The Timezones list is available only when results contain date and time information.
5. Optional: Customize the display of the heat matrix by changing the heat matrix options.

Heat matrix options
You can specify the way that your heat matrix is displayed. A display option might be the color scale,
range, whether to display all chart items or only selected items, and whether cell counts are displayed in
the heat matrix cells.
Specifying a color scale
By default, the heat matrix colors are displayed from light to dark. You can select an alternative range of
colors and reverse the colors by clicking the arrow to the right of the legend. Select Reverse Colors to
display the color scale in reverse, from dark to light. Select a different color scale to change the range of
colors that are used.
Spacing chart items by using a range
Ranges can be used to space chart items in heat matrices. A range might be linear, logarithmic, or
sequential. Ranges apply to count values.
Click the arrow to the right of the legend and select an option to display values according to different
ranges:
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Range

Description

Linear Range

Map from the range of count values to the range
of colors.

(space values equally)

For example, a heat matrix contains count values
in the range 3 - 22. A linear interval of 4 might be
used to generate a series of scale color. These
colors represent the ranges 1-4, 5-8, 9-12, 13-16,
17-20, 21-24.
Logarithmic Range

Similar to the linear range. The best linear interval
between the minimum and maximum count value
is found and mapped to a logarithmic scale.

(space smaller values more)

This range results in a scale where the first item
in the range covers many values, and subsequent
items cover decreasing numbers of values.
This scale is useful where you have few high
count values and you want to emphasize this
distribution. For example: 1-50, 51-75, 76-86,
87-93, 94-95.
Sequential

The default option.

(space colors equally)

Sort the cell count values into order and partition
into roughly equal-sized groups, one group for
each color.
For example, if the ordered unique nonzero count
values on the heat matrix are as follows: 1, 2, 4,
6, 7, 11, 13, 17, 18, 20, 27, 36, 51, 59, 60, 63,
68, 75, 80, 81, 90, and 99. The unique count
value is a total of 22. The range is broken further
down into ranges that contain approximately the
same number of unique values. In this example,
approximately every four numbers are taken
resulting in the following scale: 1-7, 11-20,
27-59, 60-75, 80-99. The generated scale is not
contiguous.

If your heat matrix is based on numerical values, you can choose to limit the number of rows in the heat
matrix to a maximum of 10, 50, or 100. For example, if you open a date and time histogram and then
create a heat matrix based on label value, you can choose to limit the number of rows.
Display cell counts in matrices
You can display cell counts in a heat matrix. Cell counts display the number of items on the chart that
use the filter. Selected cells in a heat matrix are selected on the chart.
Change whether cell counts in heat matrix cells are displayed by clicking the down arrow to the right of
the legend, and selecting Show Cell Counts.
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Displaying selected chart items
You can choose whether to display cells in a heat matrix for all chart items or only selected chart items
by clicking the required Count option at the bottom of the heat matrix. The Selected Chart items option
is only available if Brush Selection onto Bars is turned on in the Options page of the Bars Charts
and Histograms pane.
Note: When you click Selected Chart Items, any individual cell selections that exist in the heat matrix
are lost.
Selecting ranges of cells
Select a range in the legend by pressing the Shift key and clicking the first range, then clicking the last
range. Alternatively, click and drag a rectangle around the cells that you want to select. All cells that
correspond to that range are selected on the heat matrix. Corresponding chart items and bars in the
histogram are also selected. All other items on the chart are removed from the selection.
You can select a range of cells only when the Count option All Chart Items is selected.

Focus on items of interest
You can focus on specific chart items or categories of data by viewing distributions for a selection of
your chart data. For example, in a histogram you might want to see a count of only those items that
are currently selected on your chart. You can also apply filters to bar charts and histograms to look at
specific areas of interest.
View selected chart items in bar charts and histograms
You can select chart items and see how selected data is distributed across any open bar charts or
histograms. For example, you might select a number of transactions on your chart as a result of a Visual
Search operation. By default, the distribution of these selected chart items is highlighted (brushed) back
onto any open bar charts and histograms.
You can choose to turn off brushing in the Options page of the Bar Charts and Histograms pane.
View selected chart items in heat matrices
When items are selected on the chart, you can choose whether to view all chart items on a heat matrix
or only the selected items. Click the required Count option at the bottom of the heat matrix.
Filtering data
You can apply (activate) filters in bar charts and histograms by clicking the bars. The resulting actions,
such as whether chart items are selected and how filters are combined across the open bar charts and
histograms, depend on the settings on the Options page of the Bar Charts and Histograms pane.
If the chart items that correspond to the filters are selected, by default the selection is brushed back onto
any open bar charts and histograms.
You can choose what filters to apply across multiple bar charts and histograms. For example, you can
select:
•

A single bar on a single bar chart or histogram. Click a bar to select it.

•

Multiple bars on a single bar chart or histogram. Press Ctrl and click to select multiple bars or Shift
and click to select groups of bars. When you combine filters, this selection is treated as one filter.
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•

Multiple bars across multiple bar charts and histograms. Press Ctrl and click to select multiple
bars. When you combine filters, this selection is treated as multiple filters, one filter per bar chart or
histogram.

To deselect all chart items, click the background of your Analyst's Notebook chart. The chart items
are deselected but the filters are retained in the bar charts and histograms. To clear the filters across
all of the bar charts and histograms, click Clear All Filtering at the bottom of the Bar Charts page or
Histogram window.

Working with bar charts and histograms
You can choose to copy the information in a bar chart or histogram as a picture or as text to the
clipboard. You can also manage the view of your bar chart or histogram, and drill down into the results
of a histogram.
Several selection and copy options are available on the Bar Charts page of the Bar Charts and
Histograms pane and in the Histograms window:
Option

Description

Select All

Selects all bars in the bar chart or histogram and
all the cells in a heat matrix.

Clear Selection

Clears any bars or cells that are selected in the
bar chart, histogram, or heat matrix.

Clear All Filtering

Clears any filters and reveals any chart items that
were hidden.

Copy as Picture

Exports the bar chart or histogram and heat
matrix (if one is displayed) as a picture to the
clipboard. You can paste this picture into another
application, for example Microsoft Word.

Copy as Text

Saves all the data in a bar chart, histogram, or
heat matrix as text to the clipboard. You can paste
this text into another application, for example
Microsoft Word.

Drill Down

Drills down further into the results. This option
is only available for histograms that have filters
that are based on ranges such as label value or
date and time. The range of values must be large
enough to drill down into more detail.

You can copy the chart items that are selected as a result of one or more filters into a new chart by
using the Copy to New Chart options on the Analyze tab of the Analyst's Notebook ribbon. Other
options are available on the Analyze tab to list the selected chart items or their data records.

Histogram and heat matrix animation
You might want to play through the values of your quantitative or temporal data, for example to see what
activity occurred over a time period and how the chart changed over that time. You can play through the
values by animating histograms and heat matrices.
You animate heat matrices and histograms in the Histograms window.
Two animation modes are available from the list at the upper left of the histogram or heat matrix.
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Option

Description

Move

Use the selected bars or heat map cells as the
starting point and move the selection across the
x-axis. This action is the equivalent of selecting
each bar or cell in turn.

Expand

Use the selected bars or heat map cells as a
starting point and expand the selection from there
across the x-axis. This action is the equivalent of
adding each bar in turn to the previous selection.

Run an animation by selecting the bars or heat matrix cells of interest and clicking Play. When
animation mode runs, the Play button changes to Pause. Click this button to stop the animation.
By default, the animation ignores empty columns. To include empty columns in the animation, on the
Options page of the Bar Charts and Histograms pane, select the Include Empty Columns check box
under Histogram Animation.
Tip: Select a bar, heat matrix cell, or range of bars and cells and use the Left or Right arrow keys to
move manually through a histogram.

Drill down into histograms
You can analyze data by focusing on areas of interest. Drill down to examine data in finer detail. For
example, if you are analyzing data about years, you can drill down further to find information about days
of the week.
In a histogram, the Drill Down command is available for any type of data, but only if that bar has further
information to drill down into.
Right-click a bar and select Drill Down. If you have more than one selection range in the Histogram
window, the Drill Down command is unavailable.
Note: As you drill down, a path is displayed at the upper left of the Histogram window that describes
the steps. Click any item that is displayed in blue in this path to return to the previous drill-down results.
Click All to see all results before you drilled down.

Bar chart and histogram options
When you click on bars in a bar chart or histogram, a filter is applied (activated). You can control how
active filters are shown on a chart and how the results of multiple active filters are combined. The
settings that you choose in the Options page remain set even after you close and restart Analyst's
Notebook.
Showing results on the chart
When you activate a filter on a bar chart or histogram, you can choose what is selected and displayed
on the chart.
Option

Description

Select Chart Items

Selects the items on the chart that correspond to
the active filters in the bar charts and histograms.
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Option

Description

Hide Other Chart Items

Hides all the items on the chart that do not
correspond to the active filters in the bar charts
and histograms. Chart item selection remains
unchanged.
Selecting the Reveal Hidden in Gray checkbox
reveals the hidden items in gray.
Note: If a link passes the filter conditions, it
can be displayed only if both of its ends are
also displayed. As a result, some ends might be
displayed that do not pass the filter conditions.

Select Chart Items and Hide Others

Selects the items on the chart that correspond to
the active filters in the bar charts and histograms
and hides all other chart items.
Selecting the Reveal Hidden in Gray checkbox
reveals the hidden items in gray.
Note: If a link passes the filter conditions, it
can be displayed only if both of its ends are
also displayed. As a result, some ends might be
displayed that do not pass the filter conditions.
However, these ends are not selected.

Combining active filters
You can control how active filters are combined.
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Option

Description

Match Any Entity Filters

Finds entities that pass ANY active entity filters.
You can apply multiple filters across multiple bar
charts and histograms, each filtering different
types of information. Chart items that pass any
of the active entity filters are found. For example,
you might be looking for all bank accounts that
were opened after a specific date OR that have a
balance over a specific amount.
If this check box is cleared, only those chart items
that pass ALL of the active entity filters are found.
For example, you might be looking for all bank
accounts that were opened after a specific date,
which also have a balance over a specific amount.
Note: In the case where any of your bar charts
or histograms include both ends and links (rather
than just ends or just links), any active filters in
these bar charts or histograms, in combination
with other active filters, impact on the results for
BOTH ends and links. All ends and links that do
not pass the filter are excluded. For example, on a
Label text bar chart that includes ends and links, if
you apply a filter that selects only links, all entities
are therefore intrinsically excluded. If you now
apply an extra entity filter on a different bar chart
and the Match Any Entity Filters checkbox is
cleared, no entities can match all the active filters.
They are excluded by the filter on the original
Label text bar chart that selected only links.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 180

Option

Description

Match Any Link Filters

Finds links that pass ANY active link filters. You
can apply multiple filters across multiple bar charts
and histograms, each filtering different types
of information. Chart items that pass any of the
active link filters are found. For example, you
might be looking for transactions on a specific day
of the week OR of a specific amount.
If this check box is cleared, chart items that
pass ALL of the active link filters are found. For
example, you might be looking for transactions
on a specific day of the week AND of a specific
amount.
Note: In the case where any of your bar charts
or histograms include both ends and links (rather
than just ends or just links), any active filters in
these bar charts or histograms, in combination
with other active filters, impact on the results for
BOTH ends and links. All ends and links that do
not pass the filter are excluded. For example, on a
Label text bar chart that includes ends and links,
if you apply a filter that selects only entities, all
links are therefore intrinsically excluded. If you
now apply an extra link filter on a different bar
chart and the Match Any Link Filters check box
is cleared, no links can match all the active filters.
They are excluded by the filter on the original
Label text bar chart that selected only entities.

Matching Entities with Matching Links

Matches link and entity combinations. Entities
that pass the active entity filters, according to
the Match Any Entity Filters option and links
that pass the active link filters, according to the
Match Any Link Filters option, are inspected.
Only the entity-link combinations that pass the
entity and link filters are found. For example, you
might be looking for bank accounts with a balance
over 40,000 that were involved in at least one
transaction over 3000 on a Tuesday.
Note: In the case where your bar chart or
histogram contains both ends and links, you might
find that some or all, entities or links are excluded
as result of matching all active entity or all active
link filters.

Showing the distribution of selected chart items on bar charts and histograms
If you select items on your chart, by default the selection is shown (brushed) onto the bars of any open
bar charts and histograms. The distribution of the selected chart items is shown highlighted in the bars
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of the bar charts and histograms. You can choose not to brush the chart item selection onto the open
bar charts and histograms by clearing the Brush Selection onto Bars checkbox.
Including empty rows or columns
You can control whether to include empty columns in histogram and heat matrix animation and whether
rows that contain a zero value are displayed on bar charts.
Option

Description

Include Empty Columns

Includes empty columns in a histogram or heat
matrix animation.

Include Empty Rows

Displays all the rows in a bar chart, including any
rows that have a zero value. For example, you
might want to display rows that have a zero value
to highlight periods of inactivity.

Working with the Time Wheel
The Time Wheel function in Analyst's Notebook is a highly visual way to analyze the time-based data
on your chart.
The Time Wheel visualizes the relationship between the date and time properties of chart items, in a
circular diagram made up of sectors and rings. This is useful because you can quickly identify when
events occurred and with what regularity. For example, you are interested in the number of calls made
between certain telephone numbers, and when those calls were made. Individual values in the matrix
are represented by colors from a predefined palette, which you can customize. The sectors are shaded
to show the amount of activity in the time period selected. When you hover your cursor over a sector,
say between 17:00 and 18:00 on Saturday, Analyst's Notebook displays a summary of all the calls
made during that hour. When you click that sector, the relevant records are highlighted on the chart.
By default the lowest value is displayed in the lightest color, through to the highest value, which is
displayed in the darkest color. You can choose to change the palette of colors, and which values are
represented by light or dark shades. You can also select a linear, logarithmic, or sequential range
to change the color scale. The linear range shows an even color distribution, the logarithmic scale
emphasizes higher counts and the sequential range distributes color evenly across counts that contain
data. For more information about ranges, see Heat matrix options on page 173.
To use the Time Wheel:
1. Click the Analyze tab, and then in the Gain Insight group, click Time Wheel. The Time Wheel
window opens.
Option

Description

Property

Shows available date and time properties.

Sector

Shows a list of scales for use in comparison to
Rings.

Rings

Shows a list of scales for use in comparison to
Sectors.

Timezones

Selects either the chart time zone or item time
zone.
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Option

Description

Scale Color

Shows the colors available to select, gives the
option to display the color scale in reverse,
and changes the range options between linear,
logarithmic and sequential.

Copy

Copies the Time Wheel to the clipboard.

2. Click Properties and select the chart item properties that you want to investigate.
3. Click Sectors and set the time period for sectors, for example Hour of Day.
4. Click Rings and set the time period for rings, for example Day of Week. You should select different
settings for sectors and rings.
5. Click Timezones to change from item time zone to chart time zone.
The Time Wheel time zone setting defaults to item time zones, that is the time zone set in the item's
properties. If you change the setting to use the chart's time zone, values are normalized to that time.
For example, if your chart is set to Greenwich Mean Time (GMT) and the item time zone is set to
Eastern Standard Time (EST), the date and time in the Time Wheel is adjusted to +5 hours in line
with GMT.
6. Click Scale Color to see the available color options and ranges. Customize the colors used in the
Time Wheel to suit your needs.
The Time Wheel displays your data as selected. Hover over a sector to see a summary of the activity
and click to highlight the activity on the chart. You can use Ctrl+Click to select multiple cells.

Investigate item activity
Any temporal data that is stored on an item can be described as item activity. You can investigate this
information to discover common themes or discrepancies.
Activity information is displayed as either single occurrences, or as events that occur over a duration.

Adding items to the Activity View
When you add items to the Activity View, any temporal data that is associated with them can be
represented as activity indicators on the item timeline. The activity indicators provide greater visibility of
timings and sequences, making it easier to compare items.
Each item is represented as a row in the Activity View. The dates and times of sightings, meetings,
interactions, and other events, are represented by activity indicators within each row.
By adding several items to the Activity View, you can see how relationships proceed and develop over
time. In addition, patterns in the data can be identified.
Temporal data for chart items can be stored in several places, for example on the item itself and in
cards, data records, and attributes. You can choose which properties are used to generate activity
indicators. For example, your data might contain date and time information for a series of messages and
also date of birth information for the people involved. You can choose to include only the date and time
information from the messages and exclude the dates of birth.
You can choose to include properties on the items that you add to the Activity View and on their
connected links. You can also include properties on any items that are connected to the added items
and on their onward links. For example, you might choose to include properties for the onward links if
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your primary items are people who are connected to telephones. Relating the call information on the
onward links to the people might be important to you.
To add items to the Activity View:
1. Click the Analyze tab, and then in the Gain Insight group, click Activity View.
The Activity View opens.
2. From the menu at the upper left of the Activity View, select the items to add:
Option

Description

Add All Entities

Adds each entity on the chart.

Add Selected Entities

Adds each entity that is selected on the chart.

Add All Links

Adds each link on the chart.

Add Selected Links

Adds each link that is selected on the chart.

Add Ends of Selected Links

Adds entities at the ends of selected links,
without adding the link as a primary item.

Add Ends Linked to Selected Ends

Adds all the entities that are linked to the
selected entities, without adding the selected
entities or links as a primary item.

Add Items of Type

Adds all items of the type that you select.

Add Items of Semantic Type

Adds all items that are assigned the semantic
type that you select.

Tip: You can also add items to the Activity View by right-clicking on an item on the chart and
selecting one of the Activity View options.
3. Choose which temporal properties to use to generate activity indicators for the items that are added
and any items that are connected to them. From the Added Items and Items Linked to Added
Items lists, select each property that you want to use to generate activity indicators.
Only properties that contain date and time information are available for selection. If the same date
and time data is contained in more than one property, select only one of those properties to generate
the activity indicator. If you select two properties that contain the same information, the activity is
counted twice. Any dates with a value of greater than December 31, 2499 are ignored.
Tip: The number next to each property list indicates how many properties are selected. To clear all
the properties in a list, hover over the number and click the cross that appears.
Items are added to the Activity View and only the selected properties are used to generate activity
indicators.

Interpreting activity data
The Activity View displays information about item activity. It is important to understand the activities that
the view detects and how to interpret the display when you analyze your data.
Each item that is added to the Activity View is represented by an individual row. If temporal data is
selected for either an attached link or connected entity or onward link, secondary rows are added for
each related item. You can choose whether these secondary rows are listed as groups of links in each
connection or listed as separate links. To choose how the secondary rows are displayed, select or clear
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the Group by Connection options on the Added Items and Items Linked to Added Items lists where
you select which properties to use.
For each row, each piece of temporal data is shown as a symbol that is placed against the timeline. The
rows that belong to primary items contain indicators for all connected items, in addition to data stored on
the primary item. Depending on the amount of activity and the scale of the timeline, the indicators might
be merged to represent multiple properties.
Note: Some of these activity indicators, for example link direction, are only visible if the relevant
Indicator Colors options are selected in the Formatting Options window.
Table 10: Activity indicators
Activity
indicator

Description
Activity with a single temporal value stored on an entity.

Activity with start and end values that relate to two temporal values of an entity. When
an invalid duration occurs, for example when the start date and time occurs after the end
date and time, the duration bar appears in an error color.
Activity with a single temporal value that is stored as a property on a bidirectional link.

Activity with a single temporal value that is stored as a property on a nondirectional link.

Activity with a single temporal value that is stored as a property on a link that is directed
from the primary entity.

Activity with a single temporal value that is stored as a property on a link that is directed
to the primary entity.

Multiple temporal values detected.
Note: If more than nine temporal values are detected, this number is replaced by an
asterisk.
Activity indicator selected.

Multiple temporal values, some but not all of which are selected.
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Hover over an activity indicator or the label of an item row for more information about the temporal data
that is associated with the item. The summary provides the item label, and the data that is detected. For
example, John Smith (Date & Time) 12/12/2013 06:00.

Changing the scale
When items are added to the Activity View, the linear scale is determined by the earliest and latest
times that are detected. Changing the scale allows specific periods of the view to be investigated in
more detail.
Zoom into and out from the Activity View timeline to analyze activity data at different resolutions.
The timeline is affected by the properties that you select to generate activity indicators. Ensure that you
select the required properties before you change the scale. For example, if you are investigating specific
events that relate to people, you might choose to clear the properties that contain their date of birth and
date of death. Otherwise, these properties might affect the earliest and latest times on the timeline.
To change the timeline scale:
1. Click the Analyze tab, and then in the Gain Insight group, click Activity View.
The Activity View opens.
2. In the Scale list, select one of the following linear scale values:
•

Milliseconds

•

Seconds

•

Minutes

•

Hours

•

Days

•

Months

•

Years

Tip: You can also change the scale by clicking in the timeline header and then by using the mouse
wheel to zoom in and out.
The view is redrawn to use the selected scale. If the scale is such that all the activity indicators no
longer fit in the view, a horizontal scroll bar is added to aid navigation.

Looking for patterns of activity
You can study patterns of activity to identify trends and deviations in temporal data. To see these
patterns, you can change the Activity View to compare activity over recurring time periods.
Areas of activity can be grouped by a set time period to look for patterns of activity. For example, you
can examine meetings that occur every Monday, or on the second day of every month. Establishing
regular patterns of activity is important in identifying suspicious behavior. For example, establishing the
regular payments into a bank account can remove legitimate payments from further investigation.
To look for patterns of activity:
1. Click the Analyze tab, and then in the Gain Insight group, click Activity View.
The Activity View opens.
2. From the Scale list, select a comparison scale from the Repeating Scales or Repeating Scales
with Grouped Rows sections of the list.
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Option

Description

Every 60 Seconds

Sets the timeline header scale to show the time
in seconds of the minute. Rows that contain the
secondary level items are grouped by minute.

Every 60 Minutes

Sets the timeline header scale to show the time
in minutes of the hour. Rows that contain the
secondary level items are grouped by hour of
the day.

Every 24 Hours

Sets the timeline header scale to show the
time in hours of the day. Rows that contain the
secondary level items are grouped by date.

Every 7 Days

Sets the timeline header scale to show the day
of the week. Rows that contain the secondary
level items are grouped by week.

Every Month

Sets the timeline header scale to show the day
of the month. Rows that contain the secondary
level items are grouped by month.

Every 60 Seconds by their Hour

Sets the timeline header scale to show the time
in seconds of the minute. Rows that contain
the secondary level items are grouped first by
minute of the hour, and then by hour of the date.

Every 60 Minutes by their Day

Sets the timeline header scale to show the time
in minutes of the hour. Rows that contain the
secondary level items are grouped first by hour
of the day, and then by date.

Every 24 Hours by their Day of Week

Sets the timeline header scale to show the
time in hours of the day. Rows that contain the
secondary level items are grouped first by day of
the week, and then by date.

Every 24 Hours by their Day of Month

Sets the timeline header scale to show the
time in hours of the day. Rows that contain the
secondary level items are grouped first by day of
the month, and then by date.

Every 24 Hours by their Year

Sets the timeline header scale to show the
time in hours of the day. Rows that contain the
secondary level items are grouped first by day of
the year, and then by date.

Every Month by their Year

Sets the timeline header scale to show the day
of the month. Rows that contain the secondary
level items are grouped first by month, and then
by date.
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Rows are added to each primary item in the Activity View that group secondary item rows by the
selected comparison value. To zoom the view, click in the timeline header and use the mouse wheel to
scroll.

Configuring duration indicators
If activity occurs over a specific duration, the Activity View can indicate the duration as either a start
time and a duration or as start and end time indicators. You can configure which properties are used to
indicate duration.
When you configure duration information, you can specify as many start and end or start and duration
property pairs as you like. If any attributes or data record properties exist that have the semantic type of
Event Start Date & Time and Event End Date & Time, they are configured for you.
To configure a duration:
1. Click the Analyze tab, and then in the Gain Insight group, click Activity View.
The Activity View opens.
2. Click Durations.
The Durations Setup window opens.
3. To specify a duration that uses a start and end time, in the Durations (Start and End) table:
a) From the Start Property list, select a property to use as the start date and time.
b) From the End Property list, select a property to use as the end date and time.
To specify a duration that uses a start time and duration, in the Durations (Start and Elapsed Time)
table:
a) From the Start Property list, select a property to use as the start date and time.
b) From the Duration Property list, select a number property to use as the duration.
c) Select the units to use for the duration.
Any items in a list that have a value present on the chart, for example in an attribute or data record,
appear in the list as bold. They are also moved to the top of the list.
Note: To delete a row, click the cross at the end of the row.
4. Optional: To specify the units for any duration property pairs that are automatically configured for
you, select your chosen units from the Units for automatic duration properties list.
Duration property pairs are automatically configured for any attributes or data record properties that
have the semantic type of Event Start Date & Time and Duration.
5. Optional: To use these settings for any new charts that you create, select Set as Default.
6. When you finish configuring all of the duration combinations, click OK.
Any pairs that you configure become available to select as properties on the appropriate property lists in
the Activity View.

Configuring indicator formatting
Activity indicators can use shading and color information from the associated item. Color can help
highlight areas of related activity.
When activity of interest is identified, you can show the color of the indicator to signify related events.
Activity indicators can reflect the colors of entity frames, entity shading, and links.
For example, by adding frames of the same color to the people at a meeting, you can highlight other
activity that they have in common.
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To set the Activity View to reflect item color:
1. Click the Analyze tab, and then in the Gain Insight group, click Activity View.
The Activity View opens.
2. At the top of the Activity View, click Formatting.
The Formatting Options window opens.
3. Select one or more of the following options:
Option

Description

Show entity color

Updates activity indicators to reflect the icon
frame color, entity color, or entity shading color.

Show link color

Updates activity indicators to reflect the color of
the link.

Show link direction

Indicates the link direction for activity information
on directed links.

Overlap indicator color

Specify the color of the overlap indicator that
is displayed when part of an activity's duration
coincides with another.

4. Optional: To use these settings for any new charts that you create, select Set as Default.
5. Click OK.

Handling activity with partial information
The Activity View needs temporal data that includes dates and times. You can configure the behavior for
properties that contain a date but no time or a time with no date.
If the date and time information is contained in separate properties, Analyst's Notebook can recognize
the properties as a combined date and time pair. To recognize them as a pair, the properties must be
assigned the semantic types Event Start Date and Event Start Time, or Event End Date and Event End
Time.
To configure how date-only and time-only properties are handled:
1. Click the Analyze tab, and then in the Gain Insight group, click Activity View.
The Activity View opens.
2. Click Partial Properties.
The Partial Properties Setup window opens.
3. To configure how to handle properties that contain date-only information, in the Date-only
Properties area, select one of the following options:
Option

Description

Don't Show

Ignores any date-only temporal data.

Show At

Assigns a time that you specify to date-only
temporal data.

Show over the entire day

Assigns a default duration of 24 hours to dateonly temporal data.
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4. To configure how to handle properties that contain time-only information, in the Time-only
Properties area, select one of the following options:
Option

Description

Don't Show

Ignores any time-only temporal data.

Show On

Assigns a date that you specify to time-only
temporal data.

5. Optional: To use these settings for any new charts that you create, select Set as Default.
6. Click OK.

Interacting with items in the Activity View
Adding items to the Activity View provides a different view of the information that is present in the chart.
Items can be selected, edited, and centered on the chart.
•

To focus the chart on the selected item, right-click the item and select Center on Chart.

•

To automatically focus the chart on an item when you select it in the Activity View, from the Options
list, select Pan on Selection.

•

To open and edit the properties of an item, right-click the item and select Edit Item Properties.

•

To remove the selection from the Activity View, right-click an item and select Remove Selected.

•

To remove the items that are not selected from the Activity View, right-click an item and select
Remove Unselected.
Tip: To remove all items, click Remove All at the top of the Activity View.

•

To change the order of items in the Activity View, from the Sort list, select one of the following
options:
Option

Description

Most Active

Moves the items with the most activities to the
top of the grid.

Earliest

Moves the items that contain the earliest
activities to the top of the grid.

Latest

Moves the items that contain the latest activities
to the top of the grid.

Alphabetical

Sorts the items in the grid into alphabetical
order, based on their labels.

Least Active

Moves the items with the fewest activities to the
top of the grid.

Primary items are sorted according to the selected option. Within each primary item, secondary items
are also sorted according to the selected option.
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Specifying the time zone
Depending on the information that is contained within the chart, you might have data that uses different
time zones. The time zone that the Activity View uses for an activity indicator can come from either the
data itself, or from the chart.
To specify which time zone to use in the Activity View:
1. Click the Analyze tab, and then in the Gain Insight group, click Activity View.
The Activity View opens.
2. From the Options list in the Activity View, select one of the following options:
Option

Description

Use Chart Time Zone

Shows the date and time values of activity
indicators in the time zone of the chart. The
chart time zone is typically the local time zone.

Use Property Time Zones

Shows the date and time values of activity
indicators in the time zone of the item, card, or
data record.

Prefixing row labels
Within the Activity View, row labels can be prefixed with an attribute value. Adding an attribute prefix
allows items to be sorted by that value.
The label for each row of the Activity View does not necessarily match the item label on the chart. By
default:
•

The label for an entity row matches the chart label of that entity.

•

The label for a link row is constructed from the chart label of that link, and the labels of the entities at
each end.

To categorize items in the Activity View, and to change their sort order:
1. Click the Analyze tab, and then in the Gain Insight group, click Activity View.
The Activity View opens.
2. At the top of the Activity View, click Formatting.
The Formatting Options window opens.
3. Select the Prefix row labels with values of check box, and choose the attribute class to use as a
prefix from the list.
4. Click OK.
The labels are updated in the Activity View. The labels on the chart remain unchanged.

Filtering the Activity View
Like items on the chart surface, data in the Activity View updates to reflect the status of any filters that
are applied. Depending on the filter options that you select, you can control the visibility of data within
the view.
When filters are applied to the chart, items that do not match the selected filters are hidden or become
revealed in gray on the chart surface. In the Activity View, activity data that relates to hidden items is
removed from the view. However, you can control the visibility of activity data that relates to items that
are revealed in gray.
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Note: To ensure that the required items are placed in a gray state when filters are applied, make sure
that the filtering options are set up appropriately. Alternatively, to change the setting to show all hidden
items in a gray state, click the View tab, and then in the Show and Hide Items group, click Reveal >
Reveal in Gray.
To configure how to display items that are made revealed in gray as the result of a filter:
1. Click the Analyze tab, and then in the Gain Insight group, click Activity View.
The Activity View opens.
2. From the Options list in the Activity View, select one or both of the following options:
Option

Description

Include Revealed Hidden Items

Show primary rows for entities and links that are
revealed in gray.

Include Revealed Hidden Activity

For items that are shown on the chart, show
activity of connected items that are revealed in
gray.

Presenting your findings
A picture of the information that is visible in the Activity View can be copied as an image. You can use
images to present information from the Activity View in other applications for reporting.
To create an image of the current state of the Activity View:
1. In the Activity View, change the size of the view to ensure that all of the data that you want to report
on is visible.
2. Click Copy as Picture.
An image of the contents of the Activity View is copied to the clipboard.
3. Paste the picture into a document that supports images.

Conditional formatting
You can use conditional formatting to change the appearance of items on the chart to emphasize
information of interest to your investigation. You can change the appearance of both entities and links
based on rules that you define.
You can use conditional formatting to emphasize significant information, and downplay or hide
information of lower interest. Conditional formatting is useful for both analytical and presentation
purposes.
Specifications and rules
When you create a conditional formatting specification, you must add at least one rule. Each rule
changes one style based on conditions that you specify. The following styles can be changed:
•

To a specific style setting.

•

To styles stored in a selected attribute or property by setting the style to the value of the attribute or
property.

•

To styles from a color spectrum that is based on a selected attribute or property.

•

To styles from a gradual scale that is based on a selected attribute or property.
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•

To styles from a threshold or range that is based on a selected attribute or property.

•

To styles from a lookup table that is based on a selected attribute or property.

Applying a conditional formatting specification
When you open the conditional formatting pane, a number of default conditional formatting
specifications are available. You can apply these specifications directly to the items on your chart.
To apply a conditional formatting specification:
1. To open the Conditional Formatting pane, click the Style tab, and then click Conditional Formatting
> Conditional Formatting Pane.
2. In the Conditional Formatting pane, from the commands in the Actions panel at the bottom of the
pane, select:
Option

Description

Format with Selected Specification

Use the specification that is selected in the
upper part of the Conditional Formatting pane
to format all items on the current chart.

Format Selected Items with Selected
Specifications

Use the specification that is selected in the
upper part of the Conditional Formatting pane
to format items that are selected on the chart.

Undo Formatting

Remove the last conditional formatting
specification that was applied.

Any items on your chart that meet the criteria will be modified, a Formatting progress on page 192
status window will notify you of the changes that are made.
3. Click Close to return to your chart.

Formatting progress
When a Conditional Formatting Specification is running, a progress window will be displayed. You can
see reports about the various stages of the conditional formatting process, including any errors that
occur.
Formatting started
As soon as the formatting starts, information about the formatting start time and current rule is
displayed. During this stage, you can stop the formatting process by clicking Cancel.
Error or errors occurred
If errors occur, formatting will be stopped and additional details will be displayed. For example, an error
occurs if a rule is based on an attribute class or record value of one data type, but you try to apply it to a
chart that has an attribute class or record value with the same name but a different data type.
If you encounter errors, edit the specification in the Edit Conditional Formatting Specification window
before rerunning the specification.
Note: Any formatting changes that result from rules that were processed before the error occurred, are
applied to the chart.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 193

Formatting completed
The end of the formatting process. A message is displayed to show the formatting end time, total
formatting time, and the number of entities and links that were formatted. Any formatting changes are
applied to the chart after the last rule in the specification is processed. Click Close to close the window.

Creating and editing conditional formatting specifications
You can create conditional formatting specifications that contain rules that are specific to the work that
you are currently undertaking. By creating you own specifications, you can ensure that the rules that are
set up match the conditions that you would like to extenuate in your data.
To create, edit, delete, or duplicate a conditional formatting specification:
1. To open the Conditional Formatting pane, click the Style tab, and then click Conditional Formatting
> Conditional Formatting Pane.
2. In the Conditional Formatting pane, from the commands in the Actions panel at the bottom of the
pane, select:
Option

Description

New Specification

Create a conditional formatting specification to
which you can add rules. The Edit Conditional
Formatting Specification window is shown.

Edit Selected Specification

Edit the conditional formatting specification that
is selected in the upper part of the Conditional
Formatting pane. The Edit Conditional
Formatting Specification window is shown.

The Edit Conditional Formatting Specification window opens.
3. Using the following options, you can add and modify the rules that the specification contains. In the
Rules page, select:
Option

Description

New

To add a conditional formatting rule. The New
Rule window is shown, in which you specify
what the rule affects and what the actions of
the rule are based on. For more information,
see Adding rules to a conditional formatting
specification on page 194.

Edit

To edit an existing conditional formatting rule.
The Edit Rule window is shown. You can edit
the rule to change what the rule affects and what
the actions of the rule are based on. For more
information, see Adding rules to a conditional
formatting specification on page 194.

Duplicate

Duplicate a rule. By duplicating an existing rule,
you have a copy to edit.

Delete

To delete a rule.
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Option

Description

Up

To move a rule upwards in the order in the list of
rules.
Note: Rule ordering is significant as rules are
carried out sequentially, and previous rules may
prevent subsequent actions.

Down

To move a rule downwards in the order in the list
of rules.
Note: Rule ordering is significant as rules are
carried out sequentially, and previous rules may
prevent subsequent actions.

4. You can enter the following properties on the Details page:
•

Subject

•

Author

•

Keywords

•

Category

•

Comments

•

Custom properties

5. Click Save.

Adding rules to a conditional formatting specification
Emphasize significant information or de-emphasize information of lower importance by adding rules to a
conditional formatting. Applying a specification to your chart that contains rules changes the appearance
of chart items, based on their properties.
A conditional formatting rule applies formatting to chart items, you specify what the actions are based
on, and the action that you want to apply.
A conditional formatting rule is defined over four steps, involving:
•

Choosing the type of item or representation to be formatted.

•

Choosing the criteria to identify items, such as links with the Transaction attribute, or event frames
with the Day of Week analysis attribute.

•

Choosing a style to change, such as enlargement or shade color.

•

Specifying how the style changes, by selecting a particular value, or by looking up a value in a table
for example.

Note: The options available for changing the style depend on the choices you make in earlier steps.
To define a rule:
1. In the Edit Conditional Formatting Specification window, click New to show the New Rule
window.
2. In the Items to be formatted section, select the item type to apply the rule to by selecting Entities
or Links. If you select Entites, you also need to select the types of representation to apply the rule
to.
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3. In the Item criteria section, select what the rule is based on by selecting an option:
•

All items - create an unconditional rule that is applied to all items of the selected representation.

•

Items that contain records - set up rules that apply to items with records that contain specific
property types.

•

Items with attribute - set up rules that apply to items with a specified attribute.

•

Items with analysis attribute - set up rules that apply to items with a specified analysis attribute.

4. In the Style to be changed section, select the aspect of style to be changed.
For example, the rule can change the enlargement of the icon on the chart, or the color of links.
5. In the Style will be changed to section, specify how the style is changed by selecting an option.
For some styles, you must click Edit to specify more options in another window.
You can set the style:
•

To the value of the selected attribute or property type.

•

To values from a color spectrum that is based on the selected attribute or property type. For more
information, see Changing the color of items based on a specific range on page 196.

•

To values from a lookup table that is based on the selected attribute or property type.Setting
styling based on specific values on page 197

•

To a specified value from a threshold or range that is based on the selected attribute or property
type.Setting styles for a range of values on page 198

Note: To leave the style unchanged, select Leave unchanged.
6. Optional: In the Options section, you can specify the behavior of subsequent rules and the styling of
items that do not match your rule:
•

Prevent later rules changing the chart item style - locks the style for items that are matched
by the current rule. This locking information is listed in the Edit Conditional Formatting
Specification window for the current rule.

•

For items which don't match the rule, set the chart item style to - select the behavior of items
that do not match the rule:
•

To a specified value:
•

Select Shown or Hidden to set Visibility.

•

Select Specified Value and choose a style setting from the list set Font Style,
Enlargement, Icon Frame Margin, Line Width, or Line Strength.

•

Select Specified Value and choose a color from the color picker to set shade or icon frame
color.

•

Select Specified Value and click Edit to set an entity or link type.

To leave the style unchanged, select Leave unchanged.
7. To save the rule, click OK.
New rules are added to the end of the list of rules for the conditional formatting specification.
After you complete a rule, you can continue to add and edit rules until you are ready to apply the
specification to the chart. See Applying a conditional formatting specification on page 192 for details.
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Changing the formatting style based on attribute or property values
If you decide to use an item criteria that uses attribute or property values to distinguish items, you can
set a formatting style that uses a color spectrum or scale to display different values based on lookup
tables, thresholds, or ranges. The formatting emphasizes chart items according to the formatting style
that is set.

Changing the color of items based on a specific range
You can use color changes, based on the values of a selected attribute or property to indicate how data
falls within a range. You can decide how different values determine which color to use from the color
scheme.
Formatting changes can use a color scheme to visualize how data falls within a set range. The first and
last colors in the scheme correspond to the lowest and highest or earliest and latest values of a selected
attribute or property. Any items with values in between the two limits are then set by using either a linear
or logarithmic scale.
Note: You can only use a color scheme in a rule whose criteria specify numeric or date and time
values.
You can use a color spectrum to change the following styles:
•

The dominant shade color of icons, event frames, and theme lines

•

The icon frame color of icons and theme lines

•

The item type of entities and links.

To specify how the lower and upper limits are set:
1. Follow the instructions in Creating and editing conditional formatting specifications on page 193 to
create or edit a conditional formatting specification.
2. Follow the instructions in Adding rules to a conditional formatting specification on page 194 to
create a rule, and in the Style will be changed to section, select Values from a Color Spectrum
based on rule basis, and click Edit.
3. Specify how the lower limit of the scale is set:
a) If you select From chart, the lower limit is automatically set to the earliest or lowest value of the
attribute or property on the chart.
b) If you select Specified value, enter a number, or date and time. Items with values at or below this
value are mapped to the color on the left of the selected scale.
4. Specify how the upper limit of the scale is set:
a) If you select From chart, the upper limit is automatically set to the latest or highest value on the
chart.
b) If you select Specified value, enter a number, or date and time. Items with values at or above
this value are mapped to the color on the right of the selected scale.
5. If you change the link type, icon frame, or entity shade color, choose the type of scale you want to
apply to the chart:
•

Ordered - A scale that increases in intensity towards one of the ends.

•

Diverging - To accentuate data that is at the lower and upper ends of the scale, you can choose
to use a scale that either only modifies items that match the lower and upper ends of a scale, or
scales that make this data more obvious.
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•

Categories - For values that can be divided into discrete groups rather than on a particular rising
scale, you can use categories to highlight specific bands of data.

•

Legacy Spectrums - To match charts that have been created in earlier versions of Analyst's
Notebook you can select to use the legacy color scales.

6. Select the specific scale to be applied.
Tip: To reverse the scale, select the Reverse check box.
7. In the Values of rule basis in between section, select how color is applied to items with values
between the lower and upper limits:
•

Linear scale - the values are spaced equally to determine which color is used.

•

Logarithmic scale - the spacing between smaller values is greater. This type of scale is useful
when your attribute values cover a large range.

8. Click OK to finish defining the rule.

Setting styling based on specific values
You can use a lookup table to change the formatting of items based on specific values of an attribute or
property. Using a table of values allows you to specify multiple changes to a style in the same rule.
A table of specific conditions, values and formatting changes can be defined for specific attributes and
properties.
You can use a table to change the following styles:
•

The visibility of entities and links.

•

The font style of entities and links.

•

The entity or link type of any chart item except labels.

•

The enlargement (icon size) of icons, event frames, and theme lines.

•

The dominant shade color of icons, event frames, and theme lines.

•

The icon frame color or margin size of icons and theme lines.

•

The line width of links, event frames, theme lines, boxes, circles, text blocks, and OLE objects.

•

The line strength of links, event frames, theme lines, boxes, circles, text blocks, and OLE objects.

To set a formatting style from a lookup table:
1. Follow the instructions in Creating and editing conditional formatting specifications on page 193 to
create or edit a conditional formatting specification.
2. Follow the instructions in Adding rules to a conditional formatting specification on page 194 to
create a rule, and ensure that you have selected an item record property or attribute to base your
actions on, and a type of style change that supports lookup table values.
3. In the Style will be changed to section, select Values from a Lookup Table based on rule basis
and click Edit.
4. Click New. An entry with a default condition and style setting is added.
5. Set a Condition and Value for the lookup entry:
Option

Description

Contains

Items with an attribute that includes the value.
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Option

Description

Doesn't Contain

Items with an attribute that does not contain the
value.

Doesn't end with

Items with an attribute that does not end with the
value.

Not equal to

Items with an attribute that does not match the
value.

Doesn't start with

Items with an attribute that does not start with
the value.

Ends with

Items with an attribute that ends with the value.

Equal to

Items with an attribute value that matches the
value.

Starts with

Items with an attribute that starts with the value.

6. Set the style requirement for matching chart items.
Note: The requirements that are listed change, based on the rule type.
7. Enter additional entries by repeating steps 4 to 6.
Note: A chart item style is set according to the first matching entry in the list. Therefore, depending
on the type of condition that is used, position more specific lookup table entries at the top of the list.
8. Click OK.

Setting styles for a range of values
When you are working with attributes and property types that have values that are chronological or
numerical, you can set the style to change based on a specific range. This allows you to emphasize
information before, after or between specific values.
You can use a threshold or range to change the following aspects of style:
•

The visibility of entities and links.

•

The font style of entities and links.

•

The entity or link type of any chart item except labels.

•

The enlargement (icon size) of icons, event frames, and theme lines.

•

The dominant shade color of icons, event frames, and theme lines.

•

The icon frame color or margin size of icons and theme lines.

•

The line width of links, event frames, theme lines, boxes, circles, text blocks, and OLE objects.

•

The line strength of links, event frames, theme lines, boxes, circles, text blocks, and OLE objects.

1. Follow the instructions in Creating and editing conditional formatting specifications on page 193 to
create or edit a conditional formatting specification.
2. Follow the instructions in Adding rules to a conditional formatting specification on page 194 to
create a rule, and ensure that you have selected an item record property or attribute to base your
actions on, and a type of style change that supports lookup table values.
3. In the Style will be changed to section, select A specified value for a Threshold or Range of rule
basis, and click Edit.
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4. Choose whether to define a threshold, range, or specific value:
Option

Description

Above, Below

Define a threshold by using a number value.

After, Before

Define a threshold by using a date & time value.

Equal to

Define a specific value.

Between

Define a range.

5. Enter numbers in the edit boxes for a numeric attribute value. Alternatively use the date and time
picker to specify dates and times for a date & time attribute.
6. Optional: Specify that the values you entered are included in the range or threshold by selecting the
Inclusive check boxes.
7. Select the style change that you want to apply to the chart by selecting an option.
•

Select Shown or Hidden to set Visibility.

•

Select Specified Value and choose a style setting from the list to set Font Style, Enlargement,
Icon Frame Margin, Line Width, or Line Strength.

•

Select Specified Value and choose a color to set Shade or Icon Frame Color.

•

Select Specified Value and click Edit to set an entity or link type.

•

Select Leave unchanged if you do not want to change the style of items that match the condition.

8. Click OK to finish defining the rule.

Using a conditional formatting style rule to change entity or link type
When items are added to a chart, depending on the available charting schemes, you might find that the
items have been classified as a different item type to that which you expect. You can change conditional
formatting rules to modify the item type of specific items on your chart.
The type of item that is used to describe data can be important for later analysis. You can modify the
type of item using conditional formatting.
Note: Using conditional formatting to change the type of an item will only apply to items on the chart
surface, these changes are not reflected in records.
To specify a type:
1. Follow the instructions in Creating and editing conditional formatting specifications on page 193 to
create or edit a conditional formatting specification.
2. In the Style to be changed section, select Type, then in the Style will be changed to section,
select Specified value and click Edit.
3. From the Palette list, select the user palette that contains the required entity or link type.
4. From the Type list, select an entity or link type.
5. Click OK to finish defining the rule.
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Importing a conditional formatting rule
You can copy rules from a conditional formatting specification into the specification you are currently
defining. All specifications in your Local and Workgroup folders are listed in the top half of the
Conditional Formatting pane.
To import a rule:
1. To open the Conditional Formatting Specifications window, click the Style tab, and then click
Conditional Formatting > Saved Specifications.
2. Click Format with new specification, or select an existing specification and click Edit to show the
Edit Conditional Formatting Specification window.
3. Click Import.
4. Locate and select the specification that you want to import from.
All rules in a selected specification are listed in the bottom half of the window.
5. Select the rules that you want to import by selecting the relevant check boxes.
6. Click Import.
The selected rules are copied to the Edit Conditional Formatting Specification window.

Managing conditional formatting specifications
The Conditional Formatting Specifications window can be used to create a specification, apply an
existing specification to the chart, and edit, rename, duplicate, or delete it. You can also manage where
your specifications are saved by specifying folder locations, and copy specifications between folders,
and browse your specifications in Windows Explorer.
To open the Conditional Formatting pane, click the Style tab, and then click Conditional Formatting >
Saved Specifications.

Copying specifications between local and workgroup folders
You can copy conditional formatting specifications between folders so that others can use them. For
example, you can share the specification with other members of your workgroup, or copy it to a local
folder.
You must configure a workgroup folder.
Right-click the specification, and from the menu, select Copy to Workgroup Folder. The specification
is copied to your Workgroup folder.
Tip: To make a local copy of a workgroup specification, right-click the specification, and from the menu,
select Copy to Local Folder.

Changing the location of local and workgroup folders
You can specify where your conditional formatting specifications are saved. You might want to save
your specification locally on your computer, or a shared folder.
A Local folder holds specifications that only you have access to. A Workgroup folder can hold
specifications that are shared by other users.
Any specifications that are held in subfolders of the Local and Workgroup folders are also listed in the
Conditional Formatting Specifications window. You can group specifications by folder.
The Local folder is typically set to My Documents\i2\i2 Analyst's Notebook
8\Conditional Formatting Specifications. The Workgroup folder is not set by default.
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To change the location of your Local or Workgroup folders:
1. To open the Conditional Formatting pane, click the Style tab, and then click Conditional Formatting
> Saved Specifications.
2. In the Other Tasks area, click Change Local Folder or Change Workgroup Folder to show the
Browse For Folder window.
3. Select a folder or click Make New Folder.
4. Click OK to set the new folder location.

Installing the example material
Example specifications are available so that you can update the appearance of your chart by using
common item characteristics. Although these examples are installed by default, you can opt to reinstall
the examples to remove any customizations you might have made.
To install the example specifications:
1. To open the Conditional Formatting pane, click the Style tab, and then click Conditional Formatting
> Saved Specifications.
2. Click Install example material.
The example specifications are shown in the list of conditional formatting specifications.

Live formatting
Live formatting in Analyst's Notebook changes the appearance of chart items, by applying conditional
formatting specifications in real time.
Live formatting extends the capabilities of conditional formatting if your chart items contain i2
Analyze records. You can run specifications automatically when i2 Analyze records are changed,
added, or deleted from the chart. The styles of items change to reflect the changing data. You need
suitable conditional formatting specifications defined before you can set up live formatting and not all
specifications are compatible, depending on your schema. Analyst's Notebook guides you to information
about rules and how they might affect the chart, as you work through the setup process. When you run
live formatting, changes are applied immediately unless the specification is incompatible.
The live formatting command is located in the record bar and is always visible. As you continue to
work with your chart, live formatting can be stopped, edited, restarted, or reset by using a drop-down
menu of commands.

Setting up live formatting
When you set up live formatting, you specify which conditional formatting specifications Analyst's
Notebook uses when live formatting is started, the order they run in, and what other formatting to
override.
You must have access to suitable conditional formatting specifications before you can set up live
formatting. You can create and edit specifications for your own use or to share with your workgroup. For
more information, see Creating and editing conditional formatting specifications. Live formatting applies
style rules that are created as conditional formatting specifications, to items that meet the criteria you
specify.
1. Click Live Formatting > Set Up to open the Live Formatting Set Up window.
2. Select one or more specifications from the Available specifications list and move them to the
Selected specifications list by clicking the right arrow icon. If you see an information or warning
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icon next to a specification, hover your mouse pointer over the icon to display the message. For
more information about these icons, see Live formatting system messages on page 203.
3. Use the Up and Down commands to change the order that the specifications run. The order of
specifications is significant as they run sequentially from the top of the list. Rules set further down the
list might affect the specifications that you selected to run first.
4. Optional: You can override existing style changes and reset the items already on the chart to
their default style. Click the Reset all chart items to their default appearance before running
specifications check box.
Chart items are reset to the appearance defined by your schema.
Note: If you use the Stop and Reset Formatting command, your chart items are reset to the
appearance defined by your schema and not to any style changes that you applied previously.
Live formatting starts even if your chart surface is empty. The circle icon in the record bar changes
color to orange to indicate that live formatting is running. You can see a summary of your selections by
hovering your mouse pointer over the Live Formatting command. Live formatting continues to run until
you select Stop or Stop and Reset Formatting.

Defining a default set of specifications
You can save a set of conditional formatting specifications to use as your default list for running live
formatting. This is useful if you regularly need to run the same specifications.
Ensure the conditional formatting specifications that you want to use in your default list are compatible
with live formatting and are saved in your workgroup or local folder. For more information about
compatibility, see Live formatting system messages on page 203.
You can save one set of default specifications. If you make changes and save the list as your new
default, it overwrites the previous version.
1. Follow the instructions in Setting up live formatting on page 201 to select your specifications.
2. Click Live Formatting > Save Current Settings as Defaults.
The list that you selected in Live Formatting Setup is saved as your default list.
3. If you make further changes to live formatting and want to restore your saved list, click Live
Formatting > Use Default Specifications.
4. When you open a new or existing chart, click Live Formatting > Use Default Specifications if you
want to run your saved list as the live formatting setup.

Effects of live formatting
When live formatting runs, it impacts appearance settings and can override some style changes that you
make in Analyst's Notebook. You can work with live formatting effectively by understanding the impact
on other functions.
The default appearance of chart items is defined by your schema. You can reset all chart items to their
default setting during live formatting setup. This clears any existing manual or conditional changes
applied to chart items before you run live specifications.
When you run live formatting, the changes are immediate. At any point after starting live formatting, you
can click Stop and Reset Formatting to return items to their default appearance.
If you add new i2 Analyze records, or expand records while live formatting is running, the specifications
are applied to those items. If you stop formatting and add new items, the changes occur as soon as you
start formatting again.
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Live formatting overrides manual style changes if you apply them to any item that is modified by a
conditional formatting specification. If you make manual changes from the Style tab, the affected chart
items revert to the style specified by live formatting when it runs next.
When you copy altered entities and links onto a new chart, they retain their appearance. The style
change that is invoked by formatting specifications persists unless you choose a different style or reset
the style to default settings.
You cannot stop and start live formatting by clicking Undo or Redo. While you might restore or apply
style changes through these actions, they are overridden as soon as you add or expand another record.
You have more control over formatting by using specifications and the live formatting commands.

Live formatting system messages
Not all conditional formatting specifications are compatible with live formatting. Analyst's Notebook
provides information about specifications that need modifying and why some selections do not affect the
chart appearance.
Information and warnings
When you have available specifications listed in the Live Formatting Setup and no icon is displayed,
the specification is compatible with live formatting. If there is an icon next to the specification, you can
see the full message by hovering your mouse pointer over the icon.
Icon

Description
When this icon appears next to available
specifications in Live Formatting Setup, it means
that if you select the specification it will not run.
You can find out specifically why by reading the
tooltip. When this icon appears next to selected
specifications, it has a different purpose and
points to rules in the specification that might not
alter the chart in the expected way.
If you select a specification that has an information
icon and move it into the selected list, the icon
changes to a warning triangle. The detailed
warning tells you about changes that are not
supported by live formatting and the actions you
need to take if you want the specification to run.
This icon only appears in the selected
specifications list. It notifies you that a selected
specification has been moved or deleted from your
workgroup or local folder.

Social Network Analysis
You can examine group structures and communication flows within a network chart by focusing on the
relationships that exist between entities. This type of analysis is called social network analysis.
Organizational theories are combined with mathematical models to help you understand the dynamics
of groups and organizations in which you are interested.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 204

The structure of a network can determine:
•

The performance of the network as a whole and its ability to achieve its key goals.

•

Characteristics of the network that are not immediately obvious, such as the existence of a smaller
subnetwork operating within the network.

•

The relationships between prominent people of interest whose position might provide the greatest
influence over the rest of the network.

•

How directly and quickly information flows between people in different parts of the network.

Centrality and centrality measures
A highly centralized network is dominated by one person who controls information flow. A less
centralized network has no single point of failure. People can still pass on information even if some
communication channels are blocked.
Analyst's Notebook calculates betweenness, closeness, degree, and eigenvector centrality measures to
provide different perspectives on the social relationships within the network. You can also influence the
centrality measures by taking into account the direction of links and the weightings that are applied to
them.

Betweenness
Betweenness centrality measures the number of paths that pass through each entity.
This measure might identify entities with the ability to control information flow between different parts of
the network. These entities are called gatekeeper entities. Gatekeepers might have many paths that run
through them that allows them to channel information to most of the others in the network. Alternatively,
they might have few paths that run through them, but still play a powerful communication role if they
exist between different network clusters.
Closeness centrality measures both direct and indirect closeness:
•

Direct closeness is when two entities are connected by a link.

•

Indirect closeness exists when information can pass only from one entity to another by way of a path
that runs through one or more entities.

Link betweenness
Link betweenness centrality measures the number of paths that pass through each link.
This measure can help to identify key connections of influence within the network. A link through which
many paths pass might be a route for information exchange between entities.

Closeness
Closeness centrality measures the proximity of an entity to the other entities in the social network.
An entity with a high measure of closeness centrality has the shortest paths to the other entities. This
measure allows them to pass on, and receive communications more quickly than anybody else in the
organization. Information travels further to and from an entity on the edge of a network that is attached
to few other entities. They have a lower measure of closeness centrality.
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Degree
Degree centrality measures how connected an entity is by counting the number of direct links each
entity has to others in the network.
This centrality measure can reveal how much activity is going on and who are its most active members.

Eigenvector
Eigenvector measures how connected an entity is and how much direct influence it might have over
other connected entities in the network.
The eigenvector scores of the entities it is connected to, is considered. For example, a person with a
high eigenvector score is likely to be at the center of a cluster of key entities that themselves have high
eigenvector scores. That person can communicate directly with those key entities compared with a
person with a low eigenvector score on the periphery of the network.
Hubs and authorities are the terms that are used to describe the two eigenvector scores that are
calculated in networks that contain directed links. Hubs see the scores for outbound links, and
authorities see the scores for inbound links. A high-scoring hub has many outbound links to high-scoring
authorities, and a high-scoring authority has many inbound links from high-scoring hubs.

Link direction
Directed links can be considered as centrality measures. A link with arrows added to it represents
the directed flow of information between entities; either in a single direction or in both directions. This
measure might have an important bearing on how quickly information is passed from one part of the
network to another. For example, a person might receive information from many others in the network
but send information only to a select few. The centrality measures for an entity where information is
channeled in both directions is higher than the measures for an entity through which information is
channeled one way.

Link weightings
Not all relationships in a network are equal. For example, the link between two people, that are
connected through a family relationship might be stronger than a link between two business associates.
These links can be weighted so that they represent real-world strengths in social network analysis.
Weighting key paths in the network might also infer that the entities by using them to channel
information have key roles to play. For this reason, centrality measure results are affected by link
weightings.

K-Core
Coreness is a measure that can help identify tightly interlinked groups within a network. A k-core is a
maximal group of entities, all of which are connected to at least k other entities in the group.
K-Core is a measure that can help identify small interlinked core areas on a network. To be included
in the K-Core, an entity must be linked to at least k other entities in the group. The linked entities are
regardless of how many other entities that they are connected to outside of the group. Maximal in the
definition means that we are interested in the largest set of entities with the required minimum number
of neighbors within the group. The value of k is sometimes referred to as the coreness of the group.
For example, a group is the two-core if it contains all entities that are connected to at least two other
entities within the group. Similarly, a group is the three-core if it contains all entities that are linked to at
least three other entities within the group.
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Any entity in the three-core must have at least three links to all other members of the three-core. Clearly
any such entity must necessarily have at least two links to every other member of the three-core. Put
another way, the three-core is a subset (is contained within) the two-core. More generally, the K-Core
form a nested hierarchy of entity groupings on the chart. The zero-core (entire chart) contains the onecore, which contains the two-core, which contains the three-core, and so on. As k increases, the core
sizes decrease, but the cores become more interlinked. The K-Cores with the biggest coreness values
(k-values) represent the most cohesive regions of the chart.
The following diagram illustrates the K-Core decomposition of a simple network, and shows a nested
collection of zero, one, two and three-cores. Notice that the three-core actually consists of two separate
groupings on the chart. Technically these groupings are regarded as a single three-core with two
components.

Setting clustering and centrality measures
Changing the centrality measure that is used to analyze a chart provides different information about
your chart items.
To change the centrality measure:
1. Click the Analyze tab, and then in the Gain Insight group, click Social Network Analysis.
The Social Network Analysis pane opens.
2. Click the Options tab.
3. Optional: In the Clustering section, select the K-Core check box to identify clusters of linked items.
4. In the Centrality section, select the check box for the measures that you want to calculate:
Option

Description

Betweenness

To find gatekeeper entities that might control
information flow. This check box is selected by
default. If betweenness is selected, you can also
select Betweenness for Links to find links that
might be the most influential connections in the
network.
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Option

Description

Closeness

To find entities that might access the rest of the
network more quickly than others.

Degree

To find the entities with the highest number of
direct links to other entities in the network.

Eigenvector

To find the entities with direct links to the most
influential entities in the network.

Note: At least one check box must be selected for analysis to take place.
5. Select the Use Link Directions check box if you want to take directed links into consideration when
you calculate centrality measures. If arrows are not displayed on a link, it is assumed that information
flows in both directions.
6. Optional: Leave the Enhanced Analysis option selected to use the advanced mathematical
algorithms to calculate results. If your chart contains several unconnected networks, or directed
links that block paths between certain entities, Analyst's Notebook takes unconnected networks, or
directed links into account and adjusts the calculations. The results reflect the relative importance of
these entities and paths to those entities and links in the entire chart.
Note: The only time that you clear the Enhanced Analysis option is if it is important that you do not
use the mathematical algorithms that are supported in Analyst's Notebook.
For example, to maintain a consistent set of results. No adjustment is made to take into account
directed links that block paths between entities. The results that are calculated for separate
unconnected networks reflect the relative importance of the entities within each network. The links
are not relative to the entities on the chart.
7. Normalize Results to adjust the calculations and display them as percentages in the Results table.
If you clear this option, no adjustment is made to the calculations and results are displayed as raw
data. Normalizing the results makes it easier to compare the centrality results of items in different
networks and charts. Click Advanced Options and choose between two different methods of
adjustment. The adjustment applies to all the selected centrality measures:
Option

Description

Use the standard method

Results are calculated and then divided by what,
in theory, is the highest possible result for each
centrality measure. They are then expressed as
percentages in the Results table. This method is
the standard normalization method that is most
commonly used in social network analysis.

Normalize results relative to the maximum
value

Results are calculated and the highest result or
actual maximum for each centrality measure is
determined. This value is displayed as 100% in
the Results table. Every other value is divided
by the actual maximum and displayed as
percentages relative to 100% in the Results
table.

Note: The Normalize Results option is not available if you cleared the Enhanced Analysis option.
Your results are calculated and adjusted by using the methods that are supported in Analyst's
Notebook.
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8. Use the Actions on Completion section to specify:
a) Whether the results are displayed on your chart by selecting Show Results on Chart
b) Whether the appearance of chart items changes based on the analysis by selecting Apply
Conditional Formatting.

Selecting centrality measures
The Options page is used to select centrality measures and specify how the results are displayed.
To select a centrality measure and specify how results are displayed:
1. Click the Analyze tab, and then in the Gain Insight group, click Social Network Analysis.
The Social Network Analysis pane opens.
2. Click the Options tab.
3. Select the centrality measure that you want to calculate.
You can choose to calculate betweenness for entities and links, closeness, degree, and eigenvector,
and take into account the direction of links. You can also carry out enhanced analysis and normalize
your results
4. Select how the results are displayed when calculations are complete.
You can choose to show results and weightings as chart item attributes, and apply conditional
formatting to them.
When the Options page is complete, use the Weightings page to set link weightings. Or use the
Results page to calculate and analyze your results.

Adding link weightings
Use the Weightings page to set weightings on links to represent the real-world strengths of connections
between entities. Weightings are added to links as attribute values. You can set weightings manually,
base them on existing custom attributes, and import them from a weightings file.
In the Social Network Analysis pane, click the Weightings tab. Select the Use Link Weightings
checkbox.
The weightings are added to links as attributes with the following methods in order of priority:

Setting link weightings manually
You can select links and add weighting attributes to them manually.
To manually add a weightings value:
1. Select the links to which you want to add weighting attributes.
The same weighting attribute value is applied to all links selected.
2. Select the Manually Set Value check box.
3. In the text box, enter the numeric weighting attribute value, and then click Set Weighting for
Selection to. An attribute with the class name Manual Weighting and the manually set value is
added to the selected links.

Weightings files
Use the details stored in a separate file with the special file format .xwgt to add link weightings to links
based on link type or label text.
You create a file or import an existing one. Weighting values can be applied to:
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•

Links of a certain type, for example Associate links

•

Links with a certain value, for example, links labeled "Brother Of"

To use a weightings file, select the From a Weightings File check box.

Edit current weightings
A weightings value is shown on link to represent the real-world strengths of connections between
entities. Once a file is created, this can be edited to allow changes.
To edit the weightings in use:
1. Click Edit File. The Edit Weightings window is shown.
•

To add or import new weightings, use the methods that describe how to create a weightings file.

•

To edit an existing weighting, select the weighting column entry and enter a new numerical
weighting value.

•

To delete a weighting, select a row and click Delete.

2. Click OK.

Create a weightings file
A weightings value is shown on links to represent the real-world strengths of connections between
entities. You can create weightings that are based on the link types or link labels that exist on the chart.
To create a weightings file:
1. Click Create a New File to show the Edit Weightings window.
2. Optional: To create a weighting that is based on link type, select Link Type and then click New to
enter edit mode. Enter the link type and numeric weighting value in the relevant columns and click
OK. You can create a weighting that is based on link label with the same method.
3. Optional: To import weightings from an existing .csv file. Click Import and use the Select Import
File window to browse to and select the file, and then click Open. Details from the .csv file are
added to the Weightings window.
4. Optional: To add weighting that is based on link labels, select Link Label and then click Add from
Chart. The Weightings table is populated with a list of the link labels and weightings that exist on the
chart. By default, links that did not have a weighting value on the chart have a weighting value of one
in the table. You can update this value manually if necessary.
5. Click OK.

Importing existing weightings
A weightings value is shown on a link to represent the real-world strengths of connections between
entities. If you already created a weightings file, it can be imported for use in other charts.
To import an existing weighting file:
1. Click Select a File, the Select a Weightings File window is shown.
2. Use the Look in list to go to and select the .xwgt file that you want to use, and then click Open.
The file path for the weightings file currently in use is displayed.
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Use link label values
You can select links based on the values in link labels that currently exist on the chart and use their link
label values as weightings.
These weighting values can influence the centrality measure results for your social network analysis.
•

Select the Link Label Value check box.

Working with the Results page
The Social Network Analysis page is used to calculate and specify how results are displayed.
Use the Results page to:
•

Calculate the centrality measures you selected in the Options page

•

Display and analyze results in the Results table and on the chart

•

Analyze results further by using the commands in the Actions Pane.

The Calculate command label displays the centrality measures currently selected on the Options page.
Click Calculate to start generating the social network analysis results. Progress is displayed in the
status bar.
It takes Analyst's Notebook longer to calculate results for large charts. The length of time depends
on the number of items in the chart and the number of centrality measures that need calculating. If a
lengthy calculation is taking place, the chart is unavailable but you can still work with other charts while
the calculation runs in the background. The chart must remain open for background calculations to
take place; closing the chart cancels the calculation. The tab of a chart displays a progress wheel to
show that a calculation is taking place. Progress of each centrality measure calculation is displayed in
the Results page and can be canceled individually at any time. If the chart is not displayed when the
calculation is complete, the tab of the chart starts flashing.
When results are calculated, they are displayed in the Results table and added to the chart items as
attributes. A separate attribute class is created for each centrality measure. You can display these
attributes on the chart by using commands in the Action panel. You can also display the attributes in
the attribute classes table of the Attribute instances page. These attributes are displayed in the attribute
classes table in yellow shading to show that they were added automatically by Analyst's Notebook.
If link weightings are used, an attribute that is called weightings is automatically added to links after
calculation.

Results table columns
The Results table automatically displays results when the calculation is complete. Results for entities
and links are displayed in different tables, with the entity Results table displayed by default. The format
of the displayed results might be the actual numbers that are calculated or the values that are adjusted
and expressed as percentages. These results depend on the Enhanced Analysis and Normalization
options that are selected in the Options page.
The available columns for the entity Results table are as follows (default columns are marked with *):
Column heading

Column contents

Entity*

The entity icon followed by the label.
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Column heading

Column contents

Betweenness

A value that represents how many of the shortest
paths pass through each entity. An entity with the
lowest betweenness value has the lowest number
of shortest paths that run through it compared with
the other entities in the network. If
Use Link Direction is selected in the Options
page, the arrow direction determines which paths
can be measured between entities.
Authorities (In) and Hubs (Out) do not have
separate columns for betweenness results
because the number of directed inbound paths are
identical to the number of directed outbound paths
if the arrows are reversed. The same connecting
paths are used for the betweenness calculation
regardless of direction.

Closeness

A value that represents how close each entity is to
the others in the network. For example, an entity
with the highest closeness value has the shortest
paths to most other entities in the network. If Use
Link Direction is selected in the Options page,
the closeness result is displayed in two separate
columns:

Degree

•

Closeness (In): how close an entity is based on
the number of inbound paths

•

Closeness (Out): how close an entity is based
on the number of outbound paths

The number of links between an entity to others in
the network. If Use Link Direction is selected in
the Options page, the degree result is displayed
in two separate columns:
•

Degree (In): the total number of inbound links

•

Degree (Out): the total number of outbound
links

The degree of a result is affected if the links that
connect it are weighted. Examples:

©

•

A link with a weighting of four is classed as
four times more important than a link without
a weighting. It counts as four links, whereas a
link without an assigned weighting counts as
one by default.

•

An entity that is connected by two links has a
degree of five, if one link has no weighting and
the other has a weighting of four.
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Column heading

Column contents

Eigenvector

A value that represents how connected an entity
is based on its direct links to the other influential
entities in the network. An entity with the highest
eigenvector score is directly connected to many
other entities with high eigenvector scores. If
Use Link Direction is selected in the Options
page, two eigenvector results are calculated and
displayed in two separate columns:
•

Authority (In): how connected an entity is
based on its inbound links

•

Hub (Out): how connected an entity is based
on its outbound links

An eigenvector score is affected if the links
that connect to other entities are weighted. For
example, a link weighting of three means that the
link is treated as three times more important than
a link with no weighting.
Note: Hub and authority results cannot be
calculated for charts that contain certain
configurations of entities and links. In such
instances, a warning message is displayed. You
might be able to calculate hub and authority
results if you change your configuration, or edit
your link weightings.
K-Core

A value that can help identify small interlinked
core areas on a network. An entity with the
highest K-Core is directly connected to many other
entities with high K-Cores. The K-Core score of
an entity is affected if the links that connect it to
other entities are weighted. For example, a link
weighting of three means that the link is treated
as three times more important than a link with no
weighting.

To display results for links, select Links. The available columns are as follows (default columns are
marked with *):
Column heading

Column contents

Link*

The link icon followed by a summary of the link in
the format:
Entity A label > link label > Entity B label
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Column heading

Column contents

Betweenness

A value that represents how many of the shortest
paths pass through each link. A link with the
highest betweenness value has the highest
number of paths that run through it compared with
the other links in the network.

Weightings

The weighting value that is assigned to each link.

Commands to process results
Use the commands at the bottom of the Results page to specify what you want to do with your social
network analysis results.
•

Show Results on Chart to display the results as attributes of the entities and links on the chart. If
you previously chose to show weightings and results on the chart in the Actions on Completion
panel of the Options page, the results are displayed on the chart automatically.

•

Hide Results on Chart to hide the results that are currently displayed as attributes of the entities
and links on the chart.

•

Clear Results to delete results from both the chart and the Results table.

•

Select Items with Top Values to select the top 10 items based on their values for the measure that
the results table is sorted by. If there are multiple items with the same value as the 10th item, they
are also selected.

•

Hide Unselected to hide the entities or links that are not selected in the Results table.

•

Show All to display the entities or links that were hidden previously by selecting the Hide
Unselected command.

•

List Items to display the contents of the Results table in the List Items window. If subsets of results
are hidden or cleared, those results are displayed in List Items.

•

Copy Results Table to copy the column headings and contents of the Results table to Windows
Clipboard. If a subset of results is hidden or cleared, those results are not copied.

Focus on items of interest
To focus your analysis and visualization on items of interest, you can select them on the charting
surface then remove all other items from view. Or to focus on the selection later, you can save it in a
selection set, then recall the selection when you need it.
Ten selection sets are available. You might save different groups of items to different selection sets. For
example, the results of different searches of your chart.
You can recall the selection that is saved in a selection set. To gather all items of interest for focused
analysis, you can add the members of each selection set to the current selection.
To focus your analysis or visualization exclusively on the items of interest, you can copy the selected
items to a new chart. The new chart does not contain any other items from the original source chart.
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Hiding chart items
If you are working on a complex chart, you might want to show or hide subsets of the data. Hiding chart
items is useful if you want to emphasize areas of your chart or temporarily remove data that is irrelevant
or inappropriate for certain audiences.
Analyst's Notebook typically treats hidden items as if they do not exist on the chart:
•

Hidden items are not included in any selection, for example Select All.

•

All links to a hidden entity are also hidden.

•

Hidden items are unaffected by chart operations, for example layouts.

•

Hidden diverted event frames do not cause the theme line to which they are linked to be diverted.

•

Hidden items are only listed in the List Items and List Cards windows when the Hidden Items
option is selected.

Hidden items are removed from view, but are not deleted, so you can reveal them on the chart when
required. Revealing hidden items causes them to become visible temporarily, but they retain their
hidden status. You can make items fully visible or visible with a grayed out appearance by using the
Reveal options on the View tab. To remove hidden item status, you must show the items rather than
reveal them.
For some chart operations, for example Visual Search, you can choose to include hidden items and
reveal them as part of the operation by selecting Reveal Hidden in the appropriate window.
Note: Analysis attributes consider hidden items regardless of their reveal hidden status. For example,
if an entity is linked to one visible entity and one hidden entity, the value for its Entity Links analysis
attribute is always 2.
To hide items on your chart:
1. Select the items that you want to hide.
The selection might be the result of an analysis operation, such as Find Text, Find Path, or Visual
Search, or as a result of making a selection such as in List Items or List Cards.
2. Click the View tab.
3. If Reveal Fully or Reveal in Gray is selected, you must clear it. In the Show and Hide Items group,
click Reveal.
4. To hide all selected items, in the Show and Hide Items group, click Hide Selected.
To hide all items that are not selected, in the Show and Hide Items group, click Hide Unselected.
To hide items, based on criteria that you specify:
a) In the Show and Hide Items group, click Show and Hide.
The Show and Hide window opens.
b) Select an option, then click Hide.
Option

Description

All

Hide all chart items.

Selected

Hide selected chart items only.

Unselected

Hide only chart items that are not selected.

With Any of the Attributes

Hide all chart items that have attributes of any
attribute class that you select in the list. Use

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 215

Option

Description
the Ctrl or Shift keys to select more than one
attribute class. All attributes that are used on the
chart are listed.

If hidden items exist on your chart, you can choose to show hidden items that meet the specified
criteria by selecting an option and clicking Show.

Removing hidden items from a chart
If you publish or share a chart, any items that you want to conceal must be deleted. Hiding items does
not prevent others from viewing them by using the Reveal operations.
To delete all hidden items:
1. You might want to save a copy of your original chart before you delete all of the hidden items to
publish it.
2. Ensure that all hidden chart items are fully hidden on your chart (not visible). If Reveal Fully or
Reveal in Gray is selected, click the View tab and in the Show and Hide Items group, click Reveal.
3. Press Ctrl+A to select all the visible items. Then, on the View tab, in the Show and Hide Items
group, click Reveal > Reveal Fully.
All of the hidden items are revealed but not selected.
4. Click the Select tab and in the Select Items group, click Invert.
All previously selected items are unselected and the hidden items that were revealed are now
selected.
5. Press the Delete key to delete the previously hidden items that are now displayed and selected.

Copy items to a new chart
To focus on items of interest or to change the emphasis of your analysis, you can copy selected items to
a new chart. To view the items from a different perspective, you can copy them to an association chart
or to a timeline chart.
For example, during your analysis you might investigate activity over time, which results in a histogram
with a large amount of activity in one particular time period. Selecting the period of interest in the
histogram selects the relevant chart items that you can then copy to a new chart for further investigation.
The copy to new chart features are on the Analyze tab. When you copy items to a new chart, the new
chart is based on the original chart that you copied the items from. Basing your new chart on the original
chart avoids issues such as differing grading systems, and means that appropriate entity types, link
types, palettes, and so on, are available for you to continue working.
You can copy only selected items or include the direct links between the selected items. To include
direct links, even if they are not selected, use the with Connections version of the relevant option. For
example, after you select telephones on a chart, to copy the telephones and the calls between them,
use Copy to New Chart with Connections.
If you select a link to copy to a new chart, the entities at each end of the link are also copied, even if
they are not selected.
Note: If hidden items are selected as part of your analysis, they are also copied to a new chart. They
retain their hidden status but are revealed in gray.
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Copy to New Chart
During your analysis, you might identify a set of chart items that you want to focus on specifically.
For example, you might want to gather further information about specific people and add this new
information to a different chart. Alternatively, you might want to concentrate your analysis on a subset of
your original chart.
When you use the Copy to New Chart feature, the entity representations remain unchanged and the
chart items remain in the same position relative to each other.
Tip: If you copy items that are spread across a large chart, you might want to arrange the chart items
automatically in a more convenient layout. To rearrange chart items automatically, select the Copy to
New Association Chart or Copy to New Timeline Chart feature that corresponds to your chart. The
chart perspective does not change but the items are automatically rearranged on the new chart.
Copy to New Association Chart
If you have a timeline chart, you might identify a set of chart items that you want to focus on from a
network perspective. You can copy the selected items to an association chart. For example, during
your timeline analysis, you might identify a group of individuals and you might want to look at the
relationships and associations between them.
When you copy items to a new association chart, on the destination chart:
•

Any entities that have a representation of theme line are changed to icons.

•

Controlling status is removed from any items that were set to be controlling. Their status is set to
free.

•

Any groups around items are removed and the chart items are arranged in a layout appropriate to
network analysis.

•

Display and printing of the time bar is turned off.

Note: If you select all of the items on the new association chart and copy them to a new timeline chart,
previous settings such as controlling status are not restored.
Copy to New Timeline Chart
If you are analyzing from a network perspective, you might decide that you want to look at the same set
of data or a subset of that data from a timeline perspective.
This feature is useful if you are working with an association chart that contains many links between pairs
of entities where each link is displayed individually, that is with a multiple connection style. For example,
there might be many transactions between two bank accounts with each transaction displayed as a
separate link.
When you copy items to a new timeline chart, on the destination chart:
•

•

All entities are changed to theme lines, except for:
•

Entities with a representation of event frame.

•

Labels

•

Entities that have data in their date and time properties and have a semantic type that is derived
from the Event semantic type.

The following chart items are set to controlling when they have data in their date and time properties:
•

Event frames.
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•

Links between theme lines.

•

Entities that have a semantic type that is derived from the Event semantic type.

•

Any groups are removed.

•

The chart items are arranged in a layout appropriate to timeline analysis.

•

Display and printing of the time bar is turned on.

Modify item appearance
After you add an item to the charting surface, you can modify its appearance from the default style that
is specified by the chart. You can emphasize items on the charting surface, and present only the most
crucial data on the charting surface.
To emphasize an item, you might add an icon frame, increase the size of the item, or add a bold or italic
style to the item text.
To present only the most crucial item data on the charting surface, you can select which properties are
displayed. For example, you can choose to display only grades, source type, and the value of specific
attributes.
To remove irrelevant or less important data from view, you might hide those chart items. To place a
lower emphasis on those items instead of removing them, you can reveal the hidden items in gray.

Displaying icon frames
You can add a colored frame around the border of entities that are represented by icons, including the
icons on theme lines. If a picture is displayed on the entity instead of an icon, the frame is added to the
picture in the same way.
Circular frames are created around icons and theme line icons; square or rectangular frames are
created around pictures. Frames can be used to draw attention to key entities. Frames can highlight
groups of entities and change the appearance of entities that are selected by using analysis tools such
as filtering or Social Network Analysis. Frames can also indicate entities with shared attributes as a
result of applying conditional formatting.
To add an icon frame to your selection:
1. Right-click an item, and select Edit Item Properties.
The Edit window is shown.
2. Select Style > Frame.
3. Select Display a Frame. The Preview area contains an example of how the framed icon looks on the
chart. The frame that is created is shaded blue with a margin width of two.
4. To change the color, select a color from the Color bar.
5. To change the width of the frame around the icon, select an option from the Margin bar.
6. Optional: Select Set Default Style to use the current settings as the default for the entity
representation.
7. When you are happy with the icon frame that is shown in the Preview area, click OK
Tip: To remove an icon frame from the selected entity, clear the Display a Frame check box and
click OK.
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Setting the font
You can set the font type, size, style, color, and the shading style of the text on the chart.
To set the font on an item:
1. Right-click an item, and select Edit Item Properties. The Edit window is shown.
2. Select Style > Font.
3. Select a font to use in the Font area.
4. Select the style of the font in the Font Style area.
For example, you might want to show the font in bold, or italic.
5. Select the size of the font in the Size area.
6. Choose the font effects to use in the Effects area.
7. Set the font color by selecting a color from the Color list.
8. Set the shading style by selecting a shading style from the Shading list.
9. Optional: Select Set Default Style to use the current settings as the default for the link or particular
entity representation.
10.When you are happy with the font that is shown in the Sample box, click OK.

Setting display properties
When items are displayed on a chart surface, you can determine which properties to display. This
allows you to include key information of interest to your investigation.
To set display properties:
1. Right-click an item, and select Edit Item Properties.
The Edit window is shown.
2. Select Style > Display.
3. Select the options to use when items are shown:
•

Select Default to select the default display options.

•

Select Clear All to clear the display options.

4. Select how the date is shown in the "Displayed Date & Time" area. You can choose either:
Option

Description

Description

Shows the description of date and time that is
entered in the Date & Time page.

Formatted

Formats how the date and time that is entered in
the Date & Time page is shown. Select a format
from the list. When the item has a date and time,
a preview of how the date and time is shown in
the Preview box.

5. Optional: Select Wrap Text and set a value to use when you wrap text.
6. Optional: Select Set Default Style to use the current settings as the default for the link or particular
entity representation.
7. Click OK.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 219

Setting the default style
When you add new items to your chart, Analyst's Notebook uses the default style to display the item.
You can set the default style for links and for each different entity representation. For example, you can
set a default appearance for new theme lines or icons.
The default style is a group of settings that control the appearance of a chart item:
•

Font

•

Entity or link type

•

Display options, such as which items properties are shown on the chart

Setting the default style applies only to new items that you add to your chart. It does not modify the
appearance of existing items. However, if you are editing the appearance of an existing item, you can
choose to make those current settings the default style by selecting the Set Default Style check box in
the Edit Item Properties window.
1. Right-click on the background of your chart and select Set Default Styles.
The Set Default Styles window opens. A folder is listed for each entity representation and for links.
2. Click the folder of the representation whose default style you want to change.
Different style pages are available depending on which entity representation or link you choose.
3. Click to open a style page. The following options are available:
Option

Description

Type

Settings such as the entity or link types,
semantic type, line strength and width, color,
and enlargement. The type options are not
available for labels.

Display

Settings such as which item properties to display
on the chart and how the date and time are
formatted.

Font

Font settings such as style, size, and effects.

Frame

Settings to choose whether to include a frame
around an icon and to set its color and margin
size. The frame options are only available for
icons and theme lines.

Connection

Settings to determine link multiplicity, fan size,
and how theme lines are diverted through
event frames. The connection options are only
available for links.

4. Edit the options that you want to change, then click OK.

Displaying an attribute class on the charting surface
You can choose which item attributes are displayed on the charting surface. To show key item
information to chart recipients, display the attribute that it is stored in.
1. Click File > Chart Properties > Definitions > Attribute Classes.
2. Select an attribute class, then click Properties.
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3. Select Show On Chart, then click OK.
4. In the Chart Properties window, click OK.
If an item contains an instance of that attribute class, the attribute is displayed on the charting surface.

Changing entity representation
You can change the representation of entities. You might want to change an entity from an icon to a text
block, event frame, or theme line.
Entities added to the chart surface can change their representation. Changing the representation
changes the appearance, and allows different types of analysis to be carried out.
When you change the representation, you can also change the ordering behavior to follow for entities
that have date & time values.
1. Select the chart items that you want to change.
2. Click the Style tab, and then click Change Representation.
The Change Representation window is shown.
3. Select a representation to change the chart items to.
4. Select the order behavior to apply to the chart items.
Option

Description

Leave order unchanged

Does not change the order and control of the
date & time.

Remove order from all chart items

Sets items to be free - that is not ordered by
date & time values.

Add order to all chart items with date and
time

If a date & time is detected, the items are set to
be controlling.

5. Click OK.
Related concepts
Apply layouts to association charts on page 222
Layouts can be applied to association charts. You can use a layout to rearrange the chart for better
presentation so that relationships are more visible.
Apply layouts to timeline charts on page 225
Layouts can be applied to timeline charts. Applying a layout rearranges your chart so that patterns might
be revealed over a time period.

Resetting style
Reset modified chart items to their default style and appearance by using the Reset Style option.
You might decide that changes to the style of items are no longer needed and you want to reset
their appearance to the default style specified by the chart. When you reset items, you remove all
the changes whether they are manually applied, modified by live formatting, or conditional formatting
specifications. The option to reset the style is available when you select one or more items on the chart
surface.
1. Select the item or items that you want to change.
2. Click the Style tab of the ribbon, and then click Reset Style.
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The style of the selected items changes instantly. For example, if you select a Person entity that is
larger than Person entities specified by the chart, the size decreases to match the default size.
Note: You can undo and redo your actions from the Quick Access Toolbar at the top of the
screen.

Arrange items
You can automatically move chart items so that their presentation suits the data, and so that items are
uniformly positioned. You can improve the clarity of the chart, for example by shaping links so that they
do not obscure other chart items.
To produce a clearer chart and to consistently space items, you can use chart layouts such as the
Minimize Crossed Links layout and the Theme Line layout. Chart layouts automatically arrange chart
items. Other layouts move items so that their presentation suits the data, for example the Organization
layout.
To improve the uniformity of item positioning, you can use the features in the Align and Space group
on the Arrange tab. Uniform positioning can help chart recipients to focus on chart data, rather than on
inconsistent positioning.
To move items manually, you can select several of them on the chart and drag them together. When
you make another selection, Analyst's Notebook discards the temporary group that you created. As an
alternative, you can use the Group feature to create a permanent grouping of items. To move grouped
items manually, drag the handle of the group.
To shape a link so that it does not obscure other items, you can add corners to it. For example, you
can route the link around other chart items rather than over them. You can also add consistency to link
alignment, so that all links run either horizontally or vertically.

Chart layouts
Layouts provide a quick way of automatically rearranging the entities and links on your chart. Layouts
improve the appearance of your chart and to help you analyze the structure of chart data. When a layout
is applied, Analyst's Notebook automatically resizes the chart so that you can see all chart items without
having to adjust your view.
Analyst's Notebook provides two main types of layout, depending on what data your chart contains:
•

Layouts for association charts

•

Layouts for timeline charts

For new charts, it is a good idea to try different types of layout to determine which provides the best
view for your investigation. When you identify a layout, you can then try experimenting with the settings
for this layout for even better results.
Layouts can be useful when new data is incorporated into the chart. You can rerun a layout on the
whole chart to analyze what effect the new information has on the chart.
Note: After you manually arrange chart items for presentation, if you run a layout you will lose your
changes.
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Apply layouts to association charts
Layouts can be applied to association charts. You can use a layout to rearrange the chart for better
presentation so that relationships are more visible.
Note: When you apply a layout: Background and hidden chart items are ignored by all association chart
layouts but might affect timeline layouts, and corners are removed from all links.
None of the layouts are suitable for charts that contain large entities. For example, boxes - often used to
represent organizations - and large OLE objects, for example photographs.
To apply a layout, click the Arrange tab, and then in the Network Layouts group, click the layout.
Related tasks
Changing entity representation on page 220
You can change the representation of entities. You might want to change an entity from an icon to a text
block, event frame, or theme line.

Circular layout
The Circular layout does not reveal the structure of your chart data in the same way as the Peacock or
Grouped layout. It might be useful when you want to arrange a number of entities by type in a circular
pattern.
A Circular layout can be used in charts with connected and unconnected entities. If the Blocking
Required check box is cleared in the Setup Layouts window, all entities are arranged into a circle,
even if they are not linked to any other entities.
Note: The entities in a Circular layout are sorted by type and not by the number or destination of links
between them. Therefore, this layout might result in many crossed links inside the circle.
By using a Circular layout, you can:
•

Specify the maximum width and height of the rearranged chart.
Note: The height or width of the chart might exceed the height or width that you specify. For
example, if your chart contains grouped items that are spaced far apart. Chart items in a group are
not moved relative to each other.

•

Position an entity in the center of the circle.

•

Include an inner and outer ring.

•

Specify several circles or a single circle.

A Circular layout might not be appropriate for charts that contain:
•

Many ordered or controlling items. These items are not moved.

•

Many theme lines, for example timeline charts.

•

Boxes enclosing other entities. The relationship between the box and the entities within it is lost.

Compact Peacock layout
The Compact Peacock layout is useful when you have many interlinked entities. It groups sets of
entities that are linked to one entity on the chart.
Use the Compact Peacock layout for one of the following options:
•

Identify entities at the center of much activity in high volume data, for example telephone data or
financial transactions.
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•

Discern in more detail the activity within groups of interconnected entities.

The Compact Peacock layout is more flexible than the Grouped layout and the patterns it produces vary
depending on the nature of your data. The chart items in a Compact Peacock Layout are more spread
out than the standard Peacock layout, The Compact Peacock layout makes them much more legible.
When you zoom in to an area of the chart, the links between the main areas of activity are also shorter.
A more compact and legible final chart is provided.
By using a Compact Peacock layout, you can do one of the following options:
•

Set the separation distance between entities

•

Fix entities on the chart in their original location

•

Animate the layout

A Compact Peacock layout might not be suitable for charts that contain:
•

Many ordered or controlling items. These items are not moved.

•

Mostly theme lines, for example timeline charts.

•

Boxes that enclose other entities. The relationship between the box and the entities within it is lost.

Grouped layout
The Grouped layout is useful when you have many linked entities. You can find out whether there
are certain entities to which a number of other entities are linked. It helps to identify groups of
interconnected entities and the relationships between them.
The Grouped layout is more rigid than the Peacock layout. It always attempts to rearrange your chart
data into a similar pattern. This pattern has a group of interlinked entities at the center, and other groups
'fanning out' from this central group.
Note: Using a Grouped layout does not display the structure of the network within the groups clearly.
To see more detail in the structure, use a Peacock layout.
By using a Grouped layout, you can:
•

Set the maximum width and height of the rearranged chart

•

Specify a minimum separation for items

•

Position an entity at the center of the chart

A Grouped layout might not be appropriate for charts that contain:
•

Many ordered or controlling items. These items are not moved.

•

Mostly theme lines, for example timeline charts.

•

Boxes that enclose other entities. The relationship between the box and the entities within it is lost.

•

Only a few linked entities.

Hierarchy layout
For charts that contain organizational structures, you can use the Hierarchy layout to visualize how key
individuals control different operations. To show the relative status of entities, peers in the organization
are aligned.
To use the hierarchy layout, one or more entities must be identified as root entities. The other items in
the chart are rearranged in relation to the identified root items.
By using a Hierarchy layout, you can:
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•

Set the separation between entities. The depth is the separation between entities at different levels
in the hierarchy from the root entity or entities. The breadth is the separation between entities at the
same level in the hierarchy.
Note: If the Legacy Mode check box is cleared, sibling entities are grouped closer together, which
might affect the breadth separation.

•

Specify whether to arrange the entities from top-to-bottom or left-to-right.

•

Choose how to determine the root entities of the hierarchy.

•

Specify whether to use corners when you lay out the chart.

•

Choose whether to revert to the legacy mode for the layout. Legacy mode does not allow for entity
extents or allow animation. In addition, items on the same level of the hierarchy are not sorted to
reduce crossed links in legacy mode.

•

Choose whether to animate the layout. Animation is not available if you select the legacy mode.

A Hierarchy layout might not be appropriate for charts that contain:
•

Many ordered or controlling items. Ordered and controlling items are not moved.

•

Boxes that enclose other entities. The relationship between the box and the entities within it is lost.

•

Mainly theme lines, such as timeline charts. Theme lines, and items that are directly connected to
theme lines, are not moved by a hierarchy layout.

Minimize Crossed Links layout
The Minimize Crossed Links layout is useful when you have many linked entities to arrange the entities
into the clearest layout possible.
By using a Minimized Crossed Links layout, you can:
•

Specify a minimum separation between chart items

•

Set the orientation of the chart

•

Select a link to position at the outside of the chart layout

Organization layout
The Organization layout is useful for charts that contain organizational structures, and you can identify
one or more key individuals who control different operations. To ensure that links between entities are
visible, peers in the organization might not be aligned.
You can group and ungroup chart items and apply an Organization Layout. The items in the group are
retained.
By using an Organization layout, you can:
•

Set the separation between entities

•

Specify the orientation of the chart

•

Choose how to determine the root of the chart

Packed layout
The Packed layout is useful for laying out chart items such that empty space is minimized on the chart.
This layout can make your chart more compact to view and print.
A Packed layout can be used for charts that have many connected and unconnected entities. Other
layouts often arrange chart items in a single row across the width of the chart. These layouts make wide
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charts that are difficult to see in a single view. When a Packed layout is applied, the items that have the
most connected entities are grouped first on the left side of the chart. The remaining items are shown
next to that group, in descending order of nodes, across and then down. Entities that are not connected
to any other entity are shown in a row at the bottom of the chart
You can customize the behavior of a packed layout in the following ways:
•

Specify the group separation value

•

Animate the chart as the layout is applied

Peacock layout
The Peacock layout is useful when you have many interlinked entities, because it groups the other
entities that an entity is linked to.
A Peacock layout can be used to:
•

Identify entities at the center of much activity in high volume data, for example telephone data or
financial transactions.

•

Discern in more detail the activity within groups of interconnected entities

The Peacock layout is more flexible than the Grouped layout and the patterns it produces vary
depending on the nature of your data.
By using a Peacock layout, you can:
•

Set the separation distance between entities

•

Fix entities on the chart in their original location

•

Animate the layout

A Peacock layout might not be appropriate for charts that contain:
•

Many ordered or controlling items. These items are not moved.

•

Mostly theme lines, for example timeline charts.

•

Boxes enclosing other entities. The relationship between the box and the entities within it is lost.

Apply layouts to timeline charts
Layouts can be applied to timeline charts. Applying a layout rearranges your chart so that patterns might
be revealed over a time period.
Note: None of the layouts are suitable for charts that contain large entities. For example, boxes - often
used to represent organizations - and large OLE objects, for example photographs.
To apply a layout, click the Arrange tab, and then in the Timeline Layouts group, click the layout.
Related tasks
Changing entity representation on page 220
You can change the representation of entities. You might want to change an entity from an icon to a text
block, event frame, or theme line.

Ordered layout
The Ordered layout is most useful when you have a chart with a sequence of events. It separates each
event from the next horizontally by a distance you specify in the layout setup to read your data much
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more easily. The distance that you specify takes into account the width of chart item labels but not link
labels.
An Ordered layout is useful:
•

When you import a volume of data and must apply an initial layout.

•

For analysis of high volume data, especially of events with date & time.

•

For presentation and printing.

By using an Ordered layout, you can:
•

Apply the layout to the entire chart, limit the layout to selected items, or limit the layout to items that
are in a specified date and time range.

•

Set the distance between successive items. You can choose to set the distance between all items or
controlling items. For example, by selecting controlling items you can maintain the position of items
such as textual annotation or theme line icons.

Proportional layout
The Proportional layout is most useful when you have a chart with a sequence of events. It displays
an accurate representation of when items occur in relation to each other. This layout can help to gain
an understanding of how events occur in real time, but can result in wide charts with items spaced far
apart.
When you import data, for example telephone calls, the Proportional layout provides an initial view of
how the events are spread in time before you apply other layouts.
By using a Proportional layout, you can:
•

Apply the layout to the entire chart or just a selection of chart items

•

Specify how the chart width is determined

Theme Line layout
The Theme Line layout is useful when you have many theme lines on your chart.
By using a Theme Line layout, you can:
•

Sort the theme lines by a particular property, for example to place the theme line with the most
connections at the top of the chart

•

Specify the vertical separation between theme lines

•

Change the order of the theme lines

•

Align the theme line icons and event frames

•

Arrange event frames that divert

A Theme Line layout is not appropriate for charts that do not contain controlling items.

Grouped Theme Line layout
The Grouped Theme Line layout is useful when you have many theme lines on your chart and you want
to minimize the number of links that cross the theme lines.
The Grouped Theme Line layout is a proportional layout. It is effective when you target part of a large
network, for example after you filter a chart to find all of the transactions in a particular time period.
By using this layout, you can:
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•

Sort the theme lines to cluster your chart into groups of highly connected theme lines.

•

Minimize the number of links that cross theme lines.

•

Minimize the theme line extents.

•

Position the theme line icons at the start of the theme lines, just before the first link. When a theme
line has only one link, the theme line icon is placed at the time of the link.

A Grouped Theme Line layout is not appropriate for charts that do not contain controlling items.

Grouped By Time layout
Grouped by Time layout arranges items from left to right across your chart in groups. Items that occur at
similar times are displayed close together. For example, you can group telephone calls that occur within
an hour of each other to find periods of high activity.
The Grouped by Time layout is useful for:
•

High volume imported data with dates and times, for example telephone billings or financial
transactions, to find bursts of activity that might be related.

•

A timeline chart with many events that take place at irregular intervals.

•

Reducing the widths of charts that are too wide when laid out proportionally. This layout preserves
an indication of periods of high activity and periods of low activity.

Using a Grouped by Time layout results in a chart in which the distance between each subsequent item
is defined by you. It is a non-proportional layout, as the gap between items is not equivalent to the time
between them.
A Grouped by Time layout is not appropriate for charts that do not contain controlling items.
By using a Grouped by Time layout, you can:
•

Apply the layout to the entire chart, limit the layout to selected items, or limit the layout to items that
are in a specified date and time range.

•

Set the maximum time difference between consecutive items to consider them to be in a group.

•

Set the distance between groups.

•

Set the distance between successive items in a group. You can choose to set the distance between
all items or controlling items. For example, by selecting controlling items you can prevent other items
from being spaced out to the right of each group and therefore produce a more compact layout. In
this more compact layout, the separation between groups is always between controlling items.

Changing layout settings
Chart layout settings determine how items are positioned when layouts are applied to charts. These
settings can be modified to better match your needs.
To modify the layout settings:
1. Click the Arrange tab, and then click Layout Setup.
The Setup Layouts window appears.
2. From the list on the left of the window, select the chart layout to modify.
3. Change the layout settings to suit your requirements:
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Options

Description

Applicable layouts

Size

Specifies the chart area by
dimensions or by minimum
separation of entities.

Circular, Grouped

Separation

Specifies the distance between
entities or groups of entities.

Hierarchy, Minimize Crossed
Links, Organization, Packed,
Compact Peacock, Peacock,
Grouped by Time, Ordered,
Theme Line

Central Entity

Arranges the other entities
around a specified entity.

Circular, Grouped

Note: This setting asks for the
identity of the entity to be used.
As such it is a chart-specific
setting.
Entity Constraints

Prevents the rearrangement of
key entities, either based on
selection status or a specified
attribute.

Double Ring

Arranges entities into two rings, Circular
one within the other.

Blocking

Arranges groups of related
entities into multiple circles.

Animated

Specifies whether the view
Hierarchy, Minimize Crossed
shows you the steps that are
Links, Organization, Packed,
taken to transform your chart to Compact Peacock, Peacock
the selected layout.

Apply To

Specifies which items on the
chart are grouped. You can
group all items, the selected
items only, or items associated
with a particular time period.

Grouped by Time, Ordered,
Proportional, Theme Line

Group Items Within

Sets the scale at which items
are grouped.

Grouped by Time

Root

Selects the starting point for
grouping within hierarchies and
organizations.

Hierarchy, Organization

Orientation

Specifies the direction of the
layout and the alignment of
items within the layout.

Hierarchy, Minimize Crossed
Links, Organization

Add Corners

Add corners to the links in
a hierarchy so that they are
arranged horizontally and
vertically.

Hierarchy
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Options

Description

Applicable layouts

Outer Boundary

Specifies the items to position
at the boundary.

Minimize Crossed Links

Width

Specifies how the width of the
layout is determined.

Proportional

Order

Specifies how the order of the
theme lines is determined.

Theme Line

Legacy Mode

Uses the original Hierarchy
Hierarchy
layout, which does not allow for
entity extents, order items within
layers, or provide animation.

4. Click OK to save your changes.

Aligning and spacing chart items
Chart items can be aligned or spaced. You can align and space chart items vertically or horizontally.
Aligning and spacing chart items rearranges them so that they are evenly spaced out or aligned on your
chart. The buttons in the Align and Space group on the Arrange tab move preselected items around
your chart so that they can be aligned with each other or be evenly spaced. You can align or space any
number of selected items from a minimum of two chart items.
Click the Arrange tab, and then in the Align and Space group, click one of the following buttons:
Option

Description

Align Vertically

Move selected chart items so that they are aligned
vertically without moving each chart item up or
down.
The center of each chart item is moved to an
invisible alignment line. If most of the selected
items are on the same vertical line, the other
selected items are centered on that vertical line. If
none of the selected chart items are on the same
vertical line, all selected items are centered on a
line that is mid way between all of the selected
chart items.
Tip: You might use Space Vertically after Align
Vertically, to space out your aligned items evenly.

Align Horizontally

Move selected chart items so that they are aligned
horizontally without moving each chart item to the
left or right.
The center of each chart item is moved to an
invisible horizontal alignment line. If most of the
selected items are on the same horizontal line,
the other selected items are centered on that
horizontal line. If none of the selected chart items
are on the same horizontal line, all selected items
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Option

Description
are centered on a line that is mid way between all
of the selected chart items.
Tip: You might use Space Horizontally after
Align Horizontally, to space out your aligned
items evenly.

Space Entities > Space Vertically

Move automatically a number of selected chart
items so that an even amount of white space is
placed between them vertically. The chart items
are not moved horizontally.
For each selected item, an invisible box is drawn
around the chart item. This box includes the
height of the item and the full width of any labels
and attributes. The selected chart items are
moved to a set vertical distance from the top and
bottom edge of each invisible box.
Note: The File > Chart Properties > Options
> Display > Snap to Grid option has no effect
upon chart items that are spaced vertically with
this function.

Space Entities > Space Horizontally

Move automatically a number of selected chart
items so that an even amount of white space is
place between them horizontally. The chart items
are not moved vertically.
For each selected item, an invisible box is drawn
around the chart item. This box includes the
height of the item and the full width of any labels
and attributes. The selected chart items are
moved to a set horizontal distance from the left
and right edges of each invisible box.
Note: The File > Chart Properties > Options >
Display > Snap to Grid option has no effect upon
chart items that are spaced horizontally with this
function.

Grouping items
You can group or ungroup items on your chart. You can also copy groups and paste them into a new
chart or application.
You can use grouping with the following layouts:
•

Grouped

•

Circular

•

Peacock

•

Compact Peacock

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 231

•

Organization

•

Hierarchy

You cannot use grouping with the following layouts:
•

Grouped by Time

•

Minimize Crossed Links

•

Proportional

•

Ordered

•

Theme Line

Note: Analyst's Notebook tools do not use grouping.
To add chart items to a group, clear the group, or select the items in a group, select one of the following
commands:
•

Right-click a selection of chart items, and select Group from the menu.

•

To clear the group, select the group, and then select Ungroup.

•

To select all the items in the group, select the group, and then select Select Grouped Items.

•

To delete a group, select the group, and then press Delete.

Prepare a chart for publication
Before you present or publish a chart, you can check it for spelling errors, and remove data records. To
aid understanding of your chart, you can add a legend, which is a key for the conventions that are used
on your chart.
Some items on the charting surface might be displayed differently to chart recipients who use an
earlier version of Analyst's Notebook. If you use visualization features that are not supported in earlier
versions, Analyst's Notebook displays compatibility warnings when you save the chart.

Check spelling
Spelling checks can run automatically as you type. Possible spelling mistakes are highlighted and
suggestions are made for corrections. A spelling check can be run after you create a chart before it is
published. When you finish creating a chart, it is searched for spelling and other errors. When a possible
error is identified, you can correct it and then continue the check.

Checking spelling of the completed chart
Spelling can be checked in a chart that you complete before it is published. The actions that are taken,
might be to ignore, or change a word that is found with a spelling check.
To check spelling in a chart:
1. Click the Publish tab, and then in the Prepare group, click Spelling.
The first spelling error is displayed in the Not in Dictionary box.
2. A suggested replacement is displayed in the Change To box. Select one of the following options in
the Suggestions area:
Option

Description

Ignore

Leaves the error unchanged, but continues to
identify any further instances of this error.
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Option

Description

Ignore All

Leaves all instances of this error unchanged for
the current session.

Change

To accept the suggested correction, click
Change. To use another of the suggestions
in the list, click the required word then click
Change.
If none of the suggestions are the required word,
type the correction in the Change to box and
then click Change.
When the selected error is a repeated word, this
changes to Delete so you can easily remove the
second instance of the word.

Change All

Changes all instances of the word in the Not in
dictionary box to the word in the Change to
box. Changes all instances of the error in the
active chart only.

Add

Adds the word in the Not in Dictionary box
to the dictionary. When Analyst's Notebook
encounters this word in future, in this chart or
any other charts, it will not be identified as a
misspelling.

Close

Closes the Spelling window without making the
current suggested change, and stops checking
the chart.

3. A message is displayed when the spelling check is complete. Click OK to close it.

Setting spelling check options
You can set the options to use when you spell check a chart. You might want to ignore or specify certain
types of text.
To show the Spelling page:
1. Click File > Options.
2. In the Options window, select the Spelling page.
3. You can choose to spell check entities, links, or both entities and links. Specify chart items to include
in the spelling check, by selecting:
Option

Description

Entities and Links

Spell check all entities and links.

Entities Only

Spell check only entities.

Links Only

Spell check only links.
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4. You can tell Analyst's Notebook to ignore certain kinds of text in your chart when you check spelling.
You might want to ignore words with numbers. The spelling check can also suggest similarly
sounding or similarly spelled words. Select or clear the following check boxes:
Option

Description

Capitalized words

For example, Canada.

Uppercase words

For example, ASAP.

Words with numbers

For example, Windows2000.

Mixed case words

For example, AstroTurf.

Domain names

For example, www.awebsite.com

HTML markup

For example, <p>

Report doubled words

For example, the the.

Case-sensitive checking
Suggest similarly sounding words

Suggests "whose" and "hoes" for "hoose".

Suggest similarly spelled words

Suggests "house" and "choose" for "hoose".

Suggest split words

Checking spelling automatically as you type
You can check spelling automatically as you type information in to chart items. You can add an error as
a word to the dictionary. You can also ignore an error.
To check spelling automatically as you type:
1. Select the Check Spelling as You Type checkbox.
2. When you type text on your chart or in any properties page, Analyst's Notebook uses wavy red
underlining to indicate a spelling error. To correct an error, right-click a word with a wavy underline,
and then click the correction that you want from the menu.
Note: The Coverage settings that are specified in the Spelling page of the Options window do not
apply when spelling is checked as you type.
3. Select Ignore All to skip all instances of this error for the current session of Analyst's Notebook.
When you close the application, the option to ignore this word is reset.
4. Optional: If you do not want to identify the word as an error in all charts, click Add to add the word
to the dictionary. You might want to add a word to the dictionary when it is the name of a person or
organization that you regularly use.

Work with legends
A legend is a key for the conventions that are used on your chart. You can create a legend to explain
the different entity types, link types, attribute classes, line properties, fonts, and time zones on your
chart.
You can specify the shape of the legend and place it at a specific location on your chart.
A legend can have a title, chart summary information, and legend entries for the following items:
•

Attribute symbols
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•

Entity icons (such as Male and Female.)

•

Lines (for items such as event frames, theme lines, boxes, circles, and text blocks.)

•

Fonts (describing the use of fonts on your chart)

•

Links

•

Time zones

•

Icon frames

You can either populate the legend from the items on your chart, or create a blank legend and populate
it manually.

Populating the legend
Use the Populate Legend window to populate your legend with entries for items that exist on your chart.
You can select which item types are added. If a legend exists for the chart, you can also specify how
any new entries are added.
1. To open the Edit Legend window, click the Publish tab, and then in the Prepare group, click
Legend. If your chart does not currently contain a legend, the Legend Population Option window is
displayed.
2. Select the Items page on the Edit Legend window.
3. In the Add Entries For area, select the appropriate check boxes to select entry types you want
included in the legend.
4. In the Action area, select the appropriate option to specify how new entries are added to an existing
legend.
Replace Existing

Deletes all of the existing entries in the legend
before populating it

Append to Existing

Adds the new entries to the entries already in
the legend even if the legend already contains
identical entries

Merge with Existing

Merges the new entries with the entries already
in the legend

5. Click OK to populate the legend with entries for the chart items, by using the options specified.

Adding legend title entry
Use the Add Legend Title window to specify the contents of the legend title. If the legend is populated
from chart items, 'Untitled' is used as the first title entry that is displayed in the Edit Legend window.
1. On the Edit Legend window, click Title. To show the Edit Legend window, click the Publish tab,
and then in the Prepare group, click Legend. If your chart does not currently contain a legend, the
Legend Population Option window is shown.
a) To populate the legend from the items on the current chart, click Yes on this window. A legend is
created by using the default settings for each entry.
b) To populate the legend manually, click No on this window. A blank legend is created.
2. In the Text box, enter the information that you want to include in the legend title such as name, date.
3. You can enter more than one line of text, by pressing the Enter key or by creating extra title entries.
By default, each new title entry is added below any existing entries.
4. To change the font of the title, click Font. Use the Font window to select the font.
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Tip: If you are editing an existing legend, the legend text box is populated with any previously
created title (and other) entries. Use the Edit Legend Title window to edit title entries.

Adding or editing a legend attribute entry
1. On the Edit Legend window, click Attribute. To show the Edit Legend window, click the Publish
tab, and then in the Prepare group, click Legend. If your chart does not contain a legend, the
Legend Population Option window is shown.
a) To populate the legend from the items on the chart, click Yes. A legend is created by using the
default settings for each entry.
b) To populate the legend manually, click No. A blank legend is created.
2. In the Description box, enter the text to appear in the legend for that attribute.
3. Select the attribute symbol from the list that is displayed in the Symbol box. This list contains all
available attribute symbols. You can use the scroll bar or use the up and down keys to access the
attribute you require. If you know the name of the attribute, then click in the symbol list and type the
name.
4. Click OK to confirm the entry and return to the Edit Legend window.
Tip: To edit an existing entry, either double-click the entry to be edited or select it and click Edit.
The Edit Legend Attribute Entry window is shown. Edit the entry.

Adding or editing a legend icon entry
1. On the Edit Legend window, click Icon. To show the Edit Legend window, click the Publish tab,
and then in the Prepare group, click Legend. If your chart does not currently contain a legend, the
Legend Population Option window is displayed.
a) To populate the legend from the items on the current chart, click Yes on this window. A legend is
created by using the default settings for each entry.
b) To populate the legend manually, click No on this window. A blank legend is created.
2. In the Description box, enter the text to appear in the legend for that icon.
3. Select the icon from the list that is displayed in the Icon box. This list contains all icons available.
You can use the scroll bar or use the pointer up and down keys to access the icon you require. If you
know the name of the icon, then click in the icon list and type the name.
4. Click OK to confirm the entry and return to the Edit Legend window.
Tip: To edit an existing entry, either double-click the entry to be edited or select it and click Edit.
The Edit Legend Icon Entry window is shown, in which you can edit the entry.

Adding or editing an icon frame entry
The chart legend can contain icon frame entries that match the colors of icon frames on the chart. You
can add descriptions to the legend entries to explain what the icon frame colors represent.
To add or edit a icon frame legend entry:
1. To show the Edit Legend window, click the Publish tab, and then in the Prepare group, click
Legend.
a) To populate the legend from the items on the current chart, click Yes. A legend is created by
using the default setting for each entry.
b) To populate the legend manually, click No. A blank legend is created.
2. Click Icon Frame to add a new icon frame entry or double-click an existing icon frame entry to edit it.
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3. Enter the description for the legend entry.
4. Select the color to use for the icon in the legend entry.
5. Click OK to confirm the entry and return to the Edit Legend window.

Adding or editing a legend line entry
Event frame styles and theme segments styles can be added to the legend as line entries.
1. On the Edit Legend window, click Line. To show the Edit Legend window, click the Publish tab,
and then in the Prepare group, click Legend. If your chart does not currently contain a legend, the
Legend Population Option window is shown.
a) To populate the legend from the items on the current chart, click Yes on this window. A legend is
created by using the default settings for each entry.
b) To populate the legend manually, click No on this window. A blank legend is created.
2. In the Description box, enter the text to appear in the legend for the line.
3. From the Strength list, select the strength (line style) of the line. The list includes solid, dashed, and
dotted lines.
4. From the Color list, select the color from the displayed palette.
5. From the Width list, select the thickness.
6. Click OK to confirm the entry and return to the Edit Legend window.
Tip: To edit an existing entry, either double-click the entry to be edited or select it and click Edit.
The Edit Legend Line Entry window is shown. Use this window to edit the entry.
You create entries for each convention you are using in your chart.

Adding a legend font entry
If you use fonts to highlight the importance of information on your chart, the meanings can be added to
the chart legend.
To add font details to the legend:
1. To show the Edit Legend window, click the Publish tab, and then in the Prepare group, click
Legend.
2. Select Font
The Add Legend Font Entry window opens.
3. In the Description box, enter the text to show in the legend for that font.
4. To change the font, click Font.
5. Click OK to confirm the entry and return to the Edit Legend window.
Tip: To edit an existing entry, either double-click the entry to be edited, or select it and click Edit.
The Edit Legend window is shown in which you edit the entry.

Adding or editing a legend time zone entry
Short time zone names on the chart (PST, BST, GMT, and so on) can be displayed in the legend in their
full form: Pacific Standard Time, British Summer Time, Greenwich Mean Time. The Populate button on
the Edit Legend window adds any short time zone names that are displayed on the chart to the legend
automatically. Extra time zones can be added if required.
To add or edit a legend time zone entry:
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1. On the Edit Legend window, click Time Zone. To show the Edit Legend window, click the Publish
tab, and then in the Prepare group, click Legend. If your chart does not currently contain a legend,
the Legend Population Option window is shown.
a) To populate the legend from the items on the current chart, click Yes on this window. A legend is
created by using the default settings for each entry.
b) To populate the legend manually, click No on this window. A blank legend is created.
2. From the Time Zone list, select a time zone to add. The long names of the selected time zone are
shown in the Description box.
3. To change the font of the legend entry, click Font. The Font window is shown, in which you can
select the font.
4. Click OK to confirm the entry and return to the Edit Legend window.

Adding or editing a legend link entry
You can populate a legend and add it to your chart by using one of the following steps.
Legend entries can be added and edited for legend link entries.
On the Edit Legend window, click Link. To show the Edit Legend window, click the Publish tab, and
then in the Prepare group, click Legend.
•

To populate the legend from the items on the current chart, click Yes. A legend is created by using
the default settings for each entry.

•

To populate the legend manually, click No. A blank legend is created.
Tip: To edit an existing entry, either double-click the entry to be edited, or select it and click Edit.

Setting legend display properties
Use the Edit Legend Properties page to specify how the legend appears on your chart and to specify its
location.
To display the legend on the chart, select the Show on Chart check box.
Setting the legend shape
In the Shape area, select the appropriate option to specify the shape of the legend:
Tall

The legend is arranged in a rectangular box taller
than it is wide

Square

The legend is arranged in a square box

Wide

The legend is arranged in a rectangular box wider
than it is tall

Positioning the legend
The legend is positioned relative to the currently defined pages of the chart, as specified in the Page
Setup window. You might need to adjust the page setup before positioning the legend to achieve the
wanted result.
In the Horizontal Chart Location area, select the appropriate option to specify the horizontal position of
the legend:
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Left

The legend box is placed on the left of all the
currently defined pages, as specified in the Page
Setup window.

Free

The legend box can be freely moved horizontally
(by dragging it)

Right

The legend box is placed on the right of all the
currently defined pages, as specified in the Page
Setup window.

Similarly, in the Vertical Chart Location area, select the appropriate option to specify the vertical position
of the legend box:
Top

The legend box is placed at the top of all the
currently defined pages, as specified in the Page
Setup window.

Free

The legend box might be freely moved vertically
(by dragging it)

Bottom

The legend box is placed at the bottom of all the
currently defined pages, as specified in the Page
Setup window.

Note: The default Horizontal Chart Location and Vertical Chart Location options are Free. You can
drag the legend anywhere on the chart.
Setting the legend font
In the Description Text area, click Font to select the font to be used for descriptions. This font is also
used as the default font for other textual entries such as titles and time zones. The Font workspace is
displayed for you to select the required font. The panel to below the Font button displays sample text in
the chosen font.
Note: If you specify a font for a particular legend entry, this font overrides the default font.

Compatibility warnings
Support for the following features depends on the version of Analyst's Notebook that you are using. In
versions earlier than Analyst's Notebook 8.5, icon frames, displaying pictures on entities, and setting
icon options are not supported.

Handling compatibility warnings
When you save a chart in this version of Analyst's Notebook, it is checked for any significant
compatibility issues with earlier versions. A warning is shown so that you can see more information
about the warnings.
To see more information about compatibility warnings:
1. In the Compatibility Warning window, select one of the following options:
Option

Description

Details

Displays a summary of the affected features.
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Option

Description

Full Report

Generates a comma-separated value (CSV) file
that contains further information.

2. Click OK to save the chart.
Tip: If you do not want to be warned about compatibility issues in the future, clear the Show this
Warning when Saving check box. To see warnings again when you save, select the compatibility
warning option in the Setting saving application options page.

Analyst's Notebook version 6 compatibility warnings
Some features added to Analyst's Notebook 7 are not supported in Analyst's Notebook 6.
The following features that were added to Analyst's Notebook 7 are not supported in charts that are
saved as Analyst's Notebook 6:
•

Unicode text that is typically used to support multiple character sets in the same chart are converted
to ANSI encoding.

•

Changing the shading color of the icon is not supported, and revert to their default display settings.

•

Database keys that link chart items to their source database items are deleted.

•

When printing, headers and footers are deleted from page setup details.

•

Cover sheet custom properties might be deleted.

•

Time zones that were introduced at version 7, are replaced by the local time zone.

•

The information that is stored in chart item SDK property bags is deleted.

•

OLE objects might be removed if there is no version later than Analyst's Notebook 6 installed.

•

Entity type properties that are created by users are deleted.

•

Unicode

Removing data records
For chart items that have database identities, you can choose to remove any associated data records.
For example, if you want to clean the chart of sensitive or unwanted information.
You can remove the data records for a selection of chart items or for all chart items with associated data
records. Removing data records removes all of the data on the Data Records pages, but leaves the
database key and database instance intact.
Note: If you redact a chart to remove data records, the database key and database instance is no
longer intact.
•

To remove data records for a selection of chart items, click the Publish tab, and then in the Redact
and Purge group, click Purge Data Records.

•

To remove all data records, click the Publish tab, and then in the Redact and Purge group, click
Purge All Data Records.
Note: You can undo the deletion of data records from your chart items by clicking the Undo button
in the Quick Access Toolbar.
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Present and publish charts
To present the data on your chart effectively, you can build a sequence of chart items to step through,
and you can zoom into multiple areas of the chart. If you publish the chart, you can save the chart in a
format that is appropriate for the recipients, and you can print the chart.
When you present a chart to an audience, you can use the Pan through Selection pane to build and
step through a sequence of chart items. Or, you can take snapshots to capture the appearance of
a chart at particular points in time, then sequentially present the snapshots to show how your chart
developed.
To focus attention on multiple areas of a large chart simultaneously, you can split the chart into two or
four panes, then zoom each pane to a different area. To create the largest possible area to display the
chart, you can enter full screen mode.
You can publish the .anb file that you are working on, if all the content is suitable for the audience.
If the chart contains sensitive data, you can save a redacted copy of the chart in which sensitive
information is removed. If recipients do not have Analyst's Notebook, you can publish your chart as a
PDF file or as an image.
To publish chart data in text format, you can export chart information to a report.

Presenting charts
There are several ways to change your view of a chart so that it is easy to present. If the whole chart
does not fit in the application window, you can move around your chart with a keyboard or a mouse.
Alternatively, you can zoom in or out to see more or fewer items.

Splitting your chart window into panes
You can split the display of the chart into two or four panes. Splitting into panes means that you can
work with smaller, more manageable areas of the chart.
You can display a different region of your chart in each of the panes, and zoom in and out or scroll in
each pane independently. Splitting your chart into panes can make it easier to link entities that are far
apart. You can display each of the remote entities in its own pane, then drag a link that crosses panes.
To split a chart window into panes:
1. Click the View tab, and then in the Window group, click Split.
Two-gray lines that cross at right angles are displayed on your screen, which you can move around
by using the pointer.
To split your window into just two panes, drag the pointer to one edge or the bottom of the screen.
2. Double-click the split intersection in the middle of the panes to remove the split.
When the pointer is over the intersection, it changes to four small arrows. The currently selected
pane fills the entire window.
3. To move the position of the split, click Split and drag the split to a new location.
Note: You can click the vertical or horizontal split line to move the split along just one axis (left-right
or up-down).
4. Click any of the panes to work with them.
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Moving between selected items on the chart
You can use the Pan through Selection pane to view a sequence of items without manually scrolling
from one to the next. You can present a sequence of events to focus on each event in turn, or to
compare each item to the next.
To define a list of items to browse:
1. Click the View tab, and then in the Show group, click More Panes > Pan through Selection.
2. Select the items that you want to browse. This selection might result from using one of the following
analysis tools:
•

List Items

•

Visual Search

•

Find Linked

Note: You can select the items manually. If you have a theme line with many event frames attached
to it, select all of the event frames that are attached to the theme line.
3. In the List Options list on the Pan through Selection pane (the second list), select one of the
following options:
Option

Description

Replace List with Selection

Removes any existing items in the browse list
before you add the current selection.

Add Selection to List

Adds the current selection to items already in the
browse list.

4. Click Apply Command, next to the List Options list. Items are added to the browse list in the order
in which they were selected, for example in the List Items window. The item that is added last is
selected in the browse list.
Tip: To directly add items to the browse list when you click them on the chart surface, set Lock/
Unlock List to off.
5. Optional: To sort the browse list, select an option from the Sort Options list, then click Apply
Command next to the Sort Options list.
The list is sorted.
6. To move between items in the browse list, click the following buttons:
Option

Description

Browse to Next Item

Moves to the next item in the list.

Browse to Previous Item

Moves to the previous item in the list.

The item is centered in the chart window. Its label is shown in the browse list. Entities are displayed
by using their label. Links are displayed by using the link summary.
7. To clear the browse list, select Clear List from the List Options list (the second list), then click
Apply Command next to the List Options list.

Using snapshots
A snapshot is a view of your chart at a particular stage in its development. It captures the position and
number of all visible chart items. The display settings, such as level of zoom and position of chart in the
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window are also captured. Snapshots freeze the appearance of your chart at a particular moment, for
subsequent viewing.
You can take any number of snapshots of your chart as you build it and then later view each snapshot in
turn. This snapshot shows how information is added to the chart over time. Snapshots are also a useful
way of focusing on certain areas of your chart, for example a particular group of entities, or a particular
period.
Note: Avoid scrolling and zooming your chart when you take a sequence of snapshots. Each snapshot
saves the zoom level and current view of the chart. Also, avoid changing existing entities and links in
later snapshots. A change might be changing the font style and size, as these changes are reflected in
earlier snapshots.
Snapshots are saved with your chart.
Snapshots are taken, viewed, and maintained by using the Snapshots window.
To open the Snapshots window, click the Publish tab, and then in the Snapshots group, click Take
Snapshots.

Publish a chart
Analyst's Notebook provides a range of publication formats for a chart, and provides ways to ensure that
chart recipients do not receive sensitive data.
When you are ready to publish your chart, you can take one of the following actions:
•

Publish the .anb file.

•

Save the chart in alternative formats such as an image or a PDF file.

•

Produce printouts of the chart.

•

Save a redacted copy of the chart in which sensitive information is removed.
Note: You can purge data records at any time, such as when you prepare a chart for publication.

Saving as a picture
You can save a chart as a picture so that you can use it, for example, in documents or reports and
publish them. You can save the entire chart, or a portion of a chart that displays chart items of interest.
To save a chart as a picture:
1. Click the Publish tab, and then in the Save as Picture group, click one of the following buttons:
•

To save the view that is displayed by the current window, click Current View.

•

To save the entire chart, click Entire Chart.

Note: When you save a chart as a picture, the following elements of the chart are also saved in the
picture:
•

Time bar

•

Theme line icon bars

2. In the Save as Picture window, navigate to the folder in which you want to save the file.
3. Enter a file name for the picture and select a picture file type, then click Save.
You can save your chart as one of the following types of picture file formats:
•

GIF (.gif)

•

JPEG (.jpg)
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•

PNG (.png)

•

TIFF (.tif)

•

BMP (.bmp)

Note: Saving a chart as a BMP can produce large files. If the file is large, a prompt opens
confirming that you want to save it as a BMP. If you select No you are returned to the format
selection.

Saving as a PowerPoint slide
You can save a snapshot of a chart as a PowerPoint slide so that you can use it in presentations. You
can save multiple snapshots to show the process of your investigation.
You must create a snapshot before you can save it as a PowerPoint slide.
1. To save a snapshot as a PowerPoint slide, in the Snapshots window, select a snapshot and click
Export to PowerPoint. The Save As window opens.
2. In the Save As window, navigate to the directory in which you want to save the file.
3. In the File name box, enter a name for the file to be saved.
4. Click Save. Analyst's Notebook saves the file, then displays the snapshot in a PowerPoint slide.
Note: If you do not want to view the snapshot in a PowerPoint slide, clear the Open the
Powerpoint file check box.

Printing to PDF
You can print a chart as a PDF document. To protect the document, you can set PDF security options.
1. Optional: Set security options for the PDF document.
2. To print the chart as PDF, click the Publish tab, and then in the Print group, click the arrow below
Print to PDF. In the menu, click Print to PDF.
The Save As window opens.
3. In the Save As window, navigate to the directory in which you want to save the file.
4. In the File name box, enter a name for the file to be saved.
5. Click Save. Analyst's Notebook saves the PDF file, then displays options for next steps.
Note: If you specified any passwords, you are asked to confirm those passwords in the Confirm
Passwords window.
6. Select the next steps, then click OK.
For example, you can open the PDF file.

Setting PDF security options
When you print a chart as a PDF document, you can protect the document. You can password protect it,
and control whether recipients of the PDF can print it, modify it, copy its contents, or add and edit notes.
1. Click the Publish tab, and then in the Print group, click the arrow below Print to PDF.
2. In the menu, click PDF Security Options. The PDF Security Options window opens.
3. Optional: In the Document Open Password field, type the password that the reader must enter to
open the PDF document.
Note: Do not rely on PDF password protection to secure sensitive documents.
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4. Optional: To control what the reader can do with the document, you must enter a permissions
password then select which actions are permitted. If you do not enter a permissions password, all
the actions in the Permissions group are permitted.
a) In the Permissions Password field, type the password that the reader must enter, and then
modify which actions are permitted to the reader.
b) In the Permissions group, select actions.
5. To save the settings, click OK.

Printing charts
Analyst's Notebook provides various options for printing an open chart, such as choosing the printer to
use, and selecting which chart information to include in page headers and footers.
To print an open chart:
•

Click the Publish tab, and then in the Print group, click Print > Print. You can pick a printer and
choose how many copies to print.
Alternatively, if you would like to change the content that is printed:
•

Click the Publish tab, and then in the Print group, click Page Setup.
The Page Setup options are displayed. Modify the page setup and click Print.
Option

Description

Page

Controls the size and layout options of the chart.

Margins

Add a margin to frame the items on the chart.

Borders

Add a visible border to the chart and determine
whether background colors are included in the
output.

Annotation

For timeline charts, you can specify where the
time bar and theme line names are displayed.

Header and Footer

Add chart summary and custom property
information to your chart. For example, page
numbers, and a title.

Saving a redacted copy of a chart
Redaction can be used to remove items, cards, and data records from a copy of your chart.
Sensitive information is removed from a redacted copy of a chart. As the redacted version of the chart
is saved separately, you can run the redaction multiple times to tailor the redaction level for different
audiences.
To specify a method to use:
1. Click the Publish tab, and then in the Redact and Purge group, click Save a Redacted Copy.
The Save a Redacted Copy Options window opens.
2. Click Add to show the Add a Redaction Method window.
3. Select the methods to be used to redact the chart:
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Option

Description

Data Records based on their data source

To remove data records from a specific data
source, specify the name of the data source to
which the data records are attached.

Items and Cards based on their Grading

To remove items and cards that are based on
their grading:
a. Select the items to remove. Items can be
chart items and cards, only chart items or
only cards.
b. From the "Based On" list, select a grade.
c. In the "For Values" area, select one or more
values.

Items based on a specified Flag Attribute

To remove items that are based on Flag attribute
classes:
a. From the "Remove items when" list, select
the attribute class.
b. Select the condition to use with items that
have the attribute class assigned.
For example, a condition might be that the
attribute is present or absent, or has a value of
Yes, or No.

Items based on a specified Text Attribute

To remove items that are based on Text attribute
classes:
a. From the "Remove items when" list, select an
attribute class.
b. Select a condition from the list. For example,
a condition can be: equal to, contains, starts
with, or ends with.
c. Enter the value for the attribute.

4. Click OK to close the Add a Redaction Method window.
5. Optional: To remove entities that no longer have links, select the Remove entities which have all
their links removed check box.
6. Click OK. In the Save as window, navigate to the directory in which you want to save the file. Enter
a name for the redacted chart and click Save. The chart is saved as a redacted copy, and a Cover
Sheet window is shown.
7. Click OK to close the Cover Sheet window.
8. A summary of the redacted chart is shown. Select the next steps, then click OK. For example, you
can open the redacted chart.
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Report about charts
You can export chart information about entities, links, attributes, and cards to a report. Report
specifications are useful if you want to create a report that contains the information in all or part of your
chart. The generated report is created as a text file that can be then pasted into another application.
You define the items that you want to include in your report by using a report specification. A report
specification is a series of settings that tells Analyst's Notebook what report to create and what you want
to include in it. Use report specifications to define the items, content, and destination of your report. The
report specifications are stored in a file called Reporter.rep.

Opening the Reporter
You can open the Reporter to create, edit, delete, duplicate, and run report specifications.
To open the Reporter:
1. Click the Publish tab, and then click Reports.
2. In the Report On window, select one of the following options.
Option

Description

New

Create a report specification.

Duplicate

Duplicate the selected report specification.

Edit

Edit the selected report specification. For
example, you might want to change the
title, destination, content, and format of the
specification.

Delete

Delete the selected report specification.

Load

Load a report specification.

Run

The selected report specification runs. You
might be prompted for a file name and location.
A report is generted by using the criteria that you
selected.

Creating report specifications
When you create a report specification, you can run it to report on data in your chart. You can choose
whether to create a report that is based on the entire chart or one based on only selected chart items.
To create a report specification:
1. Click New.
2. The Edit Report Specification window is shown. Specify the destination, content, and format of the
specification in the pages of the window.
3. In the Report on area, select one of the options for the generated report.
4. Click OK.
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Duplicating a report specification
You can duplicate a report specification. For example, to edit a copy of an existing report specification.
To duplicate a report specification:
1. Select a report specification to duplicate, and click Duplicate. An exact copy of the currently selected
report specification is created. You might edit the duplicated report specification to change the title.
2. Optional: The duplicate report specification is added to the list of specifications. You can change the
order of report specifications, select one, and drag it up or down in the list.
3. Click Edit. The Edit Report Specification window for the duplicated specification is shown where
you edit the required properties.

Editing report specifications
When you edit a report specification, you might change the destination, content, and format of it. You
can edit the location of the generated output. You can specify the content of the output file, such as the
chart items to include. You can also specify the format of the report.
To edit a report specification:
1. Click Edit.
2. Edit the name, destination, content, and format of the generated report.

Default report specifications
Default report specifications are available. You can duplicate, edit, delete, and load these report
specifications.
The following table describes the available default report specifications:
Option

Descriptions

Full Report

Contains a list of entities and links, with the
following information for each:
•

Identity

•

Label

•

Ends (for links only)

•

Type

•

Strength

•

Date and time

•

Description

•

Grades

•

Source type

•

Source reference

•

Attributes

•

Cards

Note: Empty fields remain blank.
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Option

Descriptions

List of Entities and Links

Contains a list of entities and links, with the Type,
Label, and Ends (for links only) information for
each.

List of Entities and Links (Tabbed)

Contains a list of entities and links, with the Type,
Label, and Ends (for links only) information for
each. Tabs are included between each field of
information to make the report suitable to be
pasted into a spreadsheet

Entity, Link and Card Grades (Tabbed)

Contains a list of entities, links, and cards with
their Grade information. Tabs are included
between each field of information to make the
report suitable to be pasted into a spreadsheet.

Entity, Link and Card Descriptions

Contains a list of entities, links, and cards with
their Label, Ends (for links only), and Description
information. Cards are listed directly under the
entity or link to which they belong.

All Cards

Contains a list of cards, with the following
information for each:
•

Chart item (the chart item to which the card
belongs)

•

Summary

•

Time

•

Grade

•

Source type

•

Source reference

•

Contents

Loading report specifications
You can load report specifications, by selecting a report specification in the Report On window.
In the Edit Report Specification window:
1. Select Load.
2. Browse to the location of the report specification file.
Report specifications are stored in a file named Reporter.rep. This file is typically found in: C:
\Users\USERNAME\Documents\i2\i2 Analyst's Notebook 8\Report Specifications
\Reporter.rep.
3. Select the required report specification and click OK.
Note: You can select more than one report specification by using the Ctrl or Shift keys. The Select
Specifications window closes and you are returned to the Report On window where the loaded
report specifications are listed. If a report specification exists with the same name as the one being
loaded, it is not overwritten and both specifications are displayed in the list. For clarity, you might
want to rename specifications to provide unique names.
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Specify the content of a report specification
The item information that you specify in your report might include all item information or just the
information that is held in cards.

Selecting chart items to include in your report
You can specify the chart items to include in your report. This information might include all the item
information or just the information that is held in cards.
In the Chart Items area of the Content page of the Edit Report Specification window, select one of the
following check boxes:
•

Icons

•

Theme Lines

•

Event Frames

•

Boxes

•

Circles

•

Text Blocks

•

OLE Objects

•

Labels

•

Links

Tip: To select all chart items in the list click Select All. To clear the selected chart items, click Clear
All.

Selecting card information to include in your report
You can select card information for grades and keywords that can be included in your report.
In the Card Detail area, select one of the following check boxes:
Option

Description

Minimum Grade

A specific minimum grade for any (or all) of the
grades.
Select the Minimum Grade check box and select
the values that are required for the three grade
types from the appropriate lists.
The values that are available for the grades are
defined in the grading system that is used for your
chart.

Maximum Grade

A specific maximum grade for any (or all) of the
grades.
Select the Maximum Grade check box and select
the values that are required for the three grade
types from the appropriate lists.
The values available for the grades are defined in
the grading system that is used for your chart.
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Option

Description

Keywords

Contain specific keywords. Select the Keywords
check box and enter the required keywords in the
box. Separate multiple keywords by commas or
spaces. The keywords might be contained in the
card summary, source type, source reference, or
description.

Sorting card information in your report
You can sort the content of cards in your report by specifying the grade to sort on.
To sort card information by grade:
1. In the Sorted by list select one of the following options:
Option

Description

Unsorted

Cards are displayed in the order that they are
included in the chart item.

Grade 1

Cards are sorted alphabetically by the value of
Grade 1.

Grade 2

Cards are sorted alphabetically by the value of
Grade 2.

Grade 3

Cards are sorted alphabetically by the value of
Grade 3.

2. Click OK to save your changes and close the window.

Selecting chart item information to include in your report
You can specify the item information to include in your report. This information might include all the item
information or just the information that is held in cards.
In the Output area of the Content page of the Edit Report Specification window, select one of the
following options:
Option

Description

Everything

All the item information (such as identity and label)
and the card information that is associated with
each item.

Card Detail Only

Only the card information.

Defining the format of the generated report
You can enter the title of the report so that it describes what the report might be used for. The name of
the chart can be included in the title.
Enter the title of the report in the Title box.
Tip: To include the file name of the chart in the report title enter @chart in this box.
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For example, for a chart that is named 'Account Transactions', the title format: Report on @chart
generates a report with the title 'Report on Account Transactions'.

Chart item parameters
Information that is stored in chart items can be used when you create a report specification. For
example, you might use this information to add a label or description property that can be displayed in
the generated report.
The following entity parameters are available on the Format page of the Edit Report Specification
window:
@itemDate

The date property of the chart item.

@itemDateTimeDescription

The date & time description of the chart item.

@itemDescription

The description of the chart item.

@itemGrade1

The Grade 1 information of the chart item.

@itemGrade2

The Grade 2 information of the chart item.

@itemGrade3

The Grade 3 information of the chart item.

@itemGrades

All Grades (Grade 1, Grade 2, and Grade 3) of the
chart item.

@itemIdentity

The identity of the chart item.

@itemLabel

The label of the chart item.

@itemLabel1

The label of the entity at the first end of the link.

@itemLabel2

The label of the entity at the second end of the
link.

@itemProfile

The identity of the entities at each end of the link
and an arrow that shows the direction of the link
between them.

@itemSemanticType

The semantic type that is assigned to the chart
item.

@itemSourceRef

The reference of the source of the information that
is represented by the chart item.

@itemSourceType

The type of the source of the information that is
represented by the chart item.

@itemStrength

The line strength of the entity . For example,
confirmed, unconfirmed, tentative.

@itemTime

The time of the chart item.

@itemTimeZoneLong

The long name of the time zone of the chart item.

@itemTimeZoneShort

The short name of the time zone of the chart item.

@itemType

The type of the chart item. For example, Male,
Female, Child, Transaction, and Telephone Call.

@tab

A tab character.
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Attribute parameters
Information that is stored in attributes can be used when you create a report specification.
Attribute parameters are used to report on the attributes that are associated with the entities and links
in your chart, and as such they are entered in the Entities and Links boxes of the Format page. You
enter attribute parameters in the Entities box when you want to report on attributes for entities, and
similarly, you enter attribute parameters in the Links box when you want to report on the attributes for
links.
The @attributes parameter is always used to report on your attributes and can be entered in one of
three forms:
Option

Description

@attributes

Use this form of the parameter to report on all
your attributes by using a default format of Name
Prefix Value Suffix.

@attributes {nameParam}

Use this form of the parameter to report on a
specific attribute but by using the default format
Name Prefix Value Suffix. You must replace
the nameParam placeholder with the name of
the attribute you want to report on, for example
@attributes {Previous Convictions}.

@attributes {nameParam |formatParam

Use this form of the parameter to report on
either a specific attribute or all attributes but
with a specific format. You must replace the
nameParam placeholder with either the name
of a specific attribute, or the wildcard character
* to report on all attributes. You must also
replace the formatParam placeholder with any
of the dedicated attribute format parameters.
These parameters can be entered in any
order (with no space) and with your own text
additions, for example @attributes{Previous
Convictions|No.@Value@Suffix} where
No. is your entered text.
If you want to use format parameters, they must
always be entered in the syntax:
@attributes{nameParam|formatParam}
@attributes{formatParam} is invalid

Card parameters
Information that is stored in cards can be used when you create a report specification.
The following card parameters are available on the Format page of the Edit Import Specification
window:
@cardDate

The date of the card.

@cardDateTimeDescription

The date & time description of the card.
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@cardDescription

The description of the card.

@cardGrade1

The Grade 1 information of the card.

@cardGrade2

The Grade 2 information of the card.

@cardGrade3

The Grade 3 information of the card.

@cardGrades

All Grades (Grade 1, Grade 2, and Grade 3) of the
card.

@cardSourceRef

The reference of the source of the information that
is represented by the item to which the card is
attached.

@cardSourceType

The type of the source of the information that is
represented by the card.

@cardSummary

The summary of the card.

@cardTime

The time of the card.

@cardTimeZoneLong

The long name of the time zone of the card.

@cardTimeZoneShort

The short name of the time zone of the card.

@itemLabel

The label of the item to which the card is attached.

@itemProfile

The profile of the link to which the card is
attached.

@tab

A tab character.

Inserting page breaks
You can insert page breaks and commas, spaces, carriage returns, or other punctuation characters
between parameters.
Depending on how page breaks are displayed in the report, select the following check boxes:
Option

Description

Page Break After Each Item

Insert a page break after each entity or link that is
included in the report.

Page Break After Each Card

Insert a page break after each card that is
included in the report.

Note: You can also separate information in the report by inserting the tab character (by using the @tab
parameter), or by the use of commas, spaces, carriage returns, or other punctuation between parameter
names in the Entities, Links, or Cards boxes.
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Accessibility
Accessibility features help users who have a disability, such as restricted mobility or limited vision, to
use information technology products successfully.
Users can change some elements in the user interface by customizing Analyst's Notebook and aspects
of chart items. For example, color blind users and users with limited vision might want to change the
following elements:
•

Color of invalid data

•

Color aspects of item type definitions

•

Font of the text on the chart

Accessibility features
Analyst's Notebook uses standard Microsoft Windows navigation keys. There are multiple ways to move
around the user interface by using the keyboard.
Use the Tab and arrow keys to move through the interface and change focus.
You can also press Alt to activate keyboard shortcuts. When you press Alt, the application displays
keytips to indicate what keyboards shortcuts are currently available. Press Alt and then the
corresponding keyboard shortcut to complete an action.
The following table describes some common default keyboard shortcuts.
Action

Keyboard shortcut

OK

Press Enter

Cancel

Press Esc

Delete

Press Del

Move between items Press the Up Arrow or Down Arrow
in a list, scroll down
a menu, or select
radio buttons
Display the right-click Press Shift+F10
menu
Select checkbox

Press the Space bar

A list of more default keyboard shortcuts is given in the help. You can choose to customize these
shortcuts to your own preference.

Keyboard shortcuts
Analyst's Notebook provides a set of default keyboard shortcuts for performing common tasks. You can
use the shortcuts to reduce the time you spend navigating the ribbon.
The shortcuts in Analyst's Notebook are:
Key

Command

F1

Opens Help contents window
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Key

Command

F2

Rename the selected chart item

F3

Find next text

F4, Ctrl+F

Find text

Ctrl+F4

Close the current chart

Alt+F4

Exit Analyst's Notebook

F5

Visual Search

F6

Go to the next pane of a split window

Shift+F6

Go to the previous pane of a split window

Ctrl+Shift+F6

Go to the previous window of the current chart

F7

Check spelling

F8

Full Screen mode

F10

Display ribbon keytips

F11

List items

Ctrl+N

New standard chart

Ctrl+Shift+N

New from template

Ctrl+O

Open chart

Ctrl+P

Print chart

Ctrl+S

Save chart

Ctrl+T

Next snapshot

Ctrl+Shift+T

Previous snapshot

Alt+Enter

View properties of selected chart items

Page Up

Zoom in

Page Down

Zoom out

Right arrow

Pan right

Left arrow

Pan left

Up arrow

Pan up

Down arrow

Pan down

Shift+right arrow

Page right

Shift+left arrow

Page left

Shift+up arrow

Page up

Shift+down arrow

Page down

End

Fit chart in window

Shift+End

Fit height in window
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Key

Command

Ctrl+End

Fit selection in window

Home

View at actual size

Ctrl+Tab, Ctrl+F6

Go to the next window

Ctrl+Shift+Tab

Go to the previous window

Ctrl+A

Select all

Ctrl+C

Copy

Ctrl+Shift+C

Copy with connections

Ctrl+D

Duplicate

Ctrl+V

Paste

0-9

Select members of set (0 - 9)

Ctrl+0-9

Define selection set (0 - 9) as the currently
selected items

Ctrl+Alt+0-9

Add current selection to set (0 - 9)

Shift+0-9

Add members of set (0-9) to the selection

Assigning a shortcut to a command
In addition to the default keyboard shortcuts that are available, you can assign shortcuts manually.
Assigning a shortcut can change any default shortcut that uses that key combination.
To assign a keyboard shortcut to a command:
1. Click File > Options, and then in the Options window click Customize > Keyboard.
2. In the list of tabs, expand a tab name to view a list of all the commands in that tab.
3. Select a command in the list. A description of the command is displayed beneath the list. Any
existing keyboard shortcuts are shown in the Shortcuts area.
4. Type the key in the Press New Shortcut Key box. As you press Ctrl or Shift, this part of the
keystroke is automatically added.
You cannot assign:
•

The Alt key as part of the shortcut (except when it is combined with Ctrl). Alt is reserved for
access keys.

•

The numbers 0 - 9, or Shift+, Ctrl+, Alt+ combinations with these numbers, as shortcuts. These
numbers are reserved for Selection Sets commands.

5. Click Add.
Note: If you type a key or key combination that is already used by another command, the command
to which this key is already assigned is displayed. You can continue to add this keystroke, but
ensure that you remove it from the original command.
6. Click OK.
The shortcut can now be used. If you no longer require a particular shortcut, you can use Remove.
Alternatively use Reset All to revert to the default shortcuts.
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Customize Analyst's Notebook
You can customize Analyst's Notebook. You can set application options, and manage files and plug-ins.
You can also set up keyboard shortcuts and use utilities such as Series Import to import more than one
data file.

Infotips
When you hover over a chart item, an Infotip provides a summary of item data. You can configure
Infotips to display the information that is of greatest interest to you.
You can choose which properties Infotips display, and you can configure the order of some of the
information. For example, if you work with bank account data you might configure Infotips in the
following way:
•

Display the Account Type attribute at the top of the attribute list.

•

Sort the Linked To list of accounts by the value of their transactions with the account that you
hovered over.

If the item properties that you choose to display in Infotips contain hyperlinks, a small button appears in
the Infotip. You can click this button to open a single hyperlink. If multiple hyperlinks are contained in the
item properties, clicking the button opens a list for you to choose which hyperlink to open.
If you do not want to use Infotips, you can disable them and display tooltips instead. Tooltips contain
the item label. For links, tooltips also contain the labels of the linked entities and an indication of the link
direction.

Data records in Infotips
You can choose to display data records in Infotips.
If multiple data records are attached to the item, click the left and right arrows to step through them.
For some source databases, you can
•

Click the source icon to open the source record.

•

Click the source label to open the data record in chart item properties.

Configuring Infotips
You can configure Infotips to display the information that is of greatest interest to you. You can choose
which properties Infotips display, and you can configure the order of some of the information.
The configuration applies to every Infotip that Analyst's Notebook displays.
To configure Infotips:
1. Hover over an item on your chart to display an Infotip.
2. Click Configure in the lower right of the Infotip.
3. Select which properties to display in Infotips:
Option

Description

Attributes

Displays attributes that have a value. To choose
which attributes to display and to configure their
order, click Select.
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Option

Description

Analysis Attributes

Displays analysis attributes that have a value.
To choose which analysis attributes to display
and to configure their order, click Select.

Date & Time

Displays the item's date and time.

Line Strength

Displays the item's line strength.

Description

Displays the item's description.

Grades and Source

Displays the grade and source information about
the item. Grade and source information from
cards is not displayed.

Linked Items

Displays a reference for each link to an entity.
Clicking a reference pans to the linked item and
centers it in the window.
Use the Sort By list to choose how the linked
items are sorted, and the Order list to choose
ascending or descending order.

Cards

Displays a summary and link for each card that
is attached to the item. Clicking the link displays
the card.

Data Record Source Names

Displays a list of the sources of the data records
that are attached to the item.

Data Record Properties

Displays the properties of each data record that
is attached to the item.

4. Click OK to save your changes.

Selecting Infotip attributes
You can choose which attributes and analysis attributes that Infotips display. To give prominence to the
most important information, you can configure the order of attributes in the Infotip.
To choose and order attributes:
1. Follow the appropriate step according to whether you want to configure attributes or analysis
attributes:
•

To configure attributes, in the Configure Infotips window, click Select below the Attributes
check box.

•

To configure analysis attributes, in the Configure Infotips window, click Select below the
Analysis Attributes check box.

A configuration window opens.
2. Click the arrows to move the selected attributes into the appropriate columns:
Option

Description

Show these attributes first

If a value for an attribute in this list is present on
an item, the attribute displays on the Infotip. To
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Option

Description
change the order of this list use Move Up and
Move Down.

Show these attributes next

Attributes in this list will display after attributes
moved into the Show these attributes first
list, but only if the check box in the heading is
selected.

Don't show these attributes

Attributes in this list are not displayed as part of
an Infotip.

3. Click OK to save your selection.

Disabling Infotips
The Infotips displayed on the chart can be replaced with tooltips.
To disable Infotips and revert to tooltips, click the View tab, and then in the Show group, clear the
Infotips check box.

Custom icons
You can use your own images to supplement the icons that are provided with Analyst's Notebook. You
can assign custom icons to entity types and attribute classes.
Images must meet the following specification:
•

Bitmap (.bmp) format

•

8-bit color depth

•

Size as specified in Table 1

Pixels that are colored magenta (RGB 255,0,255) are rendered transparent.
To make your custom icons available for use, copy the images to the appropriate folders specified in
Table 1, then restart Analyst's Notebook.
Table 11: Custom icon image sizes and folders.
Type of icon

Use

Size (pixels)

Folder

Entity type

Screen

32x32

C:\Users\<username>\Documents\i2\i2
Shared\Custom Images\Screen\Icons

Print

120x120

C:\Users\<username>\Documents\i2\i2
Shared\Custom Images\Printer\Icons

Screen

12x8

C:\Users\<username>\Documents\i2\i2
Shared\Custom Images\Screen\Attribs

Print

45x30

C:\Users\<username>\Documents\i2\i2
Shared\Custom Images\Printer\Attribs

Attribute class
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Screen and print icons
Screen icons are displayed in the Analyst's Notebook window. Print icons are higher definition versions
of screen icons and are used in printouts.
Creating custom print icons is optional; if a screen icon does not have a corresponding print icon, the
screen icon is used in printouts. A print icon must have the same file name as the corresponding screen
icon.
Related tasks
Embedding and extracting custom icons on page 267
You can embed your custom icons into the charts that use them, so that recipients of the charts can see
the icons on the charting surface. You can extract the custom icons that are embedded in charts that
you open, so that the icons become available for you to use.

Custom semantic types
You can derive custom semantic types based on the ones in the i2 Semantic Type Library, then use
them in other charts and share them with colleagues. Deriving a custom semantic type is appropriate
when you need a more accurate classification of your data than the standard type library provides.
When you derive custom semantic types and assign them to items on your chart, they are saved as
part of your chart. You cannot delete the standard types from the i2 Semantic Type Library, but you can
delete any custom semantic types that are not in use on the chart. After you remove all assignments
of a custom semantic type, to access the Delete command you must first close and reopen the Chart
Properties window.
Note: When you delete a custom semantic type, all descendants of the custom semantic type are also
deleted.
Related reference
Item type definitions on page 23
Entity types and link types categorize the information on your chart and are part of a chart's properties.
If the existing item types are not suitable for your data, you can add or edit entity types and link types.
Attribute definitions on page 24
Attribute classes categorize the information that is stored as attributes on chart items and are part of
a chart's properties. If the existing attribute classes are not suitable for your data, you can add or edit
attribute classes. Attribute entries are preset values for attributes of a specific attribute class. For values
that you reuse regularly, define attribute entries and add them to the appropriate palettes.

Deriving custom semantic types
You can derive custom semantic types from semantic types that are stored in the standard library to
provide more accurate classification of the data that you assign them to.
Search carefully for an available semantic type before you derive your own custom one. Defining
a custom semantic type when the library already contains an appropriate semantic type can cause
problems with information retrieval and matching.
Typically, you might derive a custom semantic type when you define an entity type, link type, or attribute
class. You can also derive custom semantic types wherever you can assign a semantic type. For
example, you can assign a semantic type to a single entity on the chart surface.
When you derive a custom semantic type, it is important to choose the correct parent semantic type,
so that Analyst's Notebook interprets the data correctly. Some semantic types are used by Analyst's
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Notebook for entity matching. The Find Matching Entities feature uses semantic types that are assigned
to entities, links, and attributes as part of its smart matching behavior.
To derive a custom semantic type:
1. In any window where you can select a semantic type, such as when you are defining an item type or
attribute class, click the Semantic Type browse button. The Select Semantic Type window opens.
The Semantic Types pane shows the entity, link, or property semantic type hierarchy.
2. Expand the hierarchy to find the semantic type from which you want to derive your custom semantic
type. Right-click the semantic type, then click New.
Note: You cannot derive a custom semantic type from the Abstract Binary property semantic type.
This special category of semantic type is reserved for internal use.
3. Enter a name for the custom semantic type in the Name box.
The name must be unique within the semantic type hierarchy.
4. To improve your ability to search for this semantic type, add synonyms in the Synonyms box.
For example, synonyms for the semantic type Mail in the i2 Semantic Type Library are Letter, Parcel,
and Post.
Use commas to separate the synonyms.
5. Describe what this semantic type is used for in the Description box.
You can also include hyperlinks to further information.
6. Click OK to save the custom semantic type and assign it to the entity type, link type, or attribute
class.
Custom semantic types are saved with your chart. Any custom semantic types that are not assigned
to chart items, chart item types, and attribute classes are lost when you save and close your chart. To
reuse custom semantic types in a new chart:
•

Create a template based on your current chart and base your new chart on this template.

•

Save your current set of custom semantic types in a new library file (.mtc file) which other Analyst's
Notebook users can load and use.

Share custom semantic types
You can share custom semantic types between Analyst's Notebook charts by saving them in a custom
library file (.mtc file). Loading the file into another chart makes the custom semantic types available.
When you create a custom semantic type, it is saved with the current chart, but not in the i2 Semantic
Type Library. Therefore, when you create a new chart, your custom semantic type is not available for
you to use. You can, however, save the custom semantic types that you create in a custom library file
with the file extension .mtc. The custom library file contains only the custom semantic types and the
hierarchy of semantic types to which the custom types belong.
You can load a custom library file into a blank chart, which you can then save as a template. The
custom semantic types are available for use in any new charts that you create from the template. You
can also share your custom semantic types with your colleagues by sending them your custom library
file, which they can then load into an Analyst's Notebook chart. When the file is loaded, any custom
semantic types that the file contains are available for them to use.
To save a custom library file, click File, point to Chart Properties, and then click Save Custom
Semantic Types to File.
To load a custom library file, click File, point to Chart Properties, and then click Load Custom
Semantic Types from File.
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You might want to load your custom semantic type file into your standard template. Your custom
semantic types are then available whenever you create a chart based on your standard template.
Note: You cannot edit the i2 Semantic Type Library. It is maintained by i2.

Using Drag Chart
By default, you can use the scroll bars (or overview pane) to see different areas of a chart, and use
dragging to select items on the chart surface. To navigate more quickly around a large chart, you can
put the application in drag mode.
When the application is in drag mode, the cursor changes from an arrow to a hand symbol. You can
pan to bring different parts of the chart into view by dragging on its surface. Drag mode is enabled in the
following ways:
From the right mouse button

Click and hold the right mouse button.

From the bottom menu bar

Click the Drag Chart option from the bottom menu
bar.

From the Ribbon menu

Select the View tab and highlight the Drag Chart
option with the cursor. Left-click to activate.

From the chart surface

Right-click on the chart surface and select Drag
Chart from the menu.

From the space bar

Press the space bar to toggle Drag Chart on and
off.

From the mouse wheel

Press the mouse wheel to toggle Drag Chart on
and off.

Selecting the user interface language
You can manually select which language Analyst's Notebook displays the user interface in. By default,
Analyst's Notebook automatically selects a language, but you can override that selection.
By default, the Analyst's Notebook user interface language corresponds to the current Format setting,
in your workstation's Region and Language settings. The Format setting determines the format
of date, time, and numerical data. For example, if the current setting is French (Canada), then the
Analyst's Notebook user interface is displayed in French. Translated templates, user help, and example
materials are installed.
If you change the Format setting, the Analyst's Notebook user interface language changes when
you next start the application. Alternatively, you can use the Analyst's Notebook language selector to
manually select a language.
To manually select the user interface language:
1. If Analyst's Notebook is running, close the application.
2. From the Start menu, run the Analyst's Notebook language selector.
3. In the Language Selector window, select a language, then click Select.
The window closes.
4. Run Analyst's Notebook.
The Analyst's Notebook user interface is displayed in the selected language.
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Setting general application options
Use the General page of the Options window to specify general application options. Application
options might be enabling and changing the color of hyperlinks, and error text color, and displaying the
theme line icon bar.
Click File > Options, and then in the Options window click Options > General.
Note: These options are global application settings and are not saved as part of a chart or template.
They persist until changed, regardless of what chart you are working on.

Cut, copy, and paste chart items
When you cut or copy charts or parts of charts onto the clipboard, you can choose to make them
available to another application in various forms.
Select one of the following options:
Option

Description

Chart as OLE Object

Copies a picture of the chart to the clipboard. You
can then paste it into another application and still
open and edit it in Analyst's Notebook

Picture as Metafile

Copies a picture of the chart to the clipboard as
a Windows metafile (.wmf). When you paste
the copied chart into another application, it is no
longer 'live'. It shows a picture of the chart when it
was copied, but cannot be edited or opened as a
chart.
Metafiles contain both vector and bitmap
information. Vector information is a series of
instructions that tell the computer how to re-create
the graphic. Bitmap information stores the graphic
as a series of pixels.

Picture as Bitmap

Copies a picture of the chart to the clipboard as a
bitmap (.bmp). It no longer behaves as a chart but
displays a picture of the chart when it was copied.
Most applications can handle bitmaps without
problem, but might not handle metafiles.

Enabling hyperlink creation
You can enable the creation of a hyperlink and change the color that is used to display it.
To enable the creation of a hyperlink:
1. Select the Enable checkbox to enable the automatic hyperlink creation feature.
2. From the Color list that is displayed beneath the Enable checkbox in the Hyperlinks area, select the
color to use to display a hyperlink.
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Enabling the theme line icon bar
You can choose whether to display the icon for a theme line as you move across a chart. As standard
the theme line icon bar is displayed. It remains displayed as you pan across a chart so that theme lines
can be quickly and easily identified.
Clear the Enable check box in the theme line icon bar area.
You can specify the color of the theme line icon bar. Select the color to use from the color picker.

Enabling advanced analysis
Enable advanced analysis to use analysis attributes.
Select the Advanced Analysis checkbox to make analysis attributes available in:
•

Visual Search

•

List Items

•

Find Path

•

Combine Attributes

Changing zoom effect behavior
By default, Analyst's Notebook animates the zoom effect when you zoom in and out of areas on the
chart surface. You can change the option to remove the animated effect.
1. Click File > Options to open the Options window.
2. Click General and look for the check box next to Animated Zoom Effect.
3. If the box is checked, you must clear it to turn off animated zooming.
4. Click OK.
The animated effect is removed from the zoom option on all charts. This setting persists until changed,
regardless of the chart you are working on.

Enable drag hand throws chart
You can select a chart and use the drag hand to drag and throw the chart.
Select the Drag Hand Throws Chart checkbox.

Enabling high-quality drawing mode
You can enable high-quality drawing mode. High-quality drawing mode might be used when you print a
chart to PDF or use it in a presentation. It can also be used if you share the chart with other users.
Select the High Quality Drawing Mode checkbox so that the drawing uses a high quality.

Changing the behavior of drag selection
By default, you can select items in Analyst's Notebook by touching them with the rectangle that opens
when you drag on the chart surface. You can change this behavior so that items are selected only when
the rectangle fully encloses them.
1. Click File > Optionsto open the Options window.
2. Click General and look for the check box next to Drag Selects Only Fully Enclosed Items.
3. If the check box is clear, you must select it to change the behavior of drag selection.
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4. Click OK.
The behavior of drag selection changes for all charts. This setting persists until changed, regardless of
the chart you are working on.

Combining records on paste
By default, i2 Analyze records combine with matching records when you use copy and paste. You can
choose to deselect this option.
This option combines i2 Analyze records from the same Information Store. If you chart records from one
store and then connect to a different i2 Analyze server, records are not combined. For more information
about using this option, refer to Copy and paste on page 113.
1. Click File > Options to open the Options window.
2. Click General and look for the check box next to Combine Matching i2 Analyze Records On
Paste.
3. If you want to deselect the option to combine records, click the check box.
4. Click OK.

Setting user interface options
Use the User Interface page of the Options window to change the color in which invalid values are
displayed and to control the display of ribbon tooltips.
Click File > Options, and then in the Options window click Options > User Interface.
Note: These options are global application settings and are not saved as part of a chart or template.
They persist until changed, regardless of the chart on which you are working.

Changing the color of invalid data
When you enter invalid data into a field, the data is displayed in a specific color. You can choose which
color is used.
Invalid data might be an identity that is already in use on the chart. Other invalid data might be a textual
character in a numerical field, or a numerical value that is too large or too small. To move the cursor to a
different field, or save the data or setting, you must correct the invalidity.
To change the color that invalid data is displayed in, select a color from the Error Text Color list.

Changing auto hide animation
By default, when you auto hide panes in Analyst's Notebook they open and close quickly as you place
the cursor over them. When you turn animated auto hide on, the panes slide open and closed more
slowly.
1. Click File > Options, and then in the Options window click User Interface.
2. Look for the checkbox next to Animate Auto Hide. You must select the checkbox to activate
animated auto hide or clear it to remove the animated effect.
3. Click OK.
The change takes effect immediately and persists until you change it again, regardless of the chart you
are working on.

©

N. Harris Computer Corporation (2022)

i2 Analyst's Notebook user help | 266

Ribbon tooltip display options
When you hover over a button or command in the Analyst's Notebook ribbon, tooltips that provide help
on the feature are displayed by default. You can choose to show the full tooltip, just their name, or turn
them off.
Note: When you choose an option, to apply the change you must restart Analyst's Notebook.
Select one of the following options:
Option

Description

Show names and descriptions

Displays the entire tooltip, including the name,
enhanced information, and any contextual links to
the help.

Show names

Displays only the name that describes the feature.
Enhanced information and contextual links to the
help are not shown.

Do not show

No tooltips or links to the help are displayed.

Setting icons application options
Use the Icons page of the Options window to select the icon that is set to use for every new and
existing chart that is opened in Analyst's Notebook.
Select one of the following application-level options:
Option

Description

New Icons

New and existing charts use the latest, highquality icons.

Legacy Icons

New and existing charts use the icon set available
in releases before Analyst's Notebook v8.5

As Saved in Chart

By default, existing charts use the icon set that is
selected in the chart last time it was saved. New
charts use the latest, high-quality icons.

Note: You might want to override the application-level setting for the chart you are currently working
on. To do this step, select As Saved in Chart and then change the icon set that is selected in the Icons
page of the Options window.
You can open charts that contain new icons in earlier versions of Analyst's Notebook. The new icons
cannot be displayed and are represented by legacy icons, but the new icons are not overwritten if you
save the chart in versions later than Analyst's Notebook 6.
Note: If you save a chart that contains new icons in Analyst's Notebook 6, they are replaced and saved
as legacy icons.
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Embedding and extracting custom icons
You can embed your custom icons into the charts that use them, so that recipients of the charts can see
the icons on the charting surface. You can extract the custom icons that are embedded in charts that
you open, so that the icons become available for you to use.
•

To save custom icons so that they are embedded within the charts that use them, select the Save
Custom Icons in Charts checkbox. If you clear this checkbox, other users see default icons instead
of the custom icons. By default, this option is selected.

•

To extract custom icons from charts that you open, select the Extract Custom Icons from Charts
checkbox. By default, this option is selected.

Related concepts
Custom icons on page 259
You can use your own images to supplement the icons that are provided with Analyst's Notebook. You
can assign custom icons to entity types and attribute classes.

Displaying, hiding, and resetting panes
You can display or hide any Analyst's Notebook pane from the Options window. If you repositioned or
resized any panes during your analysis, you can set a single pane or all of them back to their default
visibility, position, and size.
Click File > Options, and then in the Options window click Customize > Panes. Change the visibility
or reset the visibility, position, and size of panes:
•

To display or hide a pane, select or clear the check box next to the relevant pane. When you display
a pane, it appears at the size and position it was last displayed.

•

To set the visibility, size and position of a single pane back to its default setting, select the pane and
click Reset.

•

To set the visibility, size and position of every pane back to their default settings, click Reset All.
Attention: You cannot undo the outcome of the Reset functions. Before you click Reset All,
make sure that you want to reset every pane.

Setting saving application options
Use the Save page of the Options window to specify options when you save a chart. Saving options
might be enabling and displaying the Cover Sheet, and setting the interval that is used for automatically
saving a chart.
Click File > Options, and then in the Options window click Options > Save.
Note: These options are global application settings and are not saved as part of a chart or template.
They persist until changed, regardless of what chart you are working on

Display the cover sheet when you save a chart
The cover sheet describes the content and purpose of the chart so that other users can read this
information before a chart is opened. A version is displayed when you save your chart, and can be used
to change the description.
There are one of three options you can set to determine how often the editable version of the cover
sheet is shown:
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Option

Description

Do not Display When Saving

Prevents the cover sheet from being displayed
every time that you save a chart.

Displays on First Save

Displays the cover sheet on the first save of a new
chart. This option is the default.

Display on Every Save

Displays the version of the cover sheet every time
you save a chart.

This option displays the read-only version of the cover sheet on opening a chart. It is set only on the
editable version of the cover sheet, which is displayed by using either these options or by clicking File >
Cover Sheet.

Automatically saving charts
You can choose to automatically save the charts you are working on, and specify the time interval at
which the auto save occurs.
1. Click File > Options, and then in the Options window click Options > Save
2. Select the Auto Save checkbox and enter the time period in minutes. The default auto save option is
set to save every five minutes.
3. Select the folder in which you want Analyst's Notebook to keep the temporary files. Preferably
choose a folder on your local hard disk, typically the C: drive.
4. Click OK.
All your open charts are saved automatically at the time interval you specified.
Note: Automatically saving your chart does not display the Cover Sheet. It is displayed only when you
click File > Save or File > Save As, or the On Save checkbox is selected in the Chart Properties
window.
The auto save files are only restored when you start Analyst's Notebook after a failure. They are deleted
when you close Analyst's Notebook normally. If you want to keep these charts, you must save them
normally before you close Analyst's Notebook.

Archiving charts
For backup and record-keeping, you can configure the Analyst's Notebook archiving feature to make
a separate copy of your chart every time you save it. You can decide how many copies to retain, and
whether the application monitors their integrity.
1. Click File > Options, and then in the Options window click Options > Save
2. Select the Archive on Save checkbox.
3. Choose the number of copies of each chart you want to retain. The default option is set to five
charts.
4. Optional: Select the Test Archives for Corruption checkbox to verify your archived files. Analyst's
Notebook runs a background check and alerts you if the archive fails.
5. Click OK.
Every time that you save an open chart, a backup copy is saved in an i2 Chart Archives folder, up to the
maximum number you specified.
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Display compatibility warnings
When you save a chart in this version of Analyst's Notebook, the chart is checked to see if there are any
significant compatibility issues with earlier versions and a relevant warning is displayed. For example,
new icons, pictures on icons and icon frames are not supported in versions earlier than Analyst's
Notebook 8.5.
By default, the Warn About Compatibility when Saving in Current Format checkbox is selected.
Check warnings regularly to ensure that you do not encounter unexpected incompatibility issues when
you open charts in earlier versions. If you are familiar with the compatibility warnings when you save
charts and no longer want to see them, clear the checkbox.

Managing files and file locations
For a new installation of Analyst's Notebook, a set of template and specification files is installed to
default locations on your computer.

Types of files that are installed with Analyst's Notebook
Templates and specifications that are installed with Analyst's Notebook are used to create charts that
can be used for different audiences.
The main template and specification files are:
Template

Description

Standard template (Standard.ant)

The template that is used as the basis for a new
chart when you click File > New > New Standard
Chart.

Flag template (Flag.ant)

A local template that contains only flag icons.
Local templates are selected in the New From
Template window, which opens when you click
File > New > New from Template.

Report specification (Reporter.rep)

This file contains six standard specifications for
generating reports by using the Reporter. The
report specifications in this file can be used when
you click the Publish tab and then click Reports.

As you use Analyst's Notebook you might update the template files. For example, you, might add new
entity types, or when you want to create new report specifications. You might also move the location of
some files. For example, to create central server copies for regular backups, or when you want to share
templates and specifications with other users in your group.
Managing your files means that:
•

Some key templates and specifications can be moved to new folder locations

•

All files can be updated automatically at installation when there are newer versions, or where you
edited the original versions

•

You can choose to accept or reject an update where a 'notify' feature is selected

•

The Standard template and Report specification file can be restored later where you either edit the
original file or rejected an update at installation.
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Maintaining file versions
When you upgrade Analyst's Notebook to the latest version, old files are overwritten and new files are
installed automatically.
If you changed the contents of your original installed templates or specification between versions, a
Replace window is shown when you first start Analyst's Notebook.
You must select one of two options before you can use Analyst's Notebook:
Option

Description

Use the updated <file name> (the old file is
backed up)

Creates a backup copy of your edited file with
the name Backup <n> of <file name> in a
Backup directory (for example, for templates, C:
\Documents and Settings\<user name>
\Templates\Backup), and overwrites your
edited file with the latest version.

Keep the existing <file name>

Ensures that your edited version of the template
or specification file is not overwritten and remains
available for use with your latest version of
Analyst's Notebook. If you choose this option
while you update the Standard template or Report
specification, you can reset these files with the
installed versions later by using the Templates
and Reporter pages of the Options window.

Standard template file
When you click File > New > New Standard Chart, the template that is specified in this path is used.
To reset the current Standard template with the installed version of the template:
1. Click Reset in the Standard Template File area. The Reset Standard Template File window is
shown. Note Reset is only available when either a more recent version of the template is installed
(but you chose not to use it) or you edited the current installed version.
2. You can click Details on the Reset Standard Template File window to read a description of what
happens when you reset the file.
3. Click OK. The latest version of the Standard template is installed to its default location.

Local Template folder
The Local Template folder contains templates that are in the list of local templates when you click File >
New > New from Template.
To reset the local template folder to the default local template folder, click Reset in the Local Template
Folder area.
Note: Reset is only available if the default local template folder is changed.
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Workgroup Template folder
The Workgroup folder contains templates that are in the list of workgroup templates when you click File
> New > New from Template.

Using the Reporter page
You can use the standard installed report specification Reporter.rep to create and modify reports.
This specification is typically at C:\Documents and Settings\<user name>\My Documents
\i2\i2 Analyst's Notebook 8\Report Specifications.
You can create your own .rep files, or revert to using the original installed Reporter.rep file if you
changed it.
Use the Reporter page to specify the location of the report specification (*.rep) file that you want to
use in Analyst's Notebook, and to restore the original installed version of the Reporter.rep file.
To change the location of your report specification file, enter the path or click Browse to specify a
different location.
To change the location of your report specification:
1. Click Reset. The Reset Specifications File window is shown. Reset is only available when either a
more recent version of the specification file is installed (but you chose not to use it) or you edited the
original copy.
2. You can click Details on the Reset Specifications File window to read a description of what
happens when you reset the file.
3. Click OK. The latest version of the specification file is installed to its default location.

Updating files
When you upgrade Analyst's Notebook to the latest version, old files are overwritten, and new files
are installed automatically. However, if you change the contents of your original installed templates or
specifications between versions, a Replace window is shown when you first start Analyst's Notebook.
You must select one of two options before you can update a file:
Option

Description

Use the updated <file name> (the old file is
backed up)

Creates a backup copy of your edited file with the
name Backup of <file name>, and overwrites your
edited file with the latest version.

Keep the existing <file name>

Ensures that your edited version of the template
or specification file is not overwritten and remains
available for use with your latest version of
Analyst's Notebook. If you select this option when
you update the Standard template or Report
specification, you can reset these files with the
installed versions later by using the Options
window that opens when you click File > Options.
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Managing plug-ins
Analyst's Notebook is an application that can be extended with more functions which are part of a plugin. A plug-in is a software component which might provide commands and ribbon buttons in addition to
those commands provided as standard in Analyst's Notebook.
There are two types of plug-in:
Component

Description

Standard

Standard components are provided by i2 and
are present as part of the standard Analyst's
Notebook software. Standard components are
identified in the Author box by the phrase:
Component authored by i2
Some standard components are by loaded
when the application starts. Others are only
loaded when required, such as the Visual Search
component.

Extensions

Extensions are third-party plug-ins that are not
part of the standard Analyst's Notebook product.
For more details about an extension, select it in
the list and read the information in the License
box.

Specifying available plug-ins
To list the installed plug-ins, expand either the Standard or Extension sections, and use the scroll
bar to view the list of plug-ins for each type. The list of plug-ins for each type are grouped under the
subsections Loaded and Unloaded showing those plug-ins that are successfully loaded or failed to load
To specify available and unavailable plug-ins:
•

To enable a plug-in, select the plug-in in the displayed list, and select the Load on Startup check
box.

•

To disable a plug-in, select the required plug-in and clear the Load on Startup and Protect against
Plug-in Failure check boxes

•

You also select the Protect against Plug-in Failure check box to allow Analyst's Notebook to load
properly even if the plug-in fails to load. The plug-in can then be reported in the Failed area when
Analyst's Notebook is up and running.

Glossary
This glossary includes terms and definitions for i2® Analyst's Notebook.
The following cross-references are used in this glossary:
•

See refers you from a term to a preferred synonym, or from an acronym or abbreviation to the
defined full form.

•

See also refers you to a related or contrasting term.
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A
abstract semantic type
A semantic type that only serves as the parent of other semantic types. Abstract semantic types
categorize their child semantic types, but are never associated with real data.
aligned value
A value that is used to interpret equivalent native values from different data sources. For example,
the value Male can be used to align the native values M or Ma.
analysis attribute
A characteristic or trait pertaining to a chart item. Analysis attributes are never displayed on charts.
association chart
A chart that highlights the relationships between entities, rather than a chronology of events, by
arranging data in a manner that emphasizes particular associations.
attribute
A piece of information that is associated with a chart item, such as a date of birth or an account
number. An attribute is represented by a symbol, or a value, or both, that is displayed with the chart
item.
attribute class
A descriptor of the characteristics of an attribute, including the type of its values, how its values are
displayed, and the treatment of its values when they are merged or pasted on a chart.
attribute entry
An attribute with a preset value that can be associated with a chart item.
attribute instance
A single use of an attribute on a chart item.
authority
A measure of how well-connected an entity is, based on its inbound links. Authority is one of two
eigenvector centrality measures used in social network analysis. See also centrality, eigenvector.
automatic attribute
An attribute that is created automatically by the application and added to a chart item.

B
betweenness
A measure of how important an entity is, based on the number of paths that pass through it on an
association chart. Betweenness is one of the centrality measures used in social network analysis.
See also centrality, gatekeeper.
binding strength
A measure of the strength of a relationship between two entities that are directly or indirectly linked.
See also common neighbor.
box
An entity representation that can indicate an organization or group on a chart. A box is often used to
enclose other entities. See also circle, representation.

C
card
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A record of information attached to an item. An item can have multiple cards.
centrality
The relative importance of one entity compared to other entities in social network analysis, as
determined by its relationships. See also authority, betweenness, closeness, degree, eigenvector,
hub, social network analysis.
chart
A visual representation of real-world objects, such as organizations, people, events, or locations,
and the relationships between them.
chart fragment
A view of a chart that highlights particular items of interest.
chart property
A characteristic of a chart, such as its summary description, time zone, grid size, background color,
or merge and paste rules. Chart properties are saved with the chart. See also chart template.
chart template
An object that is used for chart creation that contains preconfigured chart properties, and lists of
permitted entity types and link types. See also chart property.
child
In a generalization relationship, the specialization of another element, the parent. See also parent.
circle
An entity representation that can indicate an organization or a group on a chart. A circle is often
used to enclose other entities. See also box, representation.
circular layout
A layout in which entities are arranged by type around the circumference of a circle. See also layout.
closeness
A measure of how quickly an entity can use links to get access to other entities on an association
chart. Closeness is one of the centrality measures used in social network analysis. See also
centrality.
cluster
A group of entities that have more connections to each other than to entities outside the group.
common neighbor
An entity that is directly connected to at least two other entities. For example, if C is connected to A
and B, then C is a common neighbor of A and B. See also binding strength, connection.
compact peacock layout
A layout in which complex groups of linked entities are arranged to highlight the structure of
associations. It is most suitable for charts with many linked entities. See also layout.
condition
A specified property, a value, and an operator that defines a comparison relationship between them.
One or more conditions can be used to create a query or a conditional formatting specification.
conditional formatting
The process of defining and applying rules to change the appearance of chart items automatically,
based on their properties. See also conditional formatting specification.
conditional formatting specification
A collection of conditional formatting rules. See also conditional formatting.
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connection
A direct relationship between a pair of entities on a chart, represented by one or more links. See
also common neighbor, connection multiplicity, directed connection.
connection multiplicity
A setting that controls whether multiple links between the same items are displayed as a single line,
as directed lines, or as multiple lines. See also connection.
controlling item
A chart item whose position on the chart is defined by its date and time, and whose position affects
the positions of other timed items. See also free item, ordered item.
cover sheet
A page on which the user can view and edit the summary and custom properties of a chart.

D
degree
A measure of how many direct relationships an entity has with other entities on an association chart.
Degree is one of the centrality measures used in social network analysis. See also centrality, root
entity.
directed connection
A connection between entities in which links that are in the same direction are represented as a
single link on a chart. See also connection.
diverted theme line
A theme line that is attached to an event frame such that when the event frame is moved, the theme
line maintains its vertical position with respect to the frame. See also event frame, theme line.

E
eigenvector
A measure of how well-connected an entity is, based on its inbound and outbound links.
Eigenvector is one of the centrality measures used in social network analysis. See also authority,
centrality, hub.
end
An entity that is attached to a link. See also end constraint.
end constraint
A constraint on the types of entities that can be the end of a particular link. See also end, valid end
type.
entity
A set of details that are held about a real-world object such as a person, location, or bank account.
An entity is a kind of item.
entity semantic type
A semantic type that can be assigned only to an entity or an entity type. See also semantic type.
entity type
A descriptor of the characteristics of an entity, including the properties it can contain and its
appearance in visualizations.
event frame
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An entity representation that emphasizes date and time information. An event frame is often used in
conjunction with theme lines. See also diverted theme line, representation.
expansion
A process that searches for entities within a data source that are directly related to some selected
entities.

F
free item
A chart item that is not ordered. Free items can be moved anywhere on the chart. See also
controlling item, ordered item.

G
gatekeeper
An entity with a high measure of betweenness that may control the flow of information among other
entities on an association chart. See also betweenness.
grade
A rating that indicates the accuracy of a piece of information or the reliability of an intelligence
source.
grading system
A rating scale that is used to classify information in a data store or on a chart. A grading system is a
measure of reliability and accuracy.
grouped layout
A layout in which entities are arranged to show groups of interconnected entities. See also layout.

H
heat map
A graphical representation of data values in a two-dimensional table format, in which higher values
are represented by darker colors and lower values by lighter ones.
hierarchical layout
A layout in which entities are arranged to show organizational structures. See also layout.
histogram
A graphical display of the distribution of values for a numeric field, in the form of a vertical bar chart
in which taller bars indicate higher values. See also histogram filter.
histogram filter
A filter that changes the appearance of a chart. When a histogram bar is selected, items that
match the conditions defined by that bar are selected, while items that do not are hidden. See also
histogram.
hub
A measure of how well-connected an entity is, based on its outbound links. Hub is one of two
eigenvector centrality measures used in social network analysis. See also centrality, eigenvector.

I
icon
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An entity representation that consists of a stylized image and an optional label. See also
representation.
import design
A specification of how data from an external source will be transformed into chart or repository items
during an import procedure.
item
An entity or a link. Items are characterized by the values of their properties. See also merged item,
ordered item.

L
layout
The arrangement of items on a chart. See also circular layout, compact peacock layout, grouped
layout, hierarchical layout, minimize crossed links layout, peacock layout.
line strength
An indication of confidence in the information underlying a particular link. Line strength is
represented as a solid, dashed, or dotted line on a chart.
link
An association between two entities, such as an ownership relationship between a person and a
vehicle.
link direction
An indication that the meaning of a link is different for each of its ends. For example, the direction of
a telephone call makes one end the caller and the other the recipient. Link direction can influence
the centrality measures used in social network analysis.
link semantic type
A semantic type that can be assigned only to a link or a link type. See also semantic type.
link separation
The distance between adjacent links in a connection on a chart.
link type
A descriptor of the characteristics of a link, including the properties it can contain and its
appearance in visualizations.

M
match
The part of a result that met a condition during a search operation. A search can yield a perfect
match or a partial match.
merged item
An item that is created by merging the information held in two or more items. See also item.
minimize crossed links layout
A layout in which entities are arranged in a configuration where the fewest number of links overlap.
See also layout.
multiplicity
See connection multiplicity.
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N
network chart
See association chart.

O
ordered item
A chart item whose position is maintained within a sequence. The movement of an ordered item is
restricted such that it cannot be dragged beyond neighboring ordered items. See also controlling
item, free item, item.

P
parent
In a hierarchy or auto-level hierarchy, a member that has one or more child members at the level
immediately below.
path
A route on a chart between two entities. A path may include intermediate entities.
peacock layout
A layout where complex groups of linked entities are arranged to show the structure of associations.
It is most suitable for charts with many linked entities. See also layout.
property
A container for a single piece of information about an item.
property semantic type
A semantic type that can be assigned to a property type, a property in a data record, or an attribute
class. See also semantic type.
property type
A descriptor of the characteristics of a property, including the type of information it can contain.
proportional
Pertaining to an area of a chart in which the horizontal distances between items have a linear
relationship with the time differences between them.

R
representation
The form in which an entity is represented on a chart. See also box, circle, event frame, icon, theme
line.
root entity
An entity in a grouped layout that has the highest degree centrality in its group. Depending on the
data, there can be more than one root entity. See also degree.

S
semantic type
A category that defines the real-world meaning of data, and therefore how applications should
interpret that data. For example, Person is a semantic type that could be assigned to entity types
such as Male, Victim, and Witness. See also entity semantic type, link semantic type, property
semantic type.
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snapshot
A stored version of a chart that preserves its contents and layout at a particular stage of its
development.
social network analysis
A method of analyzing the structure of social relationships that uses mathematical metrics to make
claims about social organization and social dynamics. See also centrality, weight.
style segment
A section of a theme line between adjacent items to which color and strength can be applied.

T
theme line
An entity representation that shows the interactions of an entity over time. A theme line can be used
with event frames. See also diverted theme line, representation.
theme line extent
The distance between the beginning and end of a theme line
theme line wiring
The manner in which a theme line diverts from a horizontal trajectory in order to pass through and
travel between event frames.
timeline chart
A chart or a portion of a chart that shows a chronology of events. For example, a series of meetings
that occur over several days, or a set of transactions that occur over a period of time.

V
valid end type
An entity type that conforms to the end constraints of a particular link. See also end constraint.

W
weight
A value that is added to a link on an association chart, to represent its importance relative to other
links. Weight can influence the centrality measures used in social network analysis. See also social
network analysis.
weightings file
A file that contains information that can apply weighting values to links on a chart.
wiring segment
The section of a theme line between adjacent diverting event frames.
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